]> git.pld-linux.org Git - packages/qt5-qtwebchannel.git/blame - qt5-qtwebchannel.spec
up to 5.13.0
[packages/qt5-qtwebchannel.git] / qt5-qtwebchannel.spec
CommitLineData
1302c287
JB
1#
2# Conditional build:
a0bb59d8 3%bcond_without doc # Documentation
1302c287
JB
4
5%define orgname qtwebchannel
6%define qtbase_ver %{version}
7%define qtdeclarative_ver %{version}
8%define qttools_ver %{version}
9Summary: The Qt5 WebChannel library
10Summary(pl.UTF-8): Biblioteka Qt5 WebChannel
11Name: qt5-%{orgname}
96101da5 12Version: 5.13.0
0e96b0ba 13Release: 1
1302c287
JB
14License: LGPL v2.1 with Digia Qt LGPL Exception v1.1 or GPL v3.0
15Group: X11/Libraries
96101da5
JP
16Source0: http://download.qt.io/official_releases/qt/5.13/%{version}/submodules/%{orgname}-everywhere-src-%{version}.tar.xz
17# Source0-md5: d698e894823558c3455b8dcc9f251095
dbbcc082 18URL: http://www.qt.io/
1302c287
JB
19BuildRequires: Qt5Core-devel >= %{qtbase_ver}
20BuildRequires: Qt5Network-devel >= %{qtbase_ver}
21BuildRequires: Qt5Qml-devel >= %{qtdeclarative_ver}
22BuildRequires: Qt5Quick-devel >= %{qtdeclarative_ver}
a0bb59d8 23%if %{with doc}
1302c287
JB
24BuildRequires: qt5-assistant >= %{qttools_ver}
25%endif
26BuildRequires: qt5-build >= %{qtbase_ver}
27BuildRequires: qt5-qmake >= %{qtbase_ver}
28BuildRequires: rpmbuild(macros) >= 1.654
29BuildRequires: tar >= 1:1.22
30BuildRequires: xz
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%define specflags -fno-strict-aliasing
34%define qt5dir %{_libdir}/qt5
35
36%description
37Qt is a cross-platform application and UI framework. Using Qt, you can
38write web-enabled applications once and deploy them across desktop,
39mobile and embedded systems without rewriting the source code.
40
41This package contains Qt5 WebChannel library.
42
43%description -l pl.UTF-8
44Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
45Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
46systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
47źródłowego.
48
49Ten pakiet zawiera bibliotekę Qt5 WebChannel.
50
51%package -n Qt5WebChannel
52Summary: The Qt5 WebChannel library
53Summary(pl.UTF-8): Biblioteka Qt5 WebChannel
54Group: Libraries
55Requires: Qt5Core >= %{qtbase_ver}
56Requires: Qt5Network >= %{qtbase_ver}
57Requires: Qt5Qml >= %{qtdeclarative_ver}
58
59%description -n Qt5WebChannel
60Qt5 WebChannel library provides seamless integration of C++ and QML
61applications with HTML/JavaScript clients.
62
63%description -n Qt5WebChannel -l pl.UTF-8
64Biblioteka Qt5 WebChannel udostępnia integrację aplikacji C++ i QML z
65klientami w HTML-u/JavaScripcie.
66
67%package -n Qt5WebChannel-devel
68Summary: Qt5 WebChannel library - development files
69Summary(pl.UTF-8): Biblioteka Qt5 WebChannel - pliki programistyczne
70Group: Development/Libraries
71Requires: Qt5Core-devel >= %{qtbase_ver}
72Requires: Qt5Network-devel >= %{qtbase_ver}
73Requires: Qt5Qml-devel >= %{qtdeclarative_ver}
74Requires: Qt5WebChannel = %{version}-%{release}
75
76%description -n Qt5WebChannel-devel
77Qt5 WebChannel library - development files.
78
79%description -n Qt5WebChannel-devel -l pl.UTF-8
80Biblioteka Qt5 WebChannel - pliki programistyczne.
81
82%package doc
83Summary: Qt5 WebChannel documentation in HTML format
84Summary(pl.UTF-8): Dokumentacja do biblioteki Qt5 WebChannel w formacie HTML
85Group: Documentation
86Requires: qt5-doc-common >= %{qtbase_ver}
87%if "%{_rpmversion}" >= "5"
88BuildArch: noarch
89%endif
90
91%description doc
92Qt5 WebChannel documentation in HTML format.
93
94%description doc -l pl.UTF-8
95Dokumentacja do biblioteki Qt5 WebChannel w formacie HTML.
96
97%package doc-qch
98Summary: Qt5 WebChannel documentation in QCH format
99Summary(pl.UTF-8): Dokumentacja do biblioteki Qt5 WebChannel w formacie QCH
100Group: Documentation
101Requires: qt5-doc-common >= %{qtbase_ver}
102%if "%{_rpmversion}" >= "5"
103BuildArch: noarch
104%endif
105
106%description doc-qch
107Qt5 WebChannel documentation in QCH format.
108
109%description doc-qch -l pl.UTF-8
110Dokumentacja do biblioteki Qt5 WebChannel w formacie QCH.
111
112%package examples
113Summary: Qt5 WebChannel examples
114Summary(pl.UTF-8): Przykłady do biblioteki Qt5 WebChannel
115Group: X11/Development/Libraries
116%if "%{_rpmversion}" >= "5"
117BuildArch: noarch
118%endif
119
120%description examples
121Qt5 WebChannel examples.
122
123%description examples -l pl.UTF-8
124Przykłady do biblioteki Qt5 WebChannel.
125
126%prep
c7f74bb9 127%setup -q -n %{orgname}-everywhere-src-%{version}
1302c287
JB
128
129%build
130qmake-qt5
131%{__make}
a0bb59d8 132%{?with_doc:%{__make} docs}
1302c287
JB
133
134%install
135rm -rf $RPM_BUILD_ROOT
136%{__make} install \
137 INSTALL_ROOT=$RPM_BUILD_ROOT
138
a0bb59d8
JR
139%if %{with doc}
140%{__make} install_docs \
1302c287 141 INSTALL_ROOT=$RPM_BUILD_ROOT
a0bb59d8 142%endif
1302c287
JB
143
144# useless symlinks
c7f74bb9 145%{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.??
1302c287
JB
146# actually drop *.la, follow policy of not packaging them when *.pc exist
147%{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
148
149# Prepare some files list
150ifecho() {
151 r="$RPM_BUILD_ROOT$2"
152 if [ -d "$r" ]; then
153 echo "%%dir $2" >> $1.files
154 elif [ -x "$r" ] ; then
155 echo "%%attr(755,root,root) $2" >> $1.files
156 elif [ -f "$r" ]; then
157 echo "$2" >> $1.files
158 else
159 echo "Error generation $1 files list!"
160 echo "$r: no such file or directory!"
161 return 1
162 fi
163}
164ifecho_tree() {
165 ifecho $1 $2
166 for f in `find $RPM_BUILD_ROOT$2 -printf "%%P "`; do
167 ifecho $1 $2/$f
168 done
169}
170
171echo "%defattr(644,root,root,755)" > examples.files
1302c287
JB
172ifecho_tree examples %{_examplesdir}/qt5/webchannel
173
174%clean
175rm -rf $RPM_BUILD_ROOT
176
177%post -n Qt5WebChannel -p /sbin/ldconfig
178%postun -n Qt5WebChannel -p /sbin/ldconfig
179
180%files -n Qt5WebChannel
181%defattr(644,root,root,755)
c7f74bb9 182%doc LICENSE.GPL3-EXCEPT README.md
1302c287
JB
183%attr(755,root,root) %{_libdir}/libQt5WebChannel.so.*.*.*
184%attr(755,root,root) %ghost %{_libdir}/libQt5WebChannel.so.5
185%dir %{qt5dir}/qml/QtWebChannel
186%attr(755,root,root) %{qt5dir}/qml/QtWebChannel/libdeclarative_webchannel.so
187%{qt5dir}/qml/QtWebChannel/plugins.qmltypes
188%{qt5dir}/qml/QtWebChannel/qmldir
189
190%files -n Qt5WebChannel-devel
191%defattr(644,root,root,755)
192%attr(755,root,root) %{_libdir}/libQt5WebChannel.so
193%{_libdir}/libQt5WebChannel.prl
194%{_includedir}/qt5/QtWebChannel
195%{_pkgconfigdir}/Qt5WebChannel.pc
196%{_libdir}/cmake/Qt5WebChannel
197%{qt5dir}/mkspecs/modules/qt_lib_webchannel.pri
198%{qt5dir}/mkspecs/modules/qt_lib_webchannel_private.pri
199
a0bb59d8 200%if %{with doc}
1302c287
JB
201%files doc
202%defattr(644,root,root,755)
203%{_docdir}/qt5-doc/qtwebchannel
204
1302c287
JB
205%files doc-qch
206%defattr(644,root,root,755)
207%{_docdir}/qt5-doc/qtwebchannel.qch
208%endif
209
210%files examples -f examples.files
211%defattr(644,root,root,755)
212# XXX: dir shared with qt5-qtbase-examples
213%dir %{_examplesdir}/qt5
This page took 0.127083 seconds and 4 git commands to generate.