]> git.pld-linux.org Git - packages/qt4.git/blobdiff - qt4.spec
- icu 67 rebuild
[packages/qt4.git] / qt4.spec
index 5a5563aed94c3e27dc231a8f4d4c68a1c8edcd64..4150dbf5a06b2d994297ec6441872423a4face4f 100644 (file)
--- a/qt4.spec
+++ b/qt4.spec
@@ -1,25 +1,30 @@
 #
 # TODO:
-#      - figure out why it tries to link with system qt (fix and drop BuildConflicts Qt)
+#      - fix moc failures, see e.g. https://bugzilla.redhat.com/show_bug.cgi?id=1396755
+#        at least add some macros to QTBUG-22829 patch (BOOST_PREDEF_VERSION_NUMBER_H, _SYS_SYSMACROS_H_OUTER...)
 #      - more cleanups
 #      - check if translations are available
 #      - check Qt ui tool
-#      - QtWebKit-devel is broken: libQtWebKit.*la contains '-ljscore', it comes
-#        from src/3rdparty/webkit/JavaScriptCore, but jscore lib isn't installed
 #
 # Conditional build:
-%bcond_with    nas             # enable NAS audio support
 %bcond_without static_libs     # don't build static libraries
-%bcond_without cups            # disable CUPS support
-%bcond_without mysql           # don't build MySQL plugin
-%bcond_without odbc            # don't build unixODBC plugin
-%bcond_without pgsql           # don't build PostgreSQL plugin
-%bcond_without sqlite3         # don't build SQLite3 plugin
-%bcond_without sqlite          # don't build SQLite2 plugin
-%bcond_without ibase           # don't build ibase (InterBase/Firebird) plugin
-%bcond_without pch             # disable pch in qmake
-%bcond_without gtk             # don't build GTK theme integration
-%bcond_without system_phonon   # don't build phonon libraries
+# -- features
+%bcond_without cups            # CUPS printing support
+%bcond_with    nas             # NAS audio support
+%bcond_without gtk             # GTK+ theme integration
+%bcond_without pch             # pch (pre-compiled headers) in qmake
+%bcond_without system_phonon   # phonon libraries from phonon.spec intead of qt4.spec
+%bcond_with    wkhtml          # WKHTMLTOPDF patch (affects QtGui ABI)
+%bcond_with    openvg          # OpenVG support
+# -- databases
+%bcond_without ibase           # ibase (InterBase/Firebird) plugin
+%bcond_without mysql           # MySQL plugin
+%bcond_with    oci             # OCI (Oracle) support
+%bcond_without odbc            # unixODBC plugin
+%bcond_without pgsql           # PostgreSQL plugin
+%bcond_without sqlite3         # SQLite3 plugin
+%bcond_without sqlite          # SQLite2 plugin
+# -- SIMD CPU instructions
 %bcond_with    mmx             # use MMX instructions
 %bcond_with    3dnow           # use 3Dnow instructions
 %bcond_with    sse             # use SSE instructions in gui/painting module
@@ -29,7 +34,7 @@
 %bcond_with    sse41           # use SSE4.1 instructions (Intel since middle Core2)
 %bcond_with    sse42           # use SSE4.2 instructions (the same)
 %bcond_with    avx             # use AVX instructions (future Intel x86 CPUs only)
-#
+
 %ifnarch %{ix86} %{x8664} sparc sparcv9 alpha ppc
 %undefine      with_ibase
 %endif
 %endif
 # any SQL
 %define                _withsql        1
-%{!?with_sqlite3:%{!?with_sqlite:%{!?with_ibase:%{!?with_mysql:%{!?with_pgsql:%{!?with_odbc:%undefine _withsql}}}}}}
-#
+%{!?with_sqlite3:%{!?with_sqlite:%{!?with_ibase:%{!?with_mysql:%{!?with_pgsql:%{!?with_odbc:%{!?with_oci:%undefine _withsql}}}}}}}
+
+%define                icu_abi         67
+%define                next_icu_abi    %(echo $((%{icu_abi} + 1)))
+
 Summary:       The Qt GUI application framework
 Summary(es.UTF-8):     Biblioteca para ejecutar aplicaciones GUI Qt
 Summary(pl.UTF-8):     Biblioteka Qt do tworzenia GUI
 Summary(pt_BR.UTF-8):  Estrutura para rodar aplicações GUI Qt
 Name:          qt4
-Version:       4.8.2
-Release:       1
+Version:       4.8.7
+Release:       28
 License:       LGPL v2.1 or GPL v3.0
 Group:         X11/Libraries
-Source0:       http://releases.qt-project.org/qt4/source/qt-everywhere-opensource-src-%{version}.tar.gz
-# Source0-md5: 3c1146ddf56247e16782f96910a8423b
+Source0:       http://download.qt-project.org/official_releases/qt/4.8/%{version}/qt-everywhere-opensource-src-%{version}.tar.gz
+# Source0-md5: d990ee66bf7ab0c785589776f35ba6ad
 Source2:       %{name}-qtconfig.desktop
 Source3:       %{name}-designer.desktop
 Source4:       %{name}-assistant.desktop
@@ -77,35 +85,84 @@ Patch3:             %{name}-locale.patch
 Patch5:                %{name}-support-cflags-with-commas.patch
 Patch6:                %{name}-build-lib-static.patch
 Patch7:                %{name}-x11_fonts.patch
-Patch8:                %{name}-glib.patch
-Patch9:                %{name}-ibase.patch
-Patch10:       %{name}-git.patch
-Patch11:       qt-x11-opensource-src-4.5.1-enable_ft_lcdfilter.patch
-URL:           http://qt.nokia.com/
+Patch8:                %{name}-ibase.patch
+Patch9:                qt-x11-opensource-src-4.5.1-enable_ft_lcdfilter.patch
+Patch10:       webkit-no_Werror.patch
+Patch11:       %{name}-wkhtml.patch
+Patch12:       openssl.patch
+Patch13:       qt-asm-volatile.patch
+Patch14:       x32.patch
+# backported from Qt5 (essentially)
+# http://bugzilla.redhat.com/702493
+# https://bugreports.qt-project.org/browse/QTBUG-5545
+Patch15:       qt-everywhere-opensource-src-4.8.4-qgtkstyle_disable_gtk_theme_check.patch
+Patch16:       qt-everywhere-opensource-src-4.8.3-QTBUG-4862.patch
+Patch17:       %{name}-oracle-instantclient.patch
+# from Debian
+Patch18:       add-lxde-support.patch
+Patch19:       Better-handling-of-invalid-font-tables.patch
+Patch20:       xmlpatterns_stack_overflow_fix.diff
+Patch21:       no_libicu_message.diff
+Patch22:       add-mate-support.patch
+
+# from FC
+Patch28:       qt-x11-opensource-src-4.5.0-fix-qatomic-inline-asm.patch
+Patch29:       qt-everywhere-opensource-src-4.8.6-QTBUG-38585.patch
+Patch30:       qt-everywhere-opensource-src-4.8.6-QTBUG-37380.patch
+Patch31:       qt-everywhere-opensource-src-4.8.6-QTBUG-34614.patch
+Patch32:       qt-everywhere-opensource-src-4.8.5-QTBUG-35459.patch
+Patch33:       qt-everywhere-opensource-src-4.8.5-QTBUG-4862.patch
+Patch34:       qt-everywhere-opensource-src-4.8.5-QTBUG-21900.patch
+Patch35:       qt-4.8-poll.patch
+Patch36:       qt-cupsEnumDests.patch
+Patch37:       qt-everywhere-opensource-src-4.8.4-qmake_pkgconfig_requires_private.patch
+Patch38:       qt-everywhere-opensource-src-4.8.5-QTBUG-14467.patch
+Patch39:       qt-everywhere-opensource-src-4.8.5-tds_no_strict_aliasing.patch
+Patch40:       qt-everywhere-opensource-src-4.8.6-QTBUG-22829.patch
+Patch41:       qt-everywhere-opensource-src-4.8.7-alsa-1.1.patch
+Patch42:       qt-everywhere-opensource-src-4.8.7-gcc6.patch
+Patch43:       qt-everywhere-opensource-src-4.6.2-cups.patch
+Patch44:       qt-everywhere-opensource-src-4.8.0-tp-qtreeview-kpackagekit-crash.patch
+Patch45:       qt-everywhere-opensource-src-4.6.3-glib_eventloop_nullcheck.patch
+Patch46:       qt-everywhere-opensource-src-4.8.3-qdbusconnection_no_debug.patch
+Patch47:       qt-everywhere-opensource-src-4.8.2--assistant-crash.patch
+Patch48:       qt-everywhere-opensource-src-4.8.0-QTBUG-22037.patch
+Patch49:       icu59.patch
+Patch50:       mysql-link.patch
+Patch51:       gcc9.patch
+Patch52:       gcc9-qforeach.patch
+Patch53:       cxx11.patch
+URL:           http://qt-project.org/
 %{?with_ibase:BuildRequires:   Firebird-devel}
+%{?with_openvg:BuildRequires:  Mesa-libOpenVG-devel}
 BuildRequires: OpenGL-GLU-devel
+BuildRequires: OpenGL-devel
 BuildRequires: alsa-lib-devel
 %{?with_cups:BuildRequires:    cups-devel}
 BuildRequires: dbus-devel >= 0.93
 BuildRequires: fontconfig-devel
 BuildRequires: freetds-devel
-BuildRequires: freetype-devel >= 1:2.0.0
+BuildRequires: freetype-devel >= 2.1.3
 %{?with_pch:BuildRequires:     gcc >= 5:4.0}
 BuildRequires: glib2-devel >= 2.0.0
-BuildRequires: gstreamer-plugins-base-devel
+BuildRequires: gstreamer0.10-plugins-base-devel
 %{?with_gtk:BuildRequires:     gtk+2-devel >= 2:2.10}
-BuildRequires: libicu-devel
+# see dependency on libicu version below
+BuildRequires: libicu-devel >= %{icu_abi}
+BuildRequires: libicu-devel < %{next_icu_abi}
 BuildRequires: libjpeg-devel
 BuildRequires: libmng-devel >= 1.0.0
 BuildRequires: libpng-devel >= 2:1.0.8
 BuildRequires: libstdc++-devel
 %{?with_mysql:BuildRequires:   mysql-devel}
 %{?with_nas:BuildRequires:     nas-devel}
+%{?with_oci:BuildRequires:     oracle-instantclient-devel}
 BuildRequires: pkgconfig
 %{?with_pgsql:BuildRequires:   postgresql-backend-devel}
 %{?with_pgsql:BuildRequires:   postgresql-devel}
 BuildRequires: pulseaudio-devel >= 0.9.10
-BuildRequires: rpmbuild(macros) >= 1.602
+BuildRequires: rpmbuild(macros) >= 1.654
+BuildRequires: rsync
 BuildRequires: sed >= 4.0
 %{?with_sqlite:BuildRequires:  sqlite-devel}
 %{?with_sqlite3:BuildRequires: sqlite3-devel}
@@ -121,9 +178,6 @@ BuildRequires:      xorg-lib-libXrender-devel
 BuildRequires: xorg-lib-libXtst-devel
 BuildRequires: xorg-lib-libXv-devel
 BuildRequires: zlib-devel
-# when building it tries to link with system qt instead of built one
-BuildConflicts:        QtCore-devel <= %{version}
-BuildConflicts:        QtScript-devel <= %{version}
 Obsoletes:     qt-extensions
 Obsoletes:     qt-utils
 Conflicts:     kdelibs <= 8:3.2-0.030602.1
@@ -255,13 +309,16 @@ biblioteka statyczna.
 Summary:       Qt core classes used by other modules
 Summary(pl.UTF-8):     Podstawowe klasy Qt używane przez inne moduły
 Group:         X11/Libraries
-%requires_eq   libicu
+%requires_eq_to        libicu libicu-devel
 # be sure to depend on proper arch.
-%ifarch %{ix86}
-Requires:      libicui18n.so.48
+%ifarch %{x8664} ppc64 sparc64 s390x
+Requires:      libicui18n.so.%{icu_abi}()(64bit)
+%else
+%ifarch x32
+Requires:      libicui18n.so.%{icu_abi}()(x32bit)
+%else
+Requires:      libicui18n.so.%{icu_abi}
 %endif
-%ifarch %{x8664}
-Requires:      libicui18n.so.48()(64bit)
 %endif
 Obsoletes:     QtAssistant
 
@@ -474,7 +531,7 @@ Group:              X11/Development/Libraries
 Requires:      QtCore-devel = %{version}-%{release}
 Requires:      QtGui = %{version}-%{release}
 Requires:      fontconfig-devel
-Requires:      freetype-devel >= 1:2.0.0
+Requires:      freetype-devel >= 2.1.3
 Requires:      libpng-devel >= 2:1.0.8
 Requires:      xorg-lib-libSM-devel
 Requires:      xorg-lib-libXcursor-devel
@@ -605,6 +662,7 @@ Requires:   QtCore = %{version}-%{release}
 # the rest for qnmbearer plugin
 Requires:      QtDBus = %{version}-%{release}
 Requires:      QtXml = %{version}-%{release}
+%requires_ge_to        openssl openssl-devel
 
 %description -n QtNetwork
 Qt classes for network programming.
@@ -677,6 +735,45 @@ Qt OpenGL support classes - static libraries.
 %description -n QtOpenGL-static -l pl.UTF-8
 Klasy Qt wspomagające OpenGL - biblioteki statyczne.
 
+%package -n QtOpenVG
+Summary:       Qt OpenVG support classes
+Summary(pl.UTF-8):     Klasy Qt wspomagające OpenVG
+Group:         X11/Libraries
+Requires:      QtCore = %{version}-%{release}
+Requires:      QtGui = %{version}-%{release}
+
+%description -n QtOpenVG
+Qt OpenVG support classes.
+
+%description -n QtOpenVG -l pl.UTF-8
+Klasy Qt wspomagające OpenVG.
+
+%package -n QtOpenVG-devel
+Summary:       Qt OpenVG support classes - development files
+Summary(pl.UTF-8):     Klasy Qt wspomagające OpenVG - pliki programistyczne
+Group:         X11/Development/Libraries
+Requires:      Mesa-libOpenVG-devel
+Requires:      QtCore-devel = %{version}-%{release}
+Requires:      QtGui-devel = %{version}-%{release}
+
+%description -n QtOpenVG-devel
+Qt OpenVG support classes - development files.
+
+%description -n QtOpenVG-devel -l pl.UTF-8
+Klasy Qt wspomagające OpenVG - pliki programistyczne.
+
+%package -n QtOpenVG-static
+Summary:       Qt OpenVG support classes - static libraries
+Summary(pl.UTF-8):     Klasy Qt wspomagające OpenVG - biblioteki statyczne
+Group:         X11/Development/Libraries
+Requires:      QtOpenVG-devel = %{version}-%{release}
+
+%description -n QtOpenVG-static
+Qt OpenVG support classes - static libraries.
+
+%description -n QtOpenVG-static -l pl.UTF-8
+Klasy Qt wspomagające OpenVG - biblioteki statyczne.
+
 %package -n QtScript
 Summary:       Qt classes for scripting applications
 Summary(pl.UTF-8):     Klasy Qt pozwalające dodać obsługę skryptów w aplikacjach
@@ -840,6 +937,20 @@ danych MySQL poprzez klasy QSql.
 %description -n QtSql-mysql -l pt_BR.UTF-8
 Plugin de suporte a MySQL para Qt.
 
+%package -n QtSql-oci
+Summary:       Qt Sql driver for Oracle database (using OCI interface)
+Summary(pl.UTF-8):     Sterownik Qt Sql dla bazy danych Oracle (wykorzystujący interfejs OCI)
+Group:         Libraries
+Requires:      QtSql = %{version}-%{release}
+Provides:      QtSql-backend = %{version}-%{release}
+
+%description -n QtSql-oci
+Qt Sql driver for Oracle database (using OCI interface).
+
+%description -n QtSql-oci -l pl.UTF-8
+Sterownik Qt Sql dla bazy danych Oracle (wykorzystujący interfejs
+OCI).
+
 %package -n QtSql-odbc
 Summary:       Database plugin for ODBC Qt support
 Summary(pl.UTF-8):     Wtyczka ODBC do Qt
@@ -1247,6 +1358,17 @@ An advanced tool used for GUI designing with Qt library.
 Zaawansowane narzędzie służące do projektowania interfejsu graficznego
 za pomocą biblioteki Qt.
 
+%package devel-private
+Summary:       Private Qt headers files
+Group:         X11/Development/Libraries
+Requires:      QtCore-devel = %{version}-%{release}
+Requires:      QtDeclarative-devel = %{version}-%{release}
+Requires:      QtGui-devel = %{version}-%{release}
+Requires:      QtScript-devel = %{version}-%{release}
+
+%description devel-private
+Private Qt headers files - for calibre
+
 %package linguist
 Summary:       Translation helper for Qt
 Summary(pl.UTF-8):     Aplikacja ułatwiająca tłumaczenie aplikacji opartych o Qt
@@ -1371,6 +1493,9 @@ Summary:  Qt Documentation in HTML format
 Summary(pl.UTF-8):     Dokumentacja Qt w formacie HTML
 Group:         X11/Development/Libraries
 Suggests:      %{name}-assistant = %{version}-%{release}
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
 
 %description doc
 Qt documentation in HTML format.
@@ -1408,8 +1533,47 @@ Programas exemplo para o Qt versão.
 %patch7 -p1
 %patch8 -p1
 %patch9 -p1
-#%patch10 -p1
-%patch11 -p1
+%patch10 -p1
+%{?with_wkhtml:%patch11 -p1}
+%patch12 -p1
+%patch13 -p1
+%patch14 -p1
+%patch15 -p1
+%patch16 -p1
+%patch17 -p1
+
+%patch18 -p1
+%patch19 -p1
+%patch20 -p1
+%patch21 -p1
+%patch22 -p1
+
+%patch28 -p1
+%patch29 -p0
+%patch30 -p1
+%patch31 -p0
+%patch32 -p1
+%patch33 -p1
+%patch34 -p1
+%patch35 -p1
+%patch36 -p1
+%patch37 -p1
+%patch38 -p1
+%patch39 -p1
+%patch40 -p1
+%patch41 -p1
+%patch42 -p1
+%patch43 -p1
+%patch44 -p1
+%patch45 -p1
+%patch46 -p1
+%patch47 -p1
+%patch48 -p1
+%patch49 -p1
+%patch50 -p1
+%patch51 -p1
+%patch52 -p1
+%patch53 -p1
 
 %{__sed} -i -e 's,usr/X11R6/,usr/g,' mkspecs/linux-g++-64/qmake.conf \
        mkspecs/common/linux.conf
@@ -1441,7 +1605,7 @@ Programas exemplo para o Qt versão.
        ' mkspecs/common/linux.conf
 
 # disable webkit tests, broken build
-rm -r src/3rdparty/webkit/Source/WebKit/qt/tests
+%{__rm} -r src/3rdparty/webkit/Source/WebKit/qt/tests
 
 %build
 # pass OPTFLAGS to build qmake itself with optimization
@@ -1453,7 +1617,8 @@ export PATH=$PWD/bin:$PATH
 ##################################
 
 COMMONOPT=" \
-       -confirm-license -opensource \
+       -confirm-license \
+       -opensource \
        -buildkey pld \
        -verbose \
        -prefix %{_qtdir} \
@@ -1461,14 +1626,12 @@ COMMONOPT=" \
        -docdir %{_docdir}/%{name}-doc \
        -headerdir %{_includedir}/qt4 \
        -libdir %{_libdir} \
-       -L%{_libdir} \
        -plugindir %{_qtdir}/plugins \
        -datadir %{_datadir}/qt4 \
        -translationdir %{_localedir}/ \
        -sysconfdir %{_sysconfdir}/qt4 \
        -examplesdir %{_examplesdir}/qt4 \
        -demosdir %{_examplesdir}/qt4-demos \
-       -opensource \
        -optimized-qmake \
        -fast \
        -glib \
@@ -1501,6 +1664,7 @@ COMMONOPT=" \
        %{?with_nas:-system-nas-sound} \
        %{?debug:-debug} \
        %{!?debug:-release} \
+       -%{!?with_openvg:no-}openvg \
        -qt3support \
        -fontconfig \
        -largefile \
@@ -1510,6 +1674,7 @@ COMMONOPT=" \
        -xfixes \
        -nis \
        -sm \
+       -stl \
        -xcursor \
        -xinput \
        -xinerama \
@@ -1526,12 +1691,13 @@ COMMONOPT=" \
 
 %if %{with static_libs}
 OPT=" \
+       -%{!?with_ibase:no}%{?with_ibase:qt}-sql-ibase \
        -%{!?with_mysql:no}%{?with_mysql:qt}-sql-mysql \
        -%{!?with_odbc:no}%{?with_odbc:qt}-sql-odbc \
+       -%{!?with_oci:no}%{?with_oci:qt}-sql-oci \
        -%{!?with_pgsql:no}%{?with_pgsql:qt}-sql-psql \
        -%{!?with_sqlite3:no}%{?with_sqlite3:qt}-sql-sqlite \
        -%{!?with_sqlite:no}%{?with_sqlite:qt}-sql-sqlite2 \
-       -%{!?with_ibase:no}%{?with_ibase:qt}-sql-ibase \
        -static"
 
 ./configure $COMMONOPT $OPT
@@ -1551,16 +1717,16 @@ fi
 ##################################
 
 OPT=" \
+       -%{!?with_ibase:no}%{?with_ibase:plugin}-sql-ibase \
        -%{!?with_mysql:no}%{?with_mysql:plugin}-sql-mysql \
        -%{!?with_odbc:no}%{?with_odbc:plugin}-sql-odbc \
+       -%{!?with_oci:no}%{?with_oci:plugin}-sql-oci \
        -%{!?with_pgsql:no}%{?with_pgsql:plugin}-sql-psql \
        -%{!?with_sqlite3:no}%{?with_sqlite3:plugin}-sql-sqlite \
        -%{!?with_sqlite:no}%{?with_sqlite:plugin}-sql-sqlite2 \
-       -%{!?with_ibase:no}%{?with_ibase:plugin}-sql-ibase \
        -shared"
 
-echo "o
-yes" | ./configure $COMMONOPT $OPT
+./configure $COMMONOPT $OPT
 
 %{__make}
 %{__make} \
@@ -1570,8 +1736,12 @@ yes" | ./configure $COMMONOPT $OPT
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{/etc/env.d,%{_bindir},%{_desktopdir},%{_pixmapsdir},%{_pkgconfigdir}}
+install -d $RPM_BUILD_ROOT{/etc/{env.d,qt4},%{_bindir},%{_desktopdir},%{_pixmapsdir},%{_pkgconfigdir}}
 install -d $RPM_BUILD_ROOT%{_qtdir}/plugins/{crypto,network}
+install -d $RPM_BUILD_ROOT%{_qtdir}/imports/org
+
+# for QtSolutions (qtlockedfile, qtsingleapplication, etc)
+install -d $RPM_BUILD_ROOT%{_includedir}/qt4/QtSolutions
 
 echo '#QT_GRAPHICSSYSTEM=raster' > $RPM_BUILD_ROOT/etc/env.d/QT_GRAPHICSSYSTEM
 
@@ -1589,6 +1759,13 @@ install bin/qdoc3 $RPM_BUILD_ROOT%{_qtdir}/bin/qdoc3
        s|uic_location=.*|uic_location=%{_bindir}/uic-qt4|;
        ' $RPM_BUILD_ROOT%{_pkgconfigdir}/*.pc
 
+# kill -std=XYZ, so qmake won't pass it over to other projects
+#%{__sed} -i -e s#^\(.*\) -std=[a-z0-9+]\+\( .*\|$\)#\1 \2#g' $RPM_BUILD_ROOT%{_datadir}/qt4/mkspecs/common/g++-base.conf
+
+# libQtWebKit.la contains '-ljscore' and '-lwebcore', they come
+# from src/3rdparty/webkit/{JavaScriptCore,WebCore}} but those libs aren't installed
+%{__sed} -i -e "s,-lwebcore,,g;s,-ljscore,,g;" $RPM_BUILD_ROOT%{_libdir}/libQtWebKit.la
+
 # install tools
 install bin/findtr     $RPM_BUILD_ROOT%{_qtdir}/bin
 
@@ -1621,7 +1798,7 @@ ln -sf ../%{_lib}/qt4/bin/xmlpatternsvalidator .
 cd -
 
 # multilib
-mv $RPM_BUILD_ROOT%{_qtdir}/bin/{qdbus,qdbusviewer} $RPM_BUILD_ROOT%{_bindir}
+%{__mv} $RPM_BUILD_ROOT%{_qtdir}/bin/{qdbus,qdbusviewer} $RPM_BUILD_ROOT%{_bindir}
 ln -sf %{_bindir}/qdbus $RPM_BUILD_ROOT%{_qtdir}/bin/qdbus
 ln -sf %{_bindir}/qdbusviewer $RPM_BUILD_ROOT%{_qtdir}/bin/qdbusviewer
 
@@ -1682,7 +1859,6 @@ done
 cd -
 
 # Ship doc & qmake stuff
-ln -s %{_docdir}/%{name}-doc $RPM_BUILD_ROOT%{_qtdir}/doc
 ln -s %{_datadir}/qt4/mkspecs $RPM_BUILD_ROOT%{_qtdir}/mkspecs
 
 for f in $RPM_BUILD_ROOT%{_pkgconfigdir}/*.pc; do
@@ -1701,6 +1877,20 @@ for f in $RPM_BUILD_ROOT%{_pkgconfigdir}/*.pc; do
        sed -i -e "s:-DQT_SHARED:-DQT_SHARED $DEFS:" $f
 done
 
+# Ship private headers - ugly hack to build calibre
+install -d $RPM_BUILD_ROOT%{_includedir}/qt4/private
+rsync -aR include/QtCore/private \
+         include/QtDeclarative/private \
+         include/QtGui/private \
+         include/QtScript/private \
+         $RPM_BUILD_ROOT%{_includedir}/qt4/private
+rsync -aR src/corelib/*/*_p.h \
+          src/declarative/*/*_p.h \
+          src/gui/*/*_p.h \
+          src/script/*/*_p.h \
+         $RPM_BUILD_ROOT%{_includedir}/qt4/private
+
+
 # Prepare some files list
 ifecho() {
        RESULT=`echo $RPM_BUILD_ROOT$2 2>/dev/null`
@@ -1747,6 +1937,7 @@ mkdevfl QtGui
 mkdevfl QtMultimedia
 mkdevfl QtNetwork
 mkdevfl QtOpenGL
+%{?with_openvg:mkdevfl QtOpenVG}
 mkdevfl QtScript
 mkdevfl QtScriptTools
 mkdevfl QtSql
@@ -1767,6 +1958,9 @@ mkdevfl QtUiTools || /bin/true
 # without glob (exclude QtScriptTools* QtXmlPatterns*)
 %{__sed} -i 's,QtScript\*,QtScript,g' QtScript-devel.files
 %{__sed} -i 's,QtXml\*,QtXml,g' QtXml-devel.files
+# no duplication between QtCore-devel and QtXml-devel
+%{__sed} -i 's,%{_includedir}/qt4/Qt/QXmlStream.*,,g' QtCore-devel.files
+%{__sed} -i 's,%{_includedir}/qt4/Qt/qxmlstream\.h,,g' QtCore-devel.files
 
 echo "%defattr(644,root,root,755)" > examples.files
 ifecho examples %{_examplesdir}/qt4
@@ -1828,6 +2022,9 @@ rm -rf $RPM_BUILD_ROOT
 %post  -n QtOpenGL     -p /sbin/ldconfig
 %postun        -n QtOpenGL     -p /sbin/ldconfig
 
+%post  -n QtOpenVG     -p /sbin/ldconfig
+%postun        -n QtOpenVG     -p /sbin/ldconfig
+
 %post   -n QtScript    -p /sbin/ldconfig
 %postun -n QtScript    -p /sbin/ldconfig
 
@@ -1888,6 +2085,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libQtCore.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libQtCore.so.4
+%dir /etc/qt4
 %dir %{_qtdir}
 %dir %{_qtdir}/bin
 %dir %{_qtdir}/plugins
@@ -1902,6 +2100,7 @@ rm -rf $RPM_BUILD_ROOT
 %lang(da) %{_localedir}/da/LC_MESSAGES/qt4.qm
 %lang(de) %{_localedir}/de/LC_MESSAGES/qt4.qm
 %lang(es) %{_localedir}/es/LC_MESSAGES/qt4.qm
+%lang(eu) %{_localedir}/eu/LC_MESSAGES/qt4.qm
 %lang(fa) %{_localedir}/fa/LC_MESSAGES/qt4.qm
 %lang(fr) %{_localedir}/fr/LC_MESSAGES/qt4.qm
 %lang(gl) %{_localedir}/gl/LC_MESSAGES/qt4.qm
@@ -1951,6 +2150,7 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_qtdir}/imports/QtWebKit
 %attr(755,root,root) %{_qtdir}/imports/QtWebKit/*.so
 %{_qtdir}/imports/QtWebKit/qmldir
+%dir %{_qtdir}/imports/org
 %dir %{_qtdir}/plugins/qmltooling
 %attr(755,root,root) %{_qtdir}/plugins/qmltooling/libqmldbg_tcp.so
 %attr(755,root,root) %{_qtdir}/plugins/qmltooling/libqmldbg_inspector.so
@@ -1995,6 +2195,7 @@ rm -rf $RPM_BUILD_ROOT
 %lang(cs) %{_localedir}/cs/LC_MESSAGES/qt4-qt_help.qm
 %lang(da) %{_localedir}/da/LC_MESSAGES/qt4-qt_help.qm
 %lang(de) %{_localedir}/de/LC_MESSAGES/qt4-qt_help.qm
+%lang(eu) %{_localedir}/eu/LC_MESSAGES/qt4-qt_help.qm
 %lang(fr) %{_localedir}/fr/LC_MESSAGES/qt4-qt_help.qm
 %lang(gl) %{_localedir}/gl/LC_MESSAGES/qt4-qt_help.qm
 %lang(hu) %{_localedir}/hu/LC_MESSAGES/qt4-qt_help.qm
@@ -2025,11 +2226,19 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %ghost %{_libdir}/libQtOpenGL.so.4
 %attr(755,root,root) %{_qtdir}/plugins/graphicssystems/libqglgraphicssystem.so
 
+%if %{with openvg}
+%files -n QtOpenVG
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libQtOpenVG.so.*.*
+%attr(755,root,root) %ghost %{_libdir}/libQtOpenVG.so.4
+%endif
+
 %files -n QtScript
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libQtScript.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libQtScript.so.4
 %dir %{_qtdir}/plugins/script
+%lang(eu) %{_localedir}/eu/LC_MESSAGES/qt4-qtscript.qm
 
 %files -n QtScriptTools
 %defattr(644,root,root,755)
@@ -2042,12 +2251,30 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %ghost %{_libdir}/libQtSql.so.4
 %dir %{_qtdir}/plugins/sqldrivers
 
+%if %{with ibase}
+%files -n QtSql-ibase
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_qtdir}/plugins/sqldrivers/libqsqlibase.so
+%endif
+
 %if %{with mysql}
 %files -n QtSql-mysql
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_qtdir}/plugins/sqldrivers/libqsqlmysql.so
 %endif
 
+%if %{with oci}
+%files -n QtSql-oci
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_qtdir}/plugins/sqldrivers/libqsqloci.so
+%endif
+
+%if %{with odbc}
+%files -n QtSql-odbc
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_qtdir}/plugins/sqldrivers/libqsqlodbc.so
+%endif
+
 %if %{with pgsql}
 %files -n QtSql-pgsql
 %defattr(644,root,root,755)
@@ -2066,18 +2293,6 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_qtdir}/plugins/sqldrivers/libqsqlite.so
 %endif
 
-%if %{with ibase}
-%files -n QtSql-ibase
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_qtdir}/plugins/sqldrivers/libqsqlibase.so
-%endif
-
-%if %{with odbc}
-%files -n QtSql-odbc
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_qtdir}/plugins/sqldrivers/libqsqlodbc.so
-%endif
-
 %files -n QtSql-tds
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_qtdir}/plugins/sqldrivers/libqsqltds.so
@@ -2128,6 +2343,7 @@ rm -rf $RPM_BUILD_ROOT
 %lang(cs) %{_localedir}/cs/LC_MESSAGES/qt4-assistant.qm
 %lang(da) %{_localedir}/da/LC_MESSAGES/qt4-assistant.qm
 %lang(de) %{_localedir}/de/LC_MESSAGES/qt4-assistant.qm
+%lang(eu) %{_localedir}/eu/LC_MESSAGES/qt4-assistant.qm
 %lang(fr) %{_localedir}/fr/LC_MESSAGES/qt4-assistant.qm
 %lang(hu) %{_localedir}/hu/LC_MESSAGES/qt4-assistant.qm
 %lang(ja) %{_localedir}/ja/LC_MESSAGES/qt4-assistant.qm
@@ -2177,6 +2393,10 @@ rm -rf $RPM_BUILD_ROOT
 %{_desktopdir}/designer-qt4.desktop
 %{_pixmapsdir}/designer-qt4.png
 
+%files devel-private
+%defattr(644,root,root,755)
+%{_includedir}/qt4/private
+
 %files linguist
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/findtr-qt4
@@ -2190,7 +2410,9 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_qtdir}/bin/lupdate
 %lang(cs) %{_localedir}/cs/LC_MESSAGES/qt4-linguist.qm
 %lang(de) %{_localedir}/de/LC_MESSAGES/qt4-linguist.qm
+%lang(eu) %{_localedir}/eu/LC_MESSAGES/qt4-linguist.qm
 %lang(fr) %{_localedir}/fr/LC_MESSAGES/qt4-linguist.qm
+%lang(he) %{_localedir}/he/LC_MESSAGES/qt4-linguist.qm
 %lang(hu) %{_localedir}/hu/LC_MESSAGES/qt4-linguist.qm
 %lang(ja) %{_localedir}/ja/LC_MESSAGES/qt4-linguist.qm
 %lang(ko) %{_localedir}/ko/LC_MESSAGES/qt4-linguist.qm
@@ -2224,6 +2446,8 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qtconfig-qt4
 %attr(755,root,root) %{_qtdir}/bin/qtconfig
+%lang(eu) %{_localedir}/eu/LC_MESSAGES/qt4-qtconfig.qm
+%lang(he) %{_localedir}/he/LC_MESSAGES/qt4-qtconfig.qm
 %lang(hu) %{_localedir}/hu/LC_MESSAGES/qt4-qtconfig.qm
 %lang(ja) %{_localedir}/ja/LC_MESSAGES/qt4-qtconfig.qm
 %lang(ko) %{_localedir}/ko/LC_MESSAGES/qt4-qtconfig.qm
@@ -2240,6 +2464,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qvfb
 %attr(755,root,root) %{_qtdir}/bin/qvfb
+%lang(eu) %{_localedir}/eu/LC_MESSAGES/qt4-qvfb.qm
 %lang(hu) %{_localedir}/hu/LC_MESSAGES/qt4-qvfb.qm
 %lang(ja) %{_localedir}/ja/LC_MESSAGES/qt4-qvfb.qm
 %lang(ko) %{_localedir}/ko/LC_MESSAGES/qt4-qvfb.qm
@@ -2253,7 +2478,6 @@ rm -rf $RPM_BUILD_ROOT
 %files doc
 %defattr(644,root,root,755)
 %{_docdir}/%{name}-doc
-%{_qtdir}/doc
 
 %files -n QtCLucene-devel -f QtCLucene-devel.files
 %defattr(644,root,root,755)
@@ -2265,6 +2489,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n QtCore-devel -f QtCore-devel.files
 %defattr(644,root,root,755)
+%dir %{_includedir}/qt4/QtSolutions
 
 %files -n QtDBus-devel -f QtDBus-devel.files
 %defattr(644,root,root,755)
@@ -2290,6 +2515,11 @@ rm -rf $RPM_BUILD_ROOT
 %files -n QtOpenGL-devel -f QtOpenGL-devel.files
 %defattr(644,root,root,755)
 
+%if %{with openvg}
+%files -n QtOpenVG-devel -f QtOpenVG-devel.files
+%defattr(644,root,root,755)
+%endif
+
 %files -n QtScript-devel -f QtScript-devel.files
 %defattr(644,root,root,755)
 
@@ -2364,6 +2594,12 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/libQtOpenGL.a
 
+%if %{with openvg}
+%files -n QtOpenVG-static
+%defattr(644,root,root,755)
+%{_libdir}/libQtOpenVG.a
+%endif
+
 %files -n QtScript-static
 %defattr(644,root,root,755)
 %{_libdir}/libQtScript.a
This page took 0.051274 seconds and 4 git commands to generate.