]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu.spec
patch vga bios to support additional widescreen modes (1600x1000, 1600x900). it looks...
[packages/qemu.git] / qemu.spec
index 8f46f52a2b5a868ba94d2803daee9ed3a6cc6478..2181bec5e4ee77ca2f3264d3daa30364aabe4868 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -1,64 +1,68 @@
-#
 # TODO:
-# - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
+# - package virtfs-proxy-helper, qemu-bridge-helper.
+# - package qemu-system-or32
+# - update patches
+# - qemu-system-ppc -hda ac-ppc.img says:
+#   qemu: could not open disk image ac-ppc.img: error "Success"
+#   qemu-0.12.2-2.x86_64.rpm - broken
+#   qemu-0.12.3-3.x86_64/qemu-0.12.4-1.x86_64 - stops on "returning from prom_init"
+#   qemu-0.15.0-2.x86_64.rpm - qemu-system-sparc/ppc booting with -kernel, -initrd options stalls in openbios prompt
+#   qemu-0.11.1-*.x86_64.rpm - OK
 #
 # Conditional build:
-%bcond_with    kqemu                   # with QEMU accelerator module
-%bcond_with    cflags_passing          # with passing rpmcflags to Makefiles
 %bcond_with    nosdlgui                # do not use SDL gui (use X11 instead)
-%bcond_with    gcc4                    # use gcc4 patches (broke build on gcc33)
-%bcond_without dist_kernel             # without distribution kernel
-%bcond_without kernel                  # don't build kernel modules
-%bcond_without smp                     # don't build SMP module
-%bcond_without userspace               # don't build userspace utilities
-#
-%if %{without kqemu}
-%undefine      with_kernel
-%endif
-#
-%define        _kqemu_version  1.3.0pre7
-%define                _rel    1.2
+
 Summary:       QEMU CPU Emulator
-Summary(pl):   QEMU - emulator procesora
+Summary(pl.UTF-8):     QEMU - emulator procesora
 Name:          qemu
-Version:       0.8.0
-Release:       %{_rel}%{?with_kqemu:k}
+Version:       1.2.0
+Release:       1
 License:       GPL
 Group:         Applications/Emulators
-#Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
-Source0:       http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
-# Source0-md5: eb175b26583280706fe7e4d8910d320d
-Source1:       http://fabrice.bellard.free.fr/qemu/kqemu-%{_kqemu_version}.tar.gz
-# NoSource1-md5:       3b77edbada790f924456aa4675edd0be
-NoSource:      1
-Patch0:                %{name}-nostatic.patch
-Patch1:                %{name}-DESTDIR.patch
-Patch2:                %{name}-longjmp.patch
-Patch3:                %{name}-dot.patch
-Patch4:                %{name}-initrd_load_addr.patch
-Patch5:                %{name}-gcc4_x86.patch
-Patch6:                %{name}-gcc4_ppc.patch
-Patch7:                %{name}-parallel.patch
-Patch8:                %{name}-nosdlgui.patch
-Patch9:                %{name}-ifup.patch
-Patch10:       %{name}-gcc33.patch
-Patch11:       %{name}-slirp_throttle.patch
-URL:           http://fabrice.bellard.free.fr/qemu/
+Source0:       http://wiki.qemu.org/download/%{name}-%{version}.tar.bz2
+# Source0-md5: 78eb1e984f4532aa9f2bdd3c127b5b61
+Patch0:                %{name}-cflags.patch
+Patch1:                vgabios-widescreens.patch
+Patch6:                %{name}-nosdlgui.patch
+# Proof of concept, for reference, do not remove
+Patch8:                %{name}-kde_virtual_workspaces_hack.patch
+Patch17:       %{name}-whitelist.patch
+URL:           http://wiki.qemu.org/Index.html
 BuildRequires: SDL-devel >= 1.2.1
 BuildRequires: alsa-lib-devel
-%{!?with_gcc4:BuildRequires:   gcc < 5:4.0}
-%if %{with kqemu} && %{with dist_kernel}
-BuildRequires: kernel-module-build >= 3:2.6.7
-%endif
-BuildRequires: rpmbuild(macros) >= 1.217
+BuildRequires: bluez-libs-devel
+BuildRequires: gnutls-devel
+BuildRequires: ncurses-devel
+BuildRequires: perl-Encode
+BuildRequires: perl-tools-pod
+BuildRequires: pkgconfig
 BuildRequires: sed >= 4.0
-Requires:      SDL >= 1.2.1
+BuildRequires: texi2html
+BuildRequires: texinfo
+BuildRequires: which
+BuildRequires: xen-devel
+BuildRequires: xorg-lib-libX11-devel
+Requires:      %{name}-img = %{version}-%{release}
+Requires:      %{name}-system-alpha = %{version}-%{release}
+Requires:      %{name}-system-arm = %{version}-%{release}
+Requires:      %{name}-system-cris = %{version}-%{release}
+Requires:      %{name}-system-lm32 = %{version}-%{release}
+Requires:      %{name}-system-m68k = %{version}-%{release}
+Requires:      %{name}-system-microblaze = %{version}-%{release}
+Requires:      %{name}-system-mips = %{version}-%{release}
+Requires:      %{name}-system-ppc = %{version}-%{release}
+Requires:      %{name}-system-s390x = %{version}-%{release}
+Requires:      %{name}-system-sh4 = %{version}-%{release}
+Requires:      %{name}-system-sparc = %{version}-%{release}
+Requires:      %{name}-system-x86 = %{version}-%{release}
+Requires:      %{name}-system-xtensa = %{version}-%{release}
+Requires:      %{name}-user = %{version}-%{release}
 # sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
-ExclusiveArch: %{ix86} %{x8664} %{!?with_kqemu:ppc}
+ExclusiveArch: %{ix86} %{x8664} %{?with_userspace:ppc}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-# some SPARC boot image in ELF format
-%define                _noautostrip    .*%{_datadir}/qemu/proll.elf
+# some PPC/SPARC boot image in ELF format
+%define                _noautostrip    .*%{_datadir}/qemu/.*-.*
 
 %description
 QEMU is a FAST! processor emulator. By using dynamic translation it
@@ -74,216 +78,361 @@ CPUs. QEMU has two operating modes:
   including a processor and various peripherials. It can also be used to
   provide virtual hosting of several virtual PC on a single server.
 
-%description -l pl
-QEMU to szybki(!) emulator procesora. Poprzez u¿ycie dynamicznego
-t³umaczenia osi±ga rozs±dn± szybko¶æ i jest ³atwy do przeportowania,
-aby dzia³a³ na kolejnych procesorach. QEMU ma dwa tryby pracy:
+%description -l pl.UTF-8
+QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
+tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
+aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
 
-- Emulacja trybu u¿ytkownika. W tym trybie QEMU mo¿e uruchamiaæ
+- Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
   procesy linuksowe skompilowane dla jednego procesora na innym
-  procesorze. Linuksowe wywo³ania systemowe s± t³umaczone ze wzglêdu na
-  niezgodno¶æ kolejno¶ci bajtów w s³owie i 32/64-bitowego rozmiaru
-  s³owa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to g³ówne
+  procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
+  niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
+  słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
   cele QEMU.
 
-- Pe³na emulacja systemu. W tym trybie QEMU emuluje ca³y system,
-  w³±czaj±c w to procesor i ró¿ne urz±dzenia peryferyjne. Mo¿e byæ tak¿e
-  u¿ywane do wirtualnego hostowania kilku wirtualnych pecetów na
+- Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
+  włączając w to procesor i różne urządzenia peryferyjne. Może być także
+  używane do wirtualnego hostowania kilku wirtualnych pecetów na
   pojedynczym serwerze.
 
-%package -n kernel-misc-kqemu
-Summary:       kqemu - kernel module
-Summary(pl):   kqemu - modu³ j±dra
-Version:       %{_kqemu_version}
-Release:       %{_rel}@%{_kernel_ver_str}
-Group:         Base/Kernel
-%{?with_dist_kernel:%requires_releq_kernel_up}
-License:       Free to use, non-distributable
-Requires(post,postun): /sbin/depmod
-Requires:      module-init-tools >= 3.2.2-2
-
-%description -n kernel-misc-kqemu
-kqemu - kernel module.
-
-%description -n kernel-misc-kqemu -l pl
-kqemu - modu³ j±dra.
-
-%package -n kernel-smp-misc-kqemu
-Summary:       kqemu - SMP kernel module
-Summary(pl):   kqemu - modu³ j±dra SMP
-Version:       %{_kqemu_version}
-Release:       %{_rel}@%{_kernel_ver_str}
-Group:         Base/Kernel
-%{?with_dist_kernel:%requires_releq_kernel_up}
-License:       Free to use, non-distributable
-Requires(post,postun): /sbin/depmod
-Requires:      module-init-tools >= 3.2.2-2
-
-%description -n kernel-smp-misc-kqemu
-kqemu - SMP kernel module.
-
-%description -n kernel-smp-misc-kqemu -l pl
-kqemu - modu³ j±dra SMP.
+%package  common
+Summary:       QEMU common files needed by all QEMU targets
+Group:         Development/Tools
+Requires:      SDL >= 1.2.1
+Conflicts:     qemu < 1.0-2
+
+%description common
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the common files needed by all QEMU targets.
+
+%package  img
+Summary:       QEMU command line tool for manipulating disk images
+Group:         Development/Tools
+Conflicts:     qemu < 1.0-2
+
+%description img
+This package provides a command line tool for manipulating disk images
+
+%package user
+Summary:       QEMU user mode emulation of qemu targets
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+
+%description user
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the user mode emulation of QEMU targets.
+
+%package system-alpha
+Summary:       QEMU system emulator for alpha
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+
+%description system-alpha
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator for alpha.
+
+%package system-arm
+Summary:       QEMU system emulator for arm
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+
+%description system-arm
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator for arm.
+
+%package system-cris
+Summary:       QEMU system emulator for cris
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+
+%description system-cris
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator for cris.
+
+%package system-lm32
+Summary:       QEMU system emulator for lm32
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+
+%description system-lm32
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator for lm32.
+
+%package system-m68k
+Summary:       QEMU system emulator for m68k
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+
+%description system-m68k
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator for m68k.
+
+%package system-microblaze
+Summary:       QEMU system emulator for microblaze
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+
+%description system-microblaze
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator for microblaze.
+
+%package system-mips
+Summary:       QEMU system emulator for mips
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+
+%description system-mips
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator for mips.
+
+%package system-ppc
+Summary:       QEMU system emulator for ppc
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+
+%description system-ppc
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator for ppc.
+
+%package system-s390x
+Summary:       QEMU system emulator for s390x
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+
+%description system-s390x
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator for s390x.
+
+%package system-sh4
+Summary:       QEMU system emulator for sh4
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+
+%description system-sh4
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator for sh4.
+
+%package system-sparc
+Summary:       QEMU system emulator for sparc
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+
+%description system-sparc
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator for sparc/sparc64.
+
+%package system-x86
+Summary:       QEMU system emulator for x86
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+
+%description system-x86
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator for x86. When being run in a
+x86 machine that supports it, this package also provides the KVM
+virtualization platform.
+
+%package system-xtensa
+Summary:       QEMU system emulator for xtensa
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+
+%description system-xtensa
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator for xtensa.
 
 %prep
-%setup -q %{?with_kqemu:-a1}
+%setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
-%patch3 -p1
-%patch4 -p1
-%if %{with gcc4}
-%patch5 -p0
-%patch6 -p1
-%endif
-# probably not needed
-# %patch7 -p1
-%{?with_nosdlgui:%patch8 -p1}
-%patch9 -p1
-%patch10 -p1
-%patch11 -p0
-
-%{__sed} -i -e 's/sdl_static=yes/sdl_static=no/' configure
-%{__sed} -i 's/.*MAKE) -C kqemu$//' Makefile
-
-# cannot use optflags on x86 - they cause "no register to spill" errors
-%if %{with cflags_passing}
-%{__sed} -i -e 's/-Wall -O2 -g/-Wall %{rpmcflags}/' Makefile Makefile.target
-%else
-%{__sed} -i 's/-Wall -O2 -g/-Wall -O2/' Makefile Makefile.target
-%endif
-
-%if %{with kqemu}
-echo -n > kqemu-%{_kqemu_version}/install.sh
-%endif
+%{?with_nosdlgui:%patch6 -p1}
+#patch8 -p1
+%patch17 -p0
+
+# workaround for conflict with alsa/error.h
+ln -s ../error.h qapi/error.h
 
 %build
-%if %{with kernel}
-cd kqemu-%{_kqemu_version}
-mv -f kqemu-linux.c{,.orig}
-for cfg in %{?with_dist_kernel:%{?with_smp:smp} up}%{!?with_dist_kernel:nondist}; do
-       if [ ! -r "%{_kernelsrcdir}/config-$cfg" ]; then
-               exit 1
-       fi
-       install -d o/include/linux
-       ln -sf %{_kernelsrcdir}/config-$cfg o/.config
-       ln -sf %{_kernelsrcdir}/Module.symvers-$cfg o/Module.symvers
-       ln -sf %{_kernelsrcdir}/include/linux/autoconf-$cfg.h o/include/linux/autoconf.h
-%if %{with dist_kernel}
-       %{__make} -C %{_kernelsrcdir} O=$PWD/o prepare scripts
-%else
-       install -d o/include/config
-       touch o/include/config/MARKER
-       ln -sf %{_kernelsrcdir}/scripts o/scripts
-%endif
-       if grep -q "^CONFIG_PREEMPT_RT=y$" o/.config; then
-               sed 's/SPIN_LOCK_UNLOCKED/SPIN_LOCK_UNLOCKED(kqemu_lock)/' \
-                       kqemu-linux.c.orig > kqemu-linux.c
-       else
-               cat kqemu-linux.c.orig > kqemu-linux.c
-       fi
-
-       %{__make} -C %{_kernelsrcdir} modules \
-               CC="%{__cc}" CPP="%{__cpp}" \
-               M=$PWD O=$PWD/o \
-               %{?with_verbose:V=1}
-       mv kqemu.ko kqemu-mod-$cfg.ko
-done
-cd -
-%endif
-
-%if %{with userspace}
-# --extra-cflags don't work (overridden by CFLAGS in Makefile*)
-# they can be passed if the cflags_passing bcond is used
 ./configure \
+       --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
+       --extra-ldflags="%{rpmldflags}" \
+       --disable-strip \
+       --sysconfdir=%{_sysconfdir} \
        --prefix=%{_prefix} \
        --cc="%{__cc}" \
-       %{?with_gcc4:--disable-gcc-check} \
-       %{!?with_kqemu:--disable-kqemu} \
-       --enable-alsa \
-       --make="%{__make}" \
+       --host-cc="%{__cc}" \
+       --enable-mixemu \
+       --audio-drv-list="alsa" \
        --interp-prefix=%{_libdir}/%{name}
-%{__make}
-%endif
+%{__make} V=1
+
+# rebuild patched vesa tables with additional widescreen modes.
+%{__make} -C roms/vgabios stdvga-bios
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%if %{with userspace}
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install -d $RPM_BUILD_ROOT/sbin
-cat <<'EOF' > $RPM_BUILD_ROOT/sbin/qemu-ifup
+install -d $RPM_BUILD_ROOT%{_sysconfdir}
+cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
 #!/bin/sh
-if [ -f /etc/sysconfig/qemu ]; then
-       . /etc/sysconfig/qemu
-fi
-# of course this will work only for one interface. a lot possible to involve
-sudo /sbin/ifconfig $1 ${INTERFACE_ADDR:-172.20.0.1}
-EOF
-%endif
-
-%if %{with kernel}
-install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}{,smp}/misc
-install kqemu-%{_kqemu_version}/kqemu-mod-up.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc/kqemu.ko
-%if %{with smp} && %{with dist_kernel}
-install kqemu-%{_kqemu_version}/kqemu-mod-smp.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/misc/kqemu.ko
-%endif
-install -d $RPM_BUILD_ROOT/etc/modprobe.d
-echo 'alias char-major-250 kqemu' > $RPM_BUILD_ROOT/etc/modprobe.d/kqemu.conf
-%endif
 
-%clean
-rm -rf $RPM_BUILD_ROOT
-
-%if %{with kqemu}
-%post
-%banner %{name} -e <<EOF
-To enable qemu accelerator (kqemu), the kqemu kernel module must be loaded:
-modprobe kqemu
 EOF
-%endif
 
-%post  -n kernel-misc-kqemu
-%depmod %{_kernel_ver}
+# already packaged
+rm -rf $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
 
-%postun -n kernel-misc-kqemu
-%depmod %{_kernel_ver}
+# install patched vesa tables with additional widescreen modes.
+install -m 644 roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
 
-%post  -n kernel-smp-misc-kqemu
-%depmod %{_kernel_ver}smp
-
-%postun -n kernel-smp-misc-kqemu
-%depmod %{_kernel_ver}smp
+%clean
+rm -rf $RPM_BUILD_ROOT
 
-%if %{with userspace}
 %files
 %defattr(644,root,root,755)
+
+%files common
+%defattr(644,root,root,755)
 %doc README qemu-doc.html qemu-tech.html
-%attr(755,root,root) /sbin/qemu-ifup
-%attr(755,root,root) %{_bindir}/*
-%{_datadir}/qemu
+%attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
+%dir %{_sysconfdir}/qemu
+%attr(755,root,root) %{_bindir}/qemu-nbd
 %{_mandir}/man1/qemu.1*
+%{_mandir}/man8/qemu-nbd.8*
+
+%dir %{_datadir}/qemu
+%{_datadir}/%{name}/cpus-*.conf
+%{_datadir}/%{name}/keymaps
+# various bios images
+%{_datadir}/%{name}/*.bin
+%{_datadir}/%{name}/*.rom
+%{_datadir}/%{name}/*.dtb
+%{_datadir}/%{name}/openbios-ppc
+%{_datadir}/%{name}/openbios-sparc*
+%{_datadir}/%{name}/palcode-clipper
+
+%files img
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-img
 %{_mandir}/man1/qemu-img.1*
-# FIXME: maybe better moved this into dev.spec
-%if %{with kqemu}
-%dev(c,250,0) %attr(666,root,root) /dev/kqemu
-%endif
-%endif
-
-%if %{with kernel}
-%files -n kernel-misc-kqemu
+
+%files user
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-x86_64
+%attr(755,root,root) %{_bindir}/qemu-i386
+%attr(755,root,root) %{_bindir}/qemu-alpha
+%attr(755,root,root) %{_bindir}/qemu-arm
+%attr(755,root,root) %{_bindir}/qemu-armeb
+%attr(755,root,root) %{_bindir}/qemu-cris
+%attr(755,root,root) %{_bindir}/qemu-ga
+%attr(755,root,root) %{_bindir}/qemu-io
+%attr(755,root,root) %{_bindir}/qemu-m68k
+%attr(755,root,root) %{_bindir}/qemu-microblaze
+%attr(755,root,root) %{_bindir}/qemu-microblazeel
+%attr(755,root,root) %{_bindir}/qemu-mips
+%attr(755,root,root) %{_bindir}/qemu-mipsel
+%attr(755,root,root) %{_bindir}/qemu-ppc
+%attr(755,root,root) %{_bindir}/qemu-ppc64
+%attr(755,root,root) %{_bindir}/qemu-ppc64abi32
+%attr(755,root,root) %{_bindir}/qemu-s390x
+%attr(755,root,root) %{_bindir}/qemu-sh4
+%attr(755,root,root) %{_bindir}/qemu-sh4eb
+%attr(755,root,root) %{_bindir}/qemu-sparc
+%attr(755,root,root) %{_bindir}/qemu-sparc32plus
+%attr(755,root,root) %{_bindir}/qemu-sparc64
+%attr(755,root,root) %{_bindir}/qemu-unicore32
+
+%files system-alpha
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-alpha
+
+%files system-arm
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-arm
+
+%files system-cris
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-cris
+
+%files system-lm32
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-lm32
+
+%files system-m68k
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-m68k
+
+%files system-microblaze
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-microblaze
+%attr(755,root,root) %{_bindir}/qemu-system-microblazeel
+
+%files system-mips
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-mips
+%attr(755,root,root) %{_bindir}/qemu-system-mipsel
+%attr(755,root,root) %{_bindir}/qemu-system-mips64
+%attr(755,root,root) %{_bindir}/qemu-system-mips64el
+
+%files system-ppc
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-ppc
+%attr(755,root,root) %{_bindir}/qemu-system-ppc64
+%attr(755,root,root) %{_bindir}/qemu-system-ppcemb
+
+%files system-s390x
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-s390x
+
+%files system-sh4
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-sh4
+%attr(755,root,root) %{_bindir}/qemu-system-sh4eb
+
+%files system-sparc
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-sparc
+%attr(755,root,root) %{_bindir}/qemu-system-sparc64
+
+%files system-x86
 %defattr(644,root,root,755)
-%doc kqemu-%{_kqemu_version}/LICENSE
-%config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/kqemu.conf
-/lib/modules/%{_kernel_ver}/misc/kqemu.ko*
+%attr(755,root,root) %{_bindir}/qemu-system-i386
+%attr(755,root,root) %{_bindir}/qemu-system-x86_64
 
-%if %{with smp} && %{with dist_kernel}
-%files -n kernel-smp-misc-kqemu
+%files system-xtensa
 %defattr(644,root,root,755)
-%doc kqemu-%{_kqemu_version}/LICENSE
-%config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/kqemu.conf
-/lib/modules/%{_kernel_ver}smp/misc/kqemu.ko*
-%endif
-%endif
+%attr(755,root,root) %{_bindir}/qemu-system-xtensa
+%attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
This page took 0.114924 seconds and 4 git commands to generate.