]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu.spec
- release 3
[packages/qemu.git] / qemu.spec
index f260dcb3536958ce36d0b623189a53a67240721e..edc7e4ec501e34975993df2e9f096fbf92e9c18e 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -1,25 +1,15 @@
 #
 # TODO:
-# - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
+# - update patches
 #
 # Conditional build:
 %bcond_without kqemu                   # disable KQEMU ACCELERATOR support in QEMU
 %bcond_with    cflags_passing          # with passing rpmcflags to Makefiles
 %bcond_with    dosguest                # add special patch when use with DOS as guest os
 %bcond_with    nosdlgui                # do not use SDL gui (use X11 instead)
-# Note that gcc4 build is very problematic and not supported by qemu team
-%bcond_without gcc4                    # use gcc4 patches (broke build on gcc33)
 %bcond_without dist_kernel             # without distribution kernel
 %bcond_without kernel                  # build kqemu KERNEL MODULES
-%bcond_without userspace               # don't build userspace
-%bcond_with    grsec_kernel    # build for kernel-grsecurity
-
-%if %{without kernel}
-%undefine      with_dist_kernel
-%endif
-%if %{with dist_kernel} && %{with grsec_kernel}
-%define        alt_kernel      grsecurity
-%endif
+%bcond_without userspace               # don't build userspace utilities
 
 # no kernel kqemu module for ppc
 %ifarch ppc
 %undefine      with_kernel
 %endif
 
+%if %{without kernel}
+%undefine      with_dist_kernel
+%endif
 %if "%{_alt_kernel}" != "%{nil}"
 %undefine      with_userspace
 %endif
+%if %{without userspace}
+# nothing to be placed to debuginfo package
+%define                _enable_debug_packages  0
+%endif
 
-%define                kqemu_version   1.3.0pre11
-%define                qemu_version    0.9.1
-%define                pname   qemu
+%define                rel     3
 
-%define                rel     5
+%define                kqemu_version   1.4.0pre1
+%define                qemu_version    0.11.1
+%define                pname   qemu
 Summary:       QEMU CPU Emulator
 Summary(pl.UTF-8):     QEMU - emulator procesora
 Name:          %{pname}%{_alt_kernel}
@@ -43,25 +40,23 @@ Version:    %{qemu_version}
 Release:       %{rel}%{?with_kqemu:k}
 License:       GPL
 Group:         Applications/Emulators
-#Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
-Source0:       http://fabrice.bellard.free.fr/qemu/%{pname}-%{version}.tar.gz
-# Source0-md5: 6591df8e9270eb358c881de4ebea1262
-Source1:       http://fabrice.bellard.free.fr/qemu/k%{pname}-%{kqemu_version}.tar.gz
-# Source1-md5: 970521874ef8b1ba4598925ace5936c3
-Patch0:                %{pname}-nostatic.patch
-Patch1:                %{pname}-cc.patch
-Patch3:                %{pname}-dot.patch
-Patch4:                %{pname}-gcc4_x86.patch
-Patch5:                %{pname}-gcc4_ppc.patch
+# Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
+Source0:       http://download.savannah.gnu.org/releases/qemu/%{pname}-%{version}.tar.gz
+# Source0-md5: 193285b0bcf655a7f7577d05ffcb82b1
+Source1:       http://www.nongnu.org/qemu/k%{pname}-%{kqemu_version}.tar.gz
+# Source1-md5: d738d8ca7332211ab716ec3213d82ee1
+Patch0:                %{pname}-ncurses.patch
 Patch6:                %{pname}-nosdlgui.patch
 # Proof of concept, for reference, do not remove
 Patch8:                %{pname}-kde_virtual_workspaces_hack.patch
-# http://gwenole.beauchesne.info/en/projects/qemu
-Patch9:                %{pname}-0.8.0-gcc4-hacks.patch
-Patch11:       %{pname}-0.7.2-gcc4-opts.patch
 #Patch12:      %{pname}-0.7.2-dyngen-check-stack-clobbers.patch
 Patch13:       %{pname}-dosguest.patch
-URL:           http://fabrice.bellard.free.fr/qemu/
+Patch14:       %{pname}-ppc_old_binutils.patch
+Patch15:       %{pname}-isa-bios-ram.patch
+# below one fixes problems with passing ram size to bios/bootloader
+# which affects coreboot/linuxbios
+Patch16:       %{pname}-piix-ram-size.patch
+URL:           http://www.nongnu.org/qemu/
 %if %{with kernel} && %{with dist_kernel}
 BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7
 BuildRequires: rpmbuild(macros) >= 1.379
@@ -69,19 +64,25 @@ BuildRequires:      rpmbuild(macros) >= 1.379
 %if %{with userspace}
 BuildRequires: SDL-devel >= 1.2.1
 BuildRequires: alsa-lib-devel
-%{!?with_gcc4:BuildRequires:   gcc < 5:4.0}
+BuildRequires: bluez-libs-devel
+BuildRequires: gnutls-devel
+BuildRequires: ncurses-devel
+BuildRequires: perl-Encode
 BuildRequires: perl-tools-pod
+BuildRequires: pkgconfig
 BuildRequires: sed >= 4.0
-BuildRequires: tetex
+BuildRequires: texi2html
+BuildRequires: texinfo-texi2dvi
 BuildRequires: which
+BuildRequires: xorg-lib-libX11-devel
 %endif
 Requires:      SDL >= 1.2.1
 # sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
 ExclusiveArch: %{ix86} %{x8664} %{?with_userspace:ppc}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-# some SPARC boot image in ELF format
-%define                _noautostrip    .*%{_datadir}/qemu/openbios-sparc32
+# some PPC/SPARC boot image in ELF format
+%define                _noautostrip    .*%{_datadir}/qemu/openbios-.*
 
 %description
 QEMU is a FAST! processor emulator. By using dynamic translation it
@@ -134,16 +135,7 @@ kqemu - moduł jądra.
 
 %prep
 %setup -q -n %{pname}-%{qemu_version} %{?with_kernel:-a1}
-%patch0 -p1
-%patch1 -p1
-%patch3 -p1
-%if %{with gcc4}
-%patch9 -p1
-%patch11 -p1
-#%patch12 -p1
-#%patch4 -p0
-%patch5 -p1
-%endif
+%patch0 -p0
 %{?with_nosdlgui:%patch6 -p1}
 #%patch8 -p1
 
@@ -171,15 +163,22 @@ cat <<'EOF' > udev.conf
 KERNEL=="kqemu", NAME="%k", MODE="0666"
 EOF
 
+%if %{with dosguest}
+%patch13 -p1
+%endif
+%patch14 -p1
+#%patch15 -p1
+%patch16 -p1
+
 cd kqemu-%{kqemu_version}
 %{__sed} -i 's#include ../config-host.mak##' ./common/Makefile
 %ifarch %{x8664}
 %{__sed} -i 's/^#ARCH=x86_64/ARCH=x86_64/' ./common/Makefile
-%{__make} -j1 -C common
+%{__make} -C common -j1
 mv -f kqemu-mod-x86_64.o{,.bin}
 %else
 %{__sed} -i 's/^#ARCH=i386/ARCH=i386/' ./common/Makefile
-%{__make} -j1 -C common
+%{__make} -C common -j1
 mv -f kqemu-mod-i386.o{,.bin}
 %endif
 
@@ -194,10 +193,6 @@ EOF
 cd -
 %endif
 
-%if %{with dosguest}
-%patch13 -p1
-%endif
-
 %build
 %if %{with kernel}
 cd kqemu-%{kqemu_version}
@@ -220,13 +215,11 @@ cd -
        --cc="%{__cc}" \
        --host-cc="%{__cc}" \
        --make="%{__make}" \
-%if %{with kqemu}
-       --kernel-path=%{_kernelsrcdir} \
-%else
+%if %{without kqemu}
        --disable-kqemu \
 %endif
-       %{?with_gcc4:--disable-gcc-check} \
-       --enable-alsa \
+       --enable-mixemu \
+       --audio-drv-list="alsa" \
        --interp-prefix=%{_libdir}/%{pname}
 %{__make}
 %endif
@@ -281,6 +274,7 @@ EOF
 %{_datadir}/qemu
 %{_mandir}/man1/qemu.1*
 %{_mandir}/man1/qemu-img.1*
+%{_mandir}/man8/qemu-nbd.8*
 %endif
 
 %if %{with kernel}
This page took 0.067248 seconds and 4 git commands to generate.