]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu.spec
- rel 4
[packages/qemu.git] / qemu.spec
index 49af1ef14fe5007afd4f9c1ac850d8170dc6b9d7..7de620304e77cb472694b891d2cb466456417f6a 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -1,7 +1,6 @@
 #
 # TODO:
-# - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
-# - update or drop gcc4 bcond patches
+# - update patches
 #
 # Conditional build:
 %bcond_without kqemu                   # disable KQEMU ACCELERATOR support in QEMU
 %define                _enable_debug_packages  0
 %endif
 
-%define                __ucc   gcc-3.4
+%define                rel     4
 
-%define                rel     10
-
-%define                kqemu_version   1.3.0pre11
-%define                qemu_version    0.9.1
+%define                kqemu_version   1.4.0pre1
+%define                qemu_version    0.11.1
 %define                pname   qemu
 Summary:       QEMU CPU Emulator
 Summary(pl.UTF-8):     QEMU - emulator procesora
@@ -44,13 +41,11 @@ Release:    %{rel}%{?with_kqemu:k}
 License:       GPL
 Group:         Applications/Emulators
 # Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
-Source0:       http://bellard.org/qemu/%{pname}-%{version}.tar.gz
-# Source0-md5: 6591df8e9270eb358c881de4ebea1262
-Source1:       http://bellard.org/qemu/k%{pname}-%{kqemu_version}.tar.gz
-# Source1-md5: 970521874ef8b1ba4598925ace5936c3
-Patch0:                %{pname}-nostatic.patch
-Patch1:                %{pname}-cc.patch
-Patch3:                %{pname}-dot.patch
+Source0:       http://download.savannah.gnu.org/releases/qemu/%{pname}-%{version}.tar.gz
+# Source0-md5: 193285b0bcf655a7f7577d05ffcb82b1
+Source1:       http://www.nongnu.org/qemu/k%{pname}-%{kqemu_version}.tar.gz
+# Source1-md5: d738d8ca7332211ab716ec3213d82ee1
+Patch0:                %{pname}-ncurses.patch
 Patch6:                %{pname}-nosdlgui.patch
 # Proof of concept, for reference, do not remove
 Patch8:                %{pname}-kde_virtual_workspaces_hack.patch
@@ -61,9 +56,7 @@ Patch15:      %{pname}-isa-bios-ram.patch
 # below one fixes problems with passing ram size to bios/bootloader
 # which affects coreboot/linuxbios
 Patch16:       %{pname}-piix-ram-size.patch
-Patch17:       %{pname}-CVE-2008-0928.patch
-Patch18:       %{pname}-CVE-2008-2004.patch
-URL:           http://bellard.org/qemu/
+URL:           http://www.nongnu.org/qemu/
 %if %{with kernel} && %{with dist_kernel}
 BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7
 BuildRequires: rpmbuild(macros) >= 1.379
@@ -71,19 +64,25 @@ BuildRequires:      rpmbuild(macros) >= 1.379
 %if %{with userspace}
 BuildRequires: SDL-devel >= 1.2.1
 BuildRequires: alsa-lib-devel
-BuildRequires: compat-gcc-34
+BuildRequires: bluez-libs-devel
+BuildRequires: gnutls-devel
+BuildRequires: ncurses-devel
+BuildRequires: perl-Encode
 BuildRequires: perl-tools-pod
+BuildRequires: pkgconfig
 BuildRequires: sed >= 4.0
-BuildRequires: tetex
+BuildRequires: texi2html
+BuildRequires: texinfo-texi2dvi
 BuildRequires: which
+BuildRequires: xorg-lib-libX11-devel
 %endif
 Requires:      SDL >= 1.2.1
 # sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
 ExclusiveArch: %{ix86} %{x8664} %{?with_userspace:ppc}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-# some SPARC boot image in ELF format
-%define                _noautostrip    .*%{_datadir}/qemu/openbios-sparc32
+# some PPC/SPARC boot image in ELF format
+%define                _noautostrip    .*%{_datadir}/qemu/openbios-.*
 
 %description
 QEMU is a FAST! processor emulator. By using dynamic translation it
@@ -136,9 +135,7 @@ kqemu - moduł jądra.
 
 %prep
 %setup -q -n %{pname}-%{qemu_version} %{?with_kernel:-a1}
-%patch0 -p1
-%patch1 -p1
-%patch3 -p1
+%patch0 -p0
 %{?with_nosdlgui:%patch6 -p1}
 #%patch8 -p1
 
@@ -170,10 +167,8 @@ EOF
 %patch13 -p1
 %endif
 %patch14 -p1
-%patch15 -p1
+#%patch15 -p1
 %patch16 -p1
-%patch17 -p2
-%patch18 -p0
 
 cd kqemu-%{kqemu_version}
 %{__sed} -i 's#include ../config-host.mak##' ./common/Makefile
@@ -217,13 +212,14 @@ cd -
 # they can be passed if the cflags_passing bcond is used
 ./configure \
        --prefix=%{_prefix} \
-       --cc="%{__ucc}" \
-       --host-cc="%{__ucc}" \
+       --cc="%{__cc}" \
+       --host-cc="%{__cc}" \
        --make="%{__make}" \
 %if %{without kqemu}
        --disable-kqemu \
 %endif
-       --enable-alsa \
+       --enable-mixemu \
+       --audio-drv-list="alsa" \
        --interp-prefix=%{_libdir}/%{pname}
 %{__make}
 %endif
@@ -278,6 +274,7 @@ EOF
 %{_datadir}/qemu
 %{_mandir}/man1/qemu.1*
 %{_mandir}/man1/qemu-img.1*
+%{_mandir}/man8/qemu-nbd.8*
 %endif
 
 %if %{with kernel}
This page took 0.407627 seconds and 4 git commands to generate.