]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu.spec
- from gentoo
[packages/qemu.git] / qemu.spec
index f126da7364cc38ea1c4744c30ce297853e2c21d5..5c9b597cf482d881a11e722b3e5e12f4487bf4e0 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -1,6 +1,7 @@
 #
 # TODO:
 # - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
+# - update or drop gcc4 bcond patches
 #
 # Conditional build:
 %bcond_without kqemu                   # disable KQEMU ACCELERATOR support in QEMU
@@ -8,18 +9,14 @@
 %bcond_with    dosguest                # add special patch when use with DOS as guest os
 %bcond_with    nosdlgui                # do not use SDL gui (use X11 instead)
 # Note that gcc4 build is very problematic and not supported by qemu team
-%bcond_without gcc4                    # use gcc4 patches (broke build on gcc33)
+%bcond_with    gcc4                    # use gcc4 patches (broke build on gcc33)
 %bcond_without dist_kernel             # without distribution kernel
 %bcond_without kernel                  # build kqemu KERNEL MODULES
-%bcond_without userspace               # don't build userspace
-%bcond_with    grsec_kernel    # build for kernel-grsecurity
+%bcond_without userspace               # don't build userspace utilities
 
 %if %{without kernel}
 %undefine      with_dist_kernel
 %endif
-%if %{with dist_kernel} && %{with grsec_kernel}
-%define        alt_kernel      grsecurity
-%endif
 
 # no kernel kqemu module for ppc
 %ifarch ppc
@@ -35,7 +32,7 @@
 %define                qemu_version    0.9.1
 %define                pname   qemu
 
-%define                rel     4
+%define                rel     9
 Summary:       QEMU CPU Emulator
 Summary(pl.UTF-8):     QEMU - emulator procesora
 Name:          %{pname}%{_alt_kernel}
@@ -43,7 +40,7 @@ Version:      %{qemu_version}
 Release:       %{rel}%{?with_kqemu:k}
 License:       GPL
 Group:         Applications/Emulators
-#Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
+# Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
 Source0:       http://fabrice.bellard.free.fr/qemu/%{pname}-%{version}.tar.gz
 # Source0-md5: 6591df8e9270eb358c881de4ebea1262
 Source1:       http://fabrice.bellard.free.fr/qemu/k%{pname}-%{kqemu_version}.tar.gz
@@ -61,6 +58,13 @@ Patch9:              %{pname}-0.8.0-gcc4-hacks.patch
 Patch11:       %{pname}-0.7.2-gcc4-opts.patch
 #Patch12:      %{pname}-0.7.2-dyngen-check-stack-clobbers.patch
 Patch13:       %{pname}-dosguest.patch
+Patch14:       %{pname}-ppc_old_binutils.patch
+Patch15:       %{pname}-isa-bios-ram.patch
+# below one fixes problems with passing ram size to bios/bootloader
+# which affects coreboot/linuxbios
+Patch16:       %{pname}-piix-ram-size.patch
+Patch17:       %{pname}-CVE-2008-0928.patch
+Patch18:       %{pname}-CVE-2008-2004.patch
 URL:           http://fabrice.bellard.free.fr/qemu/
 %if %{with kernel} && %{with dist_kernel}
 BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7
@@ -171,15 +175,24 @@ cat <<'EOF' > udev.conf
 KERNEL=="kqemu", NAME="%k", MODE="0666"
 EOF
 
+%if %{with dosguest}
+%patch13 -p1
+%endif
+%patch14 -p1
+%patch15 -p1
+%patch16 -p1
+%patch17 -p2
+%patch18 -p0
+
 cd kqemu-%{kqemu_version}
 %{__sed} -i 's#include ../config-host.mak##' ./common/Makefile
 %ifarch %{x8664}
 %{__sed} -i 's/^#ARCH=x86_64/ARCH=x86_64/' ./common/Makefile
-%{__make} -j1 -C common
+%{__make} -C common -j1
 mv -f kqemu-mod-x86_64.o{,.bin}
 %else
 %{__sed} -i 's/^#ARCH=i386/ARCH=i386/' ./common/Makefile
-%{__make} -j1 -C common
+%{__make} -C common -j1
 mv -f kqemu-mod-i386.o{,.bin}
 %endif
 
@@ -194,10 +207,6 @@ EOF
 cd -
 %endif
 
-%if %{with dosguest}
-%patch13 -p1
-%endif
-
 %build
 %if %{with kernel}
 cd kqemu-%{kqemu_version}
@@ -220,9 +229,7 @@ cd -
        --cc="%{__cc}" \
        --host-cc="%{__cc}" \
        --make="%{__make}" \
-%if %{with kqemu}
-       --kernel-path=%{_kernelsrcdir} \
-%else
+%if %{without kqemu}
        --disable-kqemu \
 %endif
        %{?with_gcc4:--disable-gcc-check} \
This page took 0.492198 seconds and 4 git commands to generate.