]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu.spec
- from gentoo
[packages/qemu.git] / qemu.spec
index c2a9e3c42fed2f3c65a2be61941411fadf7040a2..5c9b597cf482d881a11e722b3e5e12f4487bf4e0 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -1,39 +1,91 @@
 #
-# Conditional build:
-%bcond_with    kqemu                   # with QEMU accelerator module
+# TODO:
+# - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
+# - update or drop gcc4 bcond patches
 #
+# Conditional build:
+%bcond_without kqemu                   # disable KQEMU ACCELERATOR support in QEMU
+%bcond_with    cflags_passing          # with passing rpmcflags to Makefiles
+%bcond_with    dosguest                # add special patch when use with DOS as guest os
+%bcond_with    nosdlgui                # do not use SDL gui (use X11 instead)
+# Note that gcc4 build is very problematic and not supported by qemu team
+%bcond_with    gcc4                    # use gcc4 patches (broke build on gcc33)
+%bcond_without dist_kernel             # without distribution kernel
+%bcond_without kernel                  # build kqemu KERNEL MODULES
+%bcond_without userspace               # don't build userspace utilities
+
+%if %{without kernel}
+%undefine      with_dist_kernel
+%endif
+
+# no kernel kqemu module for ppc
+%ifarch ppc
+%undefine      with_kqemu
+%undefine      with_kernel
+%endif
+
+%if "%{_alt_kernel}" != "%{nil}"
+%undefine      with_userspace
+%endif
+
+%define                kqemu_version   1.3.0pre11
+%define                qemu_version    0.9.1
+%define                pname   qemu
+
+%define                rel     9
 Summary:       QEMU CPU Emulator
-Summary(pl):   QEMU - emulator procesora
-Name:          qemu
-Version:       0.7.0
-Release:       1.2
+Summary(pl.UTF-8):     QEMU - emulator procesora
+Name:          %{pname}%{_alt_kernel}
+Version:       %{qemu_version}
+Release:       %{rel}%{?with_kqemu:k}
 License:       GPL
 Group:         Applications/Emulators
-#Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
-Source0:       http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
-# Source0-md5: 234e9ace03b00259bb57dc5a9c633056
-%if %{with kqemu}
-Source1:       http://fabrice.bellard.free.fr/qemu/kqemu-0.6.2-1.tar.gz
-# NoSource1-md5:       c6bb3b40fb3d526d731eb0f1f9dee7ee
-NoSource:      1
-%endif
-Patch0:                %{name}-nostatic.patch
-Patch1:                %{name}-DESTDIR.patch
-Patch2:                %{name}-longjmp.patch
-Patch3:                %{name}-dot.patch
-Patch4:                %{name}-initrd_load_addr.patch
+# Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
+Source0:       http://fabrice.bellard.free.fr/qemu/%{pname}-%{version}.tar.gz
+# Source0-md5: 6591df8e9270eb358c881de4ebea1262
+Source1:       http://fabrice.bellard.free.fr/qemu/k%{pname}-%{kqemu_version}.tar.gz
+# Source1-md5: 970521874ef8b1ba4598925ace5936c3
+Patch0:                %{pname}-nostatic.patch
+Patch1:                %{pname}-cc.patch
+Patch3:                %{pname}-dot.patch
+Patch4:                %{pname}-gcc4_x86.patch
+Patch5:                %{pname}-gcc4_ppc.patch
+Patch6:                %{pname}-nosdlgui.patch
+# Proof of concept, for reference, do not remove
+Patch8:                %{pname}-kde_virtual_workspaces_hack.patch
+# http://gwenole.beauchesne.info/en/projects/qemu
+Patch9:                %{pname}-0.8.0-gcc4-hacks.patch
+Patch11:       %{pname}-0.7.2-gcc4-opts.patch
+#Patch12:      %{pname}-0.7.2-dyngen-check-stack-clobbers.patch
+Patch13:       %{pname}-dosguest.patch
+Patch14:       %{pname}-ppc_old_binutils.patch
+Patch15:       %{pname}-isa-bios-ram.patch
+# below one fixes problems with passing ram size to bios/bootloader
+# which affects coreboot/linuxbios
+Patch16:       %{pname}-piix-ram-size.patch
+Patch17:       %{pname}-CVE-2008-0928.patch
+Patch18:       %{pname}-CVE-2008-2004.patch
 URL:           http://fabrice.bellard.free.fr/qemu/
+%if %{with kernel} && %{with dist_kernel}
+BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7
+BuildRequires: rpmbuild(macros) >= 1.379
+%endif
+%if %{with userspace}
 BuildRequires: SDL-devel >= 1.2.1
+BuildRequires: alsa-lib-devel
+%{!?with_gcc4:BuildRequires:   gcc < 5:4.0}
+BuildRequires: perl-tools-pod
 BuildRequires: sed >= 4.0
-%if %{with kqemu}
-BuildRequires: kernel-source
+BuildRequires: tetex
+BuildRequires: which
 %endif
-ExclusiveArch: %{ix86} %{x8664} ppc
+Requires:      SDL >= 1.2.1
 # sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
+ExclusiveArch: %{ix86} %{x8664} %{?with_userspace:ppc}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # some SPARC boot image in ELF format
-%define                _noautostrip    .*%{_datadir}/qemu/proll.elf
+%define                _noautostrip    .*%{_datadir}/qemu/openbios-sparc32
 
 %description
 QEMU is a FAST! processor emulator. By using dynamic translation it
@@ -46,105 +98,203 @@ CPUs. QEMU has two operating modes:
   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
 
 - Full system emulation. In this mode, QEMU emulates a full system,
-  including a processor and various peripherials. 
-  It can also be used to provide virtual hosting of several 
-  virtual PC on a single server.
+  including a processor and various peripherials. It can also be used to
+  provide virtual hosting of several virtual PC on a single server.
 
-%description -l pl
-QEMU to szybki(!) emulator procesora. Poprzez u¿ycie dynamicznego
-t³umaczenia osi±ga rozs±dn± szybko¶æ i jest ³atwy do przeportowania,
-aby dzia³a³ na kolejnych procesorach. QEMU ma dwa tryby pracy:
+%description -l pl.UTF-8
+QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
+tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
+aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
 
-- Emulacja trybu u¿ytkownika. W tym trybie QEMU mo¿e uruchamiaæ
+- Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
   procesy linuksowe skompilowane dla jednego procesora na innym
-  procesorze. Linuksowe wywo³ania systemowe s± t³umaczone ze wzglêdu
-  na niezgodno¶æ kolejno¶ci bajtów w s³owie i 32/64-bitowego rozmiaru
-  s³owa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to g³ówne
+  procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
+  niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
+  słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
   cele QEMU.
 
-- Pe³na emulacja systemu. W tym trybie QEMU emuluje ca³y system,
-  w³±czaj±c w to procesor i ró¿ne urz±dzenia peryferyjne.
-  Mo¿e byæ tak¿e u¿ywane do wirtualnego hostowania kilku wirtualnych 
-  pecetów na pojedynczym serwerze.
+- Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
+  włączając w to procesor i różne urządzenia peryferyjne. Może być także
+  używane do wirtualnego hostowania kilku wirtualnych pecetów na
+  pojedynczym serwerze.
+
+%package -n kernel%{_alt_kernel}-misc-kqemu
+Summary:       kqemu - kernel module
+Summary(pl.UTF-8):     kqemu - moduł jądra
+Version:       %{kqemu_version}
+Release:       %{rel}@%{_kernel_ver_str}
+Group:         Base/Kernel
+%{?with_dist_kernel:%requires_releq_kernel}
+License:       GPL v2
+Obsoletes:     kernel%{_alt_kernel}-smp-misc-kqemu
+Requires(post,postun): /sbin/depmod
+Requires:      module-init-tools >= 3.2.2-2
+
+%description -n kernel%{_alt_kernel}-misc-kqemu
+kqemu - kernel module.
+
+%description -n kernel%{_alt_kernel}-misc-kqemu -l pl.UTF-8
+kqemu - moduł jądra.
 
 %prep
-%setup -q %{?with_kqemu:-a1}
+%setup -q -n %{pname}-%{qemu_version} %{?with_kernel:-a1}
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
 %patch3 -p1
-%patch4 -p1
+%if %{with gcc4}
+%patch9 -p1
+%patch11 -p1
+#%patch12 -p1
+#%patch4 -p0
+%patch5 -p1
+%endif
+%{?with_nosdlgui:%patch6 -p1}
+#%patch8 -p1
+
+%{__sed} -i -e 's/sdl_static=yes/sdl_static=no/' configure
+%{__sed} -i 's/.*MAKE) -C kqemu$//' Makefile
 
-sed -i -e 's/sdl_static=yes/sdl_static=no/' configure
 # cannot use optflags on x86 - they cause "no register to spill" errors
-#sed -i -e 's/-Wall -O2 -g/-Wall %{rpmcflags}/' Makefile Makefile.target
+%if %{with cflags_passing}
+%{__sed} -i -e 's/-Wall -O2 -g/-Wall %{rpmcflags}/' Makefile Makefile.target
+%else
+%{__sed} -i 's/-Wall -O2 -g/-Wall -O2/' Makefile Makefile.target
+%endif
 
-%{?with_kqemu:echo -n > kqemu/install.sh}
+%if %{with kernel}
+echo -n > kqemu-%{kqemu_version}/install.sh
 
-%build
+cat <<'EOF' > modprobe.conf
+# enable dynamic major
+options kqemu major=0
+# for autoloading from static dev
+#alias char-major-250 kqemu
+EOF
+
+cat <<'EOF' > udev.conf
+KERNEL=="kqemu", NAME="%k", MODE="0666"
+EOF
+
+%if %{with dosguest}
+%patch13 -p1
+%endif
+%patch14 -p1
+%patch15 -p1
+%patch16 -p1
+%patch17 -p2
+%patch18 -p0
 
-%if %{with kqemu}
-cp -rdp %{_kernelsrcdir}/ .
-rm -f linux/.config
-cp -f linux/config-smp linux/.config
-make -C linux modules_prepare
+cd kqemu-%{kqemu_version}
+%{__sed} -i 's#include ../config-host.mak##' ./common/Makefile
+%ifarch %{x8664}
+%{__sed} -i 's/^#ARCH=x86_64/ARCH=x86_64/' ./common/Makefile
+%{__make} -C common -j1
+mv -f kqemu-mod-x86_64.o{,.bin}
+%else
+%{__sed} -i 's/^#ARCH=i386/ARCH=i386/' ./common/Makefile
+%{__make} -C common -j1
+mv -f kqemu-mod-i386.o{,.bin}
 %endif
 
+mv -f kqemu-linux.c{,.orig}
+cat > Makefile <<'EOF'
+obj-m := kqemu.o
+kqemu-objs:= kqemu-linux.o kqemu-mod.o
+
+$(obj)/kqemu-mod.o: $(src)/kqemu-mod-$(ARCH).o.bin
+       cp $< $@
+EOF
+cd -
+%endif
+
+%build
+%if %{with kernel}
+cd kqemu-%{kqemu_version}
+%build_kernel_modules -m kqemu <<'EOF'
+if grep -q "CONFIG_PREEMPT_RT" o/.config; then
+       sed 's/SPIN_LOCK_UNLOCKED/SPIN_LOCK_UNLOCKED(kqemu_lock)/' \
+               kqemu-linux.c.orig > kqemu-linux.c
+else
+       cat kqemu-linux.c.orig > kqemu-linux.c
+fi
+EOF
+cd -
+%endif
+
+%if %{with userspace}
 # --extra-cflags don't work (overridden by CFLAGS in Makefile*)
+# they can be passed if the cflags_passing bcond is used
 ./configure \
        --prefix=%{_prefix} \
        --cc="%{__cc}" \
-  %if %{with kqemu}
-       --enable-kqemu }\
-       --kernel-path=`pwd`/linux \
-  %endif
-       --make="%{__make}"
-
-%{__make} 
-
-%if %{with kqemu}
-mv kqemu/kqemu.ko kqemu/kqemu.smp
-cp -f linux/config-up linux/.config
-make -C linux modules_prepare
+       --host-cc="%{__cc}" \
+       --make="%{__make}" \
+%if %{without kqemu}
+       --disable-kqemu \
+%endif
+       %{?with_gcc4:--disable-gcc-check} \
+       --enable-alsa \
+       --interp-prefix=%{_libdir}/%{pname}
+%{__make}
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
+%if %{with userspace}
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-%if %{with kqemu}
-install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}{,smp}/misc
-install kqemu/kqemu.smp $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/misc/kqemu.ko
-install kqemu/kqemu.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc
+install -d $RPM_BUILD_ROOT%{_sysconfdir}
+cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
+#!/bin/sh
+
+EOF
+%endif
+
+%if %{with kernel}
+%install_kernel_modules -m kqemu-%{kqemu_version}/kqemu -d misc
+install -d $RPM_BUILD_ROOT/etc/{modprobe.d/%{_kernel_ver}{,smp},udev/rules.d}
+install modprobe.conf $RPM_BUILD_ROOT/etc/modprobe.d/%{_kernel_ver}/kqemu.conf
+install udev.conf $RPM_BUILD_ROOT/etc/udev/rules.d/kqemu.rules
 %endif
 
+# already packaged
+rm -rf $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%if %{with kernel}
 %post
-%if %{with kqemu}
-%depmod
-
-%banner %{name} -e << EOF
-To enable qemu accelerator (kqemu), You must manually create device for it:
-mknod /dev/kqemu c 250 0
-chmod 666 /dev/kqemu
-
-And before start qemu, the kqemu kernel module must be loaded:
+%banner %{pname} -e <<EOF
+To enable qemu accelerator (kqemu), the kqemu kernel module must be loaded:
 modprobe kqemu
 EOF
 %endif
 
-%postun
-%{?with_kqemu: %depmod}
+%post  -n kernel%{_alt_kernel}-misc-kqemu
+%depmod %{_kernel_ver}
 
+%postun -n kernel%{_alt_kernel}-misc-kqemu
+%depmod %{_kernel_ver}
+
+%if %{with userspace}
 %files
 %defattr(644,root,root,755)
 %doc README qemu-doc.html qemu-tech.html
+%attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
 %attr(755,root,root) %{_bindir}/*
 %{_datadir}/qemu
 %{_mandir}/man1/qemu.1*
 %{_mandir}/man1/qemu-img.1*
-%{?with_kqemu: /lib/*}
+%endif
+
+%if %{with kernel}
+%files -n kernel%{_alt_kernel}-misc-kqemu
+%defattr(644,root,root,755)
+%doc kqemu-%{kqemu_version}/LICENSE
+%config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/kqemu.rules
+%config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/%{_kernel_ver}/kqemu.conf
+/lib/modules/%{_kernel_ver}/misc/kqemu.ko*
+%endif
This page took 0.168988 seconds and 4 git commands to generate.