]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu.spec
- up to 0.10.0
[packages/qemu.git] / qemu.spec
index 45a746fbb489851940508f079b43f894cd1d1720..48e6c15cc6a02dbfc3e03d75847349ee35a58268 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -1,63 +1,82 @@
 #
 # TODO:
-# - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
-# - kqemu could be distributable if somebody bothers to contact qemu
-#   author http://fabrice.bellard.free.fr/qemu/qemu-accel.html
+# - fix ncurses detection
+# - update patches
 #
 # Conditional build:
-%bcond_without kqemu                   # disable QEMU accelerator support
+%bcond_without kqemu                   # disable KQEMU ACCELERATOR support in QEMU
 %bcond_with    cflags_passing          # with passing rpmcflags to Makefiles
+%bcond_with    dosguest                # add special patch when use with DOS as guest os
 %bcond_with    nosdlgui                # do not use SDL gui (use X11 instead)
-%bcond_with    gcc4                    # use gcc4 patches (broke build on gcc33)
 %bcond_without dist_kernel             # without distribution kernel
-%bcond_with    kernel                  # build kqemu kernel modules
-%bcond_without smp                     # don't build SMP module
+%bcond_without kernel                  # build kqemu KERNEL MODULES
 %bcond_without userspace               # don't build userspace utilities
-#
-%define        _kqemu_version  1.3.0pre9
-%define                _rel    0.4
+
+# no kernel kqemu module for ppc
+%ifarch ppc
+%undefine      with_kqemu
+%undefine      with_kernel
+%endif
+
+%if %{without kernel}
+%undefine      with_dist_kernel
+%endif
+%if "%{_alt_kernel}" != "%{nil}"
+%undefine      with_userspace
+%endif
+%if %{without userspace}
+# nothing to be placed to debuginfo package
+%define                _enable_debug_packages  0
+%endif
+
+%define                rel     0.1
+
+%define                kqemu_version   1.4.0pre1
+%define                qemu_version    0.10.0
+%define                pname   qemu
 Summary:       QEMU CPU Emulator
-Summary(pl):   QEMU - emulator procesora
-Name:          qemu
-Version:       0.8.2
-Release:       %{_rel}%{?with_kqemu:k}
+Summary(pl.UTF-8):     QEMU - emulator procesora
+Name:          %{pname}%{_alt_kernel}
+Version:       %{qemu_version}
+Release:       %{rel}%{?with_kqemu:k}
 License:       GPL
 Group:         Applications/Emulators
-#Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
-Source0:       http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
-# Source0-md5: 5b3a89eb2f256a8a6f3bb07f7b3f1b07
-Source1:       http://fabrice.bellard.free.fr/qemu/k%{name}-%{_kqemu_version}.tar.gz
-# Source1-md5: 27888c3220844ad360a6a23345fa1bcb
-Patch0:                %{name}-nostatic.patch
-Patch1:                %{name}-cc.patch
-Patch2:                %{name}-longjmp.patch
-Patch3:                %{name}-dot.patch
-Patch4:                %{name}-gcc4_x86.patch
-Patch5:                %{name}-gcc4_ppc.patch
-Patch6:                %{name}-nosdlgui.patch
-Patch7:                %{name}-ifup.patch
+# Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
+Source0:       http://download.savannah.gnu.org/releases/qemu/%{pname}-%{version}.tar.gz
+# Source0-md5: 8dc50b834fa3f5f6a17d7bc3d0559e53
+Source1:       http://www.nongnu.org/qemu/k%{pname}-%{kqemu_version}.tar.gz
+# Source1-md5: d738d8ca7332211ab716ec3213d82ee1
+Patch6:                %{pname}-nosdlgui.patch
 # Proof of concept, for reference, do not remove
-Patch8:                %{name}-kde_virtual_workspaces_hack.patch
-URL:           http://fabrice.bellard.free.fr/qemu/
+Patch8:                %{pname}-kde_virtual_workspaces_hack.patch
+#Patch12:      %{pname}-0.7.2-dyngen-check-stack-clobbers.patch
+Patch13:       %{pname}-dosguest.patch
+Patch14:       %{pname}-ppc_old_binutils.patch
+Patch15:       %{pname}-isa-bios-ram.patch
+# below one fixes problems with passing ram size to bios/bootloader
+# which affects coreboot/linuxbios
+Patch16:       %{pname}-piix-ram-size.patch
+URL:           http://www.nongnu.org/qemu/
 %if %{with kernel} && %{with dist_kernel}
 BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7
+BuildRequires: rpmbuild(macros) >= 1.379
 %endif
 %if %{with userspace}
 BuildRequires: SDL-devel >= 1.2.1
 BuildRequires: alsa-lib-devel
-%{!?with_gcc4:BuildRequires:   gcc < 5:4.0}
+BuildRequires: ncurses-devel
 BuildRequires: perl-tools-pod
-BuildRequires: rpmbuild(macros) >= 1.330
-BuildRequires: tetex
 BuildRequires: sed >= 4.0
+BuildRequires: tetex
+BuildRequires: which
 %endif
 Requires:      SDL >= 1.2.1
 # sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
-ExclusiveArch: %{ix86} %{x8664} %{!?with_kqemu:ppc}
+ExclusiveArch: %{ix86} %{x8664} %{?with_userspace:ppc}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-# some SPARC boot image in ELF format
-%define                _noautostrip    .*%{_datadir}/qemu/openbios-sparc32
+# some PPC/SPARC boot image in ELF format
+%define                _noautostrip    .*%{_datadir}/qemu/openbios-.*
 
 %description
 QEMU is a FAST! processor emulator. By using dynamic translation it
@@ -73,69 +92,44 @@ CPUs. QEMU has two operating modes:
   including a processor and various peripherials. It can also be used to
   provide virtual hosting of several virtual PC on a single server.
 
-%description -l pl
-QEMU to szybki(!) emulator procesora. Poprzez u¿ycie dynamicznego
-t³umaczenia osi±ga rozs±dn± szybko¶æ i jest ³atwy do przeportowania,
-aby dzia³a³ na kolejnych procesorach. QEMU ma dwa tryby pracy:
+%description -l pl.UTF-8
+QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
+tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
+aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
 
-- Emulacja trybu u¿ytkownika. W tym trybie QEMU mo¿e uruchamiaæ
+- Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
   procesy linuksowe skompilowane dla jednego procesora na innym
-  procesorze. Linuksowe wywo³ania systemowe s± t³umaczone ze wzglêdu na
-  niezgodno¶æ kolejno¶ci bajtów w s³owie i 32/64-bitowego rozmiaru
-  s³owa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to g³ówne
+  procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
+  niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
+  słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
   cele QEMU.
 
-- Pe³na emulacja systemu. W tym trybie QEMU emuluje ca³y system,
-  w³±czaj±c w to procesor i ró¿ne urz±dzenia peryferyjne. Mo¿e byæ tak¿e
-  u¿ywane do wirtualnego hostowania kilku wirtualnych pecetów na
+- Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
+  włączając w to procesor i różne urządzenia peryferyjne. Może być także
+  używane do wirtualnego hostowania kilku wirtualnych pecetów na
   pojedynczym serwerze.
 
 %package -n kernel%{_alt_kernel}-misc-kqemu
 Summary:       kqemu - kernel module
-Summary(pl):   kqemu - modu³ j±dra
-Version:       %{_kqemu_version}
-Release:       %{_rel}@%{_kernel_ver_str}
+Summary(pl.UTF-8):     kqemu - moduł jądra
+Version:       %{kqemu_version}
+Release:       %{rel}@%{_kernel_ver_str}
 Group:         Base/Kernel
-%{?with_dist_kernel:%requires_releq_kernel_up}
-License:       Free to use, non-distributable
+%{?with_dist_kernel:%requires_releq_kernel}
+License:       GPL v2
+Obsoletes:     kernel%{_alt_kernel}-smp-misc-kqemu
 Requires(post,postun): /sbin/depmod
 Requires:      module-init-tools >= 3.2.2-2
 
 %description -n kernel%{_alt_kernel}-misc-kqemu
 kqemu - kernel module.
 
-%description -n kernel%{_alt_kernel}-misc-kqemu -l pl
-kqemu - modu³ j±dra.
-
-%package -n kernel%{_alt_kernel}-smp-misc-kqemu
-Summary:       kqemu - SMP kernel module
-Summary(pl):   kqemu - modu³ j±dra SMP
-Version:       %{_kqemu_version}
-Release:       %{_rel}@%{_kernel_ver_str}
-Group:         Base/Kernel
-%{?with_dist_kernel:%requires_releq_kernel_smp}
-License:       Free to use, non-distributable
-Requires(post,postun): /sbin/depmod
-Requires:      module-init-tools >= 3.2.2-2
-
-%description -n kernel%{_alt_kernel}-smp-misc-kqemu
-kqemu - SMP kernel module.
-
-%description -n kernel%{_alt_kernel}-smp-misc-kqemu -l pl
-kqemu - modu³ j±dra SMP.
+%description -n kernel%{_alt_kernel}-misc-kqemu -l pl.UTF-8
+kqemu - moduł jądra.
 
 %prep
-%setup -q %{?with_kernel:-a1}
-%patch0 -p1
-%patch1 -p1
-%patch2 -p1
-%patch3 -p1
-%if %{with gcc4}
-%patch4 -p0
-%patch5 -p1
-%endif
+%setup -q -n %{pname}-%{qemu_version} %{?with_kernel:-a1}
 %{?with_nosdlgui:%patch6 -p1}
-%patch7 -p1
 #%patch8 -p1
 
 %{__sed} -i -e 's/sdl_static=yes/sdl_static=no/' configure
@@ -149,7 +143,7 @@ kqemu - modu
 %endif
 
 %if %{with kernel}
-echo -n > kqemu-%{_kqemu_version}/install.sh
+echo -n > kqemu-%{kqemu_version}/install.sh
 
 cat <<'EOF' > modprobe.conf
 # enable dynamic major
@@ -161,14 +155,26 @@ EOF
 cat <<'EOF' > udev.conf
 KERNEL=="kqemu", NAME="%k", MODE="0666"
 EOF
-%endif
-
-%build
-%if %{with kernel}
-cd kqemu-%{_kqemu_version}
 
-mv -f kqemu-mod-i386.o{,.bin}
+%if %{with dosguest}
+%patch13 -p1
+%endif
+%patch14 -p1
+#%patch15 -p1
+%patch16 -p1
+
+cd kqemu-%{kqemu_version}
+%{__sed} -i 's#include ../config-host.mak##' ./common/Makefile
+%ifarch %{x8664}
+%{__sed} -i 's/^#ARCH=x86_64/ARCH=x86_64/' ./common/Makefile
+%{__make} -C common -j1
 mv -f kqemu-mod-x86_64.o{,.bin}
+%else
+%{__sed} -i 's/^#ARCH=i386/ARCH=i386/' ./common/Makefile
+%{__make} -C common -j1
+mv -f kqemu-mod-i386.o{,.bin}
+%endif
+
 mv -f kqemu-linux.c{,.orig}
 cat > Makefile <<'EOF'
 obj-m := kqemu.o
@@ -177,7 +183,12 @@ kqemu-objs:= kqemu-linux.o kqemu-mod.o
 $(obj)/kqemu-mod.o: $(src)/kqemu-mod-$(ARCH).o.bin
        cp $< $@
 EOF
+cd -
+%endif
 
+%build
+%if %{with kernel}
+cd kqemu-%{kqemu_version}
 %build_kernel_modules -m kqemu <<'EOF'
 if grep -q "CONFIG_PREEMPT_RT" o/.config; then
        sed 's/SPIN_LOCK_UNLOCKED/SPIN_LOCK_UNLOCKED(kqemu_lock)/' \
@@ -197,14 +208,11 @@ cd -
        --cc="%{__cc}" \
        --host-cc="%{__cc}" \
        --make="%{__make}" \
-%if %{with kqemu}
-       --kernel-path=%{_kernelsrcdir} \
-%else
+%if %{without kqemu}
        --disable-kqemu \
 %endif
-       %{?with_gcc4:--disable-gcc-check} \
-       --enable-alsa \
-       --interp-prefix=%{_libdir}/%{name}
+       --audio-drv-list="alsa" \
+       --interp-prefix=%{_libdir}/%{pname}
 %{__make}
 %endif
 
@@ -215,24 +223,17 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install -d $RPM_BUILD_ROOT/sbin
-cat <<'EOF' > $RPM_BUILD_ROOT/sbin/qemu-ifup
+install -d $RPM_BUILD_ROOT%{_sysconfdir}
+cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
 #!/bin/sh
-if [ -f /etc/sysconfig/qemu ]; then
-       . /etc/sysconfig/qemu
-fi
-# of course this will work only for one interface. a lot possible to involve
-sudo /sbin/ifconfig $1 ${INTERFACE_ADDR:-172.20.0.1}
+
 EOF
 %endif
 
 %if %{with kernel}
-%install_kernel_modules -m kqemu-%{_kqemu_version}/kqemu -d misc
+%install_kernel_modules -m kqemu-%{kqemu_version}/kqemu -d misc
 install -d $RPM_BUILD_ROOT/etc/{modprobe.d/%{_kernel_ver}{,smp},udev/rules.d}
 install modprobe.conf $RPM_BUILD_ROOT/etc/modprobe.d/%{_kernel_ver}/kqemu.conf
-%if %{with smp} && %{with dist_kernel}
-install modprobe.conf $RPM_BUILD_ROOT/etc/modprobe.d/%{_kernel_ver}smp/kqemu.conf
-%endif
 install udev.conf $RPM_BUILD_ROOT/etc/udev/rules.d/kqemu.rules
 %endif
 
@@ -244,7 +245,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %if %{with kernel}
 %post
-%banner %{name} -e <<EOF
+%banner %{pname} -e <<EOF
 To enable qemu accelerator (kqemu), the kqemu kernel module must be loaded:
 modprobe kqemu
 EOF
@@ -256,37 +257,23 @@ EOF
 %postun -n kernel%{_alt_kernel}-misc-kqemu
 %depmod %{_kernel_ver}
 
-%post  -n kernel%{_alt_kernel}-smp-misc-kqemu
-%depmod %{_kernel_ver}smp
-
-%postun -n kernel%{_alt_kernel}-smp-misc-kqemu
-%depmod %{_kernel_ver}smp
-
 %if %{with userspace}
 %files
 %defattr(644,root,root,755)
 %doc README qemu-doc.html qemu-tech.html
-%attr(755,root,root) /sbin/qemu-ifup
+%attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
 %attr(755,root,root) %{_bindir}/*
 %{_datadir}/qemu
 %{_mandir}/man1/qemu.1*
 %{_mandir}/man1/qemu-img.1*
+%{_mandir}/man8/qemu-nbd.8*
 %endif
 
 %if %{with kernel}
 %files -n kernel%{_alt_kernel}-misc-kqemu
 %defattr(644,root,root,755)
-%doc kqemu-%{_kqemu_version}/LICENSE
+%doc kqemu-%{kqemu_version}/LICENSE
 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/kqemu.rules
 %config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/%{_kernel_ver}/kqemu.conf
 /lib/modules/%{_kernel_ver}/misc/kqemu.ko*
-
-%if %{with smp} && %{with dist_kernel}
-%files -n kernel%{_alt_kernel}-smp-misc-kqemu
-%defattr(644,root,root,755)
-%doc kqemu-%{_kqemu_version}/LICENSE
-%config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/kqemu.rules
-%config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/%{_kernel_ver}smp/kqemu.conf
-/lib/modules/%{_kernel_ver}smp/misc/kqemu.ko*
-%endif
 %endif
This page took 0.223998 seconds and 4 git commands to generate.