]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu.spec
- workaround for conflict with alsa/error.h
[packages/qemu.git] / qemu.spec
index 86c3db5e4e08b7cef2add21ec169ec167abc7245..257e4dace14edaaafc6724a8cf538ff5e1035bef 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -1,79 +1,52 @@
-#
 # TODO:
 # - update patches
+# - qemu-system-ppc -hda ac-ppc.img says:
+#   qemu: could not open disk image ac-ppc.img: Success
+#   qemu-0.12.2-2.x86_64.rpm - broken
+#   qemu-0.12.3-3.x86_64/qemu-0.12.4-1.x86_64 - stops on "returning from prom_init"
+#   qemu-0.11.1-7k.x86_64.rpm - OK
 #
 # Conditional build:
-%bcond_without kqemu                   # disable KQEMU ACCELERATOR support in QEMU
 %bcond_with    cflags_passing          # with passing rpmcflags to Makefiles
 %bcond_with    dosguest                # add special patch when use with DOS as guest os
 %bcond_with    nosdlgui                # do not use SDL gui (use X11 instead)
-%bcond_without dist_kernel             # without distribution kernel
-%bcond_without kernel                  # build kqemu KERNEL MODULES
-%bcond_without userspace               # don't build userspace utilities
-
-# no kernel kqemu module for ppc
-%ifarch ppc
-%undefine      with_kqemu
-%undefine      with_kernel
-%endif
 
-%if %{without kernel}
-%undefine      with_dist_kernel
-%endif
-%if "%{_alt_kernel}" != "%{nil}"
-%undefine      with_userspace
-%endif
-%if %{without userspace}
-# nothing to be placed to debuginfo package
-%define                _enable_debug_packages  0
-%endif
-
-%define                rel     1
-
-%define                kqemu_version   1.4.0pre1
-%define                qemu_version    0.10.2
-%define                pname   qemu
 Summary:       QEMU CPU Emulator
 Summary(pl.UTF-8):     QEMU - emulator procesora
-Name:          %{pname}%{_alt_kernel}
-Version:       %{qemu_version}
-Release:       %{rel}%{?with_kqemu:k}
+Name:          qemu
+Version:       0.15.1
+Release:       1
 License:       GPL
 Group:         Applications/Emulators
 # Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
-Source0:       http://download.savannah.gnu.org/releases/qemu/%{pname}-%{version}.tar.gz
-# Source0-md5: 85a323cdf620687f39c5328f450a547d
-Source1:       http://www.nongnu.org/qemu/k%{pname}-%{kqemu_version}.tar.gz
-# Source1-md5: d738d8ca7332211ab716ec3213d82ee1
-Patch0:                %{pname}-ncurses.patch
-Patch6:                %{pname}-nosdlgui.patch
+#Source0:      http://download.savannah.gnu.org/releases/qemu/%{name}-%{version}.tar.gz
+Source0:       http://wiki.qemu.org/download/%{name}-%{version}.tar.gz
+# Source0-md5: 34f17737baaf1b3495c89cd6d4a607ed
+Patch0:                %{name}-ncurses.patch
+Patch6:                %{name}-nosdlgui.patch
 # Proof of concept, for reference, do not remove
-Patch8:                %{pname}-kde_virtual_workspaces_hack.patch
-#Patch12:      %{pname}-0.7.2-dyngen-check-stack-clobbers.patch
-Patch13:       %{pname}-dosguest.patch
-Patch14:       %{pname}-ppc_old_binutils.patch
-Patch15:       %{pname}-isa-bios-ram.patch
+Patch8:                %{name}-kde_virtual_workspaces_hack.patch
+#Patch12: %{name}-0.7.2-dyngen-check-stack-clobbers.patch
+Patch13:       %{name}-dosguest.patch
+Patch14:       %{name}-ppc_old_binutils.patch
+Patch15:       %{name}-isa-bios-ram.patch
 # below one fixes problems with passing ram size to bios/bootloader
 # which affects coreboot/linuxbios
-Patch16:       %{pname}-piix-ram-size.patch
-URL:           http://www.nongnu.org/qemu/
-%if %{with kernel} && %{with dist_kernel}
-BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7
-BuildRequires: rpmbuild(macros) >= 1.379
-%endif
-%if %{with userspace}
+Patch16:       %{name}-piix-ram-size.patch
+Patch17:       %{name}-whitelist.patch
+URL:           http://wiki.qemu.org/Index.html
 BuildRequires: SDL-devel >= 1.2.1
 BuildRequires: alsa-lib-devel
 BuildRequires: bluez-libs-devel
 BuildRequires: gnutls-devel
 BuildRequires: ncurses-devel
+BuildRequires: perl-Encode
 BuildRequires: perl-tools-pod
 BuildRequires: pkgconfig
 BuildRequires: sed >= 4.0
-BuildRequires: tetex
+BuildRequires: texi2html
 BuildRequires: which
 BuildRequires: xorg-lib-libX11-devel
-%endif
 Requires:      SDL >= 1.2.1
 # sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
 ExclusiveArch: %{ix86} %{x8664} %{?with_userspace:ppc}
@@ -113,119 +86,41 @@ aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
   używane do wirtualnego hostowania kilku wirtualnych pecetów na
   pojedynczym serwerze.
 
-%package -n kernel%{_alt_kernel}-misc-kqemu
-Summary:       kqemu - kernel module
-Summary(pl.UTF-8):     kqemu - moduł jądra
-Version:       %{kqemu_version}
-Release:       %{rel}@%{_kernel_ver_str}
-Group:         Base/Kernel
-%{?with_dist_kernel:%requires_releq_kernel}
-License:       GPL v2
-Obsoletes:     kernel%{_alt_kernel}-smp-misc-kqemu
-Requires(post,postun): /sbin/depmod
-Requires:      module-init-tools >= 3.2.2-2
-
-%description -n kernel%{_alt_kernel}-misc-kqemu
-kqemu - kernel module.
-
-%description -n kernel%{_alt_kernel}-misc-kqemu -l pl.UTF-8
-kqemu - moduł jądra.
-
 %prep
-%setup -q -n %{pname}-%{qemu_version} %{?with_kernel:-a1}
-%patch0 -p0
+%setup -q
+%patch0 -p1
 %{?with_nosdlgui:%patch6 -p1}
-#%patch8 -p1
+#patch8 -p1
+%patch17 -p0
 
 %{__sed} -i -e 's/sdl_static=yes/sdl_static=no/' configure
 %{__sed} -i 's/.*MAKE) -C kqemu$//' Makefile
 
 # cannot use optflags on x86 - they cause "no register to spill" errors
 %if %{with cflags_passing}
-%{__sed} -i -e 's/-Wall -O2 -g/-Wall %{rpmcflags}/' Makefile Makefile.target
+%{__sed} -i -e 's/-g $CFLAGS/-Wall %{rpmcflags}/' configure
 %else
-%{__sed} -i 's/-Wall -O2 -g/-Wall -O2/' Makefile Makefile.target
+%{__sed} -i 's/-g $CFLAGS/-Wall -fno-var-tracking-assignments/' configure
 %endif
 
-%if %{with kernel}
-echo -n > kqemu-%{kqemu_version}/install.sh
-
-cat <<'EOF' > modprobe.conf
-# enable dynamic major
-options kqemu major=0
-# for autoloading from static dev
-#alias char-major-250 kqemu
-EOF
-
-cat <<'EOF' > udev.conf
-KERNEL=="kqemu", NAME="%k", MODE="0666"
-EOF
-
-%if %{with dosguest}
-%patch13 -p1
-%endif
-%patch14 -p1
-#%patch15 -p1
-%patch16 -p1
-
-cd kqemu-%{kqemu_version}
-%{__sed} -i 's#include ../config-host.mak##' ./common/Makefile
-%ifarch %{x8664}
-%{__sed} -i 's/^#ARCH=x86_64/ARCH=x86_64/' ./common/Makefile
-%{__make} -C common -j1
-mv -f kqemu-mod-x86_64.o{,.bin}
-%else
-%{__sed} -i 's/^#ARCH=i386/ARCH=i386/' ./common/Makefile
-%{__make} -C common -j1
-mv -f kqemu-mod-i386.o{,.bin}
-%endif
-
-mv -f kqemu-linux.c{,.orig}
-cat > Makefile <<'EOF'
-obj-m := kqemu.o
-kqemu-objs:= kqemu-linux.o kqemu-mod.o
-
-$(obj)/kqemu-mod.o: $(src)/kqemu-mod-$(ARCH).o.bin
-       cp $< $@
-EOF
-cd -
-%endif
+# workaround for conflict with alsa/error.h
+ln -s ../error.h qapi/error.h
 
 %build
-%if %{with kernel}
-cd kqemu-%{kqemu_version}
-%build_kernel_modules -m kqemu <<'EOF'
-if grep -q "CONFIG_PREEMPT_RT" o/.config; then
-       sed 's/SPIN_LOCK_UNLOCKED/SPIN_LOCK_UNLOCKED(kqemu_lock)/' \
-               kqemu-linux.c.orig > kqemu-linux.c
-else
-       cat kqemu-linux.c.orig > kqemu-linux.c
-fi
-EOF
-cd -
-%endif
-
-%if %{with userspace}
 # --extra-cflags don't work (overridden by CFLAGS in Makefile*)
 # they can be passed if the cflags_passing bcond is used
 ./configure \
        --prefix=%{_prefix} \
        --cc="%{__cc}" \
        --host-cc="%{__cc}" \
-       --make="%{__make}" \
-%if %{without kqemu}
-       --disable-kqemu \
-%endif
        --enable-mixemu \
        --audio-drv-list="alsa" \
-       --interp-prefix=%{_libdir}/%{pname}
+       --interp-prefix=%{_libdir}/%{name}
 %{__make}
-%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%if %{with userspace}
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
@@ -234,14 +129,6 @@ cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
 #!/bin/sh
 
 EOF
-%endif
-
-%if %{with kernel}
-%install_kernel_modules -m kqemu-%{kqemu_version}/kqemu -d misc
-install -d $RPM_BUILD_ROOT/etc/{modprobe.d/%{_kernel_ver}{,smp},udev/rules.d}
-install modprobe.conf $RPM_BUILD_ROOT/etc/modprobe.d/%{_kernel_ver}/kqemu.conf
-install udev.conf $RPM_BUILD_ROOT/etc/udev/rules.d/kqemu.rules
-%endif
 
 # already packaged
 rm -rf $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
@@ -249,21 +136,6 @@ rm -rf $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%if %{with kernel}
-%post
-%banner %{pname} -e <<EOF
-To enable qemu accelerator (kqemu), the kqemu kernel module must be loaded:
-modprobe kqemu
-EOF
-%endif
-
-%post  -n kernel%{_alt_kernel}-misc-kqemu
-%depmod %{_kernel_ver}
-
-%postun -n kernel%{_alt_kernel}-misc-kqemu
-%depmod %{_kernel_ver}
-
-%if %{with userspace}
 %files
 %defattr(644,root,root,755)
 %doc README qemu-doc.html qemu-tech.html
@@ -273,13 +145,3 @@ EOF
 %{_mandir}/man1/qemu.1*
 %{_mandir}/man1/qemu-img.1*
 %{_mandir}/man8/qemu-nbd.8*
-%endif
-
-%if %{with kernel}
-%files -n kernel%{_alt_kernel}-misc-kqemu
-%defattr(644,root,root,755)
-%doc kqemu-%{kqemu_version}/LICENSE
-%config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/kqemu.rules
-%config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/%{_kernel_ver}/kqemu.conf
-/lib/modules/%{_kernel_ver}/misc/kqemu.ko*
-%endif
This page took 0.492405 seconds and 4 git commands to generate.