]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu.spec
patch vga bios to support additional widescreen modes (1600x1000, 1600x900). it looks...
[packages/qemu.git] / qemu.spec
index bf122c26536bdf4a538ee7a6d2b62a740615d783..2181bec5e4ee77ca2f3264d3daa30364aabe4868 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -1,4 +1,6 @@
 # TODO:
+# - package virtfs-proxy-helper, qemu-bridge-helper.
+# - package qemu-system-or32
 # - update patches
 # - qemu-system-ppc -hda ac-ppc.img says:
 #   qemu: could not open disk image ac-ppc.img: error "Success"
 #   qemu-0.11.1-*.x86_64.rpm - OK
 #
 # Conditional build:
-%bcond_with    cflags_passing          # with passing rpmcflags to Makefiles
-%bcond_with    dosguest                # add special patch when use with DOS as guest os
 %bcond_with    nosdlgui                # do not use SDL gui (use X11 instead)
 
 Summary:       QEMU CPU Emulator
 Summary(pl.UTF-8):     QEMU - emulator procesora
 Name:          qemu
-Version:       1.0
-Release:       5
+Version:       1.2.0
+Release:       1
 License:       GPL
 Group:         Applications/Emulators
-Source0:       http://wiki.qemu.org/download/%{name}-%{version}.tar.gz
-# Source0-md5: a64b36067a191451323b0d34ebb44954
-Patch0:                %{name}-ncurses.patch
+Source0:       http://wiki.qemu.org/download/%{name}-%{version}.tar.bz2
+# Source0-md5: 78eb1e984f4532aa9f2bdd3c127b5b61
+Patch0:                %{name}-cflags.patch
+Patch1:                vgabios-widescreens.patch
 Patch6:                %{name}-nosdlgui.patch
 # Proof of concept, for reference, do not remove
 Patch8:                %{name}-kde_virtual_workspaces_hack.patch
-#Patch12: %{name}-0.7.2-dyngen-check-stack-clobbers.patch
-Patch13:       %{name}-dosguest.patch
-Patch14:       %{name}-ppc_old_binutils.patch
-Patch15:       %{name}-isa-bios-ram.patch
-# below one fixes problems with passing ram size to bios/bootloader
-# which affects coreboot/linuxbios
-Patch16:       %{name}-piix-ram-size.patch
 Patch17:       %{name}-whitelist.patch
 URL:           http://wiki.qemu.org/Index.html
 BuildRequires: SDL-devel >= 1.2.1
@@ -44,7 +38,9 @@ BuildRequires:        perl-tools-pod
 BuildRequires: pkgconfig
 BuildRequires: sed >= 4.0
 BuildRequires: texi2html
+BuildRequires: texinfo
 BuildRequires: which
+BuildRequires: xen-devel
 BuildRequires: xorg-lib-libX11-devel
 Requires:      %{name}-img = %{version}-%{release}
 Requires:      %{name}-system-alpha = %{version}-%{release}
@@ -66,7 +62,7 @@ ExclusiveArch:        %{ix86} %{x8664} %{?with_userspace:ppc}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # some PPC/SPARC boot image in ELF format
-%define                _noautostrip    .*%{_datadir}/qemu/.*-.* .*%{_datadir}/qemu/bios.bin
+%define                _noautostrip    .*%{_datadir}/qemu/.*-.*
 
 %description
 QEMU is a FAST! processor emulator. By using dynamic translation it
@@ -255,7 +251,6 @@ This package provides the system emulator for sparc/sparc64.
 Summary:       QEMU system emulator for x86
 Group:         Development/Tools
 Requires:      %{name}-common = %{version}-%{release}
-Obsoletes:     qemu-kvm
 
 %description system-x86
 QEMU is a generic and open source processor emulator which achieves a
@@ -279,27 +274,19 @@ This package provides the system emulator for xtensa.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 %{?with_nosdlgui:%patch6 -p1}
 #patch8 -p1
 %patch17 -p0
 
-%{__sed} -i -e 's/sdl_static=yes/sdl_static=no/' configure
-%{__sed} -i 's/.*MAKE) -C kqemu$//' Makefile
-
-# cannot use optflags on x86 - they cause "no register to spill" errors
-%if %{with cflags_passing}
-%{__sed} -i -e 's/-g $CFLAGS/-Wall %{rpmcflags}/' configure
-%else
-%{__sed} -i 's/-g $CFLAGS/-Wall -fno-var-tracking-assignments/' configure
-%endif
-
 # workaround for conflict with alsa/error.h
 ln -s ../error.h qapi/error.h
 
 %build
-# --extra-cflags don't work (overridden by CFLAGS in Makefile*)
-# they can be passed if the cflags_passing bcond is used
 ./configure \
+       --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
+       --extra-ldflags="%{rpmldflags}" \
+       --disable-strip \
        --sysconfdir=%{_sysconfdir} \
        --prefix=%{_prefix} \
        --cc="%{__cc}" \
@@ -309,6 +296,9 @@ ln -s ../error.h qapi/error.h
        --interp-prefix=%{_libdir}/%{name}
 %{__make} V=1
 
+# rebuild patched vesa tables with additional widescreen modes.
+%{__make} -C roms/vgabios stdvga-bios
+
 %install
 rm -rf $RPM_BUILD_ROOT
 
@@ -324,6 +314,9 @@ EOF
 # already packaged
 rm -rf $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
 
+# install patched vesa tables with additional widescreen modes.
+install -m 644 roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -341,6 +334,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man8/qemu-nbd.8*
 
 %dir %{_datadir}/qemu
+%{_datadir}/%{name}/cpus-*.conf
 %{_datadir}/%{name}/keymaps
 # various bios images
 %{_datadir}/%{name}/*.bin
This page took 0.041978 seconds and 4 git commands to generate.