]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu.spec
patch vga bios to support additional widescreen modes (1600x1000, 1600x900). it looks...
[packages/qemu.git] / qemu.spec
index 0bd00d30a6b9479c49fb3c072f3c14818652af79..2181bec5e4ee77ca2f3264d3daa30364aabe4868 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -1,4 +1,6 @@
 # TODO:
+# - package virtfs-proxy-helper, qemu-bridge-helper.
+# - package qemu-system-or32
 # - update patches
 # - qemu-system-ppc -hda ac-ppc.img says:
 #   qemu: could not open disk image ac-ppc.img: error "Success"
 #   qemu-0.11.1-*.x86_64.rpm - OK
 #
 # Conditional build:
-%bcond_with    cflags_passing          # with passing rpmcflags to Makefiles
 %bcond_with    nosdlgui                # do not use SDL gui (use X11 instead)
 
 Summary:       QEMU CPU Emulator
 Summary(pl.UTF-8):     QEMU - emulator procesora
 Name:          qemu
-Version:       1.0
-Release:       8
+Version:       1.2.0
+Release:       1
 License:       GPL
 Group:         Applications/Emulators
-Source0:       http://wiki.qemu.org/download/%{name}-%{version}.tar.gz
-# Source0-md5: a64b36067a191451323b0d34ebb44954
+Source0:       http://wiki.qemu.org/download/%{name}-%{version}.tar.bz2
+# Source0-md5: 78eb1e984f4532aa9f2bdd3c127b5b61
+Patch0:                %{name}-cflags.patch
+Patch1:                vgabios-widescreens.patch
 Patch6:                %{name}-nosdlgui.patch
 # Proof of concept, for reference, do not remove
 Patch8:                %{name}-kde_virtual_workspaces_hack.patch
@@ -37,6 +40,7 @@ BuildRequires:        sed >= 4.0
 BuildRequires: texi2html
 BuildRequires: texinfo
 BuildRequires: which
+BuildRequires: xen-devel
 BuildRequires: xorg-lib-libX11-devel
 Requires:      %{name}-img = %{version}-%{release}
 Requires:      %{name}-system-alpha = %{version}-%{release}
@@ -269,27 +273,20 @@ This package provides the system emulator for xtensa.
 
 %prep
 %setup -q
+%patch0 -p1
+%patch1 -p1
 %{?with_nosdlgui:%patch6 -p1}
 #patch8 -p1
 %patch17 -p0
 
-%{__sed} -i -e 's/sdl_static=yes/sdl_static=no/' configure
-%{__sed} -i 's/.*MAKE) -C kqemu$//' Makefile
-
-# cannot use optflags on x86 - they cause "no register to spill" errors
-%if %{with cflags_passing}
-%{__sed} -i -e 's/-g $CFLAGS/-Wall %{rpmcflags}/' configure
-%else
-%{__sed} -i 's/-g $CFLAGS/-Wall -fno-var-tracking-assignments/' configure
-%endif
-
 # workaround for conflict with alsa/error.h
 ln -s ../error.h qapi/error.h
 
 %build
-# --extra-cflags don't work (overridden by CFLAGS in Makefile*)
-# they can be passed if the cflags_passing bcond is used
 ./configure \
+       --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
+       --extra-ldflags="%{rpmldflags}" \
+       --disable-strip \
        --sysconfdir=%{_sysconfdir} \
        --prefix=%{_prefix} \
        --cc="%{__cc}" \
@@ -299,6 +296,9 @@ ln -s ../error.h qapi/error.h
        --interp-prefix=%{_libdir}/%{name}
 %{__make} V=1
 
+# rebuild patched vesa tables with additional widescreen modes.
+%{__make} -C roms/vgabios stdvga-bios
+
 %install
 rm -rf $RPM_BUILD_ROOT
 
@@ -314,6 +314,9 @@ EOF
 # already packaged
 rm -rf $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
 
+# install patched vesa tables with additional widescreen modes.
+install -m 644 roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -331,6 +334,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man8/qemu-nbd.8*
 
 %dir %{_datadir}/qemu
+%{_datadir}/%{name}/cpus-*.conf
 %{_datadir}/%{name}/keymaps
 # various bios images
 %{_datadir}/%{name}/*.bin
This page took 0.047562 seconds and 4 git commands to generate.