]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu.spec
- release 23
[packages/qemu.git] / qemu.spec
index 618458754a9b5267710dadb1e9768bb520cc996d..0f9cab4c25156180d2ff76e7d10b7a291204bbdf 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -1,55 +1,90 @@
 #
 # TODO:
 # - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
-# - kqemu could be distributable if somebody bothers to contact qemu
-#   author http://fabrice.bellard.free.fr/qemu/qemu-accel.html
+# - update or drop gcc4 bcond patches
 #
 # Conditional build:
-%bcond_without kqemu                   # disable QEMU accelerator support
+%bcond_without kqemu                   # disable KQEMU ACCELERATOR support in QEMU
 %bcond_with    cflags_passing          # with passing rpmcflags to Makefiles
+%bcond_with    dosguest                # add special patch when use with DOS as guest os
 %bcond_with    nosdlgui                # do not use SDL gui (use X11 instead)
-%bcond_with    gcc4                    # use gcc4 patches (broke build on gcc33)
 %bcond_without dist_kernel             # without distribution kernel
-%bcond_with    kernel                  # build kqemu kernel modules
-%bcond_without smp                     # don't build SMP module
+%bcond_without kernel                  # build kqemu KERNEL MODULES
 %bcond_without userspace               # don't build userspace utilities
-#
-%define        _kqemu_version  1.3.0pre9
-%define                _rel    0.4
+
+# no kernel kqemu module for ppc
+%ifarch ppc
+%undefine      with_kqemu
+%undefine      with_kernel
+%endif
+
+%if %{without kernel}
+%undefine      with_dist_kernel
+%endif
+%if "%{_alt_kernel}" != "%{nil}"
+%undefine      with_userspace
+%endif
+%if %{without userspace}
+# nothing to be placed to debuginfo package
+%define                _enable_debug_packages  0
+%endif
+
+%define                __ucc   gcc-3.4
+
+%define                rel     23
+
+%define                kqemu_version   1.3.0pre11
+%define                qemu_version    0.9.1
+%define                pname   qemu
 Summary:       QEMU CPU Emulator
-Summary(pl):   QEMU - emulator procesora
-Name:          qemu
-Version:       0.8.2
-Release:       %{_rel}%{?with_kqemu:k}
+Summary(pl.UTF-8):     QEMU - emulator procesora
+Name:          %{pname}%{_alt_kernel}
+Version:       %{qemu_version}
+Release:       %{rel}%{?with_kqemu:k}
 License:       GPL
 Group:         Applications/Emulators
-#Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
-Source0:       http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
-# Source0-md5: 5b3a89eb2f256a8a6f3bb07f7b3f1b07
-Source1:       http://fabrice.bellard.free.fr/qemu/k%{name}-%{_kqemu_version}.tar.gz
-# Source1-md5: 27888c3220844ad360a6a23345fa1bcb
-Patch0:                %{name}-nostatic.patch
-Patch1:                %{name}-cc.patch
-Patch2:                %{name}-longjmp.patch
-Patch3:                %{name}-dot.patch
-Patch4:                %{name}-gcc4_x86.patch
-Patch5:                %{name}-gcc4_ppc.patch
-Patch6:                %{name}-nosdlgui.patch
-Patch7:                %{name}-ifup.patch
-URL:           http://fabrice.bellard.free.fr/qemu/
+# Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
+Source0:       http://bellard.org/qemu/%{pname}-%{version}.tar.gz
+# Source0-md5: 6591df8e9270eb358c881de4ebea1262
+Source1:       http://bellard.org/qemu/k%{pname}-%{kqemu_version}.tar.gz
+# Source1-md5: 970521874ef8b1ba4598925ace5936c3
+Patch0:                %{pname}-nostatic.patch
+Patch1:                %{pname}-cc.patch
+Patch3:                %{pname}-dot.patch
+Patch6:                %{pname}-nosdlgui.patch
+# Proof of concept, for reference, do not remove
+Patch8:                %{pname}-kde_virtual_workspaces_hack.patch
+#Patch12:      %{pname}-0.7.2-dyngen-check-stack-clobbers.patch
+Patch13:       %{pname}-dosguest.patch
+Patch14:       %{pname}-ppc_old_binutils.patch
+Patch15:       %{pname}-isa-bios-ram.patch
+# below one fixes problems with passing ram size to bios/bootloader
+# which affects coreboot/linuxbios
+Patch16:       %{pname}-piix-ram-size.patch
+Patch17:       %{pname}-CVE-2008-0928.patch
+Patch18:       %{pname}-CVE-2008-2004.patch
+Patch19:       %{pname}-gcc-workaround.patch
+Patch20:       %{pname}-dirent.patch
+URL:           http://bellard.org/qemu/
+# http://securitytracker.com/alerts/2008/Dec/1021488.html
+# patch in vendor's svn:
+BuildRequires: security(CVE-2008-2382)
+%if %{with kernel} && %{with dist_kernel}
+BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7
+BuildRequires: rpmbuild(macros) >= 1.379
+%endif
+%if %{with userspace}
 BuildRequires: SDL-devel >= 1.2.1
 BuildRequires: alsa-lib-devel
-%{!?with_gcc4:BuildRequires:   gcc < 5:4.0}
-%if %{with kqemu} && %{with dist_kernel}
-BuildRequires: kernel-module-build >= 3:2.6.7
-%endif
+BuildRequires: compat-gcc-34
 BuildRequires: perl-tools-pod
-BuildRequires: rpmbuild(macros) >= 1.217
-BuildRequires: tetex
 BuildRequires: sed >= 4.0
+BuildRequires: tetex
+BuildRequires: which
+%endif
 Requires:      SDL >= 1.2.1
 # sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
-ExclusiveArch: %{ix86} %{x8664} %{!?with_kqemu:ppc}
+ExclusiveArch: %{ix86} %{x8664} %{?with_userspace:ppc}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # some SPARC boot image in ELF format
@@ -69,69 +104,48 @@ CPUs. QEMU has two operating modes:
   including a processor and various peripherials. It can also be used to
   provide virtual hosting of several virtual PC on a single server.
 
-%description -l pl
-QEMU to szybki(!) emulator procesora. Poprzez u¿ycie dynamicznego
-t³umaczenia osi±ga rozs±dn± szybko¶æ i jest ³atwy do przeportowania,
-aby dzia³a³ na kolejnych procesorach. QEMU ma dwa tryby pracy:
+%description -l pl.UTF-8
+QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
+tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
+aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
 
-- Emulacja trybu u¿ytkownika. W tym trybie QEMU mo¿e uruchamiaæ
+- Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
   procesy linuksowe skompilowane dla jednego procesora na innym
-  procesorze. Linuksowe wywo³ania systemowe s± t³umaczone ze wzglêdu na
-  niezgodno¶æ kolejno¶ci bajtów w s³owie i 32/64-bitowego rozmiaru
-  s³owa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to g³ówne
+  procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
+  niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
+  słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
   cele QEMU.
 
-- Pe³na emulacja systemu. W tym trybie QEMU emuluje ca³y system,
-  w³±czaj±c w to procesor i ró¿ne urz±dzenia peryferyjne. Mo¿e byæ tak¿e
-  u¿ywane do wirtualnego hostowania kilku wirtualnych pecetów na
+- Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
+  włączając w to procesor i różne urządzenia peryferyjne. Może być także
+  używane do wirtualnego hostowania kilku wirtualnych pecetów na
   pojedynczym serwerze.
 
-%package -n kernel-misc-kqemu
+%package -n kernel%{_alt_kernel}-misc-kqemu
 Summary:       kqemu - kernel module
-Summary(pl):   kqemu - modu³ j±dra
-Version:       %{_kqemu_version}
-Release:       %{_rel}@%{_kernel_ver_str}
+Summary(pl.UTF-8):     kqemu - moduł jądra
+Version:       %{kqemu_version}
+Release:       %{rel}@%{_kernel_ver_str}
 Group:         Base/Kernel
-%{?with_dist_kernel:%requires_releq_kernel_up}
-License:       Free to use, non-distributable
+%{?with_dist_kernel:%requires_releq_kernel}
+License:       GPL v2
+Obsoletes:     kernel%{_alt_kernel}-smp-misc-kqemu
 Requires(post,postun): /sbin/depmod
 Requires:      module-init-tools >= 3.2.2-2
 
-%description -n kernel-misc-kqemu
+%description -n kernel%{_alt_kernel}-misc-kqemu
 kqemu - kernel module.
 
-%description -n kernel-misc-kqemu -l pl
-kqemu - modu³ j±dra.
-
-%package -n kernel-smp-misc-kqemu
-Summary:       kqemu - SMP kernel module
-Summary(pl):   kqemu - modu³ j±dra SMP
-Version:       %{_kqemu_version}
-Release:       %{_rel}@%{_kernel_ver_str}
-Group:         Base/Kernel
-%{?with_dist_kernel:%requires_releq_kernel_up}
-License:       Free to use, non-distributable
-Requires(post,postun): /sbin/depmod
-Requires:      module-init-tools >= 3.2.2-2
-
-%description -n kernel-smp-misc-kqemu
-kqemu - SMP kernel module.
-
-%description -n kernel-smp-misc-kqemu -l pl
-kqemu - modu³ j±dra SMP.
+%description -n kernel%{_alt_kernel}-misc-kqemu -l pl.UTF-8
+kqemu - moduł jądra.
 
 %prep
-%setup -q %{?with_kernel:-a1}
+%setup -q -n %{pname}-%{qemu_version} %{?with_kernel:-a1}
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
 %patch3 -p1
-%if %{with gcc4}
-%patch4 -p0
-%patch5 -p1
-%endif
 %{?with_nosdlgui:%patch6 -p1}
-%patch7 -p1
+#%patch8 -p1
 
 %{__sed} -i -e 's/sdl_static=yes/sdl_static=no/' configure
 %{__sed} -i 's/.*MAKE) -C kqemu$//' Makefile
@@ -144,7 +158,7 @@ kqemu - modu
 %endif
 
 %if %{with kernel}
-echo -n > kqemu-%{_kqemu_version}/install.sh
+echo -n > kqemu-%{kqemu_version}/install.sh
 
 cat <<'EOF' > modprobe.conf
 # enable dynamic major
@@ -156,40 +170,52 @@ EOF
 cat <<'EOF' > udev.conf
 KERNEL=="kqemu", NAME="%k", MODE="0666"
 EOF
+
+%if %{with dosguest}
+%patch13 -p1
+%endif
+%patch14 -p1
+%patch15 -p1
+%patch16 -p1
+%patch17 -p2
+%patch18 -p0
+%patch19 -p0
+%patch20 -p1
+
+cd kqemu-%{kqemu_version}
+%{__sed} -i 's#include ../config-host.mak##' ./common/Makefile
+%ifarch %{x8664}
+%{__sed} -i 's/^#ARCH=x86_64/ARCH=x86_64/' ./common/Makefile
+%{__make} -C common -j1
+mv -f kqemu-mod-x86_64.o{,.bin}
+%else
+%{__sed} -i 's/^#ARCH=i386/ARCH=i386/' ./common/Makefile
+%{__make} -C common -j1
+mv -f kqemu-mod-i386.o{,.bin}
 %endif
 
-%build
-%if %{with kernel}
-cd kqemu-%{_kqemu_version}
 mv -f kqemu-linux.c{,.orig}
-for cfg in %{?with_dist_kernel:%{?with_smp:smp} up}%{!?with_dist_kernel:nondist}; do
-       if [ ! -r "%{_kernelsrcdir}/config-$cfg" ]; then
-               exit 1
-       fi
-       install -d o/include/linux
-       ln -sf %{_kernelsrcdir}/config-$cfg o/.config
-       ln -sf %{_kernelsrcdir}/Module.symvers-$cfg o/Module.symvers
-       ln -sf %{_kernelsrcdir}/include/linux/autoconf-$cfg.h o/include/linux/autoconf.h
-%if %{with dist_kernel}
-       %{__make} -C %{_kernelsrcdir} O=$PWD/o prepare scripts
-%else
-       install -d o/include/config
-       touch o/include/config/MARKER
-       ln -sf %{_kernelsrcdir}/scripts o/scripts
+cat > Makefile <<'EOF'
+obj-m := kqemu.o
+kqemu-objs:= kqemu-linux.o kqemu-mod.o
+
+$(obj)/kqemu-mod.o: $(src)/kqemu-mod-$(ARCH).o.bin
+       cp $< $@
+EOF
+cd -
 %endif
-       if grep -q "^CONFIG_PREEMPT_RT=y$" o/.config; then
-               sed 's/SPIN_LOCK_UNLOCKED/SPIN_LOCK_UNLOCKED(kqemu_lock)/' \
-                       kqemu-linux.c.orig > kqemu-linux.c
-       else
-               cat kqemu-linux.c.orig > kqemu-linux.c
-       fi
-
-       %{__make} -C %{_kernelsrcdir} modules \
-               CC="%{__cc}" CPP="%{__cpp}" \
-               M=$PWD O=$PWD/o \
-               %{?with_verbose:V=1}
-       mv kqemu.ko kqemu-mod-$cfg.ko
-done
+
+%build
+%if %{with kernel}
+cd kqemu-%{kqemu_version}
+%build_kernel_modules -m kqemu <<'EOF'
+if grep -q "CONFIG_PREEMPT_RT" o/.config; then
+       sed 's/SPIN_LOCK_UNLOCKED/SPIN_LOCK_UNLOCKED(kqemu_lock)/' \
+               kqemu-linux.c.orig > kqemu-linux.c
+else
+       cat kqemu-linux.c.orig > kqemu-linux.c
+fi
+EOF
 cd -
 %endif
 
@@ -198,17 +224,14 @@ cd -
 # they can be passed if the cflags_passing bcond is used
 ./configure \
        --prefix=%{_prefix} \
-       --cc="%{__cc}" \
-       --host-cc="%{__cc}" \
+       --cc="%{__ucc}" \
+       --host-cc="%{__ucc}" \
        --make="%{__make}" \
-%if %{with kqemu}
-       --kernel-path=%{_kernelsrcdir} \
-%else
+%if %{without kqemu}
        --disable-kqemu \
 %endif
-       %{?with_gcc4:--disable-gcc-check} \
        --enable-alsa \
-       --interp-prefix=%{_libdir}/%{name}
+       --interp-prefix=%{_libdir}/%{pname}
 %{__make}
 %endif
 
@@ -219,26 +242,17 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-install -d $RPM_BUILD_ROOT/sbin
-cat <<'EOF' > $RPM_BUILD_ROOT/sbin/qemu-ifup
+install -d $RPM_BUILD_ROOT%{_sysconfdir}
+cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
 #!/bin/sh
-if [ -f /etc/sysconfig/qemu ]; then
-       . /etc/sysconfig/qemu
-fi
-# of course this will work only for one interface. a lot possible to involve
-sudo /sbin/ifconfig $1 ${INTERFACE_ADDR:-172.20.0.1}
+
 EOF
 %endif
 
 %if %{with kernel}
-install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}{,smp}/misc
+%install_kernel_modules -m kqemu-%{kqemu_version}/kqemu -d misc
 install -d $RPM_BUILD_ROOT/etc/{modprobe.d/%{_kernel_ver}{,smp},udev/rules.d}
-install kqemu-%{_kqemu_version}/kqemu-mod-up.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/misc/kqemu.ko
 install modprobe.conf $RPM_BUILD_ROOT/etc/modprobe.d/%{_kernel_ver}/kqemu.conf
-%if %{with smp} && %{with dist_kernel}
-install kqemu-%{_kqemu_version}/kqemu-mod-smp.ko $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/misc/kqemu.ko
-install modprobe.conf $RPM_BUILD_ROOT/etc/modprobe.d/%{_kernel_ver}smp/kqemu.conf
-%endif
 install udev.conf $RPM_BUILD_ROOT/etc/udev/rules.d/kqemu.rules
 %endif
 
@@ -250,29 +264,23 @@ rm -rf $RPM_BUILD_ROOT
 
 %if %{with kernel}
 %post
-%banner %{name} -e <<EOF
+%banner %{pname} -e <<EOF
 To enable qemu accelerator (kqemu), the kqemu kernel module must be loaded:
 modprobe kqemu
 EOF
 %endif
 
-%post  -n kernel-misc-kqemu
+%post  -n kernel%{_alt_kernel}-misc-kqemu
 %depmod %{_kernel_ver}
 
-%postun -n kernel-misc-kqemu
+%postun -n kernel%{_alt_kernel}-misc-kqemu
 %depmod %{_kernel_ver}
 
-%post  -n kernel-smp-misc-kqemu
-%depmod %{_kernel_ver}smp
-
-%postun -n kernel-smp-misc-kqemu
-%depmod %{_kernel_ver}smp
-
 %if %{with userspace}
 %files
 %defattr(644,root,root,755)
 %doc README qemu-doc.html qemu-tech.html
-%attr(755,root,root) /sbin/qemu-ifup
+%attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
 %attr(755,root,root) %{_bindir}/*
 %{_datadir}/qemu
 %{_mandir}/man1/qemu.1*
@@ -280,19 +288,10 @@ EOF
 %endif
 
 %if %{with kernel}
-%files -n kernel-misc-kqemu
+%files -n kernel%{_alt_kernel}-misc-kqemu
 %defattr(644,root,root,755)
-%doc kqemu-%{_kqemu_version}/LICENSE
+%doc kqemu-%{kqemu_version}/LICENSE
 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/kqemu.rules
 %config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/%{_kernel_ver}/kqemu.conf
 /lib/modules/%{_kernel_ver}/misc/kqemu.ko*
-
-%if %{with smp} && %{with dist_kernel}
-%files -n kernel-smp-misc-kqemu
-%defattr(644,root,root,755)
-%doc kqemu-%{_kqemu_version}/LICENSE
-%config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/kqemu.rules
-%config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/%{_kernel_ver}smp/kqemu.conf
-/lib/modules/%{_kernel_ver}smp/misc/kqemu.ko*
-%endif
 %endif
This page took 0.322307 seconds and 4 git commands to generate.