]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu.spec
- release 23
[packages/qemu.git] / qemu.spec
index 1e956bc58ca595441252cee4dfae6a7f93099d69..0f9cab4c25156180d2ff76e7d10b7a291204bbdf 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -8,31 +8,34 @@
 %bcond_with    cflags_passing          # with passing rpmcflags to Makefiles
 %bcond_with    dosguest                # add special patch when use with DOS as guest os
 %bcond_with    nosdlgui                # do not use SDL gui (use X11 instead)
-# Note that gcc4 build is very problematic and not supported by qemu team
-%bcond_with    gcc4                    # use gcc4 patches (broke build on gcc33)
 %bcond_without dist_kernel             # without distribution kernel
 %bcond_without kernel                  # build kqemu KERNEL MODULES
 %bcond_without userspace               # don't build userspace utilities
 
-%if %{without kernel}
-%undefine      with_dist_kernel
-%endif
-
 # no kernel kqemu module for ppc
 %ifarch ppc
 %undefine      with_kqemu
 %undefine      with_kernel
 %endif
 
+%if %{without kernel}
+%undefine      with_dist_kernel
+%endif
 %if "%{_alt_kernel}" != "%{nil}"
 %undefine      with_userspace
 %endif
+%if %{without userspace}
+# nothing to be placed to debuginfo package
+%define                _enable_debug_packages  0
+%endif
+
+%define                __ucc   gcc-3.4
+
+%define                rel     23
 
 %define                kqemu_version   1.3.0pre11
 %define                qemu_version    0.9.1
 %define                pname   qemu
-
-%define                rel     8
 Summary:       QEMU CPU Emulator
 Summary(pl.UTF-8):     QEMU - emulator procesora
 Name:          %{pname}%{_alt_kernel}
@@ -40,22 +43,17 @@ Version:    %{qemu_version}
 Release:       %{rel}%{?with_kqemu:k}
 License:       GPL
 Group:         Applications/Emulators
-#Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
-Source0:       http://fabrice.bellard.free.fr/qemu/%{pname}-%{version}.tar.gz
+# Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
+Source0:       http://bellard.org/qemu/%{pname}-%{version}.tar.gz
 # Source0-md5: 6591df8e9270eb358c881de4ebea1262
-Source1:       http://fabrice.bellard.free.fr/qemu/k%{pname}-%{kqemu_version}.tar.gz
+Source1:       http://bellard.org/qemu/k%{pname}-%{kqemu_version}.tar.gz
 # Source1-md5: 970521874ef8b1ba4598925ace5936c3
 Patch0:                %{pname}-nostatic.patch
 Patch1:                %{pname}-cc.patch
 Patch3:                %{pname}-dot.patch
-Patch4:                %{pname}-gcc4_x86.patch
-Patch5:                %{pname}-gcc4_ppc.patch
 Patch6:                %{pname}-nosdlgui.patch
 # Proof of concept, for reference, do not remove
 Patch8:                %{pname}-kde_virtual_workspaces_hack.patch
-# http://gwenole.beauchesne.info/en/projects/qemu
-Patch9:                %{pname}-0.8.0-gcc4-hacks.patch
-Patch11:       %{pname}-0.7.2-gcc4-opts.patch
 #Patch12:      %{pname}-0.7.2-dyngen-check-stack-clobbers.patch
 Patch13:       %{pname}-dosguest.patch
 Patch14:       %{pname}-ppc_old_binutils.patch
@@ -63,7 +61,14 @@ Patch15:     %{pname}-isa-bios-ram.patch
 # below one fixes problems with passing ram size to bios/bootloader
 # which affects coreboot/linuxbios
 Patch16:       %{pname}-piix-ram-size.patch
-URL:           http://fabrice.bellard.free.fr/qemu/
+Patch17:       %{pname}-CVE-2008-0928.patch
+Patch18:       %{pname}-CVE-2008-2004.patch
+Patch19:       %{pname}-gcc-workaround.patch
+Patch20:       %{pname}-dirent.patch
+URL:           http://bellard.org/qemu/
+# http://securitytracker.com/alerts/2008/Dec/1021488.html
+# patch in vendor's svn:
+BuildRequires: security(CVE-2008-2382)
 %if %{with kernel} && %{with dist_kernel}
 BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7
 BuildRequires: rpmbuild(macros) >= 1.379
@@ -71,7 +76,7 @@ BuildRequires:        rpmbuild(macros) >= 1.379
 %if %{with userspace}
 BuildRequires: SDL-devel >= 1.2.1
 BuildRequires: alsa-lib-devel
-%{!?with_gcc4:BuildRequires:   gcc < 5:4.0}
+BuildRequires: compat-gcc-34
 BuildRequires: perl-tools-pod
 BuildRequires: sed >= 4.0
 BuildRequires: tetex
@@ -139,13 +144,6 @@ kqemu - moduł jądra.
 %patch0 -p1
 %patch1 -p1
 %patch3 -p1
-%if %{with gcc4}
-%patch9 -p1
-%patch11 -p1
-#%patch12 -p1
-#%patch4 -p0
-%patch5 -p1
-%endif
 %{?with_nosdlgui:%patch6 -p1}
 #%patch8 -p1
 
@@ -179,6 +177,10 @@ EOF
 %patch14 -p1
 %patch15 -p1
 %patch16 -p1
+%patch17 -p2
+%patch18 -p0
+%patch19 -p0
+%patch20 -p1
 
 cd kqemu-%{kqemu_version}
 %{__sed} -i 's#include ../config-host.mak##' ./common/Makefile
@@ -222,13 +224,12 @@ cd -
 # they can be passed if the cflags_passing bcond is used
 ./configure \
        --prefix=%{_prefix} \
-       --cc="%{__cc}" \
-       --host-cc="%{__cc}" \
+       --cc="%{__ucc}" \
+       --host-cc="%{__ucc}" \
        --make="%{__make}" \
 %if %{without kqemu}
        --disable-kqemu \
 %endif
-       %{?with_gcc4:--disable-gcc-check} \
        --enable-alsa \
        --interp-prefix=%{_libdir}/%{pname}
 %{__make}
This page took 0.073355 seconds and 4 git commands to generate.