]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
- rel 10; use compat-gcc-34 for building
[packages/qemu.git] / qemu.spec
1 #
2 # TODO:
3 # - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
4 # - update or drop gcc4 bcond patches
5 #
6 # Conditional build:
7 %bcond_without  kqemu                   # disable KQEMU ACCELERATOR support in QEMU
8 %bcond_with     cflags_passing          # with passing rpmcflags to Makefiles
9 %bcond_with     dosguest                # add special patch when use with DOS as guest os
10 %bcond_with     nosdlgui                # do not use SDL gui (use X11 instead)
11 %bcond_without  dist_kernel             # without distribution kernel
12 %bcond_without  kernel                  # build kqemu KERNEL MODULES
13 %bcond_without  userspace               # don't build userspace utilities
14
15 # no kernel kqemu module for ppc
16 %ifarch ppc
17 %undefine      with_kqemu
18 %undefine      with_kernel
19 %endif
20
21 %if %{without kernel}
22 %undefine       with_dist_kernel
23 %endif
24 %if "%{_alt_kernel}" != "%{nil}"
25 %undefine       with_userspace
26 %endif
27 %if %{without userspace}
28 # nothing to be placed to debuginfo package
29 %define         _enable_debug_packages  0
30 %endif
31
32 %define         __ucc   gcc-3.4
33
34 %define         rel     10
35
36 %define         kqemu_version   1.3.0pre11
37 %define         qemu_version    0.9.1
38 %define         pname   qemu
39 Summary:        QEMU CPU Emulator
40 Summary(pl.UTF-8):      QEMU - emulator procesora
41 Name:           %{pname}%{_alt_kernel}
42 Version:        %{qemu_version}
43 Release:        %{rel}%{?with_kqemu:k}
44 License:        GPL
45 Group:          Applications/Emulators
46 # Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
47 Source0:        http://bellard.org/qemu/%{pname}-%{version}.tar.gz
48 # Source0-md5:  6591df8e9270eb358c881de4ebea1262
49 Source1:        http://bellard.org/qemu/k%{pname}-%{kqemu_version}.tar.gz
50 # Source1-md5:  970521874ef8b1ba4598925ace5936c3
51 Patch0:         %{pname}-nostatic.patch
52 Patch1:         %{pname}-cc.patch
53 Patch3:         %{pname}-dot.patch
54 Patch6:         %{pname}-nosdlgui.patch
55 # Proof of concept, for reference, do not remove
56 Patch8:         %{pname}-kde_virtual_workspaces_hack.patch
57 #Patch12:       %{pname}-0.7.2-dyngen-check-stack-clobbers.patch
58 Patch13:        %{pname}-dosguest.patch
59 Patch14:        %{pname}-ppc_old_binutils.patch
60 Patch15:        %{pname}-isa-bios-ram.patch
61 # below one fixes problems with passing ram size to bios/bootloader
62 # which affects coreboot/linuxbios
63 Patch16:        %{pname}-piix-ram-size.patch
64 Patch17:        %{pname}-CVE-2008-0928.patch
65 Patch18:        %{pname}-CVE-2008-2004.patch
66 URL:            http://bellard.org/qemu/
67 %if %{with kernel} && %{with dist_kernel}
68 BuildRequires:  kernel%{_alt_kernel}-module-build >= 3:2.6.7
69 BuildRequires:  rpmbuild(macros) >= 1.379
70 %endif
71 %if %{with userspace}
72 BuildRequires:  SDL-devel >= 1.2.1
73 BuildRequires:  alsa-lib-devel
74 BuildRequires:  compat-gcc-34
75 BuildRequires:  perl-tools-pod
76 BuildRequires:  sed >= 4.0
77 BuildRequires:  tetex
78 BuildRequires:  which
79 %endif
80 Requires:       SDL >= 1.2.1
81 # sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
82 ExclusiveArch:  %{ix86} %{x8664} %{?with_userspace:ppc}
83 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
85 # some SPARC boot image in ELF format
86 %define         _noautostrip    .*%{_datadir}/qemu/openbios-sparc32
87
88 %description
89 QEMU is a FAST! processor emulator. By using dynamic translation it
90 achieves a reasonnable speed while being easy to port on new host
91 CPUs. QEMU has two operating modes:
92
93 - User mode emulation. In this mode, QEMU can launch Linux processes
94   compiled for one CPU on another CPU. Linux system calls are converted
95   because of endianness and 32/64 bit mismatches. Wine (Windows
96   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
97
98 - Full system emulation. In this mode, QEMU emulates a full system,
99   including a processor and various peripherials. It can also be used to
100   provide virtual hosting of several virtual PC on a single server.
101
102 %description -l pl.UTF-8
103 QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
104 tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
105 aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
106
107 - Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
108   procesy linuksowe skompilowane dla jednego procesora na innym
109   procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
110   niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
111   słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
112   cele QEMU.
113
114 - Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
115   włączając w to procesor i różne urządzenia peryferyjne. Może być także
116   używane do wirtualnego hostowania kilku wirtualnych pecetów na
117   pojedynczym serwerze.
118
119 %package -n kernel%{_alt_kernel}-misc-kqemu
120 Summary:        kqemu - kernel module
121 Summary(pl.UTF-8):      kqemu - moduł jądra
122 Version:        %{kqemu_version}
123 Release:        %{rel}@%{_kernel_ver_str}
124 Group:          Base/Kernel
125 %{?with_dist_kernel:%requires_releq_kernel}
126 License:        GPL v2
127 Obsoletes:      kernel%{_alt_kernel}-smp-misc-kqemu
128 Requires(post,postun):  /sbin/depmod
129 Requires:       module-init-tools >= 3.2.2-2
130
131 %description -n kernel%{_alt_kernel}-misc-kqemu
132 kqemu - kernel module.
133
134 %description -n kernel%{_alt_kernel}-misc-kqemu -l pl.UTF-8
135 kqemu - moduł jądra.
136
137 %prep
138 %setup -q -n %{pname}-%{qemu_version} %{?with_kernel:-a1}
139 %patch0 -p1
140 %patch1 -p1
141 %patch3 -p1
142 %{?with_nosdlgui:%patch6 -p1}
143 #%patch8 -p1
144
145 %{__sed} -i -e 's/sdl_static=yes/sdl_static=no/' configure
146 %{__sed} -i 's/.*MAKE) -C kqemu$//' Makefile
147
148 # cannot use optflags on x86 - they cause "no register to spill" errors
149 %if %{with cflags_passing}
150 %{__sed} -i -e 's/-Wall -O2 -g/-Wall %{rpmcflags}/' Makefile Makefile.target
151 %else
152 %{__sed} -i 's/-Wall -O2 -g/-Wall -O2/' Makefile Makefile.target
153 %endif
154
155 %if %{with kernel}
156 echo -n > kqemu-%{kqemu_version}/install.sh
157
158 cat <<'EOF' > modprobe.conf
159 # enable dynamic major
160 options kqemu major=0
161 # for autoloading from static dev
162 #alias char-major-250 kqemu
163 EOF
164
165 cat <<'EOF' > udev.conf
166 KERNEL=="kqemu", NAME="%k", MODE="0666"
167 EOF
168
169 %if %{with dosguest}
170 %patch13 -p1
171 %endif
172 %patch14 -p1
173 %patch15 -p1
174 %patch16 -p1
175 %patch17 -p2
176 %patch18 -p0
177
178 cd kqemu-%{kqemu_version}
179 %{__sed} -i 's#include ../config-host.mak##' ./common/Makefile
180 %ifarch %{x8664}
181 %{__sed} -i 's/^#ARCH=x86_64/ARCH=x86_64/' ./common/Makefile
182 %{__make} -C common -j1
183 mv -f kqemu-mod-x86_64.o{,.bin}
184 %else
185 %{__sed} -i 's/^#ARCH=i386/ARCH=i386/' ./common/Makefile
186 %{__make} -C common -j1
187 mv -f kqemu-mod-i386.o{,.bin}
188 %endif
189
190 mv -f kqemu-linux.c{,.orig}
191 cat > Makefile <<'EOF'
192 obj-m := kqemu.o
193 kqemu-objs:= kqemu-linux.o kqemu-mod.o
194
195 $(obj)/kqemu-mod.o: $(src)/kqemu-mod-$(ARCH).o.bin
196         cp $< $@
197 EOF
198 cd -
199 %endif
200
201 %build
202 %if %{with kernel}
203 cd kqemu-%{kqemu_version}
204 %build_kernel_modules -m kqemu <<'EOF'
205 if grep -q "CONFIG_PREEMPT_RT" o/.config; then
206         sed 's/SPIN_LOCK_UNLOCKED/SPIN_LOCK_UNLOCKED(kqemu_lock)/' \
207                 kqemu-linux.c.orig > kqemu-linux.c
208 else
209         cat kqemu-linux.c.orig > kqemu-linux.c
210 fi
211 EOF
212 cd -
213 %endif
214
215 %if %{with userspace}
216 # --extra-cflags don't work (overridden by CFLAGS in Makefile*)
217 # they can be passed if the cflags_passing bcond is used
218 ./configure \
219         --prefix=%{_prefix} \
220         --cc="%{__ucc}" \
221         --host-cc="%{__ucc}" \
222         --make="%{__make}" \
223 %if %{without kqemu}
224         --disable-kqemu \
225 %endif
226         --enable-alsa \
227         --interp-prefix=%{_libdir}/%{pname}
228 %{__make}
229 %endif
230
231 %install
232 rm -rf $RPM_BUILD_ROOT
233
234 %if %{with userspace}
235 %{__make} install \
236         DESTDIR=$RPM_BUILD_ROOT
237
238 install -d $RPM_BUILD_ROOT%{_sysconfdir}
239 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
240 #!/bin/sh
241
242 EOF
243 %endif
244
245 %if %{with kernel}
246 %install_kernel_modules -m kqemu-%{kqemu_version}/kqemu -d misc
247 install -d $RPM_BUILD_ROOT/etc/{modprobe.d/%{_kernel_ver}{,smp},udev/rules.d}
248 install modprobe.conf $RPM_BUILD_ROOT/etc/modprobe.d/%{_kernel_ver}/kqemu.conf
249 install udev.conf $RPM_BUILD_ROOT/etc/udev/rules.d/kqemu.rules
250 %endif
251
252 # already packaged
253 rm -rf $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
254
255 %clean
256 rm -rf $RPM_BUILD_ROOT
257
258 %if %{with kernel}
259 %post
260 %banner %{pname} -e <<EOF
261 To enable qemu accelerator (kqemu), the kqemu kernel module must be loaded:
262 modprobe kqemu
263 EOF
264 %endif
265
266 %post   -n kernel%{_alt_kernel}-misc-kqemu
267 %depmod %{_kernel_ver}
268
269 %postun -n kernel%{_alt_kernel}-misc-kqemu
270 %depmod %{_kernel_ver}
271
272 %if %{with userspace}
273 %files
274 %defattr(644,root,root,755)
275 %doc README qemu-doc.html qemu-tech.html
276 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
277 %attr(755,root,root) %{_bindir}/*
278 %{_datadir}/qemu
279 %{_mandir}/man1/qemu.1*
280 %{_mandir}/man1/qemu-img.1*
281 %endif
282
283 %if %{with kernel}
284 %files -n kernel%{_alt_kernel}-misc-kqemu
285 %defattr(644,root,root,755)
286 %doc kqemu-%{kqemu_version}/LICENSE
287 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/kqemu.rules
288 %config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/%{_kernel_ver}/kqemu.conf
289 /lib/modules/%{_kernel_ver}/misc/kqemu.ko*
290 %endif
This page took 0.068664 seconds and 4 git commands to generate.