]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
- add -CVE-2008-0928.patch, -CVE-2008-2004.patch from gentoo; rel 9
[packages/qemu.git] / qemu.spec
1 #
2 # TODO:
3 # - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
4 # - update or drop gcc4 bcond patches
5 #
6 # Conditional build:
7 %bcond_without  kqemu                   # disable KQEMU ACCELERATOR support in QEMU
8 %bcond_with     cflags_passing          # with passing rpmcflags to Makefiles
9 %bcond_with     dosguest                # add special patch when use with DOS as guest os
10 %bcond_with     nosdlgui                # do not use SDL gui (use X11 instead)
11 # Note that gcc4 build is very problematic and not supported by qemu team
12 %bcond_with     gcc4                    # use gcc4 patches (broke build on gcc33)
13 %bcond_without  dist_kernel             # without distribution kernel
14 %bcond_without  kernel                  # build kqemu KERNEL MODULES
15 %bcond_without  userspace               # don't build userspace utilities
16
17 %if %{without kernel}
18 %undefine       with_dist_kernel
19 %endif
20
21 # no kernel kqemu module for ppc
22 %ifarch ppc
23 %undefine      with_kqemu
24 %undefine      with_kernel
25 %endif
26
27 %if "%{_alt_kernel}" != "%{nil}"
28 %undefine       with_userspace
29 %endif
30
31 %define         kqemu_version   1.3.0pre11
32 %define         qemu_version    0.9.1
33 %define         pname   qemu
34
35 %define         rel     9
36 Summary:        QEMU CPU Emulator
37 Summary(pl.UTF-8):      QEMU - emulator procesora
38 Name:           %{pname}%{_alt_kernel}
39 Version:        %{qemu_version}
40 Release:        %{rel}%{?with_kqemu:k}
41 License:        GPL
42 Group:          Applications/Emulators
43 # Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
44 Source0:        http://fabrice.bellard.free.fr/qemu/%{pname}-%{version}.tar.gz
45 # Source0-md5:  6591df8e9270eb358c881de4ebea1262
46 Source1:        http://fabrice.bellard.free.fr/qemu/k%{pname}-%{kqemu_version}.tar.gz
47 # Source1-md5:  970521874ef8b1ba4598925ace5936c3
48 Patch0:         %{pname}-nostatic.patch
49 Patch1:         %{pname}-cc.patch
50 Patch3:         %{pname}-dot.patch
51 Patch4:         %{pname}-gcc4_x86.patch
52 Patch5:         %{pname}-gcc4_ppc.patch
53 Patch6:         %{pname}-nosdlgui.patch
54 # Proof of concept, for reference, do not remove
55 Patch8:         %{pname}-kde_virtual_workspaces_hack.patch
56 # http://gwenole.beauchesne.info/en/projects/qemu
57 Patch9:         %{pname}-0.8.0-gcc4-hacks.patch
58 Patch11:        %{pname}-0.7.2-gcc4-opts.patch
59 #Patch12:       %{pname}-0.7.2-dyngen-check-stack-clobbers.patch
60 Patch13:        %{pname}-dosguest.patch
61 Patch14:        %{pname}-ppc_old_binutils.patch
62 Patch15:        %{pname}-isa-bios-ram.patch
63 # below one fixes problems with passing ram size to bios/bootloader
64 # which affects coreboot/linuxbios
65 Patch16:        %{pname}-piix-ram-size.patch
66 Patch17:        %{pname}-CVE-2008-0928.patch
67 Patch18:        %{pname}-CVE-2008-2004.patch
68 URL:            http://fabrice.bellard.free.fr/qemu/
69 %if %{with kernel} && %{with dist_kernel}
70 BuildRequires:  kernel%{_alt_kernel}-module-build >= 3:2.6.7
71 BuildRequires:  rpmbuild(macros) >= 1.379
72 %endif
73 %if %{with userspace}
74 BuildRequires:  SDL-devel >= 1.2.1
75 BuildRequires:  alsa-lib-devel
76 %{!?with_gcc4:BuildRequires:    gcc < 5:4.0}
77 BuildRequires:  perl-tools-pod
78 BuildRequires:  sed >= 4.0
79 BuildRequires:  tetex
80 BuildRequires:  which
81 %endif
82 Requires:       SDL >= 1.2.1
83 # sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
84 ExclusiveArch:  %{ix86} %{x8664} %{?with_userspace:ppc}
85 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86
87 # some SPARC boot image in ELF format
88 %define         _noautostrip    .*%{_datadir}/qemu/openbios-sparc32
89
90 %description
91 QEMU is a FAST! processor emulator. By using dynamic translation it
92 achieves a reasonnable speed while being easy to port on new host
93 CPUs. QEMU has two operating modes:
94
95 - User mode emulation. In this mode, QEMU can launch Linux processes
96   compiled for one CPU on another CPU. Linux system calls are converted
97   because of endianness and 32/64 bit mismatches. Wine (Windows
98   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
99
100 - Full system emulation. In this mode, QEMU emulates a full system,
101   including a processor and various peripherials. It can also be used to
102   provide virtual hosting of several virtual PC on a single server.
103
104 %description -l pl.UTF-8
105 QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
106 tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
107 aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
108
109 - Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
110   procesy linuksowe skompilowane dla jednego procesora na innym
111   procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
112   niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
113   słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
114   cele QEMU.
115
116 - Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
117   włączając w to procesor i różne urządzenia peryferyjne. Może być także
118   używane do wirtualnego hostowania kilku wirtualnych pecetów na
119   pojedynczym serwerze.
120
121 %package -n kernel%{_alt_kernel}-misc-kqemu
122 Summary:        kqemu - kernel module
123 Summary(pl.UTF-8):      kqemu - moduł jądra
124 Version:        %{kqemu_version}
125 Release:        %{rel}@%{_kernel_ver_str}
126 Group:          Base/Kernel
127 %{?with_dist_kernel:%requires_releq_kernel}
128 License:        GPL v2
129 Obsoletes:      kernel%{_alt_kernel}-smp-misc-kqemu
130 Requires(post,postun):  /sbin/depmod
131 Requires:       module-init-tools >= 3.2.2-2
132
133 %description -n kernel%{_alt_kernel}-misc-kqemu
134 kqemu - kernel module.
135
136 %description -n kernel%{_alt_kernel}-misc-kqemu -l pl.UTF-8
137 kqemu - moduł jądra.
138
139 %prep
140 %setup -q -n %{pname}-%{qemu_version} %{?with_kernel:-a1}
141 %patch0 -p1
142 %patch1 -p1
143 %patch3 -p1
144 %if %{with gcc4}
145 %patch9 -p1
146 %patch11 -p1
147 #%patch12 -p1
148 #%patch4 -p0
149 %patch5 -p1
150 %endif
151 %{?with_nosdlgui:%patch6 -p1}
152 #%patch8 -p1
153
154 %{__sed} -i -e 's/sdl_static=yes/sdl_static=no/' configure
155 %{__sed} -i 's/.*MAKE) -C kqemu$//' Makefile
156
157 # cannot use optflags on x86 - they cause "no register to spill" errors
158 %if %{with cflags_passing}
159 %{__sed} -i -e 's/-Wall -O2 -g/-Wall %{rpmcflags}/' Makefile Makefile.target
160 %else
161 %{__sed} -i 's/-Wall -O2 -g/-Wall -O2/' Makefile Makefile.target
162 %endif
163
164 %if %{with kernel}
165 echo -n > kqemu-%{kqemu_version}/install.sh
166
167 cat <<'EOF' > modprobe.conf
168 # enable dynamic major
169 options kqemu major=0
170 # for autoloading from static dev
171 #alias char-major-250 kqemu
172 EOF
173
174 cat <<'EOF' > udev.conf
175 KERNEL=="kqemu", NAME="%k", MODE="0666"
176 EOF
177
178 %if %{with dosguest}
179 %patch13 -p1
180 %endif
181 %patch14 -p1
182 %patch15 -p1
183 %patch16 -p1
184 %patch17 -p2
185 %patch18 -p0
186
187 cd kqemu-%{kqemu_version}
188 %{__sed} -i 's#include ../config-host.mak##' ./common/Makefile
189 %ifarch %{x8664}
190 %{__sed} -i 's/^#ARCH=x86_64/ARCH=x86_64/' ./common/Makefile
191 %{__make} -C common -j1
192 mv -f kqemu-mod-x86_64.o{,.bin}
193 %else
194 %{__sed} -i 's/^#ARCH=i386/ARCH=i386/' ./common/Makefile
195 %{__make} -C common -j1
196 mv -f kqemu-mod-i386.o{,.bin}
197 %endif
198
199 mv -f kqemu-linux.c{,.orig}
200 cat > Makefile <<'EOF'
201 obj-m := kqemu.o
202 kqemu-objs:= kqemu-linux.o kqemu-mod.o
203
204 $(obj)/kqemu-mod.o: $(src)/kqemu-mod-$(ARCH).o.bin
205         cp $< $@
206 EOF
207 cd -
208 %endif
209
210 %build
211 %if %{with kernel}
212 cd kqemu-%{kqemu_version}
213 %build_kernel_modules -m kqemu <<'EOF'
214 if grep -q "CONFIG_PREEMPT_RT" o/.config; then
215         sed 's/SPIN_LOCK_UNLOCKED/SPIN_LOCK_UNLOCKED(kqemu_lock)/' \
216                 kqemu-linux.c.orig > kqemu-linux.c
217 else
218         cat kqemu-linux.c.orig > kqemu-linux.c
219 fi
220 EOF
221 cd -
222 %endif
223
224 %if %{with userspace}
225 # --extra-cflags don't work (overridden by CFLAGS in Makefile*)
226 # they can be passed if the cflags_passing bcond is used
227 ./configure \
228         --prefix=%{_prefix} \
229         --cc="%{__cc}" \
230         --host-cc="%{__cc}" \
231         --make="%{__make}" \
232 %if %{without kqemu}
233         --disable-kqemu \
234 %endif
235         %{?with_gcc4:--disable-gcc-check} \
236         --enable-alsa \
237         --interp-prefix=%{_libdir}/%{pname}
238 %{__make}
239 %endif
240
241 %install
242 rm -rf $RPM_BUILD_ROOT
243
244 %if %{with userspace}
245 %{__make} install \
246         DESTDIR=$RPM_BUILD_ROOT
247
248 install -d $RPM_BUILD_ROOT%{_sysconfdir}
249 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
250 #!/bin/sh
251
252 EOF
253 %endif
254
255 %if %{with kernel}
256 %install_kernel_modules -m kqemu-%{kqemu_version}/kqemu -d misc
257 install -d $RPM_BUILD_ROOT/etc/{modprobe.d/%{_kernel_ver}{,smp},udev/rules.d}
258 install modprobe.conf $RPM_BUILD_ROOT/etc/modprobe.d/%{_kernel_ver}/kqemu.conf
259 install udev.conf $RPM_BUILD_ROOT/etc/udev/rules.d/kqemu.rules
260 %endif
261
262 # already packaged
263 rm -rf $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
264
265 %clean
266 rm -rf $RPM_BUILD_ROOT
267
268 %if %{with kernel}
269 %post
270 %banner %{pname} -e <<EOF
271 To enable qemu accelerator (kqemu), the kqemu kernel module must be loaded:
272 modprobe kqemu
273 EOF
274 %endif
275
276 %post   -n kernel%{_alt_kernel}-misc-kqemu
277 %depmod %{_kernel_ver}
278
279 %postun -n kernel%{_alt_kernel}-misc-kqemu
280 %depmod %{_kernel_ver}
281
282 %if %{with userspace}
283 %files
284 %defattr(644,root,root,755)
285 %doc README qemu-doc.html qemu-tech.html
286 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
287 %attr(755,root,root) %{_bindir}/*
288 %{_datadir}/qemu
289 %{_mandir}/man1/qemu.1*
290 %{_mandir}/man1/qemu-img.1*
291 %endif
292
293 %if %{with kernel}
294 %files -n kernel%{_alt_kernel}-misc-kqemu
295 %defattr(644,root,root,755)
296 %doc kqemu-%{kqemu_version}/LICENSE
297 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/kqemu.rules
298 %config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/%{_kernel_ver}/kqemu.conf
299 /lib/modules/%{_kernel_ver}/misc/kqemu.ko*
300 %endif
This page took 0.111256 seconds and 4 git commands to generate.