]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
- release 24
[packages/qemu.git] / qemu.spec
1 #
2 # TODO:
3 # - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
4 # - update or drop gcc4 bcond patches
5 #
6 # Conditional build:
7 %bcond_without  kqemu                   # disable KQEMU ACCELERATOR support in QEMU
8 %bcond_with     cflags_passing          # with passing rpmcflags to Makefiles
9 %bcond_with     dosguest                # add special patch when use with DOS as guest os
10 %bcond_with     nosdlgui                # do not use SDL gui (use X11 instead)
11 %bcond_without  dist_kernel             # without distribution kernel
12 %bcond_without  kernel                  # build kqemu KERNEL MODULES
13 %bcond_without  userspace               # don't build userspace utilities
14
15 # no kernel kqemu module for ppc
16 %ifarch ppc
17 %undefine      with_kqemu
18 %undefine      with_kernel
19 %endif
20
21 %if %{without kernel}
22 %undefine       with_dist_kernel
23 %endif
24 %if "%{_alt_kernel}" != "%{nil}"
25 %undefine       with_userspace
26 %endif
27 %if %{without userspace}
28 # nothing to be placed to debuginfo package
29 %define         _enable_debug_packages  0
30 %endif
31
32 %define         __ucc   gcc-3.4
33
34 %define         rel     24
35
36 %define         kqemu_version   1.3.0pre11
37 %define         qemu_version    0.9.1
38 %define         pname   qemu
39 Summary:        QEMU CPU Emulator
40 Summary(pl.UTF-8):      QEMU - emulator procesora
41 Name:           %{pname}%{_alt_kernel}
42 Version:        %{qemu_version}
43 Release:        %{rel}%{?with_kqemu:k}
44 License:        GPL
45 Group:          Applications/Emulators
46 # Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
47 Source0:        http://bellard.org/qemu/%{pname}-%{version}.tar.gz
48 # Source0-md5:  6591df8e9270eb358c881de4ebea1262
49 Source1:        http://bellard.org/qemu/k%{pname}-%{kqemu_version}.tar.gz
50 # Source1-md5:  970521874ef8b1ba4598925ace5936c3
51 Patch0:         %{pname}-nostatic.patch
52 Patch1:         %{pname}-cc.patch
53 Patch3:         %{pname}-dot.patch
54 Patch6:         %{pname}-nosdlgui.patch
55 # Proof of concept, for reference, do not remove
56 Patch8:         %{pname}-kde_virtual_workspaces_hack.patch
57 #Patch12:       %{pname}-0.7.2-dyngen-check-stack-clobbers.patch
58 Patch13:        %{pname}-dosguest.patch
59 Patch14:        %{pname}-ppc_old_binutils.patch
60 Patch15:        %{pname}-isa-bios-ram.patch
61 # below one fixes problems with passing ram size to bios/bootloader
62 # which affects coreboot/linuxbios
63 Patch16:        %{pname}-piix-ram-size.patch
64 Patch17:        %{pname}-CVE-2008-0928.patch
65 Patch18:        %{pname}-CVE-2008-2004.patch
66 Patch19:        %{pname}-gcc-workaround.patch
67 Patch20:        %{pname}-dirent.patch
68 URL:            http://bellard.org/qemu/
69 # http://securitytracker.com/alerts/2008/Dec/1021488.html
70 # patch in vendor's svn:
71 BuildRequires:  security(CVE-2008-2382)
72 %if %{with kernel} && %{with dist_kernel}
73 BuildRequires:  kernel%{_alt_kernel}-module-build >= 3:2.6.7
74 BuildRequires:  rpmbuild(macros) >= 1.379
75 %endif
76 %if %{with userspace}
77 BuildRequires:  SDL-devel >= 1.2.1
78 BuildRequires:  alsa-lib-devel
79 BuildRequires:  compat-gcc-34
80 BuildRequires:  perl-tools-pod
81 BuildRequires:  sed >= 4.0
82 BuildRequires:  tetex
83 BuildRequires:  which
84 %endif
85 Requires:       SDL >= 1.2.1
86 # sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
87 ExclusiveArch:  %{ix86} %{x8664} %{?with_userspace:ppc}
88 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
89
90 # some SPARC boot image in ELF format
91 %define         _noautostrip    .*%{_datadir}/qemu/openbios-sparc32
92
93 %description
94 QEMU is a FAST! processor emulator. By using dynamic translation it
95 achieves a reasonnable speed while being easy to port on new host
96 CPUs. QEMU has two operating modes:
97
98 - User mode emulation. In this mode, QEMU can launch Linux processes
99   compiled for one CPU on another CPU. Linux system calls are converted
100   because of endianness and 32/64 bit mismatches. Wine (Windows
101   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
102
103 - Full system emulation. In this mode, QEMU emulates a full system,
104   including a processor and various peripherials. It can also be used to
105   provide virtual hosting of several virtual PC on a single server.
106
107 %description -l pl.UTF-8
108 QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
109 tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
110 aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
111
112 - Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
113   procesy linuksowe skompilowane dla jednego procesora na innym
114   procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
115   niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
116   słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
117   cele QEMU.
118
119 - Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
120   włączając w to procesor i różne urządzenia peryferyjne. Może być także
121   używane do wirtualnego hostowania kilku wirtualnych pecetów na
122   pojedynczym serwerze.
123
124 %package -n kernel%{_alt_kernel}-misc-kqemu
125 Summary:        kqemu - kernel module
126 Summary(pl.UTF-8):      kqemu - moduł jądra
127 Version:        %{kqemu_version}
128 Release:        %{rel}@%{_kernel_ver_str}
129 Group:          Base/Kernel
130 %{?with_dist_kernel:%requires_releq_kernel}
131 License:        GPL v2
132 Obsoletes:      kernel%{_alt_kernel}-smp-misc-kqemu
133 Requires(post,postun):  /sbin/depmod
134 Requires:       module-init-tools >= 3.2.2-2
135
136 %description -n kernel%{_alt_kernel}-misc-kqemu
137 kqemu - kernel module.
138
139 %description -n kernel%{_alt_kernel}-misc-kqemu -l pl.UTF-8
140 kqemu - moduł jądra.
141
142 %prep
143 %setup -q -n %{pname}-%{qemu_version} %{?with_kernel:-a1}
144 %patch0 -p1
145 %patch1 -p1
146 %patch3 -p1
147 %{?with_nosdlgui:%patch6 -p1}
148 #%patch8 -p1
149
150 %{__sed} -i -e 's/sdl_static=yes/sdl_static=no/' configure
151 %{__sed} -i 's/.*MAKE) -C kqemu$//' Makefile
152
153 # cannot use optflags on x86 - they cause "no register to spill" errors
154 %if %{with cflags_passing}
155 %{__sed} -i -e 's/-Wall -O2 -g/-Wall %{rpmcflags}/' Makefile Makefile.target
156 %else
157 %{__sed} -i 's/-Wall -O2 -g/-Wall -O2/' Makefile Makefile.target
158 %endif
159
160 %if %{with kernel}
161 echo -n > kqemu-%{kqemu_version}/install.sh
162
163 cat <<'EOF' > modprobe.conf
164 # enable dynamic major
165 options kqemu major=0
166 # for autoloading from static dev
167 #alias char-major-250 kqemu
168 EOF
169
170 cat <<'EOF' > udev.conf
171 KERNEL=="kqemu", NAME="%k", MODE="0666"
172 EOF
173
174 %if %{with dosguest}
175 %patch13 -p1
176 %endif
177 %patch14 -p1
178 %patch15 -p1
179 %patch16 -p1
180 %patch17 -p2
181 %patch18 -p0
182 %patch19 -p0
183 %patch20 -p1
184
185 cd kqemu-%{kqemu_version}
186 %{__sed} -i 's#include ../config-host.mak##' ./common/Makefile
187 %ifarch %{x8664}
188 %{__sed} -i 's/^#ARCH=x86_64/ARCH=x86_64/' ./common/Makefile
189 %{__make} -C common -j1
190 mv -f kqemu-mod-x86_64.o{,.bin}
191 %else
192 %{__sed} -i 's/^#ARCH=i386/ARCH=i386/' ./common/Makefile
193 %{__make} -C common -j1
194 mv -f kqemu-mod-i386.o{,.bin}
195 %endif
196
197 mv -f kqemu-linux.c{,.orig}
198 cat > Makefile <<'EOF'
199 obj-m := kqemu.o
200 kqemu-objs:= kqemu-linux.o kqemu-mod.o
201
202 $(obj)/kqemu-mod.o: $(src)/kqemu-mod-$(ARCH).o.bin
203         cp $< $@
204 EOF
205 cd -
206 %endif
207
208 %build
209 %if %{with kernel}
210 cd kqemu-%{kqemu_version}
211 %build_kernel_modules -m kqemu <<'EOF'
212 if grep -q "CONFIG_PREEMPT_RT" o/.config; then
213         sed 's/SPIN_LOCK_UNLOCKED/SPIN_LOCK_UNLOCKED(kqemu_lock)/' \
214                 kqemu-linux.c.orig > kqemu-linux.c
215 else
216         cat kqemu-linux.c.orig > kqemu-linux.c
217 fi
218 EOF
219 cd -
220 %endif
221
222 %if %{with userspace}
223 # --extra-cflags don't work (overridden by CFLAGS in Makefile*)
224 # they can be passed if the cflags_passing bcond is used
225 ./configure \
226         --prefix=%{_prefix} \
227         --cc="%{__ucc}" \
228         --host-cc="%{__ucc}" \
229         --make="%{__make}" \
230 %if %{without kqemu}
231         --disable-kqemu \
232 %endif
233         --enable-alsa \
234         --interp-prefix=%{_libdir}/%{pname}
235 %{__make}
236 %endif
237
238 %install
239 rm -rf $RPM_BUILD_ROOT
240
241 %if %{with userspace}
242 %{__make} install \
243         DESTDIR=$RPM_BUILD_ROOT
244
245 install -d $RPM_BUILD_ROOT%{_sysconfdir}
246 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
247 #!/bin/sh
248
249 EOF
250 %endif
251
252 %if %{with kernel}
253 %install_kernel_modules -m kqemu-%{kqemu_version}/kqemu -d misc
254 install -d $RPM_BUILD_ROOT/etc/{modprobe.d/%{_kernel_ver}{,smp},udev/rules.d}
255 install modprobe.conf $RPM_BUILD_ROOT/etc/modprobe.d/%{_kernel_ver}/kqemu.conf
256 install udev.conf $RPM_BUILD_ROOT/etc/udev/rules.d/kqemu.rules
257 %endif
258
259 # already packaged
260 rm -rf $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
261
262 %clean
263 rm -rf $RPM_BUILD_ROOT
264
265 %if %{with kernel}
266 %post
267 %banner %{pname} -e <<EOF
268 To enable qemu accelerator (kqemu), the kqemu kernel module must be loaded:
269 modprobe kqemu
270 EOF
271 %endif
272
273 %post   -n kernel%{_alt_kernel}-misc-kqemu
274 %depmod %{_kernel_ver}
275
276 %postun -n kernel%{_alt_kernel}-misc-kqemu
277 %depmod %{_kernel_ver}
278
279 %if %{with userspace}
280 %files
281 %defattr(644,root,root,755)
282 %doc README qemu-doc.html qemu-tech.html
283 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
284 %attr(755,root,root) %{_bindir}/*
285 %{_datadir}/qemu
286 %{_mandir}/man1/qemu.1*
287 %{_mandir}/man1/qemu-img.1*
288 %endif
289
290 %if %{with kernel}
291 %files -n kernel%{_alt_kernel}-misc-kqemu
292 %defattr(644,root,root,755)
293 %doc kqemu-%{kqemu_version}/LICENSE
294 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/kqemu.rules
295 %config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/%{_kernel_ver}/kqemu.conf
296 /lib/modules/%{_kernel_ver}/misc/kqemu.ko*
297 %endif
This page took 0.058216 seconds and 4 git commands to generate.