]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
- release 29
[packages/qemu.git] / qemu.spec
1 #
2 # TODO:
3 # - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
4 # - update or drop gcc4 bcond patches
5 #
6 # Conditional build:
7 %bcond_without  kqemu                   # disable KQEMU ACCELERATOR support in QEMU
8 %bcond_with     cflags_passing          # with passing rpmcflags to Makefiles
9 %bcond_with     dosguest                # add special patch when use with DOS as guest os
10 %bcond_with     nosdlgui                # do not use SDL gui (use X11 instead)
11 %bcond_without  dist_kernel             # without distribution kernel
12 %bcond_without  kernel                  # build kqemu KERNEL MODULES
13 %bcond_without  userspace               # don't build userspace utilities
14
15 # no kernel kqemu module for ppc
16 %ifarch ppc
17 %undefine      with_kqemu
18 %undefine      with_kernel
19 %endif
20
21 %if %{without kernel}
22 %undefine       with_dist_kernel
23 %endif
24 %if "%{_alt_kernel}" != "%{nil}"
25 %undefine       with_userspace
26 %endif
27 %if %{without userspace}
28 # nothing to be placed to debuginfo package
29 %define         _enable_debug_packages  0
30 %endif
31
32 %define         __ucc   gcc-3.4
33
34 %define         rel     29
35
36 %define         kqemu_version   1.3.0pre11
37 %define         qemu_version    0.9.1
38 %define         pname   qemu
39 Summary:        QEMU CPU Emulator
40 Summary(pl.UTF-8):      QEMU - emulator procesora
41 Name:           %{pname}%{_alt_kernel}
42 Version:        %{qemu_version}
43 Release:        %{rel}%{?with_kqemu:k}
44 License:        GPL
45 Group:          Applications/Emulators
46 # Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
47 Source0:        http://bellard.org/qemu/%{pname}-%{version}.tar.gz
48 # Source0-md5:  6591df8e9270eb358c881de4ebea1262
49 Source1:        http://bellard.org/qemu/k%{pname}-%{kqemu_version}.tar.gz
50 # Source1-md5:  970521874ef8b1ba4598925ace5936c3
51 Patch0:         %{pname}-nostatic.patch
52 Patch1:         %{pname}-cc.patch
53 Patch3:         %{pname}-dot.patch
54 Patch6:         %{pname}-nosdlgui.patch
55 # Proof of concept, for reference, do not remove
56 Patch8:         %{pname}-kde_virtual_workspaces_hack.patch
57 #Patch12:       %{pname}-0.7.2-dyngen-check-stack-clobbers.patch
58 Patch13:        %{pname}-dosguest.patch
59 Patch14:        %{pname}-ppc_old_binutils.patch
60 Patch15:        %{pname}-isa-bios-ram.patch
61 # below one fixes problems with passing ram size to bios/bootloader
62 # which affects coreboot/linuxbios
63 Patch16:        %{pname}-piix-ram-size.patch
64 Patch17:        %{pname}-CVE-2008-0928.patch
65 Patch18:        %{pname}-CVE-2008-2004.patch
66 Patch19:        %{pname}-gcc-workaround.patch
67 Patch20:        %{pname}-dirent.patch
68 Patch21:        %{pname}-CVE-2008-2382.patch
69 URL:            http://bellard.org/qemu/
70 %if %{with kernel} && %{with dist_kernel}
71 BuildRequires:  kernel%{_alt_kernel}-module-build >= 3:2.6.7
72 BuildRequires:  rpmbuild(macros) >= 1.379
73 %endif
74 %if %{with userspace}
75 BuildRequires:  SDL-devel >= 1.2.1
76 BuildRequires:  alsa-lib-devel
77 BuildRequires:  compat-gcc-34
78 BuildRequires:  perl-tools-pod
79 BuildRequires:  sed >= 4.0
80 BuildRequires:  tetex
81 BuildRequires:  which
82 %endif
83 Requires:       SDL >= 1.2.1
84 # sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
85 ExclusiveArch:  %{ix86} %{x8664} %{?with_userspace:ppc}
86 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
87
88 # some SPARC boot image in ELF format
89 %define         _noautostrip    .*%{_datadir}/qemu/openbios-sparc32
90
91 %description
92 QEMU is a FAST! processor emulator. By using dynamic translation it
93 achieves a reasonnable speed while being easy to port on new host
94 CPUs. QEMU has two operating modes:
95
96 - User mode emulation. In this mode, QEMU can launch Linux processes
97   compiled for one CPU on another CPU. Linux system calls are converted
98   because of endianness and 32/64 bit mismatches. Wine (Windows
99   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
100
101 - Full system emulation. In this mode, QEMU emulates a full system,
102   including a processor and various peripherials. It can also be used to
103   provide virtual hosting of several virtual PC on a single server.
104
105 %description -l pl.UTF-8
106 QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
107 tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
108 aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
109
110 - Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
111   procesy linuksowe skompilowane dla jednego procesora na innym
112   procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
113   niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
114   słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
115   cele QEMU.
116
117 - Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
118   włączając w to procesor i różne urządzenia peryferyjne. Może być także
119   używane do wirtualnego hostowania kilku wirtualnych pecetów na
120   pojedynczym serwerze.
121
122 %package -n kernel%{_alt_kernel}-misc-kqemu
123 Summary:        kqemu - kernel module
124 Summary(pl.UTF-8):      kqemu - moduł jądra
125 Version:        %{kqemu_version}
126 Release:        %{rel}@%{_kernel_ver_str}
127 Group:          Base/Kernel
128 %{?with_dist_kernel:%requires_releq_kernel}
129 License:        GPL v2
130 Obsoletes:      kernel%{_alt_kernel}-smp-misc-kqemu
131 Requires(post,postun):  /sbin/depmod
132 Requires:       module-init-tools >= 3.2.2-2
133
134 %description -n kernel%{_alt_kernel}-misc-kqemu
135 kqemu - kernel module.
136
137 %description -n kernel%{_alt_kernel}-misc-kqemu -l pl.UTF-8
138 kqemu - moduł jądra.
139
140 %prep
141 %setup -q -n %{pname}-%{qemu_version} %{?with_kernel:-a1}
142 %patch0 -p1
143 %patch1 -p1
144 %patch3 -p1
145 %{?with_nosdlgui:%patch6 -p1}
146 #%patch8 -p1
147
148 %{__sed} -i -e 's/sdl_static=yes/sdl_static=no/' configure
149 %{__sed} -i 's/.*MAKE) -C kqemu$//' Makefile
150
151 # cannot use optflags on x86 - they cause "no register to spill" errors
152 %if %{with cflags_passing}
153 %{__sed} -i -e 's/-Wall -O2 -g/-Wall %{rpmcflags}/' Makefile Makefile.target
154 %else
155 %{__sed} -i 's/-Wall -O2 -g/-Wall -O2/' Makefile Makefile.target
156 %endif
157
158 %if %{with kernel}
159 echo -n > kqemu-%{kqemu_version}/install.sh
160
161 cat <<'EOF' > modprobe.conf
162 # enable dynamic major
163 options kqemu major=0
164 # for autoloading from static dev
165 #alias char-major-250 kqemu
166 EOF
167
168 cat <<'EOF' > udev.conf
169 KERNEL=="kqemu", NAME="%k", MODE="0666"
170 EOF
171
172 %if %{with dosguest}
173 %patch13 -p1
174 %endif
175 %patch14 -p1
176 %patch15 -p1
177 %patch16 -p1
178 %patch17 -p2
179 %patch18 -p0
180 %patch19 -p0
181 %patch20 -p1
182 %patch21 -p1
183
184 cd kqemu-%{kqemu_version}
185 %{__sed} -i 's#include ../config-host.mak##' ./common/Makefile
186 %ifarch %{x8664}
187 %{__sed} -i 's/^#ARCH=x86_64/ARCH=x86_64/' ./common/Makefile
188 %{__make} -C common -j1
189 mv -f kqemu-mod-x86_64.o{,.bin}
190 %else
191 %{__sed} -i 's/^#ARCH=i386/ARCH=i386/' ./common/Makefile
192 %{__make} -C common -j1
193 mv -f kqemu-mod-i386.o{,.bin}
194 %endif
195
196 mv -f kqemu-linux.c{,.orig}
197 cat > Makefile <<'EOF'
198 obj-m := kqemu.o
199 kqemu-objs:= kqemu-linux.o kqemu-mod.o
200
201 $(obj)/kqemu-mod.o: $(src)/kqemu-mod-$(ARCH).o.bin
202         cp $< $@
203 EOF
204 cd -
205 %endif
206
207 %build
208 %if %{with kernel}
209 cd kqemu-%{kqemu_version}
210 %build_kernel_modules -m kqemu <<'EOF'
211 if grep -q "CONFIG_PREEMPT_RT" o/.config; then
212         sed 's/SPIN_LOCK_UNLOCKED/SPIN_LOCK_UNLOCKED(kqemu_lock)/' \
213                 kqemu-linux.c.orig > kqemu-linux.c
214 else
215         cat kqemu-linux.c.orig > kqemu-linux.c
216 fi
217 EOF
218 cd -
219 %endif
220
221 %if %{with userspace}
222 # --extra-cflags don't work (overridden by CFLAGS in Makefile*)
223 # they can be passed if the cflags_passing bcond is used
224 ./configure \
225         --prefix=%{_prefix} \
226         --cc="%{__ucc}" \
227         --host-cc="%{__ucc}" \
228         --make="%{__make}" \
229 %if %{without kqemu}
230         --disable-kqemu \
231 %endif
232         --enable-alsa \
233         --interp-prefix=%{_libdir}/%{pname}
234 %{__make}
235 %endif
236
237 %install
238 rm -rf $RPM_BUILD_ROOT
239
240 %if %{with userspace}
241 %{__make} install \
242         DESTDIR=$RPM_BUILD_ROOT
243
244 install -d $RPM_BUILD_ROOT%{_sysconfdir}
245 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
246 #!/bin/sh
247
248 EOF
249 %endif
250
251 %if %{with kernel}
252 %install_kernel_modules -m kqemu-%{kqemu_version}/kqemu -d misc
253 install -d $RPM_BUILD_ROOT/etc/{modprobe.d/%{_kernel_ver}{,smp},udev/rules.d}
254 install modprobe.conf $RPM_BUILD_ROOT/etc/modprobe.d/%{_kernel_ver}/kqemu.conf
255 install udev.conf $RPM_BUILD_ROOT/etc/udev/rules.d/kqemu.rules
256 %endif
257
258 # already packaged
259 rm -rf $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
260
261 %clean
262 rm -rf $RPM_BUILD_ROOT
263
264 %if %{with kernel}
265 %post
266 %banner %{pname} -e <<EOF
267 To enable qemu accelerator (kqemu), the kqemu kernel module must be loaded:
268 modprobe kqemu
269 EOF
270 %endif
271
272 %post   -n kernel%{_alt_kernel}-misc-kqemu
273 %depmod %{_kernel_ver}
274
275 %postun -n kernel%{_alt_kernel}-misc-kqemu
276 %depmod %{_kernel_ver}
277
278 %if %{with userspace}
279 %files
280 %defattr(644,root,root,755)
281 %doc README qemu-doc.html qemu-tech.html
282 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
283 %attr(755,root,root) %{_bindir}/*
284 %{_datadir}/qemu
285 %{_mandir}/man1/qemu.1*
286 %{_mandir}/man1/qemu-img.1*
287 %endif
288
289 %if %{with kernel}
290 %files -n kernel%{_alt_kernel}-misc-kqemu
291 %defattr(644,root,root,755)
292 %doc kqemu-%{kqemu_version}/LICENSE
293 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/kqemu.rules
294 %config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/%{_kernel_ver}/kqemu.conf
295 /lib/modules/%{_kernel_ver}/misc/kqemu.ko*
296 %endif
This page took 0.089988 seconds and 4 git commands to generate.