]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
- this version is broken to run qemu-system-ppc
[packages/qemu.git] / qemu.spec
1 # TODO:
2 # - update patches
3 # - qemu-system-ppc -hda ac-ppc.img says:
4 #   qemu: could not open disk image ac-ppc.img: Success
5 #   qemu-0.12.2-2.x86_64.rpm - broken
6 #   qemu-0.11.1-7k.x86_64.rpm - OK
7 #
8 # Conditional build:
9 %bcond_with     cflags_passing          # with passing rpmcflags to Makefiles
10 %bcond_with     dosguest                # add special patch when use with DOS as guest os
11 %bcond_with     nosdlgui                # do not use SDL gui (use X11 instead)
12
13 Summary:        QEMU CPU Emulator
14 Summary(pl.UTF-8):      QEMU - emulator procesora
15 Name:           qemu
16 Version:        0.12.2
17 Release:        2
18 License:        GPL
19 Group:          Applications/Emulators
20 # Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
21 Source0:        http://download.savannah.gnu.org/releases/qemu/%{name}-%{version}.tar.gz
22 # Source0-md5:  1d7c2d95acb6d0789de86508c608e26d
23 Patch0:         %{name}-ncurses.patch
24 Patch6:         %{name}-nosdlgui.patch
25 # Proof of concept, for reference, do not remove
26 Patch8:         %{name}-kde_virtual_workspaces_hack.patch
27 #Patch12:       %{name}-0.7.2-dyngen-check-stack-clobbers.patch
28 Patch13:        %{name}-dosguest.patch
29 Patch14:        %{name}-ppc_old_binutils.patch
30 Patch15:        %{name}-isa-bios-ram.patch
31 # below one fixes problems with passing ram size to bios/bootloader
32 # which affects coreboot/linuxbios
33 Patch16:        %{name}-piix-ram-size.patch
34 URL:            http://www.nongnu.org/qemu/
35 BuildRequires:  SDL-devel >= 1.2.1
36 BuildRequires:  alsa-lib-devel
37 BuildRequires:  bluez-libs-devel
38 BuildRequires:  gnutls-devel
39 BuildRequires:  ncurses-devel
40 BuildRequires:  perl-Encode
41 BuildRequires:  perl-tools-pod
42 BuildRequires:  pkgconfig
43 BuildRequires:  sed >= 4.0
44 BuildRequires:  texi2html
45 BuildRequires:  which
46 BuildRequires:  xorg-lib-libX11-devel
47 Requires:       SDL >= 1.2.1
48 # sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
49 ExclusiveArch:  %{ix86} %{x8664} %{?with_userspace:ppc}
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 # some PPC/SPARC boot image in ELF format
53 %define         _noautostrip    .*%{_datadir}/qemu/openbios-.*
54
55 %description
56 QEMU is a FAST! processor emulator. By using dynamic translation it
57 achieves a reasonnable speed while being easy to port on new host
58 CPUs. QEMU has two operating modes:
59
60 - User mode emulation. In this mode, QEMU can launch Linux processes
61   compiled for one CPU on another CPU. Linux system calls are converted
62   because of endianness and 32/64 bit mismatches. Wine (Windows
63   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
64
65 - Full system emulation. In this mode, QEMU emulates a full system,
66   including a processor and various peripherials. It can also be used to
67   provide virtual hosting of several virtual PC on a single server.
68
69 %description -l pl.UTF-8
70 QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
71 tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
72 aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
73
74 - Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
75   procesy linuksowe skompilowane dla jednego procesora na innym
76   procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
77   niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
78   słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
79   cele QEMU.
80
81 - Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
82   włączając w to procesor i różne urządzenia peryferyjne. Może być także
83   używane do wirtualnego hostowania kilku wirtualnych pecetów na
84   pojedynczym serwerze.
85
86 %prep
87 %setup -q
88 %patch0 -p1
89 %{?with_nosdlgui:%patch6 -p1}
90 #patch8 -p1
91
92 %{__sed} -i -e 's/sdl_static=yes/sdl_static=no/' configure
93 %{__sed} -i 's/.*MAKE) -C kqemu$//' Makefile
94
95 # cannot use optflags on x86 - they cause "no register to spill" errors
96 %if %{with cflags_passing}
97 %{__sed} -i -e 's/-Wall -O2 -g/-Wall %{rpmcflags}/' Makefile Makefile.target
98 %else
99 %{__sed} -i 's/-Wall -O2 -g/-Wall -O2/' Makefile Makefile.target
100 %endif
101
102 %build
103 # --extra-cflags don't work (overridden by CFLAGS in Makefile*)
104 # they can be passed if the cflags_passing bcond is used
105 ./configure \
106         --prefix=%{_prefix} \
107         --cc="%{__cc}" \
108         --host-cc="%{__cc}" \
109         --make="%{__make}" \
110         --enable-mixemu \
111         --audio-drv-list="alsa" \
112         --interp-prefix=%{_libdir}/%{name}
113 %{__make}
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 install -d $RPM_BUILD_ROOT%{_sysconfdir}
122 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
123 #!/bin/sh
124
125 EOF
126
127 # already packaged
128 rm -rf $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %files
134 %defattr(644,root,root,755)
135 %doc README qemu-doc.html qemu-tech.html
136 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
137 %attr(755,root,root) %{_bindir}/*
138 %{_datadir}/qemu
139 %{_mandir}/man1/qemu.1*
140 %{_mandir}/man1/qemu-img.1*
141 %{_mandir}/man8/qemu-nbd.8*
This page took 0.037958 seconds and 4 git commands to generate.