]> git.pld-linux.org Git - packages/qemu.git/blame_incremental - qemu.spec
- renumber patches
[packages/qemu.git] / qemu.spec
... / ...
CommitLineData
1#
2# TODO:
3# - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
4# - kqemu could be distributable if somebody bothers to contact qemu
5# author http://fabrice.bellard.free.fr/qemu/qemu-accel.html
6#
7# Conditional build:
8%bcond_without kqemu # disable QEMU accelerator support
9%bcond_with cflags_passing # with passing rpmcflags to Makefiles
10%bcond_with nosdlgui # do not use SDL gui (use X11 instead)
11%bcond_with gcc4 # use gcc4 patches (broke build on gcc33)
12%bcond_without dist_kernel # without distribution kernel
13%bcond_with kernel # build kqemu kernel modules
14%bcond_without smp # don't build SMP module
15%bcond_without userspace # don't build userspace utilities
16#
17%define _kqemu_version 1.3.0pre7
18%define _rel 0.4
19Summary: QEMU CPU Emulator
20Summary(pl): QEMU - emulator procesora
21Name: qemu
22Version: 0.8.1
23Release: %{_rel}%{?with_kqemu:k}
24License: GPL
25Group: Applications/Emulators
26#Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
27Source0: http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
28# Source0-md5: 67d924324a5ab79d017bd97a1e767285
29Source1: http://fabrice.bellard.free.fr/qemu/k%{name}-%{_kqemu_version}.tar.gz
30# NoSource1-md5: 3b77edbada790f924456aa4675edd0be
31NoSource: 1
32Patch0: %{name}-nostatic.patch
33Patch1: %{name}-cc.patch
34Patch2: %{name}-longjmp.patch
35Patch3: %{name}-dot.patch
36Patch4: %{name}-gcc4_x86.patch
37Patch5: %{name}-gcc4_ppc.patch
38Patch6: %{name}-nosdlgui.patch
39Patch7: %{name}-ifup.patch
40Patch8: %{name}-gcc33.patch
41Patch9: %{name}-parallel.patch
42URL: http://fabrice.bellard.free.fr/qemu/
43BuildRequires: SDL-devel >= 1.2.1
44BuildRequires: alsa-lib-devel
45%{!?with_gcc4:BuildRequires: gcc < 5:4.0}
46%if %{with kqemu} && %{with dist_kernel}
47BuildRequires: kernel-module-build >= 3:2.6.7
48%endif
49BuildRequires: rpmbuild(macros) >= 1.217
50BuildRequires: sed >= 4.0
51Requires: SDL >= 1.2.1
52# sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
53ExclusiveArch: %{ix86} %{x8664} %{!?with_kqemu:ppc}
54BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56# some SPARC boot image in ELF format
57%define _noautostrip .*%{_datadir}/qemu/proll.elf
58
59%description
60QEMU is a FAST! processor emulator. By using dynamic translation it
61achieves a reasonnable speed while being easy to port on new host
62CPUs. QEMU has two operating modes:
63
64- User mode emulation. In this mode, QEMU can launch Linux processes
65 compiled for one CPU on another CPU. Linux system calls are converted
66 because of endianness and 32/64 bit mismatches. Wine (Windows
67 emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
68
69- Full system emulation. In this mode, QEMU emulates a full system,
70 including a processor and various peripherials. It can also be used to
71 provide virtual hosting of several virtual PC on a single server.
72
73%description -l pl
74