]> git.pld-linux.org Git - packages/qemu.git/blame - qemu.spec
- Up to 0.14.1
[packages/qemu.git] / qemu.spec
CommitLineData
0b920c52 1# TODO:
98a1a188 2# - update patches
01b9430c
ER
3# - qemu-system-ppc -hda ac-ppc.img says:
4# qemu: could not open disk image ac-ppc.img: Success
5# qemu-0.12.2-2.x86_64.rpm - broken
cef095a4 6# qemu-0.12.3-3.x86_64/qemu-0.12.4-1.x86_64 - stops on "returning from prom_init"
01b9430c 7# qemu-0.11.1-7k.x86_64.rpm - OK
0b920c52 8#
6aef4654 9# Conditional build:
161ffd93 10%bcond_with cflags_passing # with passing rpmcflags to Makefiles
b4d7fbfb 11%bcond_with dosguest # add special patch when use with DOS as guest os
a6d3659e 12%bcond_with nosdlgui # do not use SDL gui (use X11 instead)
007877cb 13
cd19124e 14Summary: QEMU CPU Emulator
eec0535a 15Summary(pl.UTF-8): QEMU - emulator procesora
7b81d160 16Name: qemu
64aca1df 17Version: 0.14.1
ba4329df 18Release: 1
5a2da1d0
JB
19License: GPL
20Group: Applications/Emulators
c4b12b8b 21# Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
7b81d160 22Source0: http://download.savannah.gnu.org/releases/qemu/%{name}-%{version}.tar.gz
64aca1df 23# Source0-md5: b6c713a8db638e173af53a62d5178640
7b81d160 24Patch0: %{name}-ncurses.patch
25Patch6: %{name}-nosdlgui.patch
81a493f2 26# Proof of concept, for reference, do not remove
7b81d160 27Patch8: %{name}-kde_virtual_workspaces_hack.patch
ba4329df 28#Patch12: %{name}-0.7.2-dyngen-check-stack-clobbers.patch
7b81d160 29Patch13: %{name}-dosguest.patch
30Patch14: %{name}-ppc_old_binutils.patch
31Patch15: %{name}-isa-bios-ram.patch
c9c22e78
ER
32# below one fixes problems with passing ram size to bios/bootloader
33# which affects coreboot/linuxbios
7b81d160 34Patch16: %{name}-piix-ram-size.patch
ba4329df 35Patch17: %{name}-whitelist.patch
d6bd22e9 36URL: http://wiki.qemu.org/Index.html
867764ba 37BuildRequires: SDL-devel >= 1.2.1
b0b3ca8d 38BuildRequires: alsa-lib-devel
b99b1652
AM
39BuildRequires: bluez-libs-devel
40BuildRequires: gnutls-devel
98a1a188 41BuildRequires: ncurses-devel
995bac8b 42BuildRequires: perl-Encode
2fb8ea02 43BuildRequires: perl-tools-pod
ba84a935 44BuildRequires: pkgconfig
8bb1261c 45BuildRequires: sed >= 4.0
a1146336 46BuildRequires: texi2html
cad677a4 47BuildRequires: which
ba84a935 48BuildRequires: xorg-lib-libX11-devel
8bb1261c 49Requires: SDL >= 1.2.1
2ef13cb9 50# sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
007877cb 51ExclusiveArch: %{ix86} %{x8664} %{?with_userspace:ppc}
cd19124e 52BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
98a1a188
AM
54# some PPC/SPARC boot image in ELF format
55%define _noautostrip .*%{_datadir}/qemu/openbios-.*
a154aede 56
cd19124e 57%description
58QEMU is a FAST! processor emulator. By using dynamic translation it
59achieves a reasonnable speed while being easy to port on new host
60CPUs. QEMU has two operating modes:
61
62- User mode emulation. In this mode, QEMU can launch Linux processes
63 compiled for one CPU on another CPU. Linux system calls are converted
64 because of endianness and 32/64 bit mismatches. Wine (Windows
65 emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
66
67- Full system emulation. In this mode, QEMU emulates a full system,
8799423b
ER
68 including a processor and various peripherials. It can also be used to
69 provide virtual hosting of several virtual PC on a single server.
cd19124e 70
27b30e9c
JR
71%description -l pl.UTF-8
72QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
73tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
74aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
5a2da1d0 75
27b30e9c 76- Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
5a2da1d0 77 procesy linuksowe skompilowane dla jednego procesora na innym
27b30e9c
JR
78 procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
79 niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
80 słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
5a2da1d0
JB
81 cele QEMU.
82
27b30e9c
JR
83- Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
84 włączając w to procesor i różne urządzenia peryferyjne. Może być także
85 używane do wirtualnego hostowania kilku wirtualnych pecetów na
8799423b 86 pojedynczym serwerze.
5a2da1d0 87
cd19124e 88%prep
c21a255a 89%setup -q
a9a35ffb 90%patch0 -p1
8d073aaa 91%{?with_nosdlgui:%patch6 -p1}
7b81d160 92#patch8 -p1
137653c3 93%patch17 -p0
0b920c52
94
95%{__sed} -i -e 's/sdl_static=yes/sdl_static=no/' configure
8bb1261c 96%{__sed} -i 's/.*MAKE) -C kqemu$//' Makefile
cd19124e 97
c3048014 98# cannot use optflags on x86 - they cause "no register to spill" errors
0b920c52 99%if %{with cflags_passing}
f0ac4619 100%{__sed} -i -e 's/-g $CFLAGS/-Wall %{rpmcflags}/' configure
57d8430f 101%else
f0ac4619 102%{__sed} -i 's/-g $CFLAGS/-Wall -fno-var-tracking-assignments/' configure
0b920c52 103%endif
c3048014 104
80bac37e 105%build
c3048014 106# --extra-cflags don't work (overridden by CFLAGS in Makefile*)
0b920c52 107# they can be passed if the cflags_passing bcond is used
8bd2aee2 108./configure \
109 --prefix=%{_prefix} \
98a1a188
AM
110 --cc="%{__cc}" \
111 --host-cc="%{__cc}" \
b99b1652 112 --enable-mixemu \
98a1a188 113 --audio-drv-list="alsa" \
7b81d160 114 --interp-prefix=%{_libdir}/%{name}
8bb1261c 115%{__make}
cd19124e 116
117%install
118rm -rf $RPM_BUILD_ROOT
5a2da1d0 119
cd19124e 120%{__make} install \
121 DESTDIR=$RPM_BUILD_ROOT
ac6e5743 122
a91fea76 123install -d $RPM_BUILD_ROOT%{_sysconfdir}
124cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
ac6e5743 125#!/bin/sh
a91fea76 126
ac6e5743 127EOF
a62a2d89 128
c33439fc
ER
129# already packaged
130rm -rf $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
131
cd19124e 132%clean
133rm -rf $RPM_BUILD_ROOT
134
135%files
136%defattr(644,root,root,755)
867764ba 137%doc README qemu-doc.html qemu-tech.html
a91fea76 138%attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
003e2129 139%attr(755,root,root) %{_bindir}/*
140%{_datadir}/qemu
cd19124e 141%{_mandir}/man1/qemu.1*
867764ba 142%{_mandir}/man1/qemu-img.1*
98a1a188 143%{_mandir}/man8/qemu-nbd.8*
This page took 0.099319 seconds and 4 git commands to generate.