]> git.pld-linux.org Git - packages/python-fasteners.git/blame - python-fasteners.spec
- release 5 (by relup.sh)
[packages/python-fasteners.git] / python-fasteners.spec
CommitLineData
0dc23a2f
AM
1# Conditional build:
2%bcond_without tests # do not perform "make test"
3%bcond_without python2 # CPython 2.x module
4%bcond_without python3 # CPython 3.x module
5
6%define module fasteners
7%define egg_name fasteners
8%define pypi_name fasteners
9Summary: Provides useful locks
10Name: python-%{pypi_name}
11Version: 0.14.1
a78ae537 12Release: 5
0dc23a2f
AM
13License: Apache v2.0
14Group: Libraries/Python
15Source0: https://pypi.python.org/packages/f4/6f/41b835c9bf69b03615630f8a6f6d45dafbec95eb4e2bb816638f043552b2/fasteners-%{version}.tar.gz
16# Source0-md5: fcb13261c9b0039d9b1c4feb9bc75e04
17URL: https://pypi.python.org/pypi/fasteners
18BuildRequires: rpm-pythonprov
19BuildRequires: rpmbuild(macros) >= 1.714
20%if %{with python2}
21BuildRequires: python-modules
22BuildRequires: python-setuptools
23%if %{with tests}
24BuildRequires: python-monotonic
25BuildRequires: python-testtools
26%endif
27%endif
28%if %{with python3}
29BuildRequires: python3-modules
30BuildRequires: python3-setuptools
31%if %{with tests}
32BuildRequires: python3-monotonic
33BuildRequires: python3-testtools
34%endif
35%endif
36Requires: python-modules
37BuildArch: noarch
38BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40%description
41Provides useful locks.
42
43%package -n python3-%{module}
44Summary: Provides useful locks
45Group: Libraries/Python
46Requires: python3-modules
47
48%description -n python3-%{module}
49Provides useful locks
50
51%prep
52%setup -q -n %{pypi_name}-%{version}
53
54%build
55%if %{with python2}
56%py_build %{?with_tests:test}
57%endif
58
59%if %{with python3}
60%py3_build %{?with_tests:test}
61%endif
62
63%install
64rm -rf $RPM_BUILD_ROOT
65
66%if %{with python2}
67%py_install
68%py_postclean
69%endif
70
71%if %{with python3}
72%py3_install
73%endif
74
75%clean
76rm -rf $RPM_BUILD_ROOT
77
78%if %{with python2}
79%files
80%defattr(644,root,root,755)
81%doc ChangeLog README.rst
82%{py_sitescriptdir}/%{module}
83%{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
84%endif
85
86%if %{with python3}
87%files -n python3-%{module}
88%defattr(644,root,root,755)
89%doc ChangeLog README.rst
90%{py3_sitescriptdir}/%{module}
91%{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
92%endif
This page took 0.030054 seconds and 4 git commands to generate.