]> git.pld-linux.org Git - packages/python-affinity.git/blame - python-affinity.spec
automatic change: use py_build/py_install macros
[packages/python-affinity.git] / python-affinity.spec
CommitLineData
aeec7c35
JR
1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4
5%define module affinity
6Summary: Control processor affinity on linux
7Name: python-%{module}
8Version: 0.1.0
9Release: 1
10License: Python Software Foundation License
11Group: Libraries/Python
12Source0: https://pypi.python.org/packages/source/a/affinity/%{module}-%{version}.tar.gz
13# Source0-md5: cc610cdb05ca675b4089ce2f05796f57
14URL: http://cheeseshop.python.org/pypi/affinity
15BuildRequires: python-devel
16BuildRequires: python-distribute
17BuildRequires: rpm-pythonprov
18BuildRequires: rpmbuild(macros) >= 1.219
19Requires: python-modules
20BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22%description
23'affinity' provides a simple api for setting the processor affinity
24by wrapping the specific underlying function calls of each platform.
25
26%prep
27%setup -q -n %{module}-%{version}
28
29%build
148b8dd6 30%py_build
aeec7c35
JR
31
32%{?with_tests:%{__python} setup.py test}
33
34%install
35rm -rf $RPM_BUILD_ROOT
148b8dd6 36%py_install
aeec7c35
JR
37
38%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
39%py_comp $RPM_BUILD_ROOT%{py_sitedir}
40%py_postclean
41
42%clean
43rm -rf $RPM_BUILD_ROOT
44
45%files
46%defattr(644,root,root,755)
47%dir %{py_sitedir}/affinity
48%{py_sitedir}/affinity/*.py[co]
49%attr(755,root,root) %{py_sitedir}/affinity/*.so
50%{py_sitedir}/affinity-*.egg-info
This page took 0.102417 seconds and 4 git commands to generate.