]> git.pld-linux.org Git - packages/pound.git/blame - pound.spec
- up to 3.0.2, fix building with mbedtls 3
[packages/pound.git] / pound.spec
CommitLineData
95d418a4
JR
1%bcond_without tcmalloc # tcmalloc allocator
2
3%ifarch x32
4%undefine with_tcmalloc
5%endif
73807a5d 6Summary: Pound - reverse-proxy and load-balancer
7fbec31c 7Summary(pl.UTF-8): Pound - reverse-proxy i load-balancer
73807a5d 8Name: pound
875c35e0
JR
9Version: 3.0.2
10Release: 1
361f3ee8 11License: GPL v3
73807a5d 12Group: Networking/Daemons
73807a5d 13Source0: http://www.apsis.ch/pound/Pound-%{version}.tgz
875c35e0 14# Source0-md5: c0f5af4cd6aa184c00f4848ae1c4536a
6477195c 15Source1: %{name}.yaml
8a12d360
JR
16Source2: %{name}.init
17Source3: %{name}.sysconfig
8a12d360 18Source5: %{name}.tmpfiles
6477195c
JR
19Patch0: tcmalloc.patch
20Patch1: pound-man.patch
875c35e0
JR
21Patch2: mbedtls3.patch
22URL: https://www.apsis.ch/pound.html
6477195c
JR
23BuildRequires: cmake
24BuildRequires: yaml-devel
25BuildRequires: nanomsg-devel
26BuildRequires: mbedtls-devel
95d418a4 27%{?with_tcmalloc:BuildRequires: libtcmalloc-devel}
f8a55c4f 28BuildRequires: pcre-devel
0453b2b1 29BuildRequires: rpmbuild(macros) >= 1.644
6e57d9ed 30Requires(post,preun): /sbin/chkconfig
5474a5a6
ER
31Requires(postun): /usr/sbin/groupdel
32Requires(postun): /usr/sbin/userdel
33Requires(pre): /bin/id
34Requires(pre): /usr/bin/getgid
35Requires(pre): /usr/sbin/groupadd
36Requires(pre): /usr/sbin/useradd
767184e8 37Requires: pcre >= 7.8
2dbe9c52 38Requires: rc-scripts
5474a5a6
ER
39Provides: group(pound)
40Provides: user(pound)
73807a5d 41BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
9df600c4
ER
43%define _sysconfdir /etc/pound
44
73807a5d 45%description
46The Pound program is a reverse proxy, load balancer and HTTPS
47front-end for Web server(s). Pound was developped to enable
48distributing the load among several Web-servers and to allow for a
49convenient SSL wrapper for those Web servers that do not offer it
50natively. Pound is distributed under the GPL - no warranty, it's free
51to use, copy and give away.
52
ebd232a4 53%description -l pl.UTF-8
f8243939 54Program Pound jest odwrotnym proxy, load-balancerem i interfejsem
ebd232a4
JR
55HTTPS do serwera(ów) WWW. Pount został stworzony by pozwolić na
56rozdzielenie obciążenia na kilka serwerów WWW i pozwolić na wygodne
57opakowanie SSL-em tych serwerów, które same nie obsługują SSL. Pound
58jest rozpowszechniany na licencji GPL - bez gwarancji, z możliwością
59swobodnego używania, kopiowania i rozdawania.
f8243939 60
73807a5d 61%prep
fd0369ad 62%setup -q -n Pound-%{version}
9df600c4
ER
63%patch0 -p1
64%patch1 -p1
875c35e0 65%patch2 -p1
73807a5d 66
67%build
6477195c
JR
68install -d build
69cd build
70%cmake ../ \
71 %{?with_tcmalloc:-DWANT_TCMALLOC:BOOL=ON}
9df600c4 72%{__make}
73807a5d 73
74%install
75rm -rf $RPM_BUILD_ROOT
6477195c
JR
76install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8,%{_sysconfdir},/etc/{sysconfig,rc.d/init.d}} \
77 $RPM_BUILD_ROOT/var/run/%{name} \
0453b2b1 78 $RPM_BUILD_ROOT%{systemdtmpfilesdir}
73807a5d 79
6477195c
JR
80install -p build/pound $RPM_BUILD_ROOT%{_sbindir}
81cp -p man/pound.8 $RPM_BUILD_ROOT%{_mandir}/man8
b329097e
ER
82cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
83install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
84cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
e6ba7a2a 85cp -p %{SOURCE5} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
8a12d360 86
6e57d9ed
JB
87%clean
88rm -rf $RPM_BUILD_ROOT
89
5474a5a6
ER
90%pre
91%groupadd -g 200 %{name}
92%useradd -u 200 -d /var/lib/%{name} -g %{name} -c "Pound Daemon" %{name}
93
73807a5d 94%post
95/sbin/chkconfig --add %{name}
5474a5a6 96%service %{name} restart "Pound Daemon"
73807a5d 97
98%preun
cfc0cb59
ER
99if [ "$1" = "0" ]; then
100 %service %{name} stop
101 /sbin/chkconfig --del %{name}
73807a5d 102fi
73807a5d 103
5474a5a6
ER
104%postun
105if [ "$1" = "0" ]; then
106 %userremove %{name}
107 %groupremove %{name}
108fi
109
73807a5d 110%files
111%defattr(644,root,root,755)
6477195c 112%doc README.md
6b1b2506 113%attr(755,root,root) %{_sbindir}/pound
9df600c4 114%dir %{_sysconfdir}
6477195c 115%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pound.yaml
ef2dd428 116%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
9a81a858 117%attr(754,root,root) /etc/rc.d/init.d/%{name}
83dd8e4d 118%{_mandir}/man8/*
0453b2b1 119%{systemdtmpfilesdir}/%{name}.conf
5474a5a6 120%dir /var/run/%{name}
This page took 0.36677 seconds and 4 git commands to generate.