]> git.pld-linux.org Git - packages/php-pecl-sasl.git/blame - php-pecl-sasl.spec
support building for multiple php versions
[packages/php-pecl-sasl.git] / php-pecl-sasl.spec
CommitLineData
b7b553cd
ER
1%define php_name php%{?php_suffix}
2%define modname sasl
3%define status alpha
4Summary: %{modname} - Cyrus SASL extension
5Summary(pl.UTF-8): %{modname} - rozszerzenie Cyrus SASL
6Name: %{php_name}-pecl-%{modname}
9b3ecba9 7Version: 0.1.0
5e8ac438 8Release: 12
2afbc69d 9License: PHP 3.01
9b3ecba9 10Group: Development/Languages/PHP
b7b553cd 11Source0: http://pecl.php.net/get/%{modname}-%{version}.tgz
9b3ecba9 12# Source0-md5: 8431731cc8a7921a2922af23a57a572f
b7b553cd
ER
13Patch0: php-pecl-%{modname}-lib_fix.patch
14Patch1: php-pecl-%{modname}-lib64_fix.patch
9b3ecba9
AG
15URL: http://pecl.php.net/package/sasl/
16BuildRequires: cyrus-sasl-devel
b7b553cd
ER
17BuildRequires: %{php_name}-devel >= 3:5.0.0
18BuildRequires: rpmbuild(macros) >= 1.650
c3a5ebc9 19%{?requires_php_extension}
33ee3aa5 20Requires: php(core) >= 5.0.4
b7b553cd 21Obsoletes: php-pear-%{modname}
9b3ecba9
AG
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
9b3ecba9
AG
24%description
25SASL is the Simple Authentication and Security Layer (as defined by
26RFC 2222). It provides a system for adding plugable authenticating
f735bf96 27support to connection-based protocols. The SASL extension for PHP
9b3ecba9
AG
28makes the Cyrus SASL library functions available to PHP. It aims to
29provide a 1-to-1 wrapper around the SASL library to provide the
30greatest amount of implementation flexibility. To that end, it is
31possible to build both a client-side and server-side SASL
32implementation entirely in PHP.
33
b7b553cd 34In PECL status of this extension is: %{status}.
9b3ecba9 35
0cb9801d
JR
36%description -l pl.UTF-8
37SASL to warstwa prostego uwierzytelnienia i bezpieczeństwa (Simple
241d2ddc 38Authentication and Security Layer) zdefiniowana w RFC 2222. Dostarcza
0cb9801d
JR
39system do dodawania wtyczek obsługujących uwierzytelnianie do
40protokołów opartych na połączeniach. Rozszerzenie SASL dla PHP
41udostępnia w PHP funkcje biblioteki Cyrus SASL. Celem jest
42dostarczenie obudowania 1-do-1 biblioteki SASL, aby udostępnić jak
43największą elastyczność implementacji. W tym celu możliwe jest
44zbudowanie zarówno klienckiej jak i serwerowej implementacji SASL
45całkowicie w PHP.
241d2ddc 46
b7b553cd 47To rozszerzenie ma w PECL status: %{status}.
9b3ecba9
AG
48
49%prep
b7b553cd
ER
50%setup -qc
51mv %{modname}-%{version}/* .
7265728d 52# Ugly, could be done somehow prettier (one combined patch?)
1de3250c 53%if "%{_lib}" == "lib64"
b7b553cd 54%patch1 -p2
1de3250c 55%else
b7b553cd 56%patch0 -p2
7265728d 57%endif
9b3ecba9
AG
58
59%build
9b3ecba9 60phpize
7265728d 61%configure
9b3ecba9
AG
62%{__make}
63
64%install
65rm -rf $RPM_BUILD_ROOT
1302764a 66install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
b7b553cd
ER
67install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
68cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
69; Enable %{modname} extension module
70extension=%{modname}.so
c3a5ebc9 71EOF
9b3ecba9
AG
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76%post
1302764a 77%php_webserver_restart
9b3ecba9 78
c3a5ebc9
ER
79%postun
80if [ "$1" = 0 ]; then
1302764a 81 %php_webserver_restart
9b3ecba9
AG
82fi
83
84%files
85%defattr(644,root,root,755)
b7b553cd
ER
86%doc docs/TODO
87%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
88%attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.097079 seconds and 4 git commands to generate.