]> git.pld-linux.org Git - packages/perl-Sane.git/blame - perl-Sane.spec
- perl req/prov fix
[packages/perl-Sane.git] / perl-Sane.spec
CommitLineData
5007210b
JK
1#
2# Conditional build:
3%bcond_with tests # do perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir Sane
7Summary: Sane - Perl extension for the SANE (Scanner Access Now Easy) Project
1c63e450 8#Summary(pl.UTF-8):
5007210b 9Name: perl-Sane
8fd3bf16 10Version: 0.03
1335c8e2 11Release: 11
5007210b
JK
12# same as perl
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
8fd3bf16 15Source0: http://www.cpan.org/modules/by-authors/id/R/RA/RATCLIFFE/%{pdir}-%{version}.tar.gz
16# Source0-md5: db83b8b07e1263b78187c4349a183082
5007210b 17URL: http://search.cpan.org/dist/Sane/
1c63e450 18BuildRequires: perl-ExtUtils-Depends
19BuildRequires: perl-ExtUtils-PkgConfig
5007210b
JK
20BuildRequires: perl-devel >= 1:5.8.0
21BuildRequires: rpm-perlprov >= 4.1-13
22BuildRequires: sane-backends-devel
23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
1c63e450 26The Sane module allows a Perl developer to use SANE-compatible
27scanners. Find out more about SANE at <http://www.sane-project.org>.
5007210b 28
1c63e450 29Most methods set $Sane::STATUS, which is overloaded to give either an
30integer as dictated by the SANE standard, or the the corresponding
31message, as required.
5007210b
JK
32
33Returns an array with the SANE_VERSION_(MAJOR|MINOR|BUILD) versions:
1c63e450 34- join('.',Sane->get_version)
5007210b
JK
35
36# %description -l pl.UTF-8
37# TODO
38
39%prep
40%setup -q -n %{pdir}-%{version}
41
42%build
43%{__perl} Makefile.PL \
44 INSTALLDIRS=vendor
45%{__make} \
46 CC="%{__cc}" \
47 OPTIMIZE="%{rpmcflags}"
48
49%{?with_tests:%{__make} test}
50
51%install
52rm -rf $RPM_BUILD_ROOT
53
54%{__make} pure_install \
55 DESTDIR=$RPM_BUILD_ROOT
56
57install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
58cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
59
60%clean
61rm -rf $RPM_BUILD_ROOT
62
63%files
64%defattr(644,root,root,755)
65%doc Changes README
66%{perl_vendorarch}/Sane.pm
67%dir %{perl_vendorarch}/auto/Sane/
5007210b
JK
68%attr(755,root,root) %{perl_vendorarch}/auto/Sane/*.so
69%{_mandir}/man3/*
70%{_examplesdir}/%{name}-%{version}
This page took 0.072306 seconds and 4 git commands to generate.