]> git.pld-linux.org Git - packages/perl-Plack.git/blame - perl-Plack.spec
- up to 0.9985
[packages/perl-Plack.git] / perl-Plack.spec
CommitLineData
01cccd88 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%define pdir Plack
6%include /usr/lib/rpm/macros.perl
7Summary: Plack - Perl Superglue for Web frameworks and Web Servers (PSGI toolkit)
8#Summary(pl.UTF-8):
9Name: perl-Plack
51243e0d 10Version: 0.9985
01cccd88 11Release: 1
12# same as perl
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-module/Plack/%{pdir}-%{version}.tar.gz
51243e0d 16# Source0-md5: 3d340079cdec9435991fdd0e0953c99e
01cccd88 17Patch0: %{name}-tests.patch
18URL: http://search.cpan.org/dist/Plack/
19BuildRequires: perl-devel >= 1:5.8.0
20BuildRequires: rpm-perlprov >= 4.1-13
21%if %{with tests}
22BuildRequires: perl(Devel::StackTrace::AsHTML) >= 0.11
23BuildRequires: perl(Filesys::Notify::Simple)
24BuildRequires: perl(HTTP::Body) >= 1.06
25BuildRequires: perl(Hash::MultiValue) >= 0.05
26BuildRequires: perl(Test::Requires)
27BuildRequires: perl(Test::TCP) >= 0.11
28BuildRequires: perl-Devel-StackTrace >= 1.23
29BuildRequires: perl-File-ShareDir >= 1.00
30BuildRequires: perl-HTTP-Request-AsCGI
31BuildRequires: perl-Try-Tiny
32BuildRequires: perl-URI >= 1.36
33BuildRequires: perl-libwww >= 5.814
34%endif
35BuildArch: noarch
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%define _noautoreq 'perl(Apache::Constants)' 'perl(Apache::Request)'
39
40%description
41Plack is a set of tools for using the PSGI stack. It contains
42middleware components, a reference server and utilities for Web
43application frameworks. Plack is like Ruby's Rack or Python's Paste
44for WSGI.
45
46See PSGI for the PSGI specification and PSGI::FAQ to know what PSGI
47and Plack are and why we need them.
48
49
50
51# %description -l pl.UTF-8 # TODO
52
53%prep
54%setup -q -n %{pdir}-%{version}
55%patch0 -p1
56
57%build
58%{__perl} Makefile.PL \
59 INSTALLDIRS=vendor
60%{__make}
61
62%{?with_tests:%{__make} test}
63
64%install
65rm -rf $RPM_BUILD_ROOT
66
67%{__make} pure_install \
68 DESTDIR=$RPM_BUILD_ROOT
69
70install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
71cp -a eg $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76%files
77%defattr(644,root,root,755)
78%doc Changes README
79%{perl_vendorlib}/*.pm
80%{perl_vendorlib}/Plack/
81%{_mandir}/man1/*
82%{_mandir}/man3/*
83%{_examplesdir}/%{name}-%{version}
84%attr(755,root,root) %{_bindir}/plackup
85%{perl_vendorlib}/HTTP/Message/PSGI.pm
86%{perl_vendorlib}/HTTP/Server/PSGI.pm
87%{perl_vendorlib}/auto/share/dist/Plack
This page took 0.034902 seconds and 4 git commands to generate.