]> git.pld-linux.org Git - packages/perl-EV.git/blame - perl-EV.spec
- perl req/prov fix
[packages/perl-EV.git] / perl-EV.spec
CommitLineData
d0b8d537 1#
2# Conditional build:
7b6014f9 3%bcond_without tests # perform "make test"
96ca67f9
ER
4
5%define pdir EV
d0b8d537 6%include /usr/lib/rpm/macros.perl
96ca67f9 7Summary: EV - Perl interface to libev, a high performance full-featured event loop
ecd9f0ab 8Summary(pl.UTF-8): EV - perlowy interfejs do libev - wydajnej pętli zdarzeń
d0b8d537 9Name: perl-EV
28ac8016 10Version: 4.22
1efafa54 11Release: 5
05a68dee 12Epoch: 1
96ca67f9
ER
13# same as Perl, libev: BSD-like
14License: GPL v1+ or Artistic (Perl module), BSD-like (embedded libev)
d0b8d537 15Group: Development/Languages/Perl
ecd9f0ab 16Source0: http://www.cpan.org/modules/by-authors/id/M/ML/MLEHMANN/%{pdir}-%{version}.tar.gz
28ac8016 17# Source0-md5: 8bca55688edafcf98ab6d7a86ea195be
d0b8d537 18URL: http://search.cpan.org/dist/EV/
28ac8016 19BuildRequires: perl-Canary-Stability
b34e4adf 20BuildRequires: perl-common-sense
d0b8d537 21BuildRequires: perl-devel >= 1:5.8.0
22BuildRequires: rpm-perlprov >= 4.1-13
d0b8d537 23BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25%description
26This module provides an interface to libev
96ca67f9 27<http://software.schmorp.de/pkg/libev.html>.
d0b8d537 28
29This module is very fast and scalable. It is actually so fast that you
30can use it through the AnyEvent module, stay portable to other event
31loops (if you don't rely on any watcher types not available through
32it) and still be faster than with any other event loop currently
33supported in Perl.
34
d0b8d537 35%description -l pl.UTF-8
ecd9f0ab 36Moduł ten dostarcza intefejs do libev
96ca67f9 37<http://software.schmorp.de/pkg/libev.html>.
ecd9f0ab
JB
38
39Jest bardzo szybki i skalowalny. Właściwie jest na tyle szybki, że
40można go użyć poprzez moduł AnyEvent i pozostawić kod przenośnym na
41inne pętle zdarzeń (jeśli nie jest wymagane użycie typów obserwatorów
42niedostępnych przez AnyEvent), i całość jest nadal szybsza niż inne
43pętle zdarzeń dostępne z poziomu Perla.
d0b8d537 44
45%prep
46%setup -q -n %{pdir}-%{version}
47
48%build
49%{__perl} Makefile.PL \
36679d7c 50 INSTALLDIRS=vendor </dev/null
d0b8d537 51%{__make} \
52 CC="%{__cc}" \
53 OPTIMIZE="%{rpmcflags}"
54
55%{?with_tests:%{__make} test}
56
57%install
58rm -rf $RPM_BUILD_ROOT
59
60%{__make} pure_install \
61 DESTDIR=$RPM_BUILD_ROOT
62
9854614f 63install -d libev-doc
64mv -f libev/{Changes,LICENSE,README} libev-doc
dccc494d 65%{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/EV/libev.pod
9854614f 66
d0b8d537 67%clean
68rm -rf $RPM_BUILD_ROOT
69
70%files
71%defattr(644,root,root,755)
ecd9f0ab 72%doc Changes COPYING README libev-doc
95074e4c 73%dir %{perl_vendorarch}/EV
d0b8d537 74%{perl_vendorarch}/EV/*.pm
75%{perl_vendorarch}/EV.pm
76%{perl_vendorarch}/EV/EVAPI.h
77%{perl_vendorarch}/EV/ev.h
95074e4c 78%dir %{perl_vendorarch}/auto/EV
d0b8d537 79%attr(755,root,root) %{perl_vendorarch}/auto/EV/EV.so
ecd9f0ab 80%{_mandir}/man3/EV*.3pm*
This page took 0.079035 seconds and 4 git commands to generate.