]> git.pld-linux.org Git - packages/openwsman.git/blame - openwsman.spec
- release 2 (by relup.sh)
[packages/openwsman.git] / openwsman.spec
CommitLineData
5db175a1 1# TODO:
5db175a1 2# - daemon init script
ce0d47d3 3# - where should arch-dependent .jar be packaged?
6961ea6a 4# - add -module to plugins build?
a06ea685
ER
5#
6# Conditional build:
fd5cd5a5
JB
7%bcond_without cim # CIM plugin (sblim-sfcc based)
8%bcond_without java # Java bindings
9%bcond_without perl # Perl bindings
10%bcond_without python # Python bindings
11%bcond_without ruby # Ruby bindings
a06ea685 12
5db175a1 13Summary: Implementation of the Web Services Management specification (WS-Management)
15f3efed 14Summary(pl.UTF-8): Implementacja specyfikacji Web Services Management (WS-Management)
5db175a1 15Name: openwsman
83504ec0 16Version: 2.6.5
5999ba37 17Release: 2
5db175a1
AM
18License: BSD
19Group: Libraries
6961ea6a 20Source0: https://github.com/Openwsman/openwsman/archive/v%{version}/%{name}-%{version}.tar.gz
83504ec0 21# Source0-md5: 84d066233a0b9d6ef00657dc8241d353
396be572 22Patch0: %{name}-link.patch
b97ca65a
JB
23Patch1: rdoc-rubygems.patch
24Patch2: %{name}-python.patch
6961ea6a 25URL: https://github.com/Openwsman
396be572
JB
26BuildRequires: cmake >= 2.4
27BuildRequires: curl-devel >= 7.12.0
fd5cd5a5
JB
28%if %{with ruby}
29%if %(locale -a | grep -q '^en_US$'; echo $?)
30BuildRequires: glibc-localedb-all
31%endif
32%endif
ce0d47d3 33BuildRequires: jdk
993872f2 34BuildRequires: libstdc++-devel
396be572 35BuildRequires: libxml2-devel >= 2.0
5db175a1 36BuildRequires: openssl-devel
993872f2 37BuildRequires: pam-devel
fd5cd5a5 38%{?with_perl:BuildRequires: perl-devel}
993872f2 39BuildRequires: pkgconfig
93eab964 40%{?with_python:BuildRequires: python-devel >= 2}
685db724 41BuildRequires: rpmbuild(macros) >= 1.606
fd5cd5a5
JB
42%{?with_ruby:BuildRequires: ruby-devel >= 1.9}
43%{?with_cim:BuildRequires: sblim-sfcc-devel}
15f3efed 44BuildRequires: sed >= 4.0
138a0c32
JB
45BuildRequires: swig >= 2.0.5
46%{?with_perl:BuildRequires: swig-perl >= 2.0.5}
47%{?with_python:BuildRequires: swig-python >= 2.0.5}
48%{?with_ruby:BuildRequires: swig-ruby >= 2.0.5}
685db724 49Requires: %{name}-libs = %{version}-%{release}
5db175a1
AM
50BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
396be572 52# plugins use symbols from libraries, client libs have circular dependencies with libwsman
6961ea6a 53%define skip_post_check_so .*%{_libdir}/openwsman/.* libwsman_client.so.* libwsman_curl_client_transport.so.* libwsman_server.so.1.0.0 libwsman_clientpp.so.1.0.0
396be572 54
5db175a1
AM
55%description
56Openwsman is a project intended to provide an open-source
57implementation of the Web Services Management specification
58(WS-Management) and to expose system management information on the
59Linux operating system using the WS-Management protocol. WS-Management
60is based on a suite of web services specifications and usage
61requirements that exposes a set of operations focused on and covers
62all system management aspects.
63
15f3efed
JB
64%description -l pl.UTF-8
65Openwsman to projekt, którego celem jest zapewnienie mającej otwarte
66źródła implementacji specyfikacji Web Services Management
67(WS-Management) i udostępnienie informacji związanych z zarządzaniem
68systemem pod Linuksem poprzez protokół WS-Management. WS-Management
69jest oparty na zbiorze specyfikacji i wymaganiach usług WWW,
70udostępniających zbiór operacji pokrywających wszystkie aspekty
71zarządzania systemem.
72
685db724
JB
73%package libs
74Summary: Shared openwsman libraries
75Summary(pl.UTF-8): Biblioteki współdzielone openwsman
76Group: Libraries
77Conflicts: openwsman < 2.2.6
78
79%description libs
80Shared openwsman libraries.
81
82%description libs -l pl.UTF-8
83Biblioteki współdzielone openwsman.
84
5db175a1 85%package devel
15f3efed
JB
86Summary: Header files for openwsman
87Summary(pl.UTF-8): Pliki nagłówkowe openwsman
5db175a1 88Group: Development/Libraries
685db724 89Requires: %{name}-libs = %{version}-%{release}
396be572 90Obsoletes: openwsman-static
5db175a1
AM
91
92%description devel
15f3efed
JB
93Header files for openwsman.
94
95%description devel -l pl.UTF-8
96Pliki nagłówkowe openwsman.
5db175a1 97
ce0d47d3
JB
98%package -n java-openwsman
99Summary: Java bindings for openwsman libraries
100Summary(pl.UTF-8): Wiązania Javy do bibliotek openwsman
101Group: Libraries/Java
102Requires: %{name}-libs = %{version}-%{release}
103Requires: jre
104
105%description -n java-openwsman
106Java bindings for openwsman libraries.
107
108%description -n java-openwsman -l pl.UTF-8
109Wiązania Javy do bibliotek openwsman.
110
685db724
JB
111%package -n perl-openwsman
112Summary: Perl bindings for openwsman libraries
113Summary(pl.UTF-8): Wiązania Perla do bibliotek openwsman
114Group: Development/Languages/Perl
115Requires: %{name}-libs = %{version}-%{release}
116
117%description -n perl-openwsman
118Perl bindings for openwsman libraries.
119
120%description -n perl-openwsman -l pl.UTF-8
121Wiązania Perla do bibliotek openwsman.
122
123%package -n python-openwsman
124Summary: Python bindings for openwsman libraries
125Summary(pl.UTF-8): Wiązania Pythona do bibliotek openwsman
ce0d47d3 126Group: Libraries/Python
685db724 127Requires: %{name}-libs = %{version}-%{release}
6961ea6a 128Requires: python-libs
685db724
JB
129
130%description -n python-openwsman
131Python bindings for openwsman libraries.
132
133%description -n python-openwsman -l pl.UTF-8
134Wiązania Pythona do bibliotek openwsman.
135
ce0d47d3
JB
136%package -n ruby-openwsman
137Summary: Ruby bindings for openwsman libraries
138Summary(pl.UTF-8): Wiązania języka Ruby do bibliotek openwsman
139Group: Development/Languages
140Requires: %{name}-libs = %{version}-%{release}
141Requires: ruby
142
143%description -n ruby-openwsman
144Ruby bindings for openwsman libraries.
145
146%description -n ruby-openwsman -l pl.UTF-8
147Wiązania języka Ruby do bibliotek openwsman.
148
5db175a1
AM
149%prep
150%setup -q
396be572
JB
151%undos src/cpp/CMakeLists.txt
152%patch0 -p1
ce0d47d3
JB
153%patch1 -p1
154%patch2 -p1
155
5db175a1 156%build
396be572
JB
157install -d build
158cd build
159%cmake .. \
a06ea685
ER
160%if %{with java}
161 -DJAVA_INCLUDE_PATH=%{java_home}/include \
162%else
163 -DBUILD_JAVA=NO \
164%endif
fd5cd5a5
JB
165 %{!?with_cim:-DBUILD_LIBCIM=NO} \
166 %{!?with_perl:-DBUILD_PERL=NO} \
167 %{!?with_python:-DBUILD_PYTHON=NO} \
d59a0e35 168 -DBUILD_RUBY=%{!?with_ruby:NO}%{?with_ruby:YES} \
d59a0e35 169 -DPACKAGE_ARCHITECTURE=%{_target_cpu} \
93eab964
JB
170 -DPYTHON_EXECUTABLE=%{__python} \
171 -DRUBY_HAS_VENDOR_RUBY:BOOL=ON
5db175a1 172
fd5cd5a5
JB
173# ruby .gemspec contains non-ascii characters, build fails with C locale
174%{?with_ruby:LC_ALL=en_US} \
9f80c555 175%{__make} -j1
6961ea6a 176
5db175a1
AM
177%install
178rm -rf $RPM_BUILD_ROOT
396be572 179install -d $RPM_BUILD_ROOT/var/lib/openwsman/subscriptions
5db175a1 180
396be572 181%{__make} -C build install \
5db175a1
AM
182 DESTDIR=$RPM_BUILD_ROOT
183
685db724
JB
184%py_comp $RPM_BUILD_ROOT%{py_sitedir}
185%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
186%py_postclean
187
5db175a1
AM
188%clean
189rm -rf $RPM_BUILD_ROOT
190
685db724
JB
191%post libs -p /sbin/ldconfig
192%postun libs -p /sbin/ldconfig
5db175a1
AM
193
194%files
195%defattr(644,root,root,755)
6961ea6a 196%doc AUTHORS ChangeLog README.md TODO
5db175a1 197%attr(755,root,root) %{_sbindir}/openwsmand
5db175a1
AM
198%dir %{_libdir}/openwsman
199%dir %{_libdir}/openwsman/authenticators
396be572 200%attr(755,root,root) %{_libdir}/openwsman/authenticators/libwsman_*.so*
5db175a1 201%dir %{_libdir}/openwsman/plugins
396be572 202%attr(755,root,root) %{_libdir}/openwsman/plugins/libwsman_*.so*
6961ea6a 203%attr(755,root,root) %{_libdir}/openwsman/plugins/libredirect.so*
396be572
JB
204%dir %{_sysconfdir}/openwsman
205%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/openwsman/openwsman.conf
93eab964 206%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/openwsman/openwsman_client.conf
396be572
JB
207%attr(754,root,root) %{_sysconfdir}/openwsman/owsmangencert.sh
208%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/openwsman/ssleay.cnf
209%config(noreplace) %verify(not md5 mtime size) /etc/pam.d/openwsman
6961ea6a 210%dir /var/lib/openwsman
83b69cfd 211%dir /var/lib/openwsman/subscriptions
5db175a1 212
685db724
JB
213%files libs
214%defattr(644,root,root,755)
215%attr(755,root,root) %{_libdir}/libwsman.so.*.*.*
216%attr(755,root,root) %ghost %{_libdir}/libwsman.so.1
217%attr(755,root,root) %{_libdir}/libwsman_client.so.*.*.*
138a0c32 218%attr(755,root,root) %ghost %{_libdir}/libwsman_client.so.4
685db724
JB
219%attr(755,root,root) %{_libdir}/libwsman_clientpp.so.*.*.*
220%attr(755,root,root) %ghost %{_libdir}/libwsman_clientpp.so.1
221%attr(755,root,root) %{_libdir}/libwsman_curl_client_transport.so.*.*.*
222%attr(755,root,root) %ghost %{_libdir}/libwsman_curl_client_transport.so.1
223%attr(755,root,root) %{_libdir}/libwsman_server.so.*.*.*
224%attr(755,root,root) %ghost %{_libdir}/libwsman_server.so.1
225
5db175a1
AM
226%files devel
227%defattr(644,root,root,755)
396be572
JB
228%attr(755,root,root) %{_libdir}/libwsman.so
229%attr(755,root,root) %{_libdir}/libwsman_client.so
230%attr(755,root,root) %{_libdir}/libwsman_clientpp.so
231%attr(755,root,root) %{_libdir}/libwsman_curl_client_transport.so
232%attr(755,root,root) %{_libdir}/libwsman_server.so
5db175a1 233%{_includedir}/openwsman
396be572
JB
234%{_pkgconfigdir}/openwsman.pc
235%{_pkgconfigdir}/openwsman++.pc
236%{_pkgconfigdir}/openwsman-server.pc
685db724 237
a06ea685 238%if %{with java}
ce0d47d3
JB
239%files -n java-openwsman
240%defattr(644,root,root,755)
241%{_javadir}/openwsman-%{_target_cpu}-%{version}.jar
a06ea685 242%endif
ce0d47d3 243
685db724
JB
244%files -n perl-openwsman
245%defattr(644,root,root,755)
685db724 246%{perl_vendorlib}/openwsman.pm
6961ea6a 247%attr(755,root,root) %{perl_vendorarch}/openwsman.so
685db724
JB
248
249%files -n python-openwsman
250%defattr(644,root,root,755)
685db724 251%{py_sitedir}/pywsman.py[co]
6961ea6a 252%attr(755,root,root) %{py_sitedir}/_pywsman.so
ce0d47d3 253
d59a0e35 254%if %{with ruby}
ce0d47d3
JB
255%files -n ruby-openwsman
256%defattr(644,root,root,755)
b97ca65a 257%attr(755,root,root) %{_bindir}/winrs
8b81a7dd 258%{ruby_vendorlibdir}/openwsmanplugin.rb
6961ea6a 259%{ruby_vendorlibdir}/openwsman.rb
8b81a7dd 260%{ruby_vendorlibdir}/openwsman
6961ea6a 261%attr(755,root,root) %{ruby_vendorarchdir}/_openwsman.so
d59a0e35 262%endif
This page took 0.119421 seconds and 4 git commands to generate.