]> git.pld-linux.org Git - packages/ogdi.git/blame - ogdi.spec
- PROJ functionality has been removed in 4.0.0
[packages/ogdi.git] / ogdi.spec
CommitLineData
fae9fa5b 1# TODO: separate gltpd to -server package, add init script (requires portmap)
42a3233f 2#
32f089d1 3# Conditional build:
6532bb18 4%bcond_without tcl # disable gui and nviz
32f089d1 5%bcond_without odbc # disable unixODBC support
6#
fae9fa5b 7Summary: Open Geographic Datastore Interface
5a2968b5 8Summary(pl.UTF-8): OGDI - otwarty interfejs do danych geograficznych
fae9fa5b 9Name: ogdi
69a59151
JR
10Version: 4.0.0
11Release: 1
fae9fa5b 12License: BSD-like
08482132 13Group: Applications/Databases
6532bb18 14#Source0Download: https://github.com/libogdi/ogdi/releases/
69a59151
JR
15Source0: https://github.com/libogdi/ogdi/archive/ogdi_4_0_0/%{name}-%{version}.tar.gz
16# Source0-md5: d1d91f71b4748313d3f60c8f301e03da
fae9fa5b 17Source1: http://ogdi.sourceforge.net/ogdi.pdf
c7b9d0a5 18# Source1-md5: 029a8cdcd36bee73df92196ee769040e
6532bb18 19Patch1: %{name}-format.patch
fae9fa5b
JB
20URL: http://ogdi.sourceforge.net/
21BuildRequires: autoconf
22BuildRequires: expat-devel
08447712 23BuildRequires: rpmbuild(macros) >= 1.446
4c1f6d28 24%{?with_tcl:BuildRequires: tcl-devel}
32f089d1 25%{?with_odbc:BuildRequires: unixODBC-devel}
fae9fa5b
JB
26BuildRequires: zlib-devel
27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
30OGDI is the Open Geographic Datastore Interface. OGDI is an
31application programming interface (API) that uses a standardized
32access methods to work in conjunction with GIS software packages (the
33application) and various geospatial data products. OGDI uses a
34client/server architecture to facilitate the dissemination of
35geospatial data products over any TCP/IP network, and a
36driver-oriented approach to facilitate access to several geospatial
37data products/formats.
ef94e4a2 38
d6c47a2e 39%description -l pl.UTF-8
fae9fa5b 40OGDI (Open Geographic Datastore Interface) oznacza otwarty interfejs
d6c47a2e
JR
41do danych geograficznych. OGDI to API używające ustandaryzowanych
42metod dostępu do pracy z pakietami oprogramowania GIS i różnymi danymi
43geograficznymi. OGDI używa architektury klient-serwer aby udostępniać
44dane po dowolnej sieci TCP/IP oraz podejścia bazującego na
45sterownikach aby zapewnić dostęp do różnych produktów/formatów danych
fae9fa5b
JB
46geograficznych.
47
48%package devel
49Summary: OGDI header files and documentation
5a2968b5 50Summary(pl.UTF-8): Pliki nagłówkowe i dokumentacja OGDI
fae9fa5b 51Group: Development/Libraries
c7196e26 52Requires: %{name} = %{version}-%{release}
fae9fa5b
JB
53
54%description devel
55OGDI header files and developer's documentation.
56
d6c47a2e
JR
57%description devel -l pl.UTF-8
58Pliki nagłówkowe i dokumentacja programisty do OGDI.
fae9fa5b
JB
59
60%package odbc
61Summary: ODBC driver for OGDI
5a2968b5 62Summary(pl.UTF-8): Sterownik ODBC do OGDI
fae9fa5b 63Group: Libraries
c7196e26 64Requires: %{name} = %{version}-%{release}
fae9fa5b
JB
65
66%description odbc
67ODBC driver for OGDI.
68
d6c47a2e 69%description odbc -l pl.UTF-8
fae9fa5b
JB
70Sterownik ODBC do OGDI.
71
72%package -n tcl-ogdi
05c5e26d 73Summary: Tcl wrapper for OGDI
5a2968b5 74Summary(pl.UTF-8): Interfejs Tcl do OGDI
fae9fa5b 75Group: Libraries
c7196e26 76Requires: %{name} = %{version}-%{release}
fae9fa5b
JB
77
78%description -n tcl-ogdi
05c5e26d 79Tcl wrapper for OGDI.
fae9fa5b 80
d6c47a2e 81%description -n tcl-ogdi -l pl.UTF-8
05c5e26d 82Interfejs Tcl do OGDI.
fae9fa5b
JB
83
84%prep
69a59151 85%setup -q -n ogdi-ogdi_4_0_0
08482132 86%patch1 -p1
fae9fa5b
JB
87
88cp -f %{SOURCE1} .
89
90%build
fae9fa5b
JB
91TOPDIR=`pwd`; TARGET=Linux; export TOPDIR TARGET
92%configure \
93 --with-expat \
fae9fa5b
JB
94 --with-zlib
95
2c460ea2 96# bash because of pushd/popd used in makefiles
3775d26d 97%{__make} -j 1 \
2c460ea2
JB
98 SHELL=/bin/bash \
99 INST_LIB=%{_libdir} \
fae9fa5b
JB
100 OPTIMIZATION="%{rpmcflags}"
101
32f089d1 102%if %{with tcl}
3775d26d 103%{__make} -j 1 -C ogdi/tcl_interface \
fae9fa5b
JB
104 OPTIMIZATION="%{rpmcflags}" \
105 TCL_LINKLIB="-ltcl"
32f089d1 106%endif
3775d26d 107%{__make} -j 1 -C contrib/gdal \
fae9fa5b 108 OPTIMIZATION="%{rpmcflags}"
32f089d1 109%if %{with odbc}
3775d26d 110%{__make} -j 1 -C ogdi/attr_driver/odbc \
2c460ea2 111 OPTIMIZATION="%{rpmcflags} -DDONT_TD_VOID" \
fae9fa5b 112 ODBC_LINKLIB="-lodbc"
32f089d1 113%endif
fae9fa5b
JB
114
115%install
116rm -rf $RPM_BUILD_ROOT
117
118TOPDIR=`pwd`; TARGET=Linux; export TOPDIR TARGET
119
3775d26d 120%{__make} -j 1 install \
2c460ea2 121 SHELL=/bin/bash \
fae9fa5b 122 INST_INCLUDE=$RPM_BUILD_ROOT%{_includedir} \
2c460ea2 123 INST_LIB=$RPM_BUILD_ROOT%{_libdir} \
fae9fa5b
JB
124 INST_BIN=$RPM_BUILD_ROOT%{_bindir}
125
08447712
JB
126# omitted from make install
127install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
128cp -p ogdi.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
129install ogdi-config $RPM_BUILD_ROOT%{_bindir}
130
32f089d1 131%if %{with tcl}
3775d26d 132%{__make} -j 1 install -C ogdi/tcl_interface \
fae9fa5b 133 INST_LIB=$RPM_BUILD_ROOT%{_libdir}
32f089d1 134%endif
3775d26d 135%{__make} -j 1 install -C contrib/gdal \
2c460ea2 136 INST_LIB=$RPM_BUILD_ROOT%{_libdir}
32f089d1 137%if %{with odbc}
3775d26d 138%{__make} -j 1 install -C ogdi/attr_driver/odbc \
2c460ea2 139 INST_LIB=$RPM_BUILD_ROOT%{_libdir}
32f089d1 140%endif
fae9fa5b 141
6532bb18
JB
142%{__rm} $RPM_BUILD_ROOT%{_bindir}/example?
143
fae9fa5b
JB
144%clean
145rm -rf $RPM_BUILD_ROOT
146
147%post -p /sbin/ldconfig
148%postun -p /sbin/ldconfig
149
150%files
151%defattr(644,root,root,755)
152%doc LICENSE NEWS
153%attr(755,root,root) %{_bindir}/gltpd
154%attr(755,root,root) %{_bindir}/ogdi_*
2c460ea2 155%attr(755,root,root) %{_libdir}/libogdi.so.*.*
69a59151 156%attr(755,root,root) %ghost %{_libdir}/libogdi.so.4
fae9fa5b 157%dir %{_libdir}/ogdi
08482132 158%attr(755,root,root) %{_libdir}/ogdi/libadrg.so
08482132 159%attr(755,root,root) %{_libdir}/ogdi/libdted.so
08482132
JB
160%attr(755,root,root) %{_libdir}/ogdi/libgdal.so
161%attr(755,root,root) %{_libdir}/ogdi/libremote.so
162%attr(755,root,root) %{_libdir}/ogdi/librpf.so
163%attr(755,root,root) %{_libdir}/ogdi/libskeleton.so
164%attr(755,root,root) %{_libdir}/ogdi/libvrf.so
fae9fa5b
JB
165
166%files devel
167%defattr(644,root,root,755)
168%doc ogdi.pdf
08447712 169%attr(755,root,root) %{_bindir}/ogdi-config
2c460ea2 170%attr(755,root,root) %{_libdir}/libogdi.so
08482132
JB
171%{_includedir}/ecs.h
172%{_includedir}/ecs_util.h
08447712 173%{_pkgconfigdir}/ogdi.pc
fae9fa5b 174
32f089d1 175%if %{with odbc}
fae9fa5b
JB
176%files odbc
177%defattr(644,root,root,755)
178%attr(755,root,root) %{_libdir}/ogdi/liblodbc.so
32f089d1 179%endif
fae9fa5b 180
32f089d1 181%if %{with tcl}
fae9fa5b
JB
182%files -n tcl-ogdi
183%defattr(644,root,root,755)
2c460ea2 184%attr(755,root,root) %{_libdir}/ogdi/libecs_tcl.so
32f089d1 185%endif
This page took 1.005202 seconds and 4 git commands to generate.