]> git.pld-linux.org Git - packages/mythplugins.git/blame - mythplugins.spec
- reverted to 1.38
[packages/mythplugins.git] / mythplugins.spec
CommitLineData
14b5eb75 1#
ba857471 2# TODO:
3# - fix mytharchive
4# - check 64-bit build
5#
f76d04d4
ER
6# Conditional build:
7%bcond_without binary # skip building binary plugins (build only mythweb)
ba857471 8%bcond_with mytharchive # enable mytharchive plugin
f76d04d4 9%bcond_without mythbrowser # disable building mythbrowser plugin
ba857471 10%bcond_without mythcontrols # disable mythcontrols plugin
beab7214 11%bcond_without mythflix # disable building mythflix plugin
f76d04d4
ER
12%bcond_without mythgallery # disable building mythgallery plugin
13%bcond_without mythgame # disable building mythgallery plugin
14%bcond_without mythmusic # disable building mythmusic plugin
15%bcond_without mythnews # disable building mythgallery plugin
ba857471 16%bcond_without mythphone # disable building mythgallery plugin
f76d04d4
ER
17%bcond_without mythvideo # disable building mythgallery plugin
18%bcond_without mythweather # disable building mythgallery plugin
19%bcond_without mythweb # disable building mythgallery plugin
ba857471 20%bcond_without mythmovies # disable building mythmovies plugin
21%bcond_without mythzoneminder # disable building mythzoneminder plugin
22#
f8518b19 23%if !%{with binary}
beab7214 24%undefine with_mytharchive
f76d04d4 25%undefine with_mythbrowser
ba857471 26%undefine with_mythcontrols
beab7214 27%undefine with_mythflix
f76d04d4
ER
28%undefine with_mythgallery
29%undefine with_mythgame
30%undefine with_mythmusic
31%undefine with_mythnews
32%undefine with_mythphone
33%undefine with_mythvideo
34%undefine with_mythweather
ba857471 35%undefine with_mythmovies
36%undefine with_mythzoneminder
f76d04d4
ER
37%endif
38
a8181a32 39%include /usr/lib/rpm/macros.perl
f76d04d4 40
ba857471 41#define _snap 20060905
9de9d245 42#define _rev 11046
ba857471 43%define _rel 0.1
20cc2885 44Summary: Main MythTV plugins
9478e970 45Summary(pl.UTF-8): Główne wtyczki MythTV
d78b97e1 46Name: mythplugins
ba857471 47Version: 0.21
48Release: %{?_snap:0.%{_snap}.%{_rev}.}%{_rel}
69870715 49License: GPL v2
d78b97e1 50Group: Applications/Multimedia
ba857471 51Source0: ftp://ftp.osuosl.org/pub/mythtv/%{name}-%{version}.tar.bz2
52# Source0-md5: 6c08043227bef1384858deee12b5cdc3
53#Source0: %{name}-%{_snap}.%{_rev}.tar.bz2
5e68f3bc 54Source1: mythweb.conf
ba857471 55Patch0: %{name}-paths.patch
20cc2885 56URL: http://www.mythtv.org/
f76d04d4
ER
57%if %{with binary}
58%if %{with mythgallery} || %{with myhtmusic}
20cc2885 59BuildRequires: OpenGL-devel
f76d04d4 60%endif
d78b97e1 61BuildRequires: SDL-devel
69870715
ER
62BuildRequires: a52dec-libs-devel
63BuildRequires: cdparanoia-III-devel
64BuildRequires: faad2-devel >= 2.0-5.2
f76d04d4 65%{?with_mythmusic:BuildRequires: fftw-devel >= 2.1.3}
d78b97e1 66BuildRequires: flac-devel >= 1.0.4
69870715 67BuildRequires: freetype-devel
ba857471 68BuildRequires: kdelibs-devel
f76d04d4 69BuildRequires: libcdaudio-devel >= 0.99.12p2
69870715
ER
70BuildRequires: libdvdcss-devel >= 1.2.7
71BuildRequires: libdvdread-devel >= 0.9.4
f76d04d4 72%{?with_mythgallery:BuildRequires: libexif-devel >= 1:0.6.9}
69870715 73BuildRequires: libfame-devel >= 0.9.0
d78b97e1
ER
74BuildRequires: libid3tag-devel
75BuildRequires: libmad-devel
ba857471 76BuildRequires: libmyth-devel >= 0.21
69870715 77BuildRequires: libstdc++-devel
d78b97e1 78BuildRequires: libtiff-devel
f76d04d4 79BuildRequires: libvorbis-devel >= 1:1.0
d78b97e1 80BuildRequires: mjpegtools-devel >= 1.6.1
69870715 81BuildRequires: nasm
beab7214 82BuildRequires: patchutils
20cc2885
JB
83BuildRequires: rpm-perlprov >= 4.1-13
84BuildRequires: sed >= 4.0
69870715
ER
85BuildRequires: xvid-devel >= 1:0.9.1
86BuildRequires: zlib-devel
ba857471 87BuildRequires: xorg-lib-libXext-devel
88BuildRequires: xorg-lib-libXxf86vm-devel
f76d04d4 89%endif
beab7214 90%{?with_mytharchive:Requires: mytharchive}
f76d04d4 91%{?with_mythbrowser:Requires: mythbrowser}
f76d04d4
ER
92%{?with_mythflix:Requires: mythflix}
93%{?with_mythgallery:Requires: mythgallery}
94%{?with_mythgame:Requires: mythgame}
95%{?with_mythmysic:Requires: mythmusic}
96%{?with_mythnews:Requires: mythnews}
97%{?with_mythphone:Requires: mythphone}
98%{?with_mythvideo:Requires: mythvideo}
99%{?with_mythweather:Requires: mythweather}
100%{?with_mythweb:Requires: mythweb}
ba857471 101%{?with_mythmovies:Requires: mythmovies}
102%{?with_mythzoneminder:Requires: mythzoneminder}
e3001b4f 103ExclusiveArch: %{ix86} %{x8664} ppc
d78b97e1
ER
104BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
105
f76d04d4
ER
106%define myth_api_version %(awk '/LIBVERSION/{print $3}' %{_datadir}/mythtv/build/settings.pro 2>/dev/null || echo ERROR)
107%define _webapps /etc/webapps
108%define _webapp mythweb
69870715 109
d78b97e1
ER
110%description
111This is a consolidation of all the official MythTV plugins that used
112to be distributed as separate downloads from mythtv.org.
113
c2db80a4
JR
114%description -l pl.UTF-8
115Jest to zbiór wszystkich oficjalnych wtyczek MythTV, które były
116wcześniej rozpowszechniane jako osobne pakiety na mythtv.org.
20cc2885 117
beab7214 118%package -n mytharchive
68bb720e 119Summary: A MythTV module to create and burn DVDs
9478e970 120Summary(pl.UTF-8): Moduł MythTV do tworzenia i wypalania DVD
beab7214
ER
121Group: Applications/Multimedia
122Requires: mythtv-frontend-api = %{myth_api_version}
123
124%description -n mytharchive
125MythArchive is a MythTV style plugin that uses the Mythburn Script to
68bb720e 126create and burn DVDs from MythTV recordings, MythVideo files or any
beab7214
ER
127video files available on a MythTV system. It can also export
128recordings to a native archive format that can then be imported back
68bb720e
JB
129into a MythTV system restoring all the associated metadata.
130
c2db80a4
JR
131%description -n mytharchive -l pl.UTF-8
132MythArchive to wtyczka MythTV używająca skryptu Mythburn do tworzenia
133i wypalania płyt DVD z nagrań MythTV, plików MythVideo lub dowolnych
134innych plików z filmami dostępnych w systemie MythTV. Może także
135eksportować nagrania do natywnego formatu archiwum, który potem można
136zaimportować z powrotem do systemu MythTV przywracając wszystkie
137związane z nimi metadane.
beab7214 138
d78b97e1 139%package -n mythmusic
20cc2885 140Summary: The music player add-on module for MythTV
9478e970 141Summary(pl.UTF-8): Moduł odtwarzacza muzyki dla MythTV
d78b97e1 142Group: Applications/Multimedia
f76d04d4 143Requires: mythtv-frontend-api = %{myth_api_version}
d78b97e1
ER
144
145%description -n mythmusic
20cc2885
JB
146Music add-on for MythTV.
147
c2db80a4 148%description -n mythmusic -l pl.UTF-8
20cc2885 149Odtwarzacz muzyki dla MythTV.
d78b97e1
ER
150
151%package -n mythvideo
20cc2885 152Summary: A generic video player frontend module for MythTV
9478e970 153Summary(pl.UTF-8): Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV
d78b97e1
ER
154Group: Applications/Multimedia
155Requires: mplayer
f76d04d4 156Requires: mythtv-frontend-api = %{myth_api_version}
d78b97e1
ER
157
158%description -n mythvideo
ba857471 159A generic video player frontend module for MythTV.
d78b97e1 160
c2db80a4
JR
161%description -n mythvideo -l pl.UTF-8
162Moduł ogólnego interfejsu do odtwarzania obrazu dla MythTV.
20cc2885 163
d78b97e1 164%package -n mythweather
20cc2885 165Summary: A MythTV module that displays a weather forcast
9478e970 166Summary(pl.UTF-8): Moduł MythTV wyświetlający prognozę pogody
d78b97e1 167Group: Applications/Multimedia
f76d04d4 168Requires: mythtv-frontend-api = %{myth_api_version}
d78b97e1
ER
169
170%description -n mythweather
171A MythTV module that displays a weather forcast.
172
c2db80a4
JR
173%description -n mythweather -l pl.UTF-8
174Moduł MythTV wyświetlający prognozę pogody.
20cc2885 175
d78b97e1 176%package -n mythgallery
20cc2885 177Summary: A gallery/slideshow module for MythTV
9478e970 178Summary(pl.UTF-8): Moduł galerii/pokazu slajdów dla MythTV
d78b97e1 179Group: Applications/Multimedia
f76d04d4 180Requires: mythtv-frontend-api = %{myth_api_version}
d78b97e1
ER
181
182%description -n mythgallery
183A gallery/slideshow module for MythTV.
184
c2db80a4
JR
185%description -n mythgallery -l pl.UTF-8
186Moduł galerii/pokazu slajdów dla MythTV.
20cc2885 187
d78b97e1 188%package -n mythgame
20cc2885 189Summary: A game frontend (xmame, nes, snes, pc) for MythTV
9478e970 190Summary(pl.UTF-8): Interfejs do gier (xmame, nes, snes, pc) dla MythTV
d78b97e1 191Group: Applications/Multimedia
f76d04d4 192Requires: mythtv-frontend-api = %{myth_api_version}
d78b97e1
ER
193
194%description -n mythgame
195A game frontend (xmame, nes, snes, pc) for MythTV.
196
c2db80a4 197%description -n mythgame -l pl.UTF-8
20cc2885
JB
198Interfejs do gier (xmame, nes, snes, pc) dla MythTV.
199
d78b97e1 200%package -n mythnews
20cc2885 201Summary: A RSS News Feed plugin for MythTV
9478e970 202Summary(pl.UTF-8): Wtyczka czytnika nowinek RSS dla MythTV
d78b97e1 203Group: Applications/Multimedia
f76d04d4 204Requires: mythtv-frontend-api = %{myth_api_version}
d78b97e1
ER
205
206%description -n mythnews
20cc2885
JB
207A RSS News Feed plugin for MythTV.
208
c2db80a4 209%description -n mythnews -l pl.UTF-8
20cc2885 210Wtyczka czytnika nowinek RSS dla MythTV.
d78b97e1
ER
211
212%package -n mythbrowser
20cc2885 213Summary: A small web browser module for MythTV
9478e970 214Summary(pl.UTF-8): Moduł małej przeglądarki WWW dla MythTV
d78b97e1 215Group: Applications/Multimedia
f76d04d4 216Requires: mythtv-frontend-api = %{myth_api_version}
d78b97e1
ER
217
218%description -n mythbrowser
219MythBrowser is a full fledged web-browser (multiple tabs) to display
220webpages in full-screen mode. Simple page navigation is possible.
221Starting with version 0.13 it also has full support for mouse driven
20cc2885 222navigation (right mouse opens and closes the popup menu).
d78b97e1
ER
223
224MythBrowser also contains a BookmarkManager to manage the website
225links in a simple mythplugin.
226
c2db80a4
JR
227%description -n mythbrowser -l pl.UTF-8
228MythBrowser to w pełni funkcjonalna przeglądarka WWW (z wieloma
229zakładkami) wyświetlająca strony WWW w trybie pełnoekranowym. Możliwa
230jest prosta nawigacja po stronie. Począwszy od wersji 0.13 ma pełną
231obsługę nawigacji myszką (prawy przycisk otwiera i zamywa wyskakujące
20cc2885
JB
232menu).
233
c2db80a4 234MythBrowser zawiera także BookmarkManagera do zarządzania odnośnikami
20cc2885
JB
235do stron w prostej wtyczce myth.
236
d78b97e1 237%package -n mythphone
20cc2885 238Summary: A video conferencing module for MythTV
9478e970 239Summary(pl.UTF-8): Moduł wideokonferencji dla MythTV
d78b97e1 240Group: Applications/Multimedia
f76d04d4 241Requires: mythtv-frontend-api = %{myth_api_version}
d78b97e1
ER
242
243%description -n mythphone
20cc2885 244Mythphone is a phone and videophone capability on Myth using the
d78b97e1
ER
245standard SIP protocol. It is compatible with Microsoft XP Messenger
246and with SIP Service Providers such as Free World Dialup
247(fwd.pulver.com).
248
c2db80a4
JR
249%description -n mythphone -l pl.UTF-8
250Mythphone to funkcjonalność telefonu i wideofonu w Myth przy użyciu
251standardowego protokołu SIP. Jest kompatybilny z Microsoft XP
252Messengerem oraz dostawcami usług SIP, takimi jak Free World Dialup
20cc2885
JB
253(fwd.pulver.com).
254
5e68f3bc
ER
255%package -n mythweb
256Summary: The web interface to MythTV
9478e970 257Summary(pl.UTF-8): Interfejs WWW do MythTV
5e68f3bc 258Group: Applications/Multimedia
f76d04d4
ER
259Requires: webapps
260#Suggests: apache(mod_auth)
261#Suggests: apache(mod_env)
3515083d
ER
262Requires: php(mysql)
263Requires: php(posix)
264Requires: webserver(php) >= 4.3
5e68f3bc
ER
265
266%description -n mythweb
267The web interface to MythTV.
268
c2db80a4 269%description -n mythweb -l pl.UTF-8
64c9f7c0
JB
270Interfejs WWW do MythTV.
271
f76d04d4
ER
272%package -n mythflix
273Summary: MythFlix (A NetFlix MythTV)
9478e970 274Summary(pl.UTF-8): MythFlix (NetFlix MythTV)
f76d04d4
ER
275Group: Applications/Multimedia
276Requires: mythtv-frontend-api = %{myth_api_version}
277
278%description -n mythflix
279MythFlix is a MythTV plugin for adding movies to your Netflix queue.
280It currently supports the ability to view your queue and add movies to
281your queue. The browse feature is based on the Netflix RSS feeds. This
282plugin is not very mature, which means things might not work right
283and/or it might break other things.
284
c2db80a4
JR
285%description -n mythflix -l pl.UTF-8
286MythFlix to wtyczka MythTV do dodawania filmów do kolejki Netfliksa.
287Aktualnie daje możliwość oglądania kolejki i dodawania do niej filmów.
288Przeglądanie jest oparte na kanale RSS Netfliksa. Ta wtyczka nie jest
289jeszcze zbyt dojrzała, co znaczy, że coś może nie działać lub psuć coś
f76d04d4
ER
290innego.
291
ba857471 292%package -n mythcontrols
293Summary: MythTV keybindings editor
294Summary(pl.UTF-8): Edytor przypisań klawiszy MythTV
445e2012
JK
295Group: Applications/Multimedia
296Requires: mythtv-frontend-api = %{myth_api_version}
297
ba857471 298%description -n mythcontrols
299This plugin allows you to configure your keybindings on the frontend
300without having to use mythweb or edit tables by hand.
1e58f504 301
ba857471 302%description -n mythcontrols -l pl.UTF-8
303Ta wtyczka pozwala konfigurować przypisania klawiszy we frontendzie
304bez konieczności używania mythweba ani ręcznego modyfikowania tabel.
1e58f504 305
ba857471 306%package -n mythmovies
307Summary: MythTV plugin for looking up movie showtimes in a given area
308Group: Applications/Multimedia
309Requires: mythtv-frontend-api = %{myth_api_version}
310
311%description -n mythmovies
312MythMovies is a plugin for looking up movie showtimes in a given area.
445e2012
JK
313
314%package -n mythzoneminder
ba857471 315Summary: MythTV plugin to interface ZoneMinder
316Group: Applications/Multimedia
317Requires: mythtv-frontend-api = %{myth_api_version}
445e2012
JK
318
319%description -n mythzoneminder
ba857471 320MythZoneMinder is a plugin to interface to some of the features of ZoneMinder.
321You can use it to view a status window similar to the console window in ZM.
322Also there are screens to view live camera shots and replay recorded events.
323Other features may be added at a later time if there is sufficient interest.
445e2012 324
ba857471 325ZoneMinder is a Linux video camera security and surveillance solution .
445e2012 326
d78b97e1 327%prep
ba857471 328%setup -q %{?_snap:-n %{name}}
329%patch0 -p1
63c280ad 330#filterdiff -i 'mythplugins/*' %{PATCH100} | %{__patch} -p1 -s
f76d04d4
ER
331
332# make it visible
ba857471 333mv mythweb/{data/.,}htaccess
d78b97e1 334
f76d04d4
ER
335# lib64 fix - enable to update patch
336%if %{_lib} != "lib" && 0
69870715 337find '(' -name '*.[ch]' -o -name '*.cpp' -o -name '*.pro' ')' | \
123e986b 338xargs grep -l /lib/ . | xargs sed -i -e '
ba857471 339 s,/usr/lib/,/usr/%{_lib}/,g
cb9924d8 340 s,{PREFIX}/lib,{PREFIX}/%{_lib},g
123e986b 341'
f76d04d4 342exit 1
a8181a32
ER
343%endif
344
d78b97e1 345%build
f76d04d4 346%if %{with binary}
69870715 347export QTDIR="%{_prefix}"
123e986b 348# Not gnu configure
69870715 349%configure \
ba857471 350 --libdir-name=%{_lib} \
69870715 351 --enable-all \
beab7214 352 %{!?with_mytharchive:--disable-mytharchive} \
f76d04d4 353 %{!?with_mythbrowser:--disable-mythbrowser} \
f76d04d4
ER
354 %{!?with_mythgallery:--disable-mythgallery}%{?with_mythgallery:--enable-exif --enable-new-exif --enable-opengl} \
355 %{!?with_mythgame:--disable-mythgame} \
356 %{!?with_mythmusic:--disable-mythmusic}%{?with_mythmysic:--enable-fftw --enable-sdl --enable-aac --enable-opengl} \
357 %{!?with_mythnews:--disable-mythnews} \
358 %{!?with_mythphone:--disable-mythphone}%{?with_mythphone:--disable-festival} \
359 %{!?with_mythvideo:--disable-mythvideo} \
360 %{!?with_mythweather:--disable-mythweather} \
361 %{!?with_mythweb:--disable-mythweb} \
ba857471 362 %{!?with_mythcontrols:--disable-mythcontrols} \
f76d04d4
ER
363 %{!?with_mythflix:--disable-mythflix} \
364
365mv mythconfig.mak mythconfig.mak.old
366cp mythconfig.mak.old mythconfig.mak
367cat <<'EOF'>> mythconfig.mak
368QMAKE_CXX=%{__cxx}
369QMAKE_CC=%{__cc}
370OPTFLAGS=%{rpmcflags} -Wall -Wno-switch
371ECFLAGS=%{rpmcflags} -fomit-frame-pointer
372ECXXFLAGS=%{rpmcflags} -fomit-frame-pointer
373EOF
374
d78b97e1 375%{__make}
f76d04d4 376%endif
d78b97e1
ER
377
378%install
379rm -rf $RPM_BUILD_ROOT
513b080c 380
f76d04d4 381%if %{with binary}
513b080c 382export QTDIR="%{_prefix}"
20cc2885
JB
383%{__make} install \
384 INSTALL_ROOT=$RPM_BUILD_ROOT
d78b97e1 385
ba857471 386install -d $RPM_BUILD_ROOT/var/lib/{mythmusic,mythvideo,pictures}
f76d04d4 387%if %{with mythgame}
d78b97e1
ER
388install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/nes/{roms,screens}
389install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/snes/{roms,screens}
16792a62 390install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/xmame/{roms,screens,flyers,cabs}
d78b97e1 391install -d $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC/screens
a8181a32 392cp -a mythgame/gamelist.xml $RPM_BUILD_ROOT%{_datadir}/mythtv/games/PC
f76d04d4
ER
393%endif
394%endif
d78b97e1 395
f76d04d4 396%if %{with mythweb}
3cfccba6
ER
397cd mythweb
398install -d $RPM_BUILD_ROOT%{_datadir}/mythweb
f76d04d4
ER
399install -d $RPM_BUILD_ROOT/var/cache/mythweb/{image_cache,php_sessions,tv_icons}
400install -d $RPM_BUILD_ROOT%{_webapps}/%{_webapp}
ba857471 401cp -a *.php *.pl data includes js modules objects skins $RPM_BUILD_ROOT%{_datadir}/mythweb
f76d04d4
ER
402install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/apache.conf
403install %{SOURCE1} $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/httpd.conf
404touch $RPM_BUILD_ROOT%{_webapps}/%{_webapp}/htpasswd
3cfccba6 405cd -
f76d04d4
ER
406%endif
407
3cfccba6 408mv $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythbrowser_{pt_br,pt}.qm
beab7214 409rm $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/mythflix_nb.ts # i18n source
ba857471 410for p in mytharchive mythbrowser mythcontrols mythflix mythgallery mythgame mythmusic mythnews mythphone mythvideo mythweather mythmovies mythzoneminder; do
f76d04d4 411 for l in $RPM_BUILD_ROOT%{_datadir}/mythtv/i18n/${p}_*.qm; do
ba857471 412 if [ -f "$l" ] ; then
413 echo $l | sed -e "s,^$RPM_BUILD_ROOT\(.*${p}_\(.*\).qm\),%%lang(\2) \1,"
414 fi
f76d04d4
ER
415 done > $p.lang
416done
5e68f3bc 417
d78b97e1 418%clean
69870715 419rm -rf $RPM_BUILD_ROOT
d78b97e1 420
9c2555e2 421%triggerin -n mythweb -- apache1 < 1.3.37-3, apache1-base
f76d04d4
ER
422%webapp_register apache %{_webapp}
423
9c2555e2 424%triggerun -n mythweb -- apache1 < 1.3.37-3, apache1-base
f76d04d4
ER
425%webapp_unregister apache %{_webapp}
426
427%triggerin -n mythweb -- apache < 2.2.0, apache-base
428%webapp_register httpd %{_webapp}
429
430%triggerun -n mythweb -- apache < 2.2.0, apache-base
431%webapp_unregister httpd %{_webapp}
432
433%triggerpostun -n mythweb -- mythweb < 0.19
434for i in canned_searches.php conf.php htpasswd theme_Default.php theme_compact.php theme_vxml.php theme_wap.php theme_wml.php weathertypes.dat; do
435 if [ -f /etc/mythweb/$i.rpmsave ]; then
436 mv -f %{_webapps}/%{_webapp}/$i{,.rpmnew}
437 mv -f /etc/mythweb/$i.rpmsave %{_webapps}/%{_webapp}/$i
438 fi
439done
440sed -i -e 's,/etc/mythweb,%{_webapps}/%{_webapp},' %{_webapps}/%{_webapp}/{apache,httpd}.conf
441
442# migrate from apache-config macros
443if [ -f /etc/mythweb/apache.conf.rpmsave ]; then
444 if [ -d /etc/apache/webapps.d ]; then
445 cp -f %{_webapps}/%{_webapp}/apache.conf{,.rpmnew}
446 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/apache.conf
447 fi
448
449 if [ -d /etc/httpd/webapps.d ]; then
450 cp -f %{_webapps}/%{_webapp}/httpd.conf{,.rpmnew}
451 cp -f /etc/mythweb/apache.conf.rpmsave %{_webapps}/%{_webapp}/httpd.conf
452 fi
453 rm -f /etc/mythweb/apache.conf.rpmsave
454fi
455
456if [ -L /etc/apache/conf.d/99_mythplugins.conf ]; then
457 rm -f /etc/apache/conf.d/99_mythplugins.conf
458 /usr/sbin/webapp register apache %{_webapp}
459 %service -q apache reload
460fi
461if [ -L /etc/httpd/httpd.conf/99_mythplugins.conf ]; then
462 rm -f /etc/httpd/httpd.conf/99_mythplugins.conf
463 /usr/sbin/webapp register httpd %{_webapp}
464 %service -q httpd reload
465fi
5e68f3bc 466
d78b97e1
ER
467%files
468%defattr(644,root,root,755)
d78b97e1 469
beab7214
ER
470%if %{with mytharchive}
471%files -n mytharchive -f mytharchive.lang
472%defattr(644,root,root,755)
473%attr(755,root,root) %{_bindir}/mytharchivehelper
474%attr(755,root,root) %{_libdir}/mythtv/plugins/libmytharchive.so
ba857471 475%{_datadir}/mythtv/archiveformat.xml
beab7214 476%{_datadir}/mythtv/archivemenu.xml
ba857471 477%{_datadir}/mythtv/archiveselect.xml
beab7214
ER
478%{_datadir}/mythtv/themes/default/ma_*.png
479%{_datadir}/mythtv/themes/default/mytharchive-ui.xml
480%{_datadir}/mythtv/themes/default/mythburn-ui.xml
481%{_datadir}/mythtv/themes/default/mythnative-ui.xml
482%{_datadir}/mythtv/mytharchive
483%endif
484
f76d04d4
ER
485%if %{with mythmusic}
486%files -n mythmusic -f mythmusic.lang
d78b97e1 487%defattr(644,root,root,755)
beab7214 488%doc mythmusic/README mythmusic/AUTHORS mythmusic/musicdb
d78b97e1 489%attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmusic.so
513b080c 490/var/lib/mythmusic
d78b97e1
ER
491%{_datadir}/mythtv/musicmenu.xml
492%{_datadir}/mythtv/music_settings.xml
f76d04d4 493%{_datadir}/mythtv/themes/default/music-ui.xml
d78b97e1
ER
494%{_datadir}/mythtv/themes/default/ff_button_off.png
495%{_datadir}/mythtv/themes/default/ff_button_on.png
496%{_datadir}/mythtv/themes/default/ff_button_pushed.png
445e2012 497%{_datadir}/mythtv/themes/default/mm_*.png
d78b97e1 498%{_datadir}/mythtv/themes/default/music-sel-bg.png
d78b97e1
ER
499%{_datadir}/mythtv/themes/default/next_button_off.png
500%{_datadir}/mythtv/themes/default/next_button_on.png
501%{_datadir}/mythtv/themes/default/next_button_pushed.png
502%{_datadir}/mythtv/themes/default/pause_button_off.png
503%{_datadir}/mythtv/themes/default/pause_button_on.png
504%{_datadir}/mythtv/themes/default/pause_button_pushed.png
505%{_datadir}/mythtv/themes/default/play_button_off.png
506%{_datadir}/mythtv/themes/default/play_button_on.png
507%{_datadir}/mythtv/themes/default/play_button_pushed.png
508%{_datadir}/mythtv/themes/default/prev_button_off.png
509%{_datadir}/mythtv/themes/default/prev_button_on.png
510%{_datadir}/mythtv/themes/default/prev_button_pushed.png
511%{_datadir}/mythtv/themes/default/rew_button_off.png
512%{_datadir}/mythtv/themes/default/rew_button_on.png
513%{_datadir}/mythtv/themes/default/rew_button_pushed.png
514%{_datadir}/mythtv/themes/default/selectionbar.png
515%{_datadir}/mythtv/themes/default/stop_button_off.png
516%{_datadir}/mythtv/themes/default/stop_button_on.png
517%{_datadir}/mythtv/themes/default/stop_button_pushed.png
d78b97e1 518%{_datadir}/mythtv/themes/default/track_info_background.png
ba857471 519%{_datadir}/mythtv/themes/default/miniplayer*.png
f76d04d4 520%endif
d78b97e1 521
f76d04d4
ER
522%if %{with mythvideo}
523%files -n mythvideo -f mythvideo.lang
d78b97e1 524%defattr(644,root,root,755)
beab7214 525%doc mythvideo/README mythvideo/videodb
ba857471 526%attr(755,root,root) %{_bindir}/mtd
d78b97e1 527%attr(755,root,root) %{_libdir}/mythtv/plugins/libmythvideo.so
ba857471 528%{_datadir}/mythtv/themes/default/dvd-ui.xml
d78b97e1 529%{_datadir}/mythtv/themes/default/video-ui.xml
ba857471 530%{_datadir}/mythtv/themes/default/mv-*.png
1e58f504 531%{_datadir}/mythtv/themes/default/mv_*.png
ba857471 532%{_datadir}/mythtv/themes/default/md_*.png
533%{_datadir}/mythtv/themes/default-wide/dvd-ui.xml
534%{_datadir}/mythtv/themes/default-wide/video-ui.xml
535%{_datadir}/mythtv/themes/default-wide/mv-*.png
445e2012 536%{_datadir}/mythtv/themes/default-wide/mv_*.png
d78b97e1
ER
537%{_datadir}/mythtv/video_settings.xml
538%{_datadir}/mythtv/videomenu.xml
a8181a32
ER
539%dir %{_datadir}/mythtv/mythvideo
540%dir %{_datadir}/mythtv/mythvideo/scripts
d78b97e1 541%{_datadir}/mythtv/mythvideo/scripts/README
445e2012
JK
542%attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/*.pl
543%attr(755,root,root) %{_datadir}/mythtv/mythvideo/scripts/*.py
513b080c 544/var/lib/mythvideo
f76d04d4
ER
545%endif
546
547%if %{with mythweather}
548%files -n mythweather -f mythweather.lang
d78b97e1 549%defattr(644,root,root,755)
b0c55580 550%doc mythweather/README
d78b97e1 551%attr(755,root,root) %{_libdir}/mythtv/plugins/libmythweather.so
ba857471 552%dir %{_datadir}/mythtv/mythweather
553%dir %{_datadir}/mythtv/mythweather/scripts
554%{_datadir}/mythtv/mythweather/scripts/README
555%dir %{_datadir}/mythtv/mythweather/scripts/ca_envcan
556%attr(755,root,root) %{_datadir}/mythtv/mythweather/scripts/ca_envcan/*.pl
557%{_datadir}/mythtv/mythweather/scripts/ca_envcan/*.pm
558%{_datadir}/mythtv/mythweather/scripts/ca_envcan/*.xml
559%{_datadir}/mythtv/mythweather/scripts/ca_envcan/ENVCAN_icons
560%dir %{_datadir}/mythtv/mythweather/scripts/uk_bbc
561%attr(755,root,root) %{_datadir}/mythtv/mythweather/scripts/uk_bbc/*.pl
562%{_datadir}/mythtv/mythweather/scripts/uk_bbc/*.pm
563%dir %{_datadir}/mythtv/mythweather/scripts/us_nws
564%attr(755,root,root) %{_datadir}/mythtv/mythweather/scripts/us_nws/*.pl
565%{_datadir}/mythtv/mythweather/scripts/us_nws/*.pm
566%{_datadir}/mythtv/mythweather/scripts/us_nws/*.xml
567%{_datadir}/mythtv/mythweather/scripts/us_nws/*.dbx
568%{_datadir}/mythtv/mythweather/scripts/us_nws/icons
569%{_datadir}/mythtv/mythweather/scripts/us_nws/maps
570%{_datadir}/mythtv/mythweather/scripts/us_nws/weather_types
571%{_datadir}/mythtv/mythweather/weather-screens.xml
d78b97e1
ER
572%{_datadir}/mythtv/themes/default/weather-ui.xml
573%{_datadir}/mythtv/themes/default/cloudy.png
574%{_datadir}/mythtv/themes/default/fair.png
575%{_datadir}/mythtv/themes/default/flurries.png
576%{_datadir}/mythtv/themes/default/fog.png
577%{_datadir}/mythtv/themes/default/logo.png
578%{_datadir}/mythtv/themes/default/lshowers.png
579%{_datadir}/mythtv/themes/default/mcloudy.png
445e2012 580%{_datadir}/mythtv/themes/default/mw_*.png
d78b97e1
ER
581%{_datadir}/mythtv/themes/default/mwmain.png
582%{_datadir}/mythtv/themes/default/pcloudy.png
583%{_datadir}/mythtv/themes/default/rainsnow.png
584%{_datadir}/mythtv/themes/default/showers.png
585%{_datadir}/mythtv/themes/default/snowshow.png
586%{_datadir}/mythtv/themes/default/sunny.png
587%{_datadir}/mythtv/themes/default/thunshowers.png
588%{_datadir}/mythtv/themes/default/unknown.png
ba857471 589%{_datadir}/mythtv/themes/default-wide/weather-ui.xml
445e2012 590%{_datadir}/mythtv/themes/default-wide/mw-*.png
ba857471 591%{_datadir}/mythtv/weather_settings.xml
f76d04d4 592%endif
d78b97e1 593
f76d04d4
ER
594%if %{with mythgallery}
595%files -n mythgallery -f mythgallery.lang
d78b97e1 596%defattr(644,root,root,755)
beab7214 597%doc mythgallery/README
d78b97e1
ER
598%attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgallery.so
599%{_datadir}/mythtv/themes/default/gallery-ui.xml
600%{_datadir}/mythtv/themes/default/gallery-*.png
f76d04d4 601# FIXME: this is definately stupid path
513b080c 602/var/lib/pictures
f76d04d4 603%endif
d78b97e1 604
f76d04d4
ER
605%if %{with mythgame}
606%files -n mythgame -f mythgame.lang
d78b97e1 607%defattr(644,root,root,755)
d78b97e1
ER
608%attr(755,root,root) %{_libdir}/mythtv/plugins/libmythgame.so
609%{_datadir}/mythtv/games
d78b97e1
ER
610%{_datadir}/mythtv/game_settings.xml
611%{_datadir}/mythtv/themes/default/game-ui.xml
f76d04d4 612%endif
d78b97e1 613
f76d04d4
ER
614%if %{with mythnews}
615%files -n mythnews -f mythnews.lang
d78b97e1 616%defattr(644,root,root,755)
123e986b 617%doc mythnews/README mythnews/AUTHORS
d78b97e1
ER
618%attr(755,root,root) %{_libdir}/mythtv/plugins/libmythnews.so
619%{_datadir}/mythtv/mythnews
620%{_datadir}/mythtv/themes/default/news-ui.xml
1e58f504 621%{_datadir}/mythtv/themes/default/enclosures.png
622%{_datadir}/mythtv/themes/default/need-download.png
ba857471 623# DUPLICATE WITH MYTHFLIX?
624%{_datadir}/mythtv/themes/default/news-info-bg.png
f76d04d4 625%endif
d78b97e1 626
f76d04d4
ER
627%if %{with mythbrowser}
628%files -n mythbrowser -f mythbrowser.lang
d78b97e1 629%defattr(644,root,root,755)
b0c55580 630%doc mythbrowser/README mythbrowser/AUTHORS
d78b97e1
ER
631%attr(755,root,root) %{_bindir}/mythbrowser
632%attr(755,root,root) %{_libdir}/mythtv/plugins/libmythbookmarkmanager.so
ba857471 633%{_datadir}/mythtv/themes/default/webpage.png
f76d04d4 634%endif
d78b97e1 635
f76d04d4
ER
636%if %{with mythphone}
637%files -n mythphone -f mythphone.lang
d78b97e1 638%defattr(644,root,root,755)
b0c55580 639%doc mythphone/README mythphone/AUTHORS mythphone/TODO
d78b97e1
ER
640%attr(755,root,root) %{_libdir}/mythtv/plugins/libmythphone.so
641%{_datadir}/mythtv/themes/default/phone-ui.xml
642%{_datadir}/mythtv/themes/default/webcam-ui.xml
643%{_datadir}/mythtv/themes/default/mp_*.png
644%{_datadir}/mythtv/themes/default/phone.png
f76d04d4 645%endif
5e68f3bc 646
f76d04d4 647%if %{with mythweb}
5e68f3bc
ER
648%files -n mythweb
649%defattr(644,root,root,755)
ba857471 650%doc mythweb/{README,INSTALL,data,htaccess,mythweb.conf.*}
f76d04d4
ER
651%dir %attr(750,root,http) %{_webapps}/%{_webapp}
652%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/apache.conf
653%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/httpd.conf
3cfccba6
ER
654#%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.php
655#%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/*.dat
f76d04d4 656%attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_webapps}/%{_webapp}/htpasswd
5e68f3bc 657%{_datadir}/mythweb
f76d04d4 658%dir %attr(771,root,http) /var/cache/mythweb
5e68f3bc
ER
659%dir %attr(771,root,http) /var/cache/mythweb/image_cache
660%dir %attr(771,root,http) /var/cache/mythweb/php_sessions
f76d04d4
ER
661%dir %attr(771,root,http) /var/cache/mythweb/tv_icons
662%endif
663
664%if %{with mythflix}
665%files -n mythflix -f mythflix.lang
666%defattr(644,root,root,755)
667%doc mythflix/{AUTHORS,ChangeLog,README}
668%attr(755,root,root) %{_libdir}/mythtv/plugins/libmythflix.so
669%dir %{_datadir}/mythtv/mythflix
670%{_datadir}/mythtv/mythflix/netflix-rss.xml
671%dir %{_datadir}/mythtv/mythflix/scripts
672%attr(755,root,root) %{_datadir}/mythtv/mythflix/scripts/netflix.pl
673%{_datadir}/mythtv/netflix_menu.xml
674%{_datadir}/mythtv/themes/default/title_netflix.png
675%{_datadir}/mythtv/themes/default/netflix-ui.xml
676# DUPLICATE WITH MYTHNEWS?
677%{_datadir}/mythtv/themes/default/news-info-bg.png
678%endif
679
ba857471 680%if %{with mythcontrols}
681%files -n mythcontrols -f mythcontrols.lang
682%defattr(644,root,root,755)
683%doc mythcontrols/{AUTHORS,README,TODO}
684%attr(755,root,root) %{_libdir}/mythtv/plugins/libmythcontrols.so
685%{_datadir}/mythtv/themes/default/controls-ui.xml
686%{_datadir}/mythtv/themes/default/kb-button-off.png
687%{_datadir}/mythtv/themes/default/kb-button-on.png
688%endif
689
445e2012 690%if %{with mythmovies}
ba857471 691%files -n mythmovies -f mythmovies.lang
445e2012
JK
692%defattr(644,root,root,755)
693%doc mythmovies/{README,TODO}
694%attr(755,root,root) %{_bindir}/ignyte
695%attr(755,root,root) %{_libdir}/mythtv/plugins/libmythmovies.so
696%{_datadir}/mythtv/themes/default/movies-ui.xml
697%{_datadir}/mythtv/themes/default-wide/movies-ui.xml
698%endif
699
700%if %{with mythzoneminder}
ba857471 701%files -n mythzoneminder -f mythzoneminder.lang
445e2012 702%defattr(644,root,root,755)
ba857471 703%doc mythzoneminder/{README,AUTHORS}
445e2012
JK
704%attr(755,root,root) %{_bindir}/mythzmserver
705%attr(755,root,root) %{_libdir}/mythtv/plugins/libmythzoneminder.so
706%{_datadir}/mythtv/themes/default/zoneminder-ui.xml
707%{_datadir}/mythtv/themes/default-wide/zoneminder-ui.xml
ba857471 708%{_datadir}/mythtv/themes/default/mz_*.png
709%{_datadir}/mythtv/zonemindermenu.xml
445e2012 710%endif
This page took 0.140165 seconds and 4 git commands to generate.