]> git.pld-linux.org Git - packages/mono.git/blame - mono.spec
- BR: gettext-devel
[packages/mono.git] / mono.spec
CommitLineData
39176ea5 1#
fef1a4c5 2# NOTE: Makefiles are broken, build could stop long time after first fatal error
94b2d9a7
ER
3# TODO:
4# /usr/lib/mono-source-libs/Options.cs
5# /usr/lib/mono-source-libs/getline.cs
6# /usr/lib64/pkgconfig/mono-lineeditor.pc
7# /usr/lib64/pkgconfig/mono-options.pc
8# /usr/lib64/pkgconfig/mono.web.pc
9# /usr/lib64/pkgconfig/system.web.extensions.design_1.0.pc
10# /usr/lib64/pkgconfig/system.web.extensions_1.0.pc
11# /usr/lib64/pkgconfig/wcf.pc
00c74d1a
ER
12# - x86_64 searches .dll from %{_libdir}, not %{_prefix}/lib:
13# The assembly mscorlib.dll was not found or could not be loaded.
14# It should have been installed in the `/usr/lib64/mono/2.0/mscorlib.dll' directory.
245657c9
MM
15#
16# Conditional build:
fef1a4c5 17%bcond_without tls # don't use TLS (which requires recent 2.4.x or 2.6 kernel)
4d9455d0 18%bcond_without static_libs # don't build static libraries
8cabdc4d 19%bcond_with bootstrap # don't require mono-devel to find req/prov
75873ca6 20%bcond_with mint # build mint instead of mono VM (JIT) [broken]
245657c9 21#
75873ca6
JB
22%ifnarch %{ix86} %{x8664} alpha arm ia64 ppc s390 s390x sparc sparcv9 sparc64
23# JIT not supported on hppa
a465d985 24%define with_mint 1
f1c5438d 25%endif
5114c445 26%define glib_ver 1:2.4
8cabdc4d 27#
728c2265 28Summary: Common Language Infrastructure implementation
d1081961 29Summary(pl.UTF-8): Implementacja Common Language Infrastructure
728c2265 30Name: mono
94b2d9a7 31Version: 2.4.2.3
9bfc17bb 32Release: 0.4
5114c445 33License: LGPL (VM), GPL (C# compilers), MIT X11 with GPL additions (classes, tools)
728c2265 34Group: Development/Languages
0f6bc6e4
JB
35# latest downloads summary at http://ftp.novell.com/pub/mono/sources-stable/
36Source0: http://ftp.novell.com/pub/mono/sources/mono/%{name}-%{version}.tar.bz2
94b2d9a7 37# Source0-md5: 696f25afc8453cd0d1c78de6e905dcf2
ddb02eae
JB
38Patch0: %{name}-alpha-float.patch
39Patch1: %{name}-mint.patch
40Patch2: %{name}-sonames.patch
3cdc32b9
JB
41Patch3: %{name}-awk.patch
42Patch4: %{name}-console-no-utf8-bom.patch
5114c445 43Patch5: %{name}-pc.patch
0f6bc6e4 44Patch6: %{name}-ARG_MAX.patch
e9945d9e 45Patch7: %{name}-metadata-makefile.patch
68174c6e 46URL: http://www.mono-project.com/
39176ea5 47%if %(test -r /dev/random; echo $?)
96185d3a
JB
48BuildRequires: ACCESSIBLE_/dev/random
49%endif
8aa3dace 50BuildRequires: autoconf
51BuildRequires: automake
3c4b0944 52BuildRequires: bison
4f07b841 53BuildRequires: gettext-devel
5114c445 54BuildRequires: glib2-devel >= %{glib_ver}
f7c57864 55BuildRequires: libtool
609d5e15 56%{!?with_bootstrap:BuildRequires: mono-devel >= 1.1.8.3-2}
f7c57864 57BuildRequires: pkgconfig
71415791 58BuildRequires: rpmbuild(macros) >= 1.213
2ca5ca77 59BuildRequires: rpmbuild(monoautodeps)
8c34c74b 60Suggests: binfmt-detector
5114c445 61# for System.Drawing
7b0dd1f7 62Suggests: libgdiplus >= 2.0
e19321c3 63ExclusiveArch: %{ix86} %{x8664} alpha arm hppa ia64 mips ppc s390 s390x sparc sparcv9
1de8200d
JB
64# plain i386 is not supported; mono uses cmpxchg/xadd which require i486
65ExcludeArch: i386
728c2265
AM
66BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
ad29385a 68%define _rpmlibdir /usr/lib/rpm
69
baf6636c 70# debugger doesn't work with stripped mono
71%define _noautostrip .*/mono
72
39176ea5 73%if %{without bootstrap}
d0023a38 74%define __mono_provides %{_rpmlibdir}/mono-find-provides
75%define __mono_requires %{_rpmlibdir}/mono-find-requires
76%endif
77
728c2265
AM
78%description
79The Common Language Infrastructure platform. Microsoft has created a
80new development platform. The highlights of this new development
81platform are:
86d7bbf3 82- A runtime environment that provides garbage collection, threading
728c2265 83 and a virtual machine specification (The Virtual Execution System,
8aa3dace 84 VES),
85- A comprehensive class library,
728c2265 86- A new language, C#. Very similar to Java, C# allows programmers to
8aa3dace 87 use all the features available on the .NET runtime,
728c2265
AM
88- A language specification that compilers can follow if they want to
89 generate classes and code that can interoperate with other programming
8aa3dace 90 languages (The Common Language Specification: CLS).
728c2265 91
39176ea5 92%{?with_tls:This version was built with TLS __thread.}
245657c9 93
a86cd9c8
JR
94%description -l pl.UTF-8
95Platforma CLI (Common Language Infrastructure). Microsoft stworzył
96nową platformę developerską. Zalety tej platformy to:
97- środowisko, które dostarcza garbage collector, wątki oraz
98 specyfikację maszyny wirtualnej (The Virtual Execution System, VES),
99- bibliotekę klas,
100- nowy język, C#. Bardzo podobny do Javy, C# pozwala programistom na
101 używanie wszystkich możliwości dostarczanych przez platformę .NET,
102- specyfikacja dla kompilatorów, które chcą generować kod
103 współpracujący z innymi językami programowania (The Common Language
8aa3dace 104 Specification: CLS).
105
a86cd9c8 106%{?with_tls:Ta wersja została zbudowana z TLS __thread.}
245657c9 107
8aa3dace 108%package devel
109Summary: Development resources for mono
d1081961 110Summary(pl.UTF-8): Zasoby programisty do mono
5114c445 111License: LGPL (VM), MIT X11 with GPL additions (classes, tools)
8aa3dace 112Group: Development/Libraries
76e7cb31 113Requires: %{name} = %{version}-%{release}
5114c445 114Requires: glib2-devel >= %{glib_ver}
8aa3dace 115
116%description devel
117Development resources for mono.
118
a86cd9c8 119%description devel -l pl.UTF-8
18ff84b2
MM
120Zasoby programisty dla mono.
121
5dab3216 122%package debug
123Summary: Mono libraries debugging resources
d1081961 124Summary(pl.UTF-8): Pliki umożliwiające debugowanie bibliotek mono
5dab3216 125Group: Development/Libraries
126Requires: %{name} = %{version}-%{release}
127
128%description debug
129Mono libraries debugging resources.
130
a86cd9c8
JR
131%description debug -l pl.UTF-8
132Pliki umożliwiające debugowanie bibliotek mono.
5dab3216 133
18ff84b2
MM
134%package csharp
135Summary: C# compiler for mono
d1081961 136Summary(pl.UTF-8): Kompilator C# dla mono
5114c445 137License: GPL
18ff84b2 138Group: Development/Languages
76e7cb31 139Requires: %{name}-devel = %{version}-%{release}
18ff84b2
MM
140
141%description csharp
142C# compiler for mono.
143
a86cd9c8 144%description csharp -l pl.UTF-8
18ff84b2
MM
145Kompilator C# dla mono.
146
147%package ilasm
148Summary: ILasm compiler for mono
d1081961 149Summary(pl.UTF-8): Kompilator ILasm dla mono
5114c445
JB
150# implied
151License: MIT X11
18ff84b2 152Group: Development/Languages
76e7cb31 153Requires: %{name}-devel = %{version}-%{release}
6ec58c77 154Provides: ilasm
155Obsoletes: pnet-compiler-ilasm
18ff84b2
MM
156
157%description ilasm
158ILasm compiler for mono.
159
a86cd9c8 160%description ilasm -l pl.UTF-8
18ff84b2 161Kompilator ILasm dla mono.
71c7a580 162
245657c9
MM
163%package jscript
164Summary: jscript compiler for mono
d1081961 165Summary(pl.UTF-8): Kompilator jscript dla mono
5114c445 166License: MIT X11
245657c9
MM
167Group: Development/Languages
168Requires: %{name}-devel = %{version}-%{release}
169
170%description jscript
171jscript compiler for mono.
172
a86cd9c8 173%description jscript -l pl.UTF-8
245657c9
MM
174Kompilator jscript dla mono.
175
e9945d9e 176%package monodoc
177Summary: Documentation for Mono class libraries and tools to produce and edit the documentation
178Summary(pl.UTF-8): Dokumentacja klas Mono wraz z narzędziami do jej generowania i przeglądania
179License: LGPL
180Group: Development/Libraries
181Requires: %{name}-devel = %{version}-%{release}
9bfc17bb 182Provides: monodoc = %{version}-%{release}
e9945d9e 183Obsoletes: monodoc
184
185%description monodoc
186This package contains the documentation for the Mono class libraries,
187tools to produce and edit the documentation, and a documentation
188browser.
189
190%description monodoc -l pl.UTF-8
191Ten pakiet zawiera dokumentację klas Mono wraz z narzędziami do jej
192generowania i przeglądania.
193
8aa3dace 194%package static
195Summary: Static mono library
d1081961 196Summary(pl.UTF-8): Statyczna biblioteka mono
5114c445 197License: LGPL
8aa3dace 198Group: Development/Libraries
76e7cb31 199Requires: %{name}-devel = %{version}-%{release}
8aa3dace 200
201%description static
202Static mono library.
203
a86cd9c8 204%description static -l pl.UTF-8
71c7a580
JB
205Statyczna biblioteka mono.
206
ea0e88d4
MM
207%package jay
208Summary: Yacc-like parser generator for Java and C#
d1081961 209Summary(pl.UTF-8): Podobny do Yacca generator parserów dla Javy i C#
5114c445 210License: BSD
ea0e88d4
MM
211Group: Development/Tools
212
213%description jay
214Yacc-like parser generator for Java and C#.
215
a86cd9c8
JR
216%description jay -l pl.UTF-8
217Podobny do Yacca generator parserów dla Javy i C#.
ea0e88d4 218
f327d485
MM
219%package compat-links
220Summary: Mono compatibility links
d1081961 221Summary(pl.UTF-8): Dowiązania dla kompatybilności
5114c445
JB
222# resgen license
223License: MIT X11
f327d485
MM
224Group: Development/Languages
225Requires: %{name}-devel = %{version}-%{release}
226
227%description compat-links
228This package contains links to binaries with names used in .NET and
229dotGNU.
230
a86cd9c8
JR
231%description compat-links -l pl.UTF-8
232Pakiet ten zawiera dowiązania do programów o nazwach używanych w .NET
f327d485
MM
233oraz dotGNU.
234
728c2265 235%prep
245657c9 236%setup -q
ddb02eae 237%patch0 -p1
24b388af 238%patch1 -p1
b3bdc9af 239%patch2 -p1
3cdc32b9 240%patch3 -p1
4a893061 241%patch4 -p1
ca59b162 242#%patch5 -p1
0f6bc6e4 243%patch6 -p1
e9945d9e 244%patch7 -p1
394cba3f 245
5114c445
JB
246# for jay
247cat >>mcs/build/config-default.make <<EOF
248CC = %{__cc}
249CFLAGS = %{rpmcflags}
250EOF
251
728c2265 252%build
7f02b7bf
JB
253cp -f /usr/share/automake/config.sub .
254cp -f /usr/share/automake/config.sub libgc
18ff84b2
MM
255%{__libtoolize}
256%{__aclocal}
245657c9 257%{__autoheader}
18ff84b2
MM
258%{__autoconf}
259%{__automake}
245657c9
MM
260cd libgc
261%{__libtoolize}
262%{__aclocal}
263%{__autoconf}
264%{__automake}
265cd ..
266
5114c445
JB
267# -DUSE_COMPILER_TLS is passed to libgc by main configure, but our
268# CPPFLAGS override that CPPFLAGS
269CPPFLAGS="-DUSE_LIBC_PRIVATE_SYMBOLS -DUSE_COMPILER_TLS"
0eeed8fb 270%configure \
f1c5438d 271 %{!?with_static_libs:--disable-static} \
91164168 272 --enable-fast-install \
f1c5438d 273 --with-gc=included \
245657c9 274 --with-icu=no \
f1c5438d
JB
275 --with-interp=%{?with_mint:yes}%{!?with_mint:no} \
276 --with-jit=%{?with_mint:no}%{!?with_mint:yes} \
277 --with-preview=yes \
fef1a4c5 278 --with-tls=%{?with_tls:__thread}%{!?with_tls:pthread}
0eeed8fb 279
a317f685
JB
280# mint uses heap to make trampolines, which need to be executable
281# there is mprotect(...,PROT_EXEC) for ppc/s390, but not used
282# (ifdef NEED_MPROTECT, which is never defined)
283# in fact the flag should be "-Wl,-z,execheap" for libmint, but:
284# -z execheap doesn't seem to do anything currently
285# -z execstack for library makes only stack executable, but not heap
24b469a9 286%{__make} -j1 \
a317f685 287 mint_LDFLAGS="-Wl,-z,execheap -Wl,-z,execstack"
728c2265
AM
288
289%install
290rm -rf $RPM_BUILD_ROOT
ad29385a 291install -d $RPM_BUILD_ROOT%{_rpmlibdir}
728c2265 292
24b469a9 293%{__make} -j1 install \
866e5301 294 DESTDIR=$RPM_BUILD_ROOT
b11f008f 295
65a9c4dc 296strip --strip-debug $RPM_BUILD_ROOT%{_bindir}/mono
297
ea0e88d4 298rm -f $RPM_BUILD_ROOT%{_datadir}/jay/[A-Z]*
728c2265 299
18ff84b2
MM
300# this way we can run rpmbuild -bi several times, and directories
301# have more meaningful name.
302rm -rf pld-doc
e6c59841 303install -d pld-doc/{webpage,notes}
5385129f 304cp -a web/* pld-doc/webpage
03ad8b19 305cp -a docs/* pld-doc/notes
18ff84b2 306rm -f pld-doc/*/Makefile*
728c2265 307
245657c9
MM
308rm -rf $RPM_BUILD_ROOT%{_datadir}/libgc-mono
309
5114c445
JB
310mv -f $RPM_BUILD_ROOT%{_bindir}/mono-find-* $RPM_BUILD_ROOT%{_rpmlibdir}
311
312# loadable modules
94b2d9a7
ER
313rm $RPM_BUILD_ROOT%{_libdir}/lib{MonoPosixHelper,MonoSupportW,ikvm-native}.la
314%if %{with static_libs}
315rm $RPM_BUILD_ROOT%{_libdir}/lib{MonoPosixHelper,MonoSupportW,ikvm-native}.a
316%endif
ad29385a 317
728c2265
AM
318%clean
319rm -rf $RPM_BUILD_ROOT
320
71c7a580
JB
321%post -p /sbin/ldconfig
322%postun -p /sbin/ldconfig
323
728c2265
AM
324%files
325%defattr(644,root,root,755)
4ffe85ea 326%doc AUTHORS ChangeLog NEWS README pld-doc/*
f1c5438d 327%if %{with mint}
245657c9 328%attr(755,root,root) %{_bindir}/mint
f1c5438d
JB
329%else
330%attr(755,root,root) %{_bindir}/mono
48941467 331%endif
840f8203 332%attr(755,root,root) %{_bindir}/caspol
5114c445
JB
333%attr(755,root,root) %{_bindir}/cert2spc
334%attr(755,root,root) %{_bindir}/certmgr
335%attr(755,root,root) %{_bindir}/chktrust
48cd6fab 336%attr(755,root,root) %{_bindir}/dtd2rng
e6c59841 337%attr(755,root,root) %{_bindir}/gacutil1
5114c445 338%attr(755,root,root) %{_bindir}/gacutil
7b0dd1f7 339%attr(755,root,root) %{_bindir}/gacutil2
4f35821b 340%attr(755,root,root) %{_bindir}/httpcfg
341%attr(755,root,root) %{_bindir}/installvst
5114c445
JB
342%attr(755,root,root) %{_bindir}/makecert
343%attr(755,root,root) %{_bindir}/mconfig
344%attr(755,root,root) %{_bindir}/mkbundle
7b0dd1f7 345%attr(755,root,root) %{_bindir}/mkbundle1
5114c445 346%attr(755,root,root) %{_bindir}/mkbundle2
840f8203 347%attr(755,root,root) %{_bindir}/mono-service
48cd6fab 348%attr(755,root,root) %{_bindir}/mono-service2
f3b0e346 349%attr(755,root,root) %{_bindir}/mono-test-install
48cd6fab 350%attr(755,root,root) %{_bindir}/mono-xmltool
840f8203 351%attr(755,root,root) %{_bindir}/mozroots
5114c445
JB
352%attr(755,root,root) %{_bindir}/secutil
353%attr(755,root,root) %{_bindir}/setreg
8ef557a4 354%attr(755,root,root) %{_bindir}/sgen
5114c445
JB
355%attr(755,root,root) %{_bindir}/signcode
356%attr(755,root,root) %{_bindir}/sn
357%if %{with mint}
358%attr(755,root,root) %{_libdir}/libmint.so.*.*.*
359%attr(755,root,root) %ghost %{_libdir}/libmint.so.0
360%else
361%attr(755,root,root) %{_libdir}/libmono.so.*.*.*
362%attr(755,root,root) %ghost %{_libdir}/libmono.so.0
363%attr(755,root,root) %{_libdir}/libmono-profiler-aot.so.*.*.*
364%attr(755,root,root) %ghost %{_libdir}/libmono-profiler-aot.so.0
365%attr(755,root,root) %{_libdir}/libmono-profiler-cov.so.*.*.*
366%attr(755,root,root) %ghost %{_libdir}/libmono-profiler-cov.so.0
7b0dd1f7 367%attr(755,root,root) %{_libdir}/libmono-profiler-logging.so.*.*.*
368%attr(755,root,root) %ghost %{_libdir}/libmono-profiler-logging.so.0
5114c445 369%endif
2c1ff86a 370%attr(755,root,root) %{_libdir}/libMonoPosixHelper.so
ff3439a4 371%attr(755,root,root) %{_libdir}/libMonoSupportW.so
2c1ff86a 372%attr(755,root,root) %{_libdir}/libikvm-native.so
f1c5438d
JB
373%dir %{_prefix}/lib/mono
374%dir %{_prefix}/lib/mono/1.0
5114c445
JB
375%{_prefix}/lib/mono/1.0/*.dll
376%attr(755,root,root) %{_prefix}/lib/mono/1.0/caspol.exe
377%attr(755,root,root) %{_prefix}/lib/mono/1.0/cert2spc.exe
378%attr(755,root,root) %{_prefix}/lib/mono/1.0/certmgr.exe
379%attr(755,root,root) %{_prefix}/lib/mono/1.0/chktrust.exe
380%attr(755,root,root) %{_prefix}/lib/mono/1.0/culevel.exe
381%attr(755,root,root) %{_prefix}/lib/mono/1.0/gacutil.exe
f3b0e346 382%attr(755,root,root) %{_prefix}/lib/mono/1.0/installutil.exe
5114c445
JB
383%attr(755,root,root) %{_prefix}/lib/mono/1.0/installvst.exe
384%attr(755,root,root) %{_prefix}/lib/mono/1.0/mkbundle.exe
385%attr(755,root,root) %{_prefix}/lib/mono/1.0/mono-service.exe
386%attr(755,root,root) %{_prefix}/lib/mono/1.0/mozroots.exe
387%attr(755,root,root) %{_prefix}/lib/mono/1.0/secutil.exe
388%attr(755,root,root) %{_prefix}/lib/mono/1.0/setreg.exe
389%attr(755,root,root) %{_prefix}/lib/mono/1.0/signcode.exe
390%attr(755,root,root) %{_prefix}/lib/mono/1.0/sn.exe
f1c5438d 391%dir %{_prefix}/lib/mono/2.0
5114c445 392%{_prefix}/lib/mono/2.0/*.dll
7b0dd1f7 393%attr(755,root,root) %{_prefix}/lib/mono/2.0/gacutil.exe
5114c445 394%attr(755,root,root) %{_prefix}/lib/mono/2.0/httpcfg.exe
f3b0e346 395%attr(755,root,root) %{_prefix}/lib/mono/2.0/installutil.exe
5114c445
JB
396%attr(755,root,root) %{_prefix}/lib/mono/2.0/mconfig.exe
397%attr(755,root,root) %{_prefix}/lib/mono/2.0/mkbundle.exe
398%attr(755,root,root) %{_prefix}/lib/mono/2.0/mono-service.exe
399%attr(755,root,root) %{_prefix}/lib/mono/2.0/sgen.exe
7b0dd1f7 400%attr(755,root,root) %{_prefix}/lib/mono/2.0/xsd.exe
f3b0e346 401%dir %{_prefix}/lib/mono/2.1
402%{_prefix}/lib/mono/2.1/*.dll
403%attr(755,root,root) %{_prefix}/lib/mono/2.1/smcs.exe
404%dir %{_prefix}/lib/mono/3.5
405%{_prefix}/lib/mono/3.5/*.dll
6d20487b 406%dir %{_prefix}/lib/mono/compat-1.0
5114c445 407%{_prefix}/lib/mono/compat-1.0/*.dll
6d20487b 408%dir %{_prefix}/lib/mono/compat-2.0
5114c445 409%{_prefix}/lib/mono/compat-2.0/*.dll
f1c5438d 410%{_prefix}/lib/mono/gac
5dab3216 411%exclude %{_prefix}/lib/mono/gac/*/*/*.mdb
5114c445
JB
412%{_mandir}/man1/cert2spc.1*
413%{_mandir}/man1/certmgr.1*
245657c9
MM
414%{_mandir}/man1/chktrust.1*
415%{_mandir}/man1/gacutil.1*
4a893061 416%{_mandir}/man1/httpcfg.1*
5385129f 417%{_mandir}/man1/makecert.1*
5114c445 418%{_mandir}/man1/mconfig.1*
245657c9
MM
419%{_mandir}/man1/mkbundle.1*
420%{_mandir}/man1/mint.1*
421%{_mandir}/man1/mono.1*
422%{_mandir}/man1/mono-service.1*
840f8203 423%{_mandir}/man1/mozroots.1*
5385129f 424%{_mandir}/man1/secutil.1*
5385129f 425%{_mandir}/man1/setreg.1*
8ef557a4 426%{_mandir}/man1/sgen.1*
245657c9
MM
427%{_mandir}/man1/signcode.1*
428%{_mandir}/man1/sn.1*
245657c9 429%{_mandir}/man5/mono-config.5*
fdd46781 430%dir %{_sysconfdir}/mono
f1c5438d 431%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/browscap.ini
f3b0e346 432%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/config
5114c445
JB
433%dir %{_sysconfdir}/mono/mconfig
434%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/mconfig/config.xml
245657c9 435%dir %{_sysconfdir}/mono/1.0
f1c5438d 436%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/1.0/DefaultWsdlHelpGenerator.aspx
f3b0e346 437%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/1.0/machine.config
245657c9 438%dir %{_sysconfdir}/mono/2.0
f1c5438d 439%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/DefaultWsdlHelpGenerator.aspx
f3b0e346 440%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/machine.config
441%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/settings.map
48cd6fab 442%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/web.config
7b0dd1f7 443%dir %{_sysconfdir}/mono/2.0/Browsers
444%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mono/2.0/Browsers/Compat.browser
8aa3dace 445
9f4cf2f1 446%exclude %{_prefix}/lib/mono/gac/Microsoft.JScript
447%exclude %{_prefix}/lib/mono/1.0/Microsoft.JScript.dll
448%exclude %{_prefix}/lib/mono/2.0/Microsoft.JScript.dll
504c4464 449%exclude %{_prefix}/lib/mono/gac/monodoc
9f4cf2f1 450
ea0e88d4
MM
451%files jay
452%defattr(644,root,root,755)
245657c9 453%doc mcs/jay/{ACKNOWLEDGEMENTS,ChangeLog,NEW_FEATURES,NOTES,README,README.jay}
ea0e88d4
MM
454%attr(755,root,root) %{_bindir}/jay
455%dir %{_datadir}/jay
456%{_datadir}/jay/skeleton*
457%{_mandir}/man1/jay.1*
458
245657c9
MM
459%files jscript
460%defattr(644,root,root,755)
461%attr(755,root,root) %{_bindir}/mjs
5114c445 462%attr(755,root,root) %{_prefix}/lib/mono/1.0/mjs.exe
9f4cf2f1 463%{_prefix}/lib/mono/gac/Microsoft.JScript
464%{_prefix}/lib/mono/1.0/Microsoft.JScript.dll
465%{_prefix}/lib/mono/2.0/Microsoft.JScript.dll
5dab3216 466%exclude %{_prefix}/lib/mono/gac/*/*/*.mdb
245657c9 467
f327d485
MM
468%files compat-links
469%defattr(644,root,root,755)
470%attr(755,root,root) %{_bindir}/resgen
7b0dd1f7 471%attr(755,root,root) %{_bindir}/resgen1
3d1af25b 472%attr(755,root,root) %{_bindir}/resgen2
f327d485 473
8aa3dace 474%files devel
475%defattr(644,root,root,755)
5114c445 476%attr(755,root,root) %{_bindir}/al
7b0dd1f7 477%attr(755,root,root) %{_bindir}/al1
5114c445
JB
478%attr(755,root,root) %{_bindir}/al2
479%attr(755,root,root) %{_bindir}/cilc
480%attr(755,root,root) %{_bindir}/disco
994ec6f9 481%attr(755,root,root) %{_bindir}/dtd2xsd
5114c445 482%attr(755,root,root) %{_bindir}/genxs
7b0dd1f7 483%attr(755,root,root) %{_bindir}/genxs1
994ec6f9 484%attr(755,root,root) %{_bindir}/macpack
39d58cda 485%attr(755,root,root) %{_bindir}/mono-api-info
e6c59841 486%attr(755,root,root) %{_bindir}/mono-cil-strip
245657c9 487%attr(755,root,root) %{_bindir}/monodis
2affc12a 488%attr(755,root,root) %{_bindir}/monograph
613285b2 489%attr(755,root,root) %{_bindir}/monolinker
5114c445 490%attr(755,root,root) %{_bindir}/monop
7b0dd1f7 491%attr(755,root,root) %{_bindir}/monop1
5114c445
JB
492%attr(755,root,root) %{_bindir}/monop2
493%attr(755,root,root) %{_bindir}/mono-shlib-cop
ff3439a4 494%attr(755,root,root) %{_bindir}/nunit-console
48cd6fab 495%attr(755,root,root) %{_bindir}/nunit-console2
18ff84b2 496%attr(755,root,root) %{_bindir}/pedump
994ec6f9 497%attr(755,root,root) %{_bindir}/permview
498%attr(755,root,root) %{_bindir}/prj2make
613285b2 499%attr(755,root,root) %{_bindir}/smcs
5114c445
JB
500%attr(755,root,root) %{_bindir}/soapsuds
501%attr(755,root,root) %{_bindir}/sqlsharp
502%attr(755,root,root) %{_bindir}/wsdl
7b0dd1f7 503%attr(755,root,root) %{_bindir}/wsdl1
5114c445 504%attr(755,root,root) %{_bindir}/wsdl2
4ffe85ea 505%attr(755,root,root) %{_bindir}/xbuild
5114c445 506%attr(755,root,root) %{_bindir}/xsd
7b0dd1f7 507%attr(755,root,root) %{_bindir}/xsd2
f1c5438d
JB
508%if %{with mint}
509%attr(755,root,root) %{_libdir}/libmint.so
5114c445 510%{_libdir}/libmint.la
f1c5438d 511%else
2c1ff86a 512%attr(755,root,root) %{_libdir}/libmono.so
5114c445 513%attr(755,root,root) %{_libdir}/libmono-profiler-aot.so
2c1ff86a 514%attr(755,root,root) %{_libdir}/libmono-profiler-cov.so
7b0dd1f7 515%attr(755,root,root) %{_libdir}/libmono-profiler-logging.so
5114c445
JB
516%{_libdir}/libmono.la
517%{_libdir}/libmono-profiler-aot.la
518%{_libdir}/libmono-profiler-cov.la
7b0dd1f7 519%{_libdir}/libmono-profiler-logging.la
f1c5438d 520%endif
5114c445
JB
521%attr(755,root,root) %{_prefix}/lib/mono/1.0/al.exe
522%attr(755,root,root) %{_prefix}/lib/mono/1.0/browsercaps-updater.exe
523%attr(755,root,root) %{_prefix}/lib/mono/1.0/cilc.exe
524%attr(755,root,root) %{_prefix}/lib/mono/1.0/disco.exe
525%attr(755,root,root) %{_prefix}/lib/mono/1.0/dtd2rng.exe
526%attr(755,root,root) %{_prefix}/lib/mono/1.0/dtd2xsd.exe
527%attr(755,root,root) %{_prefix}/lib/mono/1.0/genxs.exe
528%attr(755,root,root) %{_prefix}/lib/mono/1.0/ictool.exe
529%attr(755,root,root) %{_prefix}/lib/mono/1.0/macpack.exe
530%attr(755,root,root) %{_prefix}/lib/mono/1.0/makecert.exe
e6c59841 531%attr(755,root,root) %{_prefix}/lib/mono/1.0/mono-cil-strip.exe
5114c445
JB
532%attr(755,root,root) %{_prefix}/lib/mono/1.0/mono-xmltool.exe
533%attr(755,root,root) %{_prefix}/lib/mono/1.0/monolinker.exe
534%attr(755,root,root) %{_prefix}/lib/mono/1.0/monop.exe
535%attr(755,root,root) %{_prefix}/lib/mono/1.0/nunit-console.exe
536%{_prefix}/lib/mono/1.0/nunit-console.exe.config
537%attr(755,root,root) %{_prefix}/lib/mono/1.0/permview.exe
538%attr(755,root,root) %{_prefix}/lib/mono/1.0/prj2make.exe
539%attr(755,root,root) %{_prefix}/lib/mono/1.0/resgen.exe
540%attr(755,root,root) %{_prefix}/lib/mono/1.0/soapsuds.exe
5114c445
JB
541%attr(755,root,root) %{_prefix}/lib/mono/1.0/wsdl.exe
542%attr(755,root,root) %{_prefix}/lib/mono/1.0/xsd.exe
543%attr(755,root,root) %{_prefix}/lib/mono/2.0/al.exe
544%attr(755,root,root) %{_prefix}/lib/mono/2.0/mono-api-info.exe
e6c59841 545%attr(755,root,root) %{_prefix}/lib/mono/2.0/mono-shlib-cop.exe
546%{_prefix}/lib/mono/2.0/mono-shlib-cop.exe.config
5114c445
JB
547%attr(755,root,root) %{_prefix}/lib/mono/2.0/monop.exe
548%attr(755,root,root) %{_prefix}/lib/mono/2.0/nunit-console.exe
549%{_prefix}/lib/mono/2.0/nunit-console.exe.config
550%attr(755,root,root) %{_prefix}/lib/mono/2.0/resgen.exe
e6c59841 551%attr(755,root,root) %{_prefix}/lib/mono/2.0/sqlsharp.exe
5114c445
JB
552%attr(755,root,root) %{_prefix}/lib/mono/2.0/wsdl.exe
553%attr(755,root,root) %{_prefix}/lib/mono/2.0/xbuild.exe
554%{_prefix}/lib/mono/2.0/xbuild.rsp
4a893061 555%{_prefix}/lib/mono/2.0/MSBuild
5114c445
JB
556%{_prefix}/lib/mono/2.0/Microsoft.Build.xsd
557%{_prefix}/lib/mono/2.0/Microsoft.CSharp.targets
558%{_prefix}/lib/mono/2.0/Microsoft.Common.targets
559%{_prefix}/lib/mono/2.0/Microsoft.VisualBasic.targets
560%{_prefix}/lib/mono/2.0/Microsoft.Common.tasks
561%attr(755,root,root) %{_rpmlibdir}/mono-find-provides
562%attr(755,root,root) %{_rpmlibdir}/mono-find-requires
4a893061 563%{_datadir}/%{name}-1.0
5114c445
JB
564%{_pkgconfigdir}/cecil.pc
565%{_pkgconfigdir}/dotnet.pc
7b0dd1f7 566%{_pkgconfigdir}/dotnet35.pc
5114c445
JB
567%{_pkgconfigdir}/mono-cairo.pc
568%{_pkgconfigdir}/mono-nunit.pc
569%if %{with mint}
570%{_pkgconfigdir}/mint.pc
571%else
572%{_pkgconfigdir}/mono.pc
573%endif
7b0dd1f7 574%{_pkgconfigdir}/smcs.pc
4a893061 575%{_includedir}/%{name}-1.0
ff3439a4 576%{_mandir}/man1/al.1*
c8f3b110 577%{_mandir}/man1/cilc.1*
994ec6f9 578%{_mandir}/man1/disco.1*
579%{_mandir}/man1/dtd2xsd.1*
e0aee78b 580%{_mandir}/man1/genxs.1*
994ec6f9 581%{_mandir}/man1/macpack.1*
2affc12a 582%{_mandir}/man1/monodis.1*
613285b2 583%{_mandir}/man1/monolinker.1*
994ec6f9 584%{_mandir}/man1/monop.1*
e9945d9e 585%{_mandir}/man1/mono-cil-strip.1*
994ec6f9 586%{_mandir}/man1/mono-shlib-cop.1*
2affc12a 587%{_mandir}/man1/monostyle.1*
613285b2 588%{_mandir}/man1/mono-xmltool.1*
994ec6f9 589%{_mandir}/man1/oldmono.1*
5114c445 590%{_mandir}/man1/permview.1*
994ec6f9 591%{_mandir}/man1/prj2make.1*
613285b2 592%{_mandir}/man1/resgen.1*
994ec6f9 593%{_mandir}/man1/soapsuds.1*
18ff84b2 594%{_mandir}/man1/sqlsharp.1*
ff112d9b 595%{_mandir}/man1/wsdl.1*
a66172db 596%{_mandir}/man1/xsd.1*
18ff84b2 597
b6aa60a1
JB
598%files debug
599%defattr(644,root,root,755)
600%{_prefix}/lib/mono/1.0/*.mdb
601%{_prefix}/lib/mono/2.0/*.mdb
f3b0e346 602%{_prefix}/lib/mono/2.1/*.mdb
b6aa60a1
JB
603%{_prefix}/lib/mono/gac/*/*/*.mdb
604
18ff84b2 605%files csharp
609883c4 606%defattr(644,root,root,755)
e6c59841 607%attr(755,root,root) %{_bindir}/csharp
a66172db 608%attr(755,root,root) %{_bindir}/mcs
7b0dd1f7 609%attr(755,root,root) %{_bindir}/mcs1
a66172db 610%attr(755,root,root) %{_bindir}/gmcs
5114c445
JB
611%attr(755,root,root) %{_prefix}/lib/mono/1.0/mcs.exe
612%{_prefix}/lib/mono/1.0/mcs.exe.config
613%attr(755,root,root) %{_prefix}/lib/mono/2.0/gmcs.exe
614%{_prefix}/lib/mono/2.0/gmcs.exe.config
e6c59841 615%attr(755,root,root) %{_prefix}/lib/mono/2.0/csharp.exe
18ff84b2 616%{_mandir}/man1/mcs.1*
e6c59841 617%{_mandir}/man1/csharp.1*
18ff84b2 618
18ff84b2 619%files ilasm
609883c4 620%defattr(644,root,root,755)
5114c445 621%attr(755,root,root) %{_bindir}/ilasm
7b0dd1f7 622%attr(755,root,root) %{_bindir}/ilasm1
5114c445
JB
623%attr(755,root,root) %{_bindir}/ilasm2
624%attr(755,root,root) %{_prefix}/lib/mono/1.0/ilasm.exe
625%attr(755,root,root) %{_prefix}/lib/mono/2.0/ilasm.exe
c8f3b110 626%{_mandir}/man1/ilasm.1*
8aa3dace 627
e9945d9e 628%files monodoc
629%defattr(644,root,root,755)
630%attr(755,root,root) %{_bindir}/mdassembler
631%attr(755,root,root) %{_bindir}/mdoc*
632%attr(755,root,root) %{_bindir}/mod
633%attr(755,root,root) %{_bindir}/monodocer
634%attr(755,root,root) %{_bindir}/monodocs2html
635%attr(755,root,root) %{_bindir}/monodocs2slashdoc
636%attr(755,root,root) %{_bindir}/mdvalidater
7bad922f 637%attr(755,root,root) %{_prefix}/lib/mono/1.0/mod.exe
638%attr(755,root,root) %{_prefix}/lib/mono/2.0/mdoc.exe
e65b976c 639%attr(755,root,root) %{_prefix}/lib/mono/monodoc/monodoc.dll
e9945d9e 640%{_prefix}/lib/mono/gac/monodoc
7bad922f 641%dir %{_prefix}/lib/mono/monodoc
fa67b165 642%dir %{_prefix}/lib/monodoc
7bad922f 643%{_prefix}/lib/monodoc/*
e9945d9e 644%{_pkgconfigdir}/monodoc.pc
645%{_mandir}/man1/mdassembler.1*
646%{_mandir}/man1/mdoc*.1*
647%{_mandir}/man1/monodocer.1*
648%{_mandir}/man1/monodocs2html.1*
649%{_mandir}/man1/mdvalidater.1*
650%{_mandir}/man5/mdoc.5*
651
4d9455d0 652%if %{with static_libs}
8aa3dace 653%files static
654%defattr(644,root,root,755)
5114c445
JB
655%if %{with mint}
656%{_libdir}/libmint.a
657%else
658%{_libdir}/libmono.a
659%{_libdir}/libmono-profiler-aot.a
660%{_libdir}/libmono-profiler-cov.a
7b0dd1f7 661%{_libdir}/libmono-profiler-logging.a
5114c445 662%endif
4d9455d0 663%endif
This page took 0.216813 seconds and 4 git commands to generate.