]> git.pld-linux.org Git - packages/mksh.git/commitdiff
- turns out there is a option for skipping tty-using tests, so no need for awk
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 7 Jul 2011 21:05:36 +0000 (21:05 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    mksh.spec -> 1.25

mksh.spec

index 42e1ffaafcecd122d7d81110f8ce73def3f98b59..0a3210ef4da3c7184e3167d20b0f8f31d392f195 100644 (file)
--- a/mksh.spec
+++ b/mksh.spec
@@ -97,14 +97,10 @@ sh ./Build.sh -Q -r -j
 
 # skip some tests if not on terminal
 if ! tty -s; then
-do_tests=$(awk '
-/^---/ { if (need_ctty == 0) { print name; }; need_ctty=0; }
-/^name:/ { name=$2; }
-/^need-ctty:/ { need_ctty=1; }
-' check.t)
+       skip_tests="-C regress:no-ctty"
 fi
 
-%{?with_tests:./test.sh -v $do_tests}
+%{?with_tests:./test.sh -v $skip_tests}
 mv mksh out/mksh.dynamic
 
 %if %{with static}
@@ -113,7 +109,7 @@ CFLAGS="%{rpmcppflags} %{rpmcflags}" \
 LDFLAGS="%{rpmldflags} -static" \
 sh ./Build.sh -Q -r -j
 
-%{?with_tests:./test.sh -v $do_tests}
+%{?with_tests:./test.sh -v $skip_tests}
 mv mksh out/mksh.static
 %endif
 
This page took 0.13093 seconds and 4 git commands to generate.