]> git.pld-linux.org Git - packages/mksh.git/blobdiff - mksh.spec
rel 3; drop builtin cat and sleep
[packages/mksh.git] / mksh.spec
index fca8e565c81f71b1bb1df2859eb3129a394fa632..2ee61f353b31269af4c1801e8ddb5518391ee5e1 100644 (file)
--- a/mksh.spec
+++ b/mksh.spec
@@ -4,19 +4,22 @@
 %bcond_without static  # static version of mksh
 %bcond_without tests   # rtchecks and test.sh checks
 
+%define                vernr   %(echo %{version} | tr -d 'a-z')
+
 Summary:       MirBSD Korn Shell
 Summary(pl.UTF-8):     Powłoka Korna z MirBSD
 Name:          mksh
-Version:       57
-Release:       1
+Version:       59c
+Release:       3
 License:       BSD
 Group:         Applications/Shells
 Source0:       https://www.mirbsd.org/MirOS/dist/mir/mksh/%{name}-R%{version}.tgz
-# Source0-md5: 4d2686535252ea6a57bdec531498239a
+# Source0-md5: 99f8ac3c1d8a30b913d509f1969a4aaa
 Source1:       %{name}-mkshrc
 Source2:       get-source.sh
 Patch0:                %{name}-mkshrc_support.patch
 Patch1:                %{name}-circumflex.patch
+Patch2:         drop-builtins.patch
 URL:           https://www.mirbsd.org/mksh.htm
 %if %{with tests}
 BuildRequires: ed
@@ -83,10 +86,13 @@ W tym pakiecie jest mksh skonsolidowany statycznie.
 
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
+
+sed -i -e 's|fgrep|grep -F|g' check.t
 
 # sed rules instead of patch (needed update for every release)
 sed -i -e 's|\(#define.*MKSH_VERSION.*\)"|\1 @DISTRO@"|g' sh.h
-sed -i -e 's|\(@(#)MIRBSD KSH.*\)|\1 @DISTRO@|g' check.t
+sed -i -e 's|\(KSH R%{vernr}.*\)|\1 @DISTRO@|g' check.t
 
 # fill distro
 sed -i -e 's#@DISTRO@#PLD/Linux 3.0#g' check.t sh.h
@@ -205,7 +211,7 @@ end
 %files
 %defattr(644,root,root,755)
 %doc dot.mkshrc
-%config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/mkshrc
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mkshrc
 %attr(755,root,root) %{_bindir}/mksh
 %attr(755,root,root) %{_bindir}/ksh
 %attr(755,root,root) %{_bindir}/sh
This page took 0.10044 seconds and 4 git commands to generate.