]> git.pld-linux.org Git - packages/mksh.git/blob - mksh.spec
- up to R40
[packages/mksh.git] / mksh.spec
1 %bcond_without  tests
2 Summary:        MirBSD Korn Shell
3 Summary(pl.UTF-8):      Powłoka Korna z MirBSD
4 Name:           mksh
5 Version:        40
6 Release:        0.1
7 License:        BSD
8 Group:          Applications/Shells
9 Source0:        http://www.mirbsd.org/MirOS/dist/mir/mksh/%{name}-R%{version}.cpio.gz
10 # Source0-md5:  395a6c5f39c7e2afd8f6504d90ca90bd
11 URL:            https://www.mirbsd.org/mksh.htm
12 %if %{with tests}
13 BuildRequires:  ed
14 BuildRequires:  perl-base
15 %endif
16 BuildRequires:  rpmbuild(macros) >= 1.462
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _bindir                 /bin
20
21 %description
22 mksh is the MirBSD enhanced version of the Public Domain Korn shell
23 (pdksh), a Bourne-compatible shell which is largely similar to the
24 original AT&T Korn shell. It includes bug fixes and feature
25 improvements in order to produce a modern, robust shell good for
26 interactive and especially script use. It has UTF-8 support in the
27 emacs command line editing mode; corresponds to OpenBSD 4.2-current
28 ksh sans GNU bash-like $PS1; the build environment requirements are
29 autoconfigured; throughout code simplification/bugfix/enhancement has
30 been done, and the shell has extended compatibility to other modern
31 shells.
32
33 %description -l pl.UTF-8
34 mksh to pochodząca z MirBSD rozszerzona wersja powłoki Public Domain
35 Korn Shell (pdksh) - kompatybilnej z powłoką Bourne'a, w większości
36 zbliżonej do oryginalnej powłoki Korna z AT&T. Zawiera poprawki błędów
37 i rozszerzenia mające na celu stworzenie współczesnej powłoki o
38 bogatych możliwościach do użytku interaktywnego i (zwłaszcza) w
39 skryptach. Ma obsługę UTF-8 w trybie edycji linii poleceń w stylu
40 emacsa; $PS1 odpowiada temu z ksh obecnym w OpenBSD 4.2-current;
41 środowisko budowania jest automatycznie konfigurowane; dzięki
42 wykonanym uproszczeniom kodu, poprawkom i rozszerzeniom powłoka ma
43 rozszerzoną kompatybilność z innymi współczesnymi powłokami.
44
45 %prep
46 %setup -qcT
47 gzip -dc %{SOURCE0} | cpio -mid
48 mv mksh/* .; rmdir mksh
49
50 %build
51 CC="%{__cc}" CFLAGS="%{rpmcppflags} %{rpmcflags}" sh ./Build.sh -Q -r -j
52
53 %{?with_tests:./test.sh -v}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
58 install -p mksh $RPM_BUILD_ROOT%{_bindir}/mksh
59 cp -a mksh.1 $RPM_BUILD_ROOT%{_mandir}/man1/mksh.1
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %post   -p <lua>
65 %lua_add_etc_shells %{_bindir}/mksh
66
67 %preun  -p <lua>
68 if arg[2] == 0 then
69         %lua_remove_etc_shells  %{_bindir}/mksh
70 end
71
72 %files
73 %defattr(644,root,root,755)
74 %doc dot.mkshrc
75 %attr(755,root,root) %{_bindir}/mksh
76 %{_mandir}/man1/mksh.1*
This page took 0.051529 seconds and 4 git commands to generate.