]> git.pld-linux.org Git - packages/llvm.git/blobdiff - llvm.spec
- fix building with latest glibc https://reviews.llvm.org/D35246
[packages/llvm.git] / llvm.spec
index b299c295e8ae6b8f743c1365aaf2ad612b0d8a5f..2e5359a25be636a7126b945f784e41031f0ebd02 100644 (file)
--- a/llvm.spec
+++ b/llvm.spec
@@ -4,52 +4,56 @@
 #      %{_datadir}/clang/clang-format.el - emacs mode
 #      %{_datadir}/clang/clang-format.py - vim plugin
 # - no content in doc package (it used to contain parts of clang apidocs and some examples)
+# - system isl in polly?
 #
 # Conditional build:
-%bcond_without lldb    # LLDB debugger
-%bcond_without polly   # Polly cache-locality optimization, auto-parallelism and vectorization
-%bcond_without rt      # compiler-rt libraries
-%bcond_without ocaml   # OCaml binding
-%bcond_without doc     # HTML docs and man pages
-%bcond_with    apidocs # doxygen docs (HUGE, so they are not built by default)
-%bcond_with    tests   # run tests
+%bcond_without lldb            # LLDB debugger
+%bcond_without polly           # Polly cache-locality optimization, auto-parallelism and vectorization
+%bcond_without rt              # compiler-rt libraries
+%bcond_without multilib        # compiler-rt multilib libraries
+%bcond_without ocaml           # OCaml binding
+%bcond_without doc             # HTML docs and man pages
+%bcond_with    apidocs         # doxygen docs (HUGE, so they are not built by default)
+%bcond_with    tests           # run tests
 
 # No ocaml on other arches or no native ocaml (required for ocaml-ctypes)
-%ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9 
+%ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
 %undefine      with_ocaml
 %endif
 
 Summary:       The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
 Summary(pl.UTF-8):     Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
 Name:          llvm
-Version:       3.7.0
-Release:       3
+Version:       3.9.1
+Release:       3.2
 License:       University of Illinois/NCSA Open Source License
 Group:         Development/Languages
 #Source0Download: http://llvm.org/releases/download.html
 Source0:       http://llvm.org/releases/%{version}/%{name}-%{version}.src.tar.xz
-# Source0-md5: b98b9495e5655a672d6cb83e1a180f8e
+# Source0-md5: 3259018a7437e157f3642df80f1983ea
 Source1:       http://llvm.org/releases/%{version}/cfe-%{version}.src.tar.xz
-# Source1-md5: 8f9d27335e7331cf0a4711e952f21f01
+# Source1-md5: 45713ec5c417ed9cad614cd283d786a1
 Source2:       http://llvm.org/releases/%{version}/compiler-rt-%{version}.src.tar.xz
-# Source2-md5: 383c10affd513026f08936b5525523f5
+# Source2-md5: aadc76e7e180fafb10fb729444e287a3
 Source3:       http://llvm.org/releases/%{version}/lldb-%{version}.src.tar.xz
-# Source3-md5: e5931740400d1dc3e7db4c7ba2ceff68
+# Source3-md5: 91399402f287d3f637db1207113deecb
 Source4:       http://llvm.org/releases/%{version}/polly-%{version}.src.tar.xz
-# Source4-md5: 32f93ffc9cc7e042df22089761558f8b
+# Source4-md5: 2cc7fe2bd9539775ba140abfd375bec6
 Source5:       http://llvm.org/releases/%{version}/clang-tools-extra-%{version}.src.tar.xz
-# Source5-md5: d5a87dacb65d981a427a536f6964642e
+# Source5-md5: 1a01d545a064fcbc46a2f05f6880d3d7
 Source6:       http://llvm.org/releases/%{version}/lld-%{version}.src.tar.xz
-# Source6-md5: 91bd593a67293d84dad0bf11845546c2
+# Source6-md5: 6254dd138e23b098df4ef7840c11e2c8
 Patch0:                %{name}-lld-link.patch
 Patch1:                %{name}-pld.patch
 Patch2:                libdir.patch
 Patch3:                x32-gcc-toolchain.patch
-Patch5:                debuginfo-fix.patch
+Patch4:                cmake-buildtype.patch
+Patch5:                %{name}-ocaml-shared.patch
+Patch6:                D35246.diff
 URL:           http://llvm.org/
 BuildRequires: bash
 BuildRequires: bison
-BuildRequires: cmake
+BuildRequires: cmake >= 3.4.3
 BuildRequires: flex
 BuildRequires: gcc >= 5:3.4
 # gcc4 might be installed, but not current __cc
@@ -60,8 +64,10 @@ BuildRequires:       __cc >= 3.4
 BuildRequires: glibc-devel(x86_64)
 %endif
 BuildRequires: groff
+BuildRequires: libedit-devel
 BuildRequires: libltdl-devel
 BuildRequires: libstdc++-devel >= 5:3.4
+BuildRequires: ncurses-devel
 %if %{with ocaml}
 BuildRequires: ocaml-ctypes-devel >= 0.4
 BuildRequires: ocaml-findlib
@@ -70,39 +76,50 @@ BuildRequires:      ocaml-ounit
 %endif
 BuildRequires: perl-base >= 1:5.6
 BuildRequires: perl-tools-pod
+BuildRequires: python >= 1:2.7
 BuildRequires: rpm-pythonprov
 %{?with_doc:BuildRequires:     sphinx-pdg}
 BuildRequires: tar >= 1:1.22
 BuildRequires: xz
+BuildRequires: zlib-devel
 %if %{with apidocs}
 BuildRequires: doxygen
 BuildRequires: graphviz
 %endif
 %if %{with tests}
 BuildRequires: dejagnu
-BuildRequires: python
 BuildRequires: tcl-devel
 %endif
+%if %{with rt} && %{with multilib}
+%ifarch %{x8664}
+BuildRequires: gcc-c++-multilib-32
+BuildRequires: libstdc++-multilib-32-devel
+%endif
+%ifarch x32
+BuildRequires: gcc-c++-multilib-32
+BuildRequires: libstdc++-multilib-32-devel
+BuildRequires: gcc-c++-multilib-64
+BuildRequires: libstdc++-multilib-64-devel
+%endif
+%endif
 %if %{with lldb}
 BuildRequires: epydoc
 %ifarch i386 i486
 BuildRequires: libatomic-devel
 %endif
-BuildRequires: libedit-devel
 BuildRequires: libxml2-devel >= 2
 BuildRequires: ncurses-ext-devel
 BuildRequires: python-devel >= 2
 BuildRequires: swig-python
 %endif
 %if %{with polly}
-BuildRequires: cloog-isl-devel
-# >= 0.18.2-2
-BuildRequires: gmp-devel
-BuildRequires: isl-devel >= 0.14
-# optional
-BuildRequires: pluto-devel
-BuildRequires: scoplib-devel >= 0.2.1-2
-#cuda-devel
+#BuildRequires:        gmp-devel or imath-devel (private copy in polly/lib/External/isl/imath)
+# private copy in polly/lib/External/isl
+#BuildRequires:        isl-devel >= 0.17.1
+#TODO (bcond): cuda-devel (with POLLY_ENABLE_GPGPU_CODEGEN=ON)
+%endif
+%if %{with ocaml}
+BuildConflicts:        llvm-ocaml
 %endif
 Requires:      %{name}-libs = %{version}-%{release}
 # LLVM is not supported on PPC64
@@ -110,20 +127,26 @@ Requires: %{name}-libs = %{version}-%{release}
 ExcludeArch:   ppc64
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                abi     3.9
 %define                _sysconfdir     /etc/%{name}
 
 %define                specflags_ppc   -fno-var-tracking-assignments
+# ix86 and x32 - the same issue as https://llvm.org/bugs/show_bug.cgi?id=27237
+%define                specflags_ia32  -gsplit-dwarf
+%define                specflags_x32   -gsplit-dwarf
 
 # strip corrupts: $RPM_BUILD_ROOT/usr/lib64/llvm-gcc/bin/llvm-c++ ...
 %define                _noautostrip    .*/\\(libmud.*\\.a\\|bin/llvm-.*\\|lib.*++\\.a\\)
 
-# clang doesn't know it, and leaving it here would pollute llvm-config
+# clang doesn't know -fvar-tracking-assignments, and leaving it here would pollute llvm-config
+# -Werror=format-security is for swig
+# TODO: add - -Werror=format-security to tools/lldb/scripts/LLDBWrapPython.cpp
 %define                filterout_c     -fvar-tracking-assignments
-%define                filterout_cxx   -fvar-tracking-assignments
+%define                filterout_cxx   -fvar-tracking-assignments -Werror=format-security
 %define                filterout_ccpp  -fvar-tracking-assignments
 
 # std::__once_call, std::__once_callable non-function symbols
-%define                skip_post_check_so      liblldAArch64ELFTarget.so.* liblldARMELFTarget.so.* liblldHexagonELFTarget.so.* liblldMipsELFTarget.so.* liblldb.so.*
+%define                skip_post_check_so      liblldb.so.*
 
 %description
 LLVM is a compiler infrastructure designed for compile-time,
@@ -141,16 +164,16 @@ roku 2000 przez Uniwersytet w Illinois i Apple. Aktualnie obsługuje
 kompilację programów w C i C++ przy użyciu frontendu clang.
 
 %package libs
-Summary:       LLVM shared library
-Summary(pl.UTF-8):     Biblioteka współdzielona LLVM-a
+Summary:       LLVM shared libraries
+Summary(pl.UTF-8):     Biblioteki współdzielone LLVM-a
 Group:         Libraries
 Conflicts:     llvm < 3.2
 
 %description libs
-LLVM shared library.
+LLVM shared libraries.
 
 %description libs -l pl.UTF-8
-Biblioteka współdzielona LLVM-a.
+Biblioteki współdzielone LLVM-a.
 
 %package devel
 Summary:       Static libraries and header files for LLVM
@@ -231,6 +254,7 @@ Summary(pl.UTF-8):  Frontend LLVM-a do języków z rodziny C
 License:       NCSA
 Group:         Development/Languages
 Requires:      %{name} = %{version}-%{release}
+Requires:      clang-libs = %{version}-%{release}
 
 %description -n clang
 clang: noun 1. A loud, resonant, metallic sound. 2. The strident call
@@ -250,6 +274,17 @@ LLVM do języków C, C++, Objective C i Objective C++. Narzędzia są
 budowane jako biblioteki i zaprojektowane z myślą o swobodnym łączeniu
 i rozszerzaniu.
 
+%package -n clang-libs
+Summary:       Clang shared libraries
+Summary(pl.UTF-8):     Biblioteki współdzielone Clanga
+Group:         Libraries
+
+%description -n clang-libs
+Clang shared libraries.
+
+%description -n clang-libs -l pl.UTF-8
+Biblioteki współdzielone Clanga.
+
 %package -n clang-multilib
 Summary:       A C language family frontend for LLVM - 32-bit support
 Summary(pl.UTF-8):     Frontend LLVM-a do języków z rodziny C - obsługa binariów 32-bitowych
@@ -386,6 +421,7 @@ Summary(pl.UTF-8):  Wydajny debugger nowej generacji
 Group:         Development/Debuggers
 URL:           http://lldb.llvm.org/
 Requires:      %{name} = %{version}-%{release}
+Requires:      python-six
 
 %description -n lldb
 LLDB is a next generation, high-performance debugger. It is built as a
@@ -419,7 +455,9 @@ Summary:    OCaml binding for LLVM
 Summary(pl.UTF-8):     Wiązanie OCamla do LLVM-a
 Group:         Libraries
 Requires:      %{name} = %{version}-%{release}
+%if %{with ocaml}
 %requires_eq   ocaml-runtime
+%endif
 
 %description ocaml
 OCaml binding for LLVM.
@@ -456,18 +494,20 @@ Dokumentacja HTML wiązania OCamla do LLVM-a.
 
 %prep
 %setup -q -n %{name}-%{version}.src -a1 %{?with_rt:-a2} %{?with_lldb:-a3} %{?with_polly:-a4} -a5 -a6
-mv cfe-%{version}.src tools/clang
+%{__mv} cfe-%{version}.src tools/clang
 %{?with_rt:mv compiler-rt-%{version}.src projects/compiler-rt}
 %{?with_lldb:mv lldb-%{version}.src tools/lldb}
 %{?with_polly:mv polly-%{version}.src tools/polly}
-mv clang-tools-extra-%{version}.src tools/clang/tools/extra
-mv lld-%{version}.src tools/lld
+%{__mv} clang-tools-extra-%{version}.src tools/clang/tools/extra
+%{__mv} lld-%{version}.src tools/lld
 
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 %patch5 -p1
+%patch6 -p0
 
 grep -rl /usr/bin/env tools utils | xargs sed -i -e '1{
        s,^#!.*bin/env python,#!%{__python},
@@ -482,26 +522,30 @@ install -d build
 cd build
 CPPFLAGS="%{rpmcppflags} -D_FILE_OFFSET_BITS=64"
 
-%{cmake} ../ \
+%cmake \
 %ifarch %{x8664}
        -DLLVM_LIBDIR_SUFFIX:STRING=64 \
 %endif
 %ifarch x32
        -DLLVM_LIBDIR_SUFFIX:STRING=x32 \
 %endif
-%ifarch %{ix86}
-       -DLLVM_ENABLE_PIC:BOOL=OFF \
-%endif
 %if %{with apidocs}
        -DLLVM_ENABLE_DOXYGEN:BOOL=ON \
 %endif
 %if %{with doc}
        -DLLVM_ENABLE_SPHINX:BOOL=ON \
+       -DSPHINX_WARNINGS_AS_ERRORS=OFF \
 %endif
+       -DLLVM_ENABLE_PIC:BOOL=ON \
        -DLLVM_ENABLE_ASSERTIONS:BOOL=OFF \
        -DLLVM_ENABLE_CXX1Y:BOOL=ON \
        -DLLVM_BINDINGS_LIST:LIST="%{?with_ocaml:ocaml}" \
-       -DBUILD_SHARED_LIBS:BOOL=ON
+       -DLLVM_BUILD_LLVM_DYLIB:BOOL=ON \
+       -DLLVM_LINK_LLVM_DYLIB:BOOL=ON \
+       -DBUILD_SHARED_LIBS:BOOL=OFF \
+       -DENABLE_LINKER_BUILD_ID:BOOL=ON \
+       -DLLVM_BINUTILS_INCDIR:STRING=%{_includedir} \
+       ../
 
 %{__make} \
        VERBOSE=1 \
@@ -524,7 +568,6 @@ CPPFLAGS="%{rpmcppflags} -D_FILE_OFFSET_BITS=64"
 %{__make} -C tools/lld/docs docs-lld-html
 %{__make} -C tools/lldb/docs lldb-python-doc
 %{__make} -C tools/lldb/docs lldb-cpp-doc
-%{__make} -C ../tools/clang/tools/extra/docs html
 %endif
 
 %install
@@ -536,24 +579,16 @@ rm -rf $RPM_BUILD_ROOT
 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
 
-# Static analyzer not installed by default:
+# Adjust static analyzer installation
 # http://clang-analyzer.llvm.org/installation#OtherPlatforms
-install -d $RPM_BUILD_ROOT%{_libdir}/clang-analyzer
-# create launchers
-for f in scan-{build,view}; do
-       ln -s %{_libdir}/clang-analyzer/$f/$f $RPM_BUILD_ROOT%{_bindir}/$f
-       cp -pr tools/clang/tools/$f $RPM_BUILD_ROOT%{_libdir}/clang-analyzer
-done
-install -d $RPM_BUILD_ROOT%{_mandir}/man1
-%{__mv} $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-build/scan-build.1 $RPM_BUILD_ROOT%{_mandir}/man1
-%py_comp $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-view
-%py_ocomp $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-view
-%py_postclean %{_libdir}/clang-analyzer/scan-view
-# not this OS
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-build/*.bat
+install -d $RPM_BUILD_ROOT%{_libdir}/scan-build
+%{__mv} $RPM_BUILD_ROOT%{_prefix}/libexec/c??-analyzer $RPM_BUILD_ROOT%{_libdir}/scan-build
+%{__sed} -i -e 's,/\.\./libexec/,/../%{_lib}/scan-build/,' $RPM_BUILD_ROOT%{_bindir}/scan-build
+%py_comp $RPM_BUILD_ROOT%{_datadir}/scan-view
+%py_ocomp $RPM_BUILD_ROOT%{_datadir}/scan-view
+%py_postclean %{_datadir}/scan-view
 
 # not installed by cmake buildsystem
-install build/bin/clang-query $RPM_BUILD_ROOT%{_bindir}
 install build/bin/pp-trace $RPM_BUILD_ROOT%{_bindir}
 
 %if %{with doc}
@@ -567,7 +602,7 @@ echo '.so llvm-ar.1' > $RPM_BUILD_ROOT%{_mandir}/man1/llvm-ranlib.1
 # Move documentation back to build directory
 %if %{with ocaml}
 rm -rf ocamldocs
-mv $RPM_BUILD_ROOT%{_prefix}/docs/ocaml/html/html ocamldocs
+%{__mv} $RPM_BUILD_ROOT%{_prefix}/docs/ocaml/html/html ocamldocs
 %endif
 
 # and separate the apidoc
@@ -586,9 +621,13 @@ done
 # Get rid of erroneously installed example files.
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/LLVMHello.so
 # test?
-%{__rm} $RPM_BUILD_ROOT%{_bindir}/llvm-c-test
+%{__rm} $RPM_BUILD_ROOT%{_bindir}/{c-index-test,llvm-c-test}
 # not this OS
 %{__rm} $RPM_BUILD_ROOT%{_datadir}/clang/clang-format-bbedit.applescript
+# use system six
+%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/six.py*
+# it seems it is used internally by an extra clang tool
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libfindAllSymbols.a
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -599,9 +638,6 @@ rm -rf $RPM_BUILD_ROOT
 %post  -n clang -p /sbin/ldconfig
 %postun        -n clang -p /sbin/ldconfig
 
-%post  -n clang-tools-extra -p /sbin/ldconfig
-%postun        -n clang-tools-extra -p /sbin/ldconfig
-
 %post  -n lldb -p /sbin/ldconfig
 %postun        -n lldb -p /sbin/ldconfig
 
@@ -619,12 +655,11 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/llvm-dis
 %attr(755,root,root) %{_bindir}/llvm-dsymutil
 %attr(755,root,root) %{_bindir}/llvm-dwarfdump
+%attr(755,root,root) %{_bindir}/llvm-dwp
 %attr(755,root,root) %{_bindir}/llvm-extract
 %attr(755,root,root) %{_bindir}/llvm-lib
 %attr(755,root,root) %{_bindir}/llvm-link
-%ifarch %{x8664} x32
 %attr(755,root,root) %{_bindir}/llvm-lto
-%endif
 %attr(755,root,root) %{_bindir}/llvm-mc
 %attr(755,root,root) %{_bindir}/llvm-mcmarkup
 %attr(755,root,root) %{_bindir}/llvm-nm
@@ -634,14 +669,16 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/llvm-readobj
 %attr(755,root,root) %{_bindir}/llvm-rtdyld
 %attr(755,root,root) %{_bindir}/llvm-size
+%attr(755,root,root) %{_bindir}/llvm-split
 %attr(755,root,root) %{_bindir}/llvm-stress
 %attr(755,root,root) %{_bindir}/llvm-symbolizer
 %attr(755,root,root) %{_bindir}/llvm-tblgen
 %attr(755,root,root) %{_bindir}/llvm-cxxdump
 %attr(755,root,root) %{_bindir}/llvm-pdbdump
-%attr(755,root,root) %{_bindir}/macho-dump
 %attr(755,root,root) %{_bindir}/obj2yaml
 %attr(755,root,root) %{_bindir}/opt
+%attr(755,root,root) %{_bindir}/sancov
+%attr(755,root,root) %{_bindir}/sanstats
 %attr(755,root,root) %{_bindir}/verify-uselistorder
 %attr(755,root,root) %{_bindir}/yaml2obj
 %if %{with doc}
@@ -657,6 +694,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/llvm-dis.1*
 %{_mandir}/man1/llvm-dwarfdump.1*
 %{_mandir}/man1/llvm-extract.1*
+%{_mandir}/man1/llvm-lib.1*
 %{_mandir}/man1/llvm-link.1*
 %{_mandir}/man1/llvm-nm.1*
 %{_mandir}/man1/llvm-profdata.1*
@@ -670,25 +708,21 @@ rm -rf $RPM_BUILD_ROOT
 
 %files libs
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libLLVM*.so.%{version}
-%attr(755,root,root) %ghost %{_libdir}/libLLVM*.so.3.7
-%ifarch %{x8664} x32
-%attr(755,root,root) %{_libdir}/libLTO.so.%{version}
-%attr(755,root,root) %ghost %{_libdir}/libLTO.so.3.7
-%endif
+%attr(755,root,root) %{_libdir}/libLLVM-%{abi}.so
+# non-soname symlink
+%attr(755,root,root) %{_libdir}/libLLVM-%{version}.so
+%attr(755,root,root) %{_libdir}/libLTO.so
+%attr(755,root,root) %{_libdir}/LLVMgold.so
 
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/llvm-config
-%attr(755,root,root) %{_libdir}/libLLVM*.so
+%attr(755,root,root) %{_libdir}/libLLVM.so
 %attr(755,root,root) %{_libdir}/BugpointPasses.so
-%ifarch %{x8664} x32
-%attr(755,root,root) %{_libdir}/libLTO.so
-%endif
+%{_libdir}/libLLVM*.a
 %{_includedir}/llvm
 %{_includedir}/llvm-c
-%dir %{_datadir}/llvm
-%{_datadir}/llvm/cmake
+%{_libdir}/cmake/llvm
 %if %{with doc}
 %{_mandir}/man1/llvm-config.1*
 %endif
@@ -705,12 +739,14 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with polly}
 %files polly
 %defattr(644,root,root,755)
-%doc tools/polly/{CREDITS.txt,LICENSE.txt,README}
+%doc tools/polly/{CREDITS.txt,LICENSE.txt,README} tools/polly/www/{bugs,changelog,contributors}.html
 %attr(755,root,root) %{_libdir}/LLVMPolly.so
-%attr(755,root,root) %{_libdir}/libPolly.so
 
 %files polly-devel
 %defattr(644,root,root,755)
+%{_libdir}/libPolly.a
+%{_libdir}/libPollyISL.a
+%{_libdir}/libPollyPPCG.a
 %{_includedir}/polly
 %endif
 
@@ -719,19 +755,16 @@ rm -rf $RPM_BUILD_ROOT
 %doc clang-docs/{LICENSE.TXT,NOTES.txt,README.txt} %{?with_tests:clang-testlog.txt}
 %attr(755,root,root) %{_bindir}/clang
 %attr(755,root,root) %{_bindir}/clang++
-%attr(755,root,root) %{_bindir}/clang-3.7
+%attr(755,root,root) %{_bindir}/clang-%{abi}
 %attr(755,root,root) %{_bindir}/clang-check
 %attr(755,root,root) %{_bindir}/clang-cl
 %attr(755,root,root) %{_bindir}/clang-format
 %attr(755,root,root) %{_bindir}/git-clang-format
-%attr(755,root,root) %{_libdir}/libclang*.so.%{version}
-%attr(755,root,root) %ghost %{_libdir}/libclang*.so.3.7
 %dir %{_libdir}/clang
 %dir %{_libdir}/clang/%{version}
 %{_libdir}/clang/%{version}/include
 %if %{with rt}
-%ifarch %{ix86} %{x8664}
-%{_libdir}/clang/%{version}/asan_blacklist.txt
+%ifarch %{ix86} %{x8664} x32
 %dir %{_libdir}/clang/%{version}/lib
 %dir %{_libdir}/clang/%{version}/lib/linux
 %endif
@@ -740,51 +773,60 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i*86.so
 %endif
 %ifarch %{x8664}
-%{_libdir}/clang/%{version}/dfsan_abilist.txt
-%{_libdir}/clang/%{version}/msan_blacklist.txt
 %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.a
 %attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.so
 %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.a.syms
 %endif
+%ifarch %{ix86} %{x8664} x32 %{arm} aarch64 mips mips64 ppc64
+%{_libdir}/clang/%{version}/asan_blacklist.txt
+%endif
+%ifarch %{ix86} %{x8664} x32 mips64
+%{_libdir}/clang/%{version}/cfi_blacklist.txt
+%endif
+%ifarch %{x8664} x32 aarch64 mips64
+%{_libdir}/clang/%{version}/dfsan_abilist.txt
+%{_libdir}/clang/%{version}/msan_blacklist.txt
+%endif
 %endif
 %dir %{_datadir}/clang
 %{_datadir}/clang/clang-format-diff.py
 
-%if %{with rt}
-%ifarch %{x8664}
+%files -n clang-libs
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libclang.so.%{abi}
+
+%if %{with rt} && %{with multilib}
+%ifarch %{x8664} x32
 %files -n clang-multilib
 %defattr(644,root,root,755)
 %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i386.a
 %attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-i386.so
 %endif
+%ifarch x32
+%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.a
+%attr(755,root,root) %{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.so
+%{_libdir}/clang/%{version}/lib/linux/libclang_rt.*-x86_64.a.syms
+%endif
 %endif
 
 %files -n clang-analyzer
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/scan-build
 %attr(755,root,root) %{_bindir}/scan-view
+%{_datadir}/scan-build
+%{_datadir}/scan-view
 %{_mandir}/man1/scan-build.1*
-%dir %{_libdir}/clang-analyzer
-
-%dir %{_libdir}/clang-analyzer/scan-build
-%{_libdir}/clang-analyzer/scan-build/*.css
-%{_libdir}/clang-analyzer/scan-build/*.js
-%attr(755,root,root) %{_libdir}/clang-analyzer/scan-build/scan-build
-%attr(755,root,root) %{_libdir}/clang-analyzer/scan-build/*-analyzer
-
-%dir %{_libdir}/clang-analyzer/scan-view
-%attr(755,root,root) %{_libdir}/clang-analyzer/scan-view/scan-view
-%{_libdir}/clang-analyzer/scan-view/Resources
-%{_libdir}/clang-analyzer/scan-view/*.py[co]
+%dir %{_libdir}/scan-build
+%attr(755,root,root) %{_libdir}/scan-build/c++-analyzer
+%attr(755,root,root) %{_libdir}/scan-build/ccc-analyzer
 
 %files -n clang-devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libclang*.so
-%ifarch %{ix86} # ???
-%{_libdir}/libclang.a
-%endif
+%attr(755,root,root) %{_libdir}/libclang.so
+%{_libdir}/libclang*.a
 %{_includedir}/clang
 %{_includedir}/clang-c
+%{_libdir}/cmake/clang
 
 %files -n clang-doc
 %defattr(644,root,root,755)
@@ -798,44 +840,45 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n clang-tools-extra
 %defattr(644,root,root,755)
-%doc tools/clang/tools/extra/{CODE_OWNERS.TXT,README.txt} tools/clang/tools/extra/docs/_build/html/{*.html,*.js,_static}
+%doc tools/clang/tools/extra/{CODE_OWNERS.TXT,README.txt}
 %attr(755,root,root) %{_bindir}/clang-apply-replacements
-%attr(755,root,root) %{_bindir}/clang-modernize
+%attr(755,root,root) %{_bindir}/clang-include-fixer
 %attr(755,root,root) %{_bindir}/clang-query
 %attr(755,root,root) %{_bindir}/clang-rename
 %attr(755,root,root) %{_bindir}/clang-tidy
+%attr(755,root,root) %{_bindir}/find-all-symbols
+%attr(755,root,root) %{_bindir}/modularize
 %attr(755,root,root) %{_bindir}/pp-trace
-%attr(755,root,root) %{_libdir}/libmodernizeCore.so.%{version}
-%attr(755,root,root) %ghost %{_libdir}/libmodernizeCore.so.3.7
-# -devel?
-%attr(755,root,root) %{_libdir}/libmodernizeCore.so
+%{_datadir}/clang/clang-include-fixer.py
+%{_datadir}/clang/clang-tidy-diff.py
+%{_datadir}/clang/run-clang-tidy.py
+%{_datadir}/clang/run-find-all-symbols.py
 
 %files -n lld
 %defattr(644,root,root,755)
 %doc tools/lld/{LICENSE.TXT,README.md}
+%attr(755,root,root) %{_bindir}/ld.lld
 %attr(755,root,root) %{_bindir}/lld
-%attr(755,root,root) %{_libdir}/liblld[ACDEHMPRXY]*.so.%{version}
-%attr(755,root,root) %ghost %{_libdir}/liblld[ACDEHMPRXY]*.so.3.7
+%attr(755,root,root) %{_bindir}/lld-link
 
 %files -n lld-devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/liblld[ACDEHMPRXY]*.so
+%{_libdir}/liblld[ACDEHMRXY]*.a
 %{_includedir}/lld
 
 %if %{with lldb}
 %files -n lldb
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/argdumper
 %attr(755,root,root) %{_bindir}/lldb
 %attr(755,root,root) %{_bindir}/lldb-%{version}
+%attr(755,root,root) %{_bindir}/lldb-argdumper
 %attr(755,root,root) %{_bindir}/lldb-mi
 %attr(755,root,root) %{_bindir}/lldb-mi-%{version}
 %attr(755,root,root) %{_bindir}/lldb-server
 %attr(755,root,root) %{_bindir}/lldb-server-%{version}
 %attr(755,root,root) %{_libdir}/liblldb.so.%{version}
-%attr(755,root,root) %ghost %{_libdir}/liblldb.so.3.7
 %dir %{py_sitedir}/lldb
-%attr(755,root,root) %{py_sitedir}/lldb/argdumper
+%attr(755,root,root) %{py_sitedir}/lldb/lldb-argdumper
 %{py_sitedir}/lldb/formatters
 %{py_sitedir}/lldb/runtime
 %{py_sitedir}/lldb/utils
This page took 0.084457 seconds and 4 git commands to generate.