]> git.pld-linux.org Git - packages/lighttpd.git/blobdiff - lighttpd.spec
up to 1.4.49
[packages/lighttpd.git] / lighttpd.spec
index c435df0d56600e08f160c022082f24e7d385f50f..9e50f515052a0bb8b084c81f2d7bd968be76cbc9 100644 (file)
@@ -1,49 +1,50 @@
 # TODO:
-# - provide or autogenerate self signed cert in post, so after installing
+# - provide or autogenerated self signed cert in post, so after installing
 #   lighttpd-ssl server will still work
 # - patch with mod_websocket: https://github.com/Juniper/lighttpd-for-juise
 # - lighttpd-mod_fd_transfer: https://redmine.lighttpd.net/boards/3/topics/4992
-# - add db specific mod_vhostdb_* packages
+# - add db specific mod_vhostdb_* sub-packages
 #
 # Conditional build:
 %bcond_with            tests           # build with tests
 %bcond_without xattr           # support of extended attributes
 %bcond_without ipv6            # IPv4-only version (doesn't require IPv6 in kernel)
 %bcond_without largefile       # largefile support (see notes above)
+%bcond_without dbi             # libdbi, enables mod_vhostdb_dbi
 %bcond_without ssl             # ssl support
 %bcond_without mysql           # mysql support in mod_mysql_vhost, mod_vhostdb_mysql
+%bcond_without pgsql           # PgSQL, enables mod_vhostdb_pgsql
 %bcond_without geoip           # GeoIP support
 %bcond_with    krb5            # krb5 support (does not work with heimdal)
 %bcond_without ldap            # ldap support in mod_auth, mod_vhostdb_ldap
 %bcond_without lua             # LUA support in mod_cml (needs LUA >= 5.1)
-%bcond_with    memcache        # memcached support in mod_cml / mod_trigger_b4_dl
-%bcond_with    gamin           # gamin for reducing number of stat() calls.
-                               # NOTE: must be enabled in config: server.stat-cache-engine = "fam"
-%bcond_with    gdbm            # gdbm in mod_trigger_b4_dl
+%bcond_with    gamin           # gamin for reducing number of stat() calls. must be enabled in config: server.stat-cache-engine = "fam"
 %bcond_without mod_trigger_b4_dl               # mod_trigger_b4_dl
 %bcond_with    webdav_props    # properties in mod_webdav (includes extra sqlite3/libxml deps)
 %bcond_with    webdav_locks    # webdav locks with extra efsprogs deps
 %bcond_with    valgrind        # compile code with valgrind support.
 %bcond_with    h264_streaming          # build h264_streaming module
+%bcond_without storage_memcached       # memcached storage for mod_trigger_b4_dl/mod_cml
+%bcond_without storage_gdbm            # gdbm storage for mod_trigger_b4_dl
 
 %if %{with webdav_locks}
 %define                webdav_progs    1
 %endif
 
 # if(WITH_PCRE AND (WITH_MEMCACHED OR WITH_GDBM))
-%if %{without memcached} && %{without gdbm}
+%if %{without storage_memcached} && %{without storage_gdbm}
 %undefine      with_mod_trigger_b4_dl
 %endif
 
 Summary:       Fast and light HTTP server
 Summary(pl.UTF-8):     Szybki i lekki serwer HTTP
 Name:          lighttpd
-Version:       1.4.48
+Version:       1.4.49
 Release:       1
 License:       BSD
 Group:         Networking/Daemons/HTTP
 Source0:       https://download.lighttpd.net/lighttpd/releases-1.4.x/%{name}-%{version}.tar.xz
-# Source0-md5: 1e3a9eb5078f481e3a8a1d0aaac8c3c8
+# Source0-md5: aaf8165379351c3766e5ad1e5c9dbe8b
 Source1:       %{name}.init
 Source2:       %{name}.conf
 Source3:       %{name}.user
@@ -131,15 +132,17 @@ BuildRequires:    automake
 BuildRequires: bzip2-devel
 BuildRequires: fcgi-devel
 %{?with_gamin:BuildRequires:   gamin-devel}
-%{?with_gdbm:BuildRequires:    gdbm-devel}
+%{?with_storage_gdbm:BuildRequires:    gdbm-devel}
 %{?with_krb5:BuildRequires:    krb5-devel}
-%{?with_memcache:BuildRequires:        libmemcache-devel}
+%{?with_dbi:BuildRequires:     libdbi-devel}
+%{?with_storage_memcached:BuildRequires:       libmemcached-devel}
 BuildRequires: libtool
 BuildRequires: libuuid-devel
 %{?with_webdav_props:BuildRequires:    libxml2-devel}
 %{?with_lua:BuildRequires:     lua51-devel}
 BuildRequires: mailcap >= 2.1.14-4.4
 %{?with_mysql:BuildRequires:   mysql-devel}
+%{?with_pgsql:BuildRequires:   postgresql-devel}
 %{?with_ldap:BuildRequires:    openldap-devel}
 %{?with_ssl:BuildRequires:     openssl-devel}
 BuildRequires: pcre-devel
@@ -982,17 +985,19 @@ fi
        %{!?with_largefile:--disable-lfs} \
        %{?with_valgrind:--with-valgrind} \
        %{?with_xattr:--with-attr} \
+       %{?with_dbi:--with-dbi} \
        %{?with_krb5:--with-krb5} \
        %{?with_geoip:--with-geoip} \
        %{?with_mysql:--with-mysql} \
        %{?with_ldap:--with-ldap} \
        %{?with_ssl:--with-openssl} \
+       %{?with_pgsql:--with-pgsql} \
        %{?with_lua:--with-lua=lua51} \
-       %{?with_memcache:--with-memcache} \
+       %{?with_storage_memcached:--with-memcached} \
        %{?with_webdav_props:--with-webdav-props} \
        %{?with_webdav_locks:--with-webdav-locks} \
        %{?with_gamin:--with-gamin} \
-       %{?with_gdbm:--with-gdbm}
+       %{?with_storage_gdbm:--with-gdbm}
 
 # -j1 as src/mod_ssi_exprparser.h regeneration deps are broken
 %{__make} -j1
@@ -1505,12 +1510,19 @@ fi
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_vhostdb.conf
 %attr(755,root,root) %{pkglibdir}/mod_vhostdb.so
+# TODO: subpackages
+%if %{with dbi}
+%attr(755,root,root) %{pkglibdir}/mod_vhostdb_dbi.so
+%endif
 %if %{with ldap}
 %attr(755,root,root) %{pkglibdir}/mod_vhostdb_ldap.so
 %endif
 %if %{with mysql}
 %attr(755,root,root) %{pkglibdir}/mod_vhostdb_mysql.so
 %endif
+%if %{with pgsql}
+%attr(755,root,root) %{pkglibdir}/mod_vhostdb_pgsql.so
+%endif
 
 %files mod_webdav
 %defattr(644,root,root,755)
This page took 0.158039 seconds and 4 git commands to generate.