]> git.pld-linux.org Git - packages/libfilezilla.git/blame - libfilezilla.spec
- updated to 0.6.1
[packages/libfilezilla.git] / libfilezilla.spec
CommitLineData
fdec25bb
WF
1#
2# Conditional build:
3%bcond_without apidocs # do not build and package API docs
4%bcond_without static_libs # don't build static libraries
5#
6Summary: libfilezilla
7Summary(pl.UTF-8): libfilezilla
8Name: libfilezilla
be98743d 9Version: 0.6.1
fdec25bb
WF
10Release: 1
11License: GPL v2
12Group: Libraries
13Source0: http://downloads.sourceforge.net/filezilla/%{name}-%{version}.tar.bz2
be98743d 14# Source0-md5: 3d4728ce8949490b09198443e955c8b6
fdec25bb
WF
15URL: http://lib.filezilla-project.org/
16BuildRequires: libstdc++-devel
17BuildRequires: rpmbuild(macros) >= 1.583
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20%description
21libfilezilla is a free, open source C++ library, offering some basic
22functionality to build high-performing, platform-independent programs.
23Some of the highlights include:
24
25- A typesafe, multi-threaded event system that's very simple to use
26 yet extremely efficient
27- Timers for periodic events
28- A datetime class that not only tracks timestamp but also their
29 accuracy, which simplifies dealing with timestamps originating from
30 different sources
31- Simple process handling for spawning child processes with redirected
32 I/O
33
34#%description -l pl.UTF-8
35
36%package devel
37Summary: Header files for %{name} library
38Summary(pl.UTF-8): Pliki nagłówkowe biblioteki %{name}
39Group: Development/Libraries
40Requires: %{name} = %{version}-%{release}
41
42%description devel
43Header files for %{name} library.
44
45%description devel -l pl.UTF-8
46Pliki nagłówkowe biblioteki %{name}.
47
48%package static
49Summary: Static %{name} library
50Summary(pl.UTF-8): Statyczna biblioteka %{name}
51Group: Development/Libraries
52Requires: %{name}-devel = %{version}-%{release}
53
54%description static
55Static %{name} library.
56
57%description static -l pl.UTF-8
58Statyczna biblioteka %{name}.
59
60%package apidocs
61Summary: %{name} API documentation
62Summary(pl.UTF-8): Dokumentacja API biblioteki %{name}
63Group: Documentation
64
65%description apidocs
66API documentation for %{name} library.
67
68%description apidocs -l pl.UTF-8
69Dokumentacja API biblioteki %{name}.
70
71%prep
72%setup -q
73
74%build
75%configure \
76 %{!?with_static_libs:--disable-static}
77%{__make}
78
79%install
80rm -rf $RPM_BUILD_ROOT
81
82%{__make} install \
83 DESTDIR=$RPM_BUILD_ROOT
84
85%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
86
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90%post -p /sbin/ldconfig
91%postun -p /sbin/ldconfig
92
93%files
94%defattr(644,root,root,755)
95%doc AUTHORS NEWS README
96%attr(755,root,root) %{_libdir}/%{name}.so.*.*.*
97%attr(755,root,root) %ghost %{_libdir}/%{name}.so.0
98
99%files devel
100%defattr(644,root,root,755)
101%attr(755,root,root) %{_libdir}/%{name}.so
102%{_includedir}/%{name}
103%{_pkgconfigdir}/%{name}.pc
104
105%if %{with static_libs}
106%files static
107%defattr(644,root,root,755)
108%{_libdir}/%{name}.a
109%endif
110
111%if 0
112%files apidocs
113%defattr(644,root,root,755)
114%doc doc/*
115%endif
This page took 0.050441 seconds and 4 git commands to generate.