]> git.pld-linux.org Git - packages/libde265.git/blame - libde265.spec
- updated to 1.0.8
[packages/libde265.git] / libde265.spec
CommitLineData
a37a1d37
JB
1#
2# Conditional build:
3%bcond_without qt # Qt based visual inspection GUI (sherlock265)
4%bcond_without static_libs # don't build static libraries
5#
6Summary: H.265/HEVC video decoder
7Summary(pl.UTF-8): Dekoder obrazu H.265/HEVC
8Name: libde265
bd0fac39 9Version: 1.0.8
a37a1d37
JB
10Release: 1
11License: LGPL v3+ (library), GPL v3+ (programs)
12Group: Libraries
5aac95ca 13#Source0Download: https://github.com/strukturag/libde265/releases/
a37a1d37 14Source0: https://github.com/strukturag/libde265/releases/download/v%{version}/%{name}-%{version}.tar.gz
bd0fac39 15# Source0-md5: e5a8c91c533ae5926e5118087f78930f
a37a1d37
JB
16URL: http://www.libde265.org/
17BuildRequires: SDL-devel
18BuildRequires: autoconf >= 2.68
19BuildRequires: ffmpeg-devel
20BuildRequires: libstdc++-devel
21BuildRequires: libtool >= 2:2
22BuildRequires: libvideogfx-devel
23BuildRequires: pkgconfig
24%if %{with qt}
25BuildRequires: Qt5Core-devel >= 5
26BuildRequires: Qt5Gui-devel >= 5
27BuildRequires: Qt5Widgets-devel >= 5
28BuildRequires: qt5-build >= 5
29%endif
30BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32%description
33libde265 is an open source implementation of the H.265 video codec. It
34is written from scratch and has a plain C API to enable a simple
35integration into other software.
36
37%description -l pl.UTF-8
38libde265 to mająca otwarte źródła implementacja kodeka obrazu H.265.
39Została napisana od zera i ma API w czystym C, pozwalające na prostą
40integrację w innym oprogramowaniu.
41
42%package tools
43Summary: Encoding and decoding tools for libde265 library
44Summary(pl.UTF-8): Narzędzia kodujące i dekodujące dla biblioteki libde265
45License: LGPL v3+ (library), GPL v3+ (programs)
46Group: Applications/Graphics
47Requires: %{name} = %{version}-%{release}
48
49%description tools
50Encoding and decoding tools for libde265 library.
51
52%description tools -l pl.UTF-8
53Narzędzia kodujące i dekodujące dla biblioteki libde265.
54
55%package gui
56Summary: Visual inspection tool (sherlock265) for libde265 library
57Summary(pl.UTF-8): Narzędzie do wizualnego badania (sherlock265) dla biblioteki libde265
58Group: X11/Applications/Graphics
59Requires: %{name} = %{version}-%{release}
60
61%description gui
62Visual inspection tool (sherlock265) for libde265 library.
63
64%description gui -l pl.UTF-8
65Narzędzie do wizualnego badania (sherlock265) dla biblioteki libde265.
66
67%package devel
68Summary: Header files for libde265 library
69Summary(pl.UTF-8): Pliki nagłówkowe biblioteki libde265
70License: LGPL v3+
71Group: Development/Libraries
72Requires: %{name} = %{version}-%{release}
73Requires: libstdc++-devel
74
75%description devel
76Header files for libde265 library.
77
78%description devel -l pl.UTF-8
79Pliki nagłówkowe biblioteki libde265.
80
81%package static
82Summary: Static libde265 library
83Summary(pl.UTF-8): Statyczna biblioteka libde265
84License: LGPL v3+
85Group: Development/Libraries
86Requires: %{name}-devel = %{version}-%{release}
87
88%description static
89Static libde265 library.
90
91%description static -l pl.UTF-8
92Statyczna biblioteka libde265.
93
94%prep
95%setup -q
a37a1d37
JB
96
97%build
98%{__libtoolize}
99%{__aclocal} -I m4
100%{__autoconf}
101%{__autoheader}
102%{__automake}
103%configure \
104 %{!?with_qt:--disable-sherlock265} \
105 %{!?with_static_libs:--disable-static}
106%{__make}
107
108%install
109rm -rf $RPM_BUILD_ROOT
110
111%{__make} install \
112 DESTDIR=$RPM_BUILD_ROOT
113
114# examples
115%{__rm} $RPM_BUILD_ROOT%{_bindir}/{bjoentegaard,block-rate-estim,gen-enc-table,hdrcopy,rd-curves,tests,yuv-distortion}
116
117# obsoleted by pkg-config
118%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
119
120%clean
121rm -rf $RPM_BUILD_ROOT
122
123%post -p /sbin/ldconfig
124%postun -p /sbin/ldconfig
125
126%files
127%defattr(644,root,root,755)
5aac95ca 128%doc AUTHORS NEWS README.md
a37a1d37
JB
129%attr(755,root,root) %{_libdir}/libde265.so.*.*.*
130%attr(755,root,root) %ghost %{_libdir}/libde265.so.0
131
132%files tools
133%defattr(644,root,root,755)
5aac95ca 134%attr(755,root,root) %{_bindir}/acceleration_speed
a37a1d37
JB
135# R: SDL libvideogfx
136%attr(755,root,root) %{_bindir}/dec265
137# R: (only base)
138%attr(755,root,root) %{_bindir}/enc265
139
140%if %{with qt}
141%files gui
142%defattr(644,root,root,755)
143%doc sherlock265/README
144# R: Qt5 (Core Gui Widgets) ffmpeg/libswscale
145%attr(755,root,root) %{_bindir}/sherlock265
146%endif
147
148%files devel
149%defattr(644,root,root,755)
150%attr(755,root,root) %{_libdir}/libde265.so
151%{_includedir}/libde265
152%{_pkgconfigdir}/libde265.pc
153
154%if %{with static_libs}
155%files static
156%defattr(644,root,root,755)
157%{_libdir}/libde265.a
158%endif
This page took 0.409084 seconds and 4 git commands to generate.