]> git.pld-linux.org Git - packages/kazehakase.git/blame - kazehakase.spec
- updated gettext BR
[packages/kazehakase.git] / kazehakase.spec
CommitLineData
03160c97 1#
5e7397d1 2# - force kazehakase to use old SSL dialogs using nsIBadCertListener, ie. port
3# EphyBadCertRejector from Epiphany, this will fix issues with https sites
4# using self signed and expired certificates or mismatches in domain names
5#
6# Conditional builds
9eee9440
JB
7%bcond_without gecko # build without gecko support
8%bcond_without webkit # build without webkit support
03160c97 9#
10Summary: A browser with multiple rendering engines support
9eee9440 11Summary(pl.UTF-8): Przeglądarka obsługująca wiele silników renderujących
a0563285 12Name: kazehakase
d5e6c46c 13Version: 0.5.6
6df7eba4 14Release: 13
fa48900a
JB
15License: GPL
16Group: X11/Applications/Networking
d5e6c46c 17Source0: http://downloads.sourceforge.jp/kazehakase/33533/%{name}-%{version}.tar.gz
18# Source0-md5: b88257aa10dd53fd5d39c627f8f95890
a6b45d00 19Patch0: %{name}-desktop.patch
5306880a 20Patch1: %{name}-deprecated.patch
21Patch2: %{name}-ti-agent.patch
22Patch3: %{name}-agent.patch
ecee25b5 23Patch4: %{name}-libxul.patch
5e7397d1 24Patch5: %{name}-xulappinfo.patch
5d98c101 25Patch6: %{name}-gnutls.patch
26Patch7: %{name}-xulrunner-1_9_1.patch
fa48900a 27URL: http://kazehakase.sourceforge.jp/
e30aeaf6 28BuildRequires: autoconf
171705b2 29BuildRequires: automake
73b8345a 30BuildRequires: gettext-tools
cc3ad5d6 31BuildRequires: gnutls-devel
4c5fe5e2 32BuildRequires: gtk+2-devel
03160c97 33%{?with_webkit:BuildRequires: gtk-webkit-devel}
4c5fe5e2 34BuildRequires: libstdc++-devel
1c8859c8 35BuildRequires: libtool
4c5fe5e2 36BuildRequires: pkgconfig
5306880a 37BuildRequires: rpm >= 4.4.9-56
03160c97 38%{?with_gecko:BuildRequires: xulrunner-devel}
ed2f17cf 39Requires: %{name}-libs = %{version}-%{release}
20830783 40Requires: kazehakase_engine
c482f379 41%requires_eq_to xulrunner xulrunner-devel
a0563285 42BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
c482f379
MB
44# we have strict deps for it
45%define _noautoreq libxpcom.so
46
a0563285 47%description
03160c97 48Kazehakase is a browser which allow use many rendering engines. For
9eee9440 49now it support only Gecko (like Epiphany or Galeon) and webkit engines.
a0563285 50
321a9c12 51%description -l pl.UTF-8
03160c97 52Kazehakase jest przeglądarką, która pozwala na używanie wielu
9eee9440
JB
53silników renderujących. Na dzień dzisiejszy obsługuje silniki Gecko
54(taki jak w Epiphany lub Galeonie) oraz webkit.
a0563285 55
ed2f17cf 56%package libs
57Summary: Kazehakase libraries
58Summary(pl.UTF-8): Biblioteki Kazehakase
59Group: Libraries
60
61%description libs
62This package contains Kazehakase libraries.
63
64%description libs -l pl.UTF-8
65Pakiet zawiera biblioteki Kazehakase.
66
03160c97 67%package plugin-gecko
68Summary: Gecko plugin engine for Kazehakase
9eee9440 69Summary(pl.UTF-8): Wtyczka Gecko dla Kazehakase
03160c97 70Group: X11/Applications/Networking
71Requires: xulrunner
20830783 72Provides: kazehakase_engine
03160c97 73
74%description plugin-gecko
9eee9440 75This plugin provides Gecko rendering engine support.
03160c97 76
77%description plugin-gecko -l pl.UTF-8
9eee9440 78Ta wtyczka dodaje obsługę silnika renderującego Gecko.
03160c97 79
80%package plugin-webkit
81Summary: Webkit plugin engine for Kazehakase
9eee9440 82Summary(pl.UTF-8): Wtyczka webkit dla Kazehakase
03160c97 83Group: X11/Applications/Networking
20830783 84Provides: kazehakase_engine
03160c97 85
86%description plugin-webkit
87This plugin provides webkit rendering engine support.
88
89%description plugin-webkit -l pl.UTF-8
9eee9440 90Ta wtyczka dodaje obsługę silnika renderującego webkit.
03160c97 91
a0563285 92%prep
93%setup -q
679126f2 94%patch0 -p1
b27b22f5 95%patch1 -p1
5306880a 96%if "%{pld_release}" == "ti"
1a55cf25 97%patch2 -p1
5306880a 98%else
99%patch3 -p1
100%endif
ecee25b5 101%patch4 -p1
5e7397d1 102%patch5 -p1
5d98c101 103%patch6 -p0
104%patch7 -p1
a0563285 105
106%build
4c5fe5e2 107%{__libtoolize}
2860fed1 108%{__aclocal} -I macros
cc58b2fa 109%{__autoconf}
110%{__automake}
03160c97 111%configure \
c3843468 112 %{!?with_gecko:--disable-gecko} \
03160c97 113 %{!?with_webkit:--disable-webkit}
a0563285 114
115%{__make}
116
117%install
118rm -rf $RPM_BUILD_ROOT
fa48900a 119
a0563285 120%{__make} install \
cf902c03 121 libkazehakasedir=%{_libdir} \
a0563285 122 DESTDIR=$RPM_BUILD_ROOT
cf902c03
KK
123
124# unnecessary
125rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
2860fed1 126rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/embed/*.la
cf902c03 127
dc2a4855 128%find_lang %{name}
cf902c03 129
a0563285 130%clean
131rm -rf $RPM_BUILD_ROOT
132
ed2f17cf 133%post libs -p /sbin/ldconfig
134%postun libs -p /sbin/ldconfig
cc3ad5d6 135
dc2a4855 136%files -f %{name}.lang
a0563285 137%defattr(644,root,root,755)
138%doc README README.ja AUTHORS ChangeLog COPYING.README TODO.ja
139%{_sysconfdir}/%{name}
140%attr(755,root,root) %{_bindir}/*
056ea567 141%{_desktopdir}/%{name}.desktop
a0563285 142%{_datadir}/%{name}
143%{_pixmapsdir}/*
a6b45d00 144%{_mandir}/man?/*
ed2f17cf 145
146%files libs
147%defattr(644,root,root,755)
850ffdd1 148%attr(755,root,root) %{_libdir}/lib*.so
149%attr(755,root,root) %{_libdir}/lib*.so.*
ed2f17cf 150%dir %{_libdir}/%{name}
9eee9440 151%dir %{_libdir}/%{name}/embed
03160c97 152
ebed0e96 153%if %{with gecko}
03160c97 154%files plugin-gecko
155%defattr(644,root,root,755)
156%attr(755,root,root) %{_libdir}/%{name}/embed/gecko.so
157%endif
ebed0e96 158%if %{with webkit}
03160c97 159%files plugin-webkit
160%defattr(644,root,root,755)
161%attr(755,root,root) %{_libdir}/%{name}/embed/webkit_gtk.so
162%endif
This page took 0.09582 seconds and 4 git commands to generate.