]> git.pld-linux.org Git - packages/kannel.git/blame - kannel.spec
- release 7 (by relup.sh)
[packages/kannel.git] / kannel.spec
CommitLineData
9468b827 1# TODO:
9468b827 2# - check file list when built with docs
8961ecde 3#
4# Conditional build:
5%bcond_with doc # build documentation
8bc7020a 6%bcond_without openssl # link against openssl (requires multithreaded libs)
8961ecde 7%bcond_without mysql # don't link against mysql
8#
9468b827 9Summary: SMS/WAP gateway
2375cc07 10Summary(pl.UTF-8): Bramka WAP oraz SMS
51a540df 11Name: kannel
8bc7020a 12Version: 1.4.3
731effc0 13Release: 7
e4b5efdb 14License: BSD-like (see COPYING)
51a540df 15Group: Networking/Daemons
9468b827 16Source0: http://www.kannel.org/download/%{version}/gateway-%{version}.tar.gz
8bc7020a 17# Source0-md5: 8925b147fb7aa01a10fa4f53cfeb03e9
51a540df 18Source1: %{name}.init
9468b827 19Source2: %{name}.sysconfig
20Source3: %{name}.conf
40c9dbce
JB
21Patch0: %{name}-types.patch
22Patch1: %{name}-nolibs.patch
27eb402a 23URL: http://www.kannel.org/
51a540df 24BuildRequires: ImageMagick
40c9dbce 25BuildRequires: autoconf
38a92f05 26BuildRequires: automake
741694c7 27BuildRequires: libxml2-devel
8bc7020a
AM
28BuildRequires: pcre-devel
29BuildRequires: pam-devel
8961ecde 30%{?with_mysql:BuildRequires: mysql-devel}
8bc7020a
AM
31%if %{with doc}
32BuildRequires: openjade
33BuildRequires: texlive-latex
34BuildRequires: texlive-latex-ams
35BuildRequires: texlive-latex-extend
36%endif
9468b827 37# requires multithread enabled openssl (?)
a24f3c69 38%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
9468b827 39BuildRequires: zlib-devel
27eb402a 40Requires(post,preun): /sbin/chkconfig
51a540df
AM
41BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43%description
fb10c3c2 44Kannel is an Open Source SMS/WAP gateway. WAP is short for Wireless
45Application Protocol. It lets the phone act as a simple hypertext
46browser, but optimizes the markup language, scripting language, and
47the transmission protocols for wirelessuse. The optimized protocols
48are translated to normal Internet protocols by a WAP gateway. Kannel
49also works as a SMS gateway for GSM networks. Almost all GSM phones
50can send and receive SMS messages, so this is a way to serve many more
51clients than just those using WAP phones.
51a540df 52
7a220c34
JR
53%description -l pl.UTF-8
54Kannel jest bramką SMS/WAP Open Source. WAP pozwala używać telefonów
55jako prostych przeglądarek hipertekstowych, ale korzysta ze
56zoptymalizowanych protokołów transmisji. Bramka WAP tłumaczy je na
57protokoły internetowe. Kannel działa również jako bramka SMS dla sieci
58GSM. Prawie wszystkie telefony GSM mogą odbierać i wysyłać wiadomości
59SMS, więc pozwala to na obsługę większej liczby klientów.
51a540df
AM
60
61%prep
62%setup -q -n gateway-%{version}
40c9dbce 63%patch0 -p1
8bc7020a 64#%patch1 -p1
51a540df
AM
65
66%build
741694c7 67cp -f /usr/share/automake/config.sub .
40c9dbce
JB
68%{__autoconf}
69%configure \
8bc7020a
AM
70 CFLAGS="%{rpmcppflags} %{rpmcflags}" \
71 --with-malloc=native \
51a540df 72 --enable-cookies \
8bc7020a
AM
73 --enable-pcre \
74 --enable-pam \
75 --with%{!?with_mysql:out}-mysql \
8961ecde 76 %{?with_openssl: --with-wtls=openssl --with-ssl=%{_prefix} --en}%{!?with_openssl: --dis}able-ssl \
77 --%{!?with_doc:dis}%{?with_doc:en}able-docs
51a540df
AM
78
79touch .depend
80%{__make} depend
81%{__make}
82
83%install
84rm -rf $RPM_BUILD_ROOT
7fa4f974 85install -d $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_mandir}/man{1,8}}
9468b827 86
7fa4f974
PG
87%{__make} install \
88 DESTDIR=$RPM_BUILD_ROOT
51a540df 89
33dcd0a2 90install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
91install -D %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
e9f73c49 92install -D %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/kannel/%{name}.conf
9468b827 93install gw/smskannel.conf $RPM_BUILD_ROOT%{_sysconfdir}/kannel/smskannel.conf
94install test/fakesmsc $RPM_BUILD_ROOT%{_bindir}
95install test/fakewap $RPM_BUILD_ROOT%{_bindir}
51a540df
AM
96
97%clean
98rm -rf $RPM_BUILD_ROOT
99
100%post
2e3a0733 101if [ "$1" = "1" ]; then
102 /sbin/chkconfig --add %{name}
103 echo "Run \"/etc/rc.d/init.d/kannel start\" to start kannel." >&2
104else
105 if [ -f /var/lock/subsys/kannel ]; then
106 /etc/rc.d/init.d/kannel restart >&2
107 fi
108fi
109
51a540df
AM
110
111%preun
112if [ "$1" = "0" ]; then
e9f73c49 113 if [ -f /var/lock/subsys/kannel ]; then
114 /etc/rc.d/init.d/kannel stop >&2
115 fi
116 /sbin/chkconfig --del kannel
51a540df
AM
117fi
118
119%files
120%defattr(644,root,root,755)
8bc7020a
AM
121%doc LICENSE README COPYING NEWS VERSION STATUS doc/{*.txt,examples/*.conf}
122%doc doc/ChangeLog*
51a540df
AM
123%attr(755,root,root) %{_bindir}/*
124%attr(755,root,root) %{_sbindir}/*
e4b5efdb 125%attr(754,root,root) /etc/rc.d/init.d/%{name}
38a92f05
ER
126%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
127%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/kannel/kannel.conf
128%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/kannel/smskannel.conf
7fa4f974
PG
129%dir %{_sysconfdir}/kannel
130%{_mandir}/man*/*
This page took 0.081424 seconds and 4 git commands to generate.