]> git.pld-linux.org Git - packages/gtef.git/blob - gtef.spec
- new (and the last release undef gtef name)
[packages/gtef.git] / gtef.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        Gtef - GTK+ Text Editor Framework
6 Summary(pl.UTF-8):      Gtef (GTK+ Text Editor Framework) - szkielet edytora tekstu operatego na GTK+
7 Name:           gtef
8 Version:        2.0.1
9 Release:        1
10 License:        LGPL v2.1+
11 Group:          Libraries
12 Source0:        http://ftp.acc.umu.se/pub/GNOME/sources/gtef/2.0/%{name}-%{version}.tar.xz
13 # Source0-md5:  fbd29e1b3503156e5d40714839474b25
14 URL:            https://wiki.gnome.org/Projects/Gtef
15 BuildRequires:  autoconf >= 2.64
16 BuildRequires:  automake >= 1:1.14
17 BuildRequires:  gettext-tools >= 0.19.4
18 BuildRequires:  glib2-devel >= 1:2.52
19 BuildRequires:  gobject-introspection-devel >= 1.42.0
20 BuildRequires:  gtk+3-devel >= 3.20
21 BuildRequires:  gtk-doc >= 1.25
22 BuildRequires:  gtksourceview3-devel >= 3.22
23 BuildRequires:  libtool >= 2:2.2.6
24 BuildRequires:  libxml2-devel >= 1:2.5
25 BuildRequires:  pkgconfig
26 BuildRequires:  uchardet-devel
27 BuildRequires:  vala
28 Requires:       glib2 >= 1:2.52
29 Requires:       gtk+3 >= 3.20
30 Requires:       gtksourceview3 >= 3.22
31 Requires:       libxml2 >= 1:2.5
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 The final goal is to create a Tabbed Document Interface (TDI)
36 framework suitable for text editors.
37
38 But the first short-term goal is to have a higher-level API to load
39 and save a file. All the errors would be handled by Gtef, showing
40 GtkInfoBars etc.
41
42 %description -l pl.UTF-8
43 Ostatecznym celem projektu jest stworzenie szkieletu zakładkowego
44 interfejsu do dokumentów (TDI - Tabbed Document Interface), nadającego
45 się do edytorów tekstu.
46
47 Ale pierwszym, krótkoterminowym celem, jest stworzenie
48 wysokopoziomowego API do wczytywania i zapisywania plików. Wszystkie
49 błędy mają być obsługiwane przez Gtef, z wyświetlaniem GtkInfoBarów
50 itp.
51
52 %package devel
53 Summary:        Header files for Gtef library
54 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Gtef
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57 Requires:       glib2-devel >= 1:2.52
58 Requires:       gtk+3-devel >= 3.20
59 Requires:       gtksourceview3-devel >= 3.22
60 Requires:       libxml2-devel >= 1:2.5
61 Requires:       uchardet-devel
62
63 %description devel
64 Header files for Gtef library.
65
66 %description devel -l pl.UTF-8
67 Pliki nagłówkowe biblioteki Gtef.
68
69 %package static
70 Summary:        Static Gtef library
71 Summary(pl.UTF-8):      Statyczna biblioteka Gtef
72 Group:          Development/Libraries
73 Requires:       %{name}-devel = %{version}-%{release}
74
75 %description static
76 Static Gtef library.
77
78 %description static -l pl.UTF-8
79 Statyczna biblioteka Gtef.
80
81 %package -n vala-gtef
82 Summary:        Vala API for Gtef library
83 Summary(pl.UTF-8):      API języka Vala do biblioteki Gtef
84 Group:          Development/Libraries
85 Requires:       %{name}-devel = %{version}-%{release}
86 Requires:       vala
87
88 %description -n vala-gtef
89 Vala API for Gtef library.
90
91 %description -n vala-gtef -l pl.UTF-8
92 API języka Vala do biblioteki Gtef.
93
94 %package apidocs
95 Summary:        API documentation for Gtef library
96 Summary(pl.UTF-8):      Dokumentacja API biblioteki Gtef
97 Group:          Documentation
98 %if "%{_rpmversion}" >= "5"
99 BuildArch:      noarch
100 %endif
101
102 %description apidocs
103 API documentation for Gtef library.
104
105 %description apidocs -l pl.UTF-8
106 Dokumentacja API biblioteki Gtef.
107
108 %prep
109 %setup -q
110
111 %build
112 # rebuild ac/am/lt for as-needed to work
113 %{__libtoolize}
114 %{__aclocal} -I m4
115 %{__autoconf}
116 %{__autoheader}
117 %{__automake}
118 %configure \
119         --disable-silent-rules \
120         %{?with_static_libs:--enable-static} \
121         --with-html-dir=%{_gtkdocdir}
122 %{__make}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 # obsoleted by pkg-config
131 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgtef-2.la
132
133 %find_lang gtef-2
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %post   -p /sbin/ldconfig
139 %postun -p /sbin/ldconfig
140
141 %files -f gtef-2.lang
142 %defattr(644,root,root,755)
143 %doc AUTHORS NEWS README
144 %attr(755,root,root) %{_libdir}/libgtef-2.so.*.*.*
145 %attr(755,root,root) %ghost %{_libdir}/libgtef-2.so.0
146 %{_libdir}/girepository-1.0/Gtef-2.typelib
147
148 %files devel
149 %defattr(644,root,root,755)
150 %attr(755,root,root) %{_libdir}/libgtef-2.so
151 %{_includedir}/gtef-2
152 %{_datadir}/gir-1.0/Gtef-2.gir
153 %{_pkgconfigdir}/gtef-2.pc
154
155 %if %{with static_libs}
156 %files static
157 %defattr(644,root,root,755)
158 %{_libdir}/libgtef-2.a
159 %endif
160
161 %files -n vala-gtef
162 %defattr(644,root,root,755)
163 %{_datadir}/vala/vapi/gtef-2.deps
164 %{_datadir}/vala/vapi/gtef-2.vapi
165
166 %files apidocs
167 %defattr(644,root,root,755)
168 %{_gtkdocdir}/gtef-2.0
This page took 0.076348 seconds and 3 git commands to generate.