]> git.pld-linux.org Git - packages/gitlab-ce.git/blobdiff - gitlab-ce.spec
v8.12.6
[packages/gitlab-ce.git] / gitlab-ce.spec
index 96fb2aef306521f0d30a83b235569e879fb842ea..4dfaeab1315b6d8e5653a4b89a3226e38d391fc6 100644 (file)
 %bcond_with    krb5            # build with kerberos support
 %bcond_without gem_cache       # use local cache to speedup gem installation
 
-%define        shell_version 3.6.0
+%define        shell_version 3.6.1
 %define        workhorse_version 0.8.2
 Summary:       A Web interface to create projects and repositories, manage access and do code reviews
 Name:          gitlab-ce
-Version:       8.12.0
-Release:       0.75
+Version:       8.12.6
+Release:       0.76
 License:       MIT
 Group:         Applications/WWW
 # md5 deliberately omitted until this package is useful
@@ -56,6 +56,7 @@ BuildRequires:        zlib-devel
 Requires(post,preun):  /sbin/chkconfig
 Requires:      apache-base
 Requires:      git-core >= 2.7.4
+Requires:      gitlab-common >= 8.12-2
 Requires:      gitlab-shell >= %{shell_version}
 Requires:      gitlab-workhorse >= %{workhorse_version}
 Requires:      nodejs
@@ -107,12 +108,12 @@ mv config/database.yml.mysql config/database.yml
 
 find -name .gitkeep | xargs rm
 
-%build
 v=$(cat GITLAB_SHELL_VERSION)
 test "$v" = "%{shell_version}"
 v=$(cat GITLAB_WORKHORSE_VERSION)
 test "$v" = "%{workhorse_version}"
 
+%build
 %if %{with gem_cache}
 cachedir="%{_specdir}/cache/%{version}.%{_arch}"
 install -d vendor/bundle
@@ -165,7 +166,7 @@ install -d \
        $RPM_BUILD_ROOT%{_docdir}/gitlab \
        $RPM_BUILD_ROOT%{vardir}/public \
        $RPM_BUILD_ROOT%{cachedir}/tmp \
-       $RPM_BUILD_ROOT%{_localstatedir}/{run,log}/gitlab
+       $RPM_BUILD_ROOT%{_localstatedir}/run/gitlab
 
 # test if we can hardlink -- %{_builddir} and $RPM_BUILD_ROOT on same partition
 if cp -al VERSION $RPM_BUILD_ROOT/VERSION 2>/dev/null; then
@@ -233,7 +234,7 @@ install -p %{SOURCE5} $RPM_BUILD_ROOT/etc/rc.d/init.d/gitlab-unicorn
 
 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdunitdir}/gitlab.target
 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/gitlab.conf
-cp -p %{SOURCE6} $RPM_BUILD_ROOT/etc/logrotate.d/gitlab.logrotate
+cp -p %{SOURCE6} $RPM_BUILD_ROOT/etc/logrotate.d/gitlab
 cp -p %{SOURCE8} $RPM_BUILD_ROOT/etc/httpd/webapps.d/gitlab.conf
 install -p %{SOURCE9} $RPM_BUILD_ROOT%{_sbindir}/gitlab-rake
 install -p %{SOURCE11} $RPM_BUILD_ROOT%{_sbindir}/gitlab-ctl
@@ -298,7 +299,7 @@ fi
 
 %ghost %{_sysconfdir}/gitlab/skip-auto-migrations
 %config(noreplace) %verify(not md5 mtime size) /etc/httpd/webapps.d/gitlab.conf
-/etc/logrotate.d/gitlab.logrotate
+/etc/logrotate.d/gitlab
 %attr(754,root,root) /etc/rc.d/init.d/gitlab-sidekiq
 %attr(754,root,root) /etc/rc.d/init.d/gitlab-unicorn
 %attr(755,root,root) %{_sbindir}/gitlab-rake
@@ -339,7 +340,6 @@ fi
 %{appdir}/tmp
 %{appdir}/satellites
 
-%dir %{vardir}
 %{vardir}/.gitconfig
 %dir %attr(755,%{uname},%{gname}) %{vardir}/satellites
 %dir %attr(755,%{uname},%{gname}) %{vardir}/builds
@@ -364,7 +364,6 @@ fi
 %attr(-,%{uname},%{gname}) %{cachedir}/cache
 %dir %attr(750,%{uname},%{gname}) %{cachedir}/artifacts
 
-%dir %attr(771,root,%{gname}) %{_localstatedir}/log/gitlab
 %dir %attr(771,root,%{gname}) %{_localstatedir}/run/gitlab
 
 %defattr(-,root,root,-)
This page took 0.035028 seconds and 4 git commands to generate.