]> git.pld-linux.org Git - packages/feathercoin.git/blame - feathercoin.spec
- up to 0.18.3
[packages/feathercoin.git] / feathercoin.spec
CommitLineData
d71863a9
JB
1# NOTE: "portable wallet" wants BDB 4.8
2#
3# Conditional build:
4%bcond_with ccache # use ccache for building
5%bcond_without gui # Qt5 GUI
6
24d61d02
JB
7Summary: Feathercoin - a peer-to-peer currency
8Summary(pl.UTF-8): Feathercoin - waluta peer-to-peer
0f77417f 9Name: feathercoin
4e6b795e
JR
10Version: 0.18.3
11Release: 1
d71863a9
JB
12License: MIT
13Group: Applications/Networking
14#Source0Download: https://github.com/FeatherCoin/Feathercoin/releases
15Source0: https://github.com/FeatherCoin/Feathercoin/archive/v%{version}/%{name}-%{version}.tar.gz
4e6b795e 16# Source0-md5: e5e3fc683a09ec7c2efc21dda691c402
d27150c9 17Patch0: lib.patch
4e6b795e 18Patch1: qt-5.15.patch
24d61d02 19URL: https://www.feathercoin.com/
d71863a9
JB
20%if %{with gui}
21BuildRequires: Qt5Core-devel >= 5
22BuildRequires: Qt5DBus-devel >= 5
23BuildRequires: Qt5Gui-devel >= 5
24BuildRequires: Qt5Network-devel >= 5
25BuildRequires: Qt5PrintSupport-devel >= 5
26BuildRequires: Qt5Test-devel >= 5
27BuildRequires: Qt5Widgets-devel >= 5
28%endif
29BuildRequires: autoconf >= 2.69
30BuildRequires: automake
d5d03ba6 31BuildRequires: boost-devel >= 1.47.0
d71863a9
JB
32%{?with_ccache:BuildRequires: ccache}
33BuildRequires: db-cxx-devel >= 4.8
34BuildRequires: gettext-tools
35%{?with_gui:BuildRequires: libpng-devel}
d27150c9 36BuildRequires: libsecp256k1-devel
d71863a9 37BuildRequires: libstdc++-devel
d5d03ba6
JB
38BuildRequires: libtool >= 2:2
39BuildRequires: libunivalue-devel >= 1.0.4
0f77417f
AM
40BuildRequires: miniupnpc-devel >= 1.5
41BuildRequires: openssl-devel
d71863a9
JB
42BuildRequires: pkgconfig
43BuildRequires: protobuf-devel
0f77417f 44BuildRequires: qrencode-devel
d71863a9 45%{?with_gui:BuildRequires: qt5-build >= 5}
d5d03ba6 46BuildRequires: zeromq-devel >= 4
d71863a9 47%{?with_gui:BuildRequires: zlib-devel}
d27150c9 48BuildRequires: zxing-cpp-devel
d5d03ba6 49Requires: libunivalue >= 1.0.4
0f77417f
AM
50Requires: perl-base
51BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
d5d03ba6
JB
53# uses nNeoScryptOptions symbol from binaries
54%define skip_post_check_so libbitcoinconsensus.so.*
55
0f77417f 56%description
24d61d02
JB
57Feathercoin is a peer-to-peer currency. Peer-to-peer means that no
58central authority issues new money or tracks transactions. These tasks
59are managed collectively by the network.
60
61%description -l pl.UTF-8
62Feathercoin to waluta peer-to-peer. Peer-to-peer oznacza, że nie ma
63centralnego urzędu, który emituje nowe pieniądze czy śledzi
64transakcje. Zadania te są obsługiwane zespołowo przez sieć.
0f77417f 65
f6a6bc9a
JB
66%package devel
67Summary: Header file for bitcoinconsensus library
68Summary(pl.UTF-8): Plik nagłówkowy biblioteki bitcoinconsensus
69Group: Development/Libraries
70Requires: %{name} = %{version}-%{release}
71Requires: openssl-devel
72Conflicts: bitcoin-devel
73
74%description devel
75Header file for bitcoinconsensus library.
76
77%description devel -l pl.UTF-8
78Plik nagłówkowy biblioteki bitcoinconsensus.
79
80%package static
81Summary: Static bitcoinconsensus library
82Summary(pl.UTF-8): Statyczna biblioteka bitcoinconsensus
83Group: Development/Libraries
84Requires: %{name}-devel = %{version}-%{release}
85Conflicts: bitcoin-static
86
87%description static
88Static bitcoinconsensus library.
89
90%description static -l pl.UTF-8
91Statyczna biblioteka bitcoinconsensus.
92
0f77417f
AM
93%package qt
94Summary: Qt-based Feathercoin Wallet
24d61d02 95Summary(pl.UTF-8): Oparty na Qt portfel Feathercoin
0f77417f
AM
96Group: X11/Applications
97
98%description qt
99Qt-based Feathercoin Wallet.
100
24d61d02
JB
101%description qt -l pl.UTF-8
102Oparty na Qt portfel Feathercoin.
103
0f77417f 104%prep
d71863a9
JB
105%setup -q -n Feathercoin-%{version}
106%patch0 -p1
4e6b795e 107%patch1 -p1
0f77417f
AM
108
109%build
d27150c9
AM
110%{__libtoolize}
111%{__aclocal}
d71863a9
JB
112%{__autoconf}
113%{__autoheader}
114%{__automake}
115# --with-gui defaults to qt4, but it doesn't build (QJsonObject is required)
116%configure \
117 --enable-ccache%{!?with_ccache:=no} \
118 --disable-silent-rules \
d27150c9 119 --with-gui=%{?with_gui:qt5}%{!?with_gui:no} \
f6a6bc9a 120 --with-incompatible-bdb \
d27150c9 121 --with-system-univalue
0f77417f
AM
122
123%{__make}
124
0f77417f
AM
125%install
126rm -rf $RPM_BUILD_ROOT
0f77417f 127
d71863a9
JB
128%{__make} install \
129 DESTDIR=$RPM_BUILD_ROOT
0f77417f 130
f6a6bc9a
JB
131# obsoleted by pkg-config
132%{__rm} $RPM_BUILD_ROOT%{_libdir}/libbitcoinconsensus.la
133
134install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_datadir}/kde4/services}
d5d03ba6
JB
135cat <<EOF >$RPM_BUILD_ROOT%{_desktopdir}/feathercoin-qt.desktop
136[Desktop Entry]
137Encoding=UTF-8
138Name=Feathercoin
139Comment=Feathercoin P2P Cryptocurrency
140Comment[fr]=Feathercoin, monnaie virtuelle cryptographique pair à pair
141Comment[pl]=Feathercoin - kryptowaluta P2P
142Comment[tr]=Feathercoin, eşten eşe kriptografik sanal para birimi
143Exec=feathercoin-qt %u
144Terminal=false
145Type=Application
146Icon=bitcoin128
147MimeType=x-scheme-handler/feathercoin;
148Categories=Office;Finance;
149EOF
150
151cat <<EOF >$RPM_BUILD_ROOT%{_datadir}/kde4/services/feathercoin-qt.protocol
152[Protocol]
153exec=feathercoin-qt '%u'
154protocol=feathercoin
155input=none
156output=none
157helper=true
158listing=
159reading=false
160writing=false
161makedir=false
162deleting=false
163EOF
0f77417f
AM
164
165%clean
166rm -rf $RPM_BUILD_ROOT
167
f6a6bc9a
JB
168%post -p /sbin/ldconfig
169%postun -p /sbin/ldconfig
d27150c9 170
0f77417f
AM
171%files
172%defattr(644,root,root,755)
d5d03ba6 173%doc COPYING README.md doc/*.txt
d71863a9 174%attr(755,root,root) %{_bindir}/feathercoin-cli
d27150c9 175%attr(755,root,root) %{_bindir}/feathercoin-tx
4e6b795e 176%attr(755,root,root) %{_bindir}/feathercoin-wallet
0f77417f 177%attr(755,root,root) %{_bindir}/feathercoind
d71863a9 178%{_mandir}/man1/feathercoin-cli.1*
d27150c9 179%{_mandir}/man1/feathercoin-tx.1*
4e6b795e 180%{_mandir}/man1/feathercoin-wallet.1*
d71863a9 181%{_mandir}/man1/feathercoind.1*
f6a6bc9a 182%attr(755,root,root) %{_libdir}/libbitcoinconsensus.so.*.*.*
d27150c9 183%attr(755,root,root) %ghost %{_libdir}/libbitcoinconsensus.so.0
f6a6bc9a
JB
184
185%files devel
186%defattr(644,root,root,755)
187%attr(755,root,root) %{_libdir}/libbitcoinconsensus.so
188%{_includedir}/bitcoinconsensus.h
189%{_pkgconfigdir}/libbitcoinconsensus.pc
190
191%files static
192%defattr(644,root,root,755)
193%{_libdir}/libbitcoinconsensus.a
0f77417f
AM
194
195%files qt
196%defattr(644,root,root,755)
197%attr(755,root,root) %{_bindir}/feathercoin-qt
198%{_datadir}/kde4/services/feathercoin-qt.protocol
199%{_desktopdir}/feathercoin-qt.desktop
d71863a9 200%{_mandir}/man1/feathercoin-qt.1*
This page took 0.179316 seconds and 4 git commands to generate.