]> git.pld-linux.org Git - packages/eric6.git/blame - eric6.spec
Rel. 2
[packages/eric6.git] / eric6.spec
CommitLineData
50968d52 1%bcond_with python2 # Use python2 (NOTE: as for 17.03.1 it has issuses in PLD)
e2cab009
MK
2
3%define module eric6
4Summary: Eric6 - a full featured Python IDE
5Summary(pl.UTF-8): Eric6 - pełnowartościowe IDE dla Pythona
6# Name must match the python module/package name (as on pypi or in 'import' statement)
7Name: eric6
30e23900 8Version: 17.03.1
13bb2a71 9Release: 2
e2cab009
MK
10License: GPL v3
11Group: Libraries/Python
a9909cc0 12Source0: https://sourceforge.net/projects/eric-ide/files/eric6/stable/%{version}/%{name}-%{version}.tar.gz
30e23900 13# Source0-md5: 4e56a985387cceed981db1ba2579183b
e2cab009
MK
14URL: http://eric-ide.python-projects.org/index.html
15BuildRequires: rpm-pythonprov
50968d52
MK
16BuildRequires: rpmbuild(macros) >= 1.714
17%if %{with python2}
e2cab009
MK
18BuildRequires: python-modules
19BuildRequires: python-setuptools
20# NOTE: As for 6.1.8 eric6 still tries to import PyQt5 while having PyQt4 leading to crash
21# http://die-offenbachs.homelinux.org:48888/issues/issue204
22# for --pyqt=4
e2cab009 23# BuildRequires: python-PyQt4-qscintilla2
5c2f16b8 24# BuildRequires: python-PyQt4-uic
e2cab009
MK
25# for --pyqt=5
26BuildRequires: python-PyQt5-qscintilla2
27BuildRequires: python-PyQt5-uic
2758d547 28Requires: python-PyQt5-qscintilla2
a9909cc0 29Requires: python-modules
50968d52
MK
30Suggests: python-pylint
31%else
32BuildRequires: python3-PyQt5-qscintilla2
33BuildRequires: python3-PyQt5-uic
34BuildRequires: python3-modules
35BuildRequires: python3-setuptools
e585e44e
MK
36# NOTE: Not sure if Qt5Svg should be listed here or be R by other BRs.
37BuildRequires: Qt5Svg
50968d52
MK
38Requires: python3-PyQt5-qscintilla2
39Requires: python3-modules
40Suggests: python3-pylint
41%endif
42
e2cab009
MK
43BuildArch: noarch
44BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46%description
5c2f16b8
MK
47Eric is a Python IDE written using PyQt and QScintilla. It provides
48various features such as any number of open editors, an integrated
49(remote) debugger, project management facilities, unit test,
50refactoring and much more.
e2cab009
MK
51
52%description -l pl.UTF-8
5c2f16b8
MK
53Eric jest pythonowym graficznym środowiskiem programistycznym
54używającym PyQt i QScintilla.
e2cab009
MK
55
56%prep
57%setup -q
58
59%build
60
61%install
62rm -rf $RPM_BUILD_ROOT
50968d52 63%if %{with python2}
e2cab009 64python install.py -z -c -b %{_bindir} -d %{py_sitescriptdir} -i $RPM_BUILD_ROOT --pyqt=5
50968d52
MK
65%else
66python3 install.py -z -c -b %{_bindir} -d %{py3_sitescriptdir} -i $RPM_BUILD_ROOT --pyqt=5
67%endif
a9909cc0
MK
68mkdir $RPM_BUILD_ROOT%{_datadir}/appdata
69mv $RPM_BUILD_ROOT%{_datadir}/metainfo/eric6.appdata.xml $RPM_BUILD_ROOT%{_datadir}/appdata
e2cab009
MK
70
71%clean
72rm -rf $RPM_BUILD_ROOT
73
e2cab009
MK
74%files
75%defattr(644,root,root,755)
76%doc README.rst
50968d52 77%if %{with python2}
e2cab009 78%{py_sitescriptdir}/%{module}
50968d52
MK
79%else
80%{py3_sitescriptdir}/%{module}
81%endif
82
e2cab009
MK
83%attr(755,root,root) %{_bindir}/eric6
84%attr(755,root,root) %{_bindir}/eric6_*
85# for --pyqt=4
5c2f16b8
MK
86# %{_datadir}/qt4/qsci/api/qss/
87# %{_datadir}/qt4/qsci/api/ruby/
d5275b1c 88# NOTE: file %{_datadir}/qt4/qsci/api/ruby/Ruby-1.8.7.api from install of eric6-6.1.8-0.1.noarch conflicts with file from package eric4-4.5.24-3.noarch
5c2f16b8
MK
89# %{_datadir}/qt4/qsci/api/python/eric6.*
90# %{_datadir}/qt4/qsci/api/python/zope-*.api
e2cab009
MK
91
92# for --pyqt=5
5c2f16b8
MK
93%{_datadir}/qt5/qsci/api/qss/
94%{_datadir}/qt5/qsci/api/ruby/
95%{_datadir}/qt5/qsci/api/python/eric6.*
96%{_datadir}/qt5/qsci/api/python/zope-*.api
e2cab009 97
5c2f16b8
MK
98%{_pixmapsdir}/eric*.png
99%{_desktopdir}/eric6.desktop
100%{_desktopdir}/eric6_webbrowser.desktop
fd4f94e0 101%{_desktopdir}/eric6_browser.desktop
a9909cc0 102%{_datadir}/appdata/eric6.appdata.xml
50968d52 103%if %{with python2}
5c2f16b8
MK
104%{py_sitescriptdir}/eric6config.py
105%{py_sitescriptdir}/eric6plugins
50968d52
MK
106%else
107%{py3_sitescriptdir}/eric6config.py
108%{py3_sitescriptdir}/eric6plugins
109%endif
This page took 0.303987 seconds and 4 git commands to generate.