]> git.pld-linux.org Git - packages/cwiid.git/blame - cwiid.spec
disable ldconfig via configure option
[packages/cwiid.git] / cwiid.spec
CommitLineData
3e3a7450
ER
1%define subver fadf11e
2%define rel 1
3Summary: Wiimote interface library
4Name: cwiid
5Version: 0.6.00
6Release: 0.%{rel}.%{subver}
7License: GPL v2+
8Group: Libraries
9#Source0: https://github.com/abstrakraft/cwiid/archive/%{name}-%{version}/%{name}-%{version}.tar.gz
10Source0: https://github.com/abstrakraft/cwiid/archive/%{subver}/%{name}-%{version}-%{subver}.tar.gz
11# Source0-md5: 2d5430a465357242514942ae82139609
12Source1: wmgui.desktop
13Patch0: wmdemo-lib.patch
14URL: http://abstrakraft.org/cwiid/
15BuildRequires: autoconf
16BuildRequires: automake
17BuildRequires: bison
18BuildRequires: bluez-libs-devel
19BuildRequires: desktop-file-utils
20BuildRequires: flex
21BuildRequires: gawk
22BuildRequires: gtk+2-devel
23BuildRequires: python-devel >= 2.4
24BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26%description
27CWiiD is a library that enables your application to communicate with a
28wiimote using a bluetooth connection.
29
30%package devel
31Summary: Development files for %{name}
32Group: Development/Libraries
33Requires: %{name} = %{version}-%{release}
34Requires: bluez-libs-devel
35
36%description devel
37The %{name}-devel package contains libraries and header files for
38developing applications that use %{name}.
39
40%package -n python-%{name}
41Summary: Python binding for %{name}
42Group: Development/Languages
43Requires: %{name} = %{version}-%{release}
44Obsoletes: %{name}-python2
45
46%description -n python-%{name}
47Python2 binding for %{name}
48
49%package utils
50Summary: Wiimote connection test application
51Group: Applications/System
52Requires: %{name} = %{version}-%{release}
53Provides: %{name}-wmgui = %{version}-%{release}
54Obsoletes: cwiid-wmgui < 0.6.00-7
55
56%description utils
57Applications to test the wiimote connection
58
59%package wminput
60Summary: Enables using the wiimote as an input source
61# The licence must be GPLv2 instead of GPLv2+ for this package
62# since the file wminput/action_enum.txt is GPLv2 as stated
63# in the file.
64License: GPL v2
65Group: Applications/System
66Requires: %{name} = %{version}-%{release}
67Requires: python-%{name} = %{version}-%{release}
68
69%description wminput
70This program allows the user to use the wiimote to emulate normal
71system input sources like the mouse and keyboard.
72
73%prep
74%setup -qc
75mv %{name}-*/* .
76%patch0 -p1
77
78%build
79%{__aclocal}
80%{__autoconf}
81CC="%{__cc} %{rpmcflags}"
fdb1303c
ER
82%configure \
83 --disable-ldconfig
3e3a7450
ER
84%{__make}
85
86%install
87rm -rf $RPM_BUILD_ROOT
88%{__make} install \
3e3a7450
ER
89 DESTDIR=$RPM_BUILD_ROOT
90
91%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
92
93rm -v $RPM_BUILD_ROOT%{_libdir}/libcwiid.a
94
95desktop-file-install --dir=$RPM_BUILD_ROOT%{_desktopdir} %{SOURCE1}
96
97%clean
98rm -rf $RPM_BUILD_ROOT
99
100%post -p /sbin/ldconfig
101%postun -p /sbin/ldconfig
102
103%files
104%defattr(644,root,root,755)
105%doc AUTHORS NEWS README COPYING ChangeLog
106%attr(755,root,root) %{_libdir}/libcwiid.so.1.0
107%ghost %{_libdir}/libcwiid.so.1
108
109%files devel
110%defattr(644,root,root,755)
111%{_includedir}/cwiid.h
112%{_libdir}/libcwiid.so
113%{_pkgconfigdir}/cwiid.pc
114
115%files -n python-%{name}
116%defattr(644,root,root,755)
117%attr(755,root,root) %{py_sitedir}/cwiid.so
118%{py_sitedir}/cwiid-%{version}-py*.egg-info
119
120%files wminput
121%defattr(644,root,root,755)
122%doc doc/Xmodmap doc/wminput.list
123%dir %{_sysconfdir}/cwiid
124%dir %{_sysconfdir}/cwiid/wminput
125%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cwiid/wminput/acc_led
126%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cwiid/wminput/acc_ptr
127%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cwiid/wminput/buttons
128%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cwiid/wminput/default
129%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cwiid/wminput/gamepad
130%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cwiid/wminput/ir_ptr
131%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cwiid/wminput/neverball
132%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cwiid/wminput/nunchuk_acc_ptr
133%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/cwiid/wminput/nunchuk_stick2btn
134%attr(755,root,root) %{_bindir}/wminput
135%{_mandir}/man1/wminput.1*
136%dir %{_libdir}/%{name}
137%dir %{_libdir}/%{name}/plugins
138%attr(755,root,root) %{_libdir}/%{name}/plugins/acc.so
139%attr(755,root,root) %{_libdir}/%{name}/plugins/ir_ptr.so
140%attr(755,root,root) %{_libdir}/%{name}/plugins/led.so
141%attr(755,root,root) %{_libdir}/%{name}/plugins/nunchuk_acc.so
142%attr(755,root,root) %{_libdir}/%{name}/plugins/nunchuk_stick2btn.so
143
144%files utils
145%defattr(644,root,root,755)
146%attr(755,root,root) %{_bindir}/lswm
147%attr(755,root,root) %{_bindir}/wmgui
148%{_mandir}/man1/wmgui.1*
149%{_desktopdir}/wmgui.desktop
This page took 0.103066 seconds and 4 git commands to generate.