]> git.pld-linux.org Git - packages/curl.git/blobdiff - curl.spec
bump required libssh2 version to 1.11.0
[packages/curl.git] / curl.spec
index f343b7d8ece6a5ab8784dd4bc889d0e98752b5c9..fa3d20378486c73453a626f0b32a0cca3670187f 100644 (file)
--- a/curl.spec
+++ b/curl.spec
@@ -1,4 +1,4 @@
-# TODO: ngtpc2/nghttp3 when ready (packages released, support working in curl) or quiche
+# TODO: ngtpc2/nghttp3 or quiche or msh3 for HTTP3?
 #
 # Conditional build:
 %bcond_without ssh             # SSH support
@@ -8,6 +8,7 @@
 %bcond_without kerberos5       # Heimdal Kerberos 5 support
 %bcond_without ldap            # LDAP support
 %bcond_without http2           # HTTP/2.0 support (nghttp2 based)
+%bcond_with    http3           # HTTP/3.0 support (nghttp3/ngtcp2 based)
 %if "%{pld_release}" != "ac"
 %bcond_without ares            # c-ares (asynchronous DNS operations) library support
 %bcond_without rtmp            # Real Time Media Protocol support
@@ -23,15 +24,15 @@ Summary(pt_BR.UTF-8):       Busca URL (suporta FTP, TELNET, LDAP, GOPHER, DICT, HTTP e
 Summary(ru.UTF-8):     Утилита для получения файлов с серверов FTP, HTTP и других
 Summary(uk.UTF-8):     Утиліта для отримання файлів з серверів FTP, HTTP та інших
 Name:          curl
-Version:       7.82.0
+Version:       8.2.1
 Release:       1
 License:       MIT-like
 Group:         Applications/Networking
-Source0:       https://curl.haxx.se/download/%{name}-%{version}.tar.xz
-# Source0-md5: ce05eb61ef7c398feb7dbe23122d0bd9
+Source0:       https://curl.se/download/%{name}-%{version}.tar.xz
+# Source0-md5: 556576a795bdd2c7d10de6886480065f
 Patch0:                %{name}-ac.patch
 Patch1:                %{name}-krb5flags.patch
-URL:           http://curl.haxx.se/
+URL:           https://curl.se/
 BuildRequires: autoconf >= 2.57
 BuildRequires: automake
 %{?with_ares:BuildRequires:    c-ares-devel >= 1.17.0}
@@ -41,10 +42,13 @@ BuildRequires:      libbrotli-devel >= 1.0.0
 BuildRequires: libidn2-devel
 BuildRequires: libpsl-devel
 %{?with_rtmp:BuildRequires:    librtmp-devel}
-%{?with_ssh:BuildRequires:     libssh2-devel >= 1.2.8}
+%{?with_ssh:BuildRequires:     libssh2-devel >= 1.11.0}
 BuildRequires: libtool
 BuildRequires: nettle-devel
-%{?with_http2:BuildRequires:   nghttp2-devel >= 1.12.0}
+%{?with_http2:BuildRequires:   nghttp2-devel >= 1.15.0}
+%{?with_http3:BuildRequires:   nghttp3-devel}
+# with gnutls or openssl crypto, conforming to chosen curl crypto library
+%{?with_http3:BuildRequires:   ngtcp2-devel}
 %{?with_ldap:BuildRequires:    openldap-devel}
 BuildRequires: pkgconfig
 BuildRequires: rpm >= 4.4.9-56
@@ -62,7 +66,7 @@ BuildRequires:        xz
 BuildRequires: zlib-devel
 BuildRequires: zstd-devel
 Requires:      %{name}-libs = %{version}-%{release}
-Obsoletes:     libcurl2
+Obsoletes:     libcurl2 < 7.12
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -120,8 +124,8 @@ Summary(pl.UTF-8):  Biblioteka curl
 Group:         Libraries
 %{?with_ares:Requires: c-ares >= 1.17.0}
 %{?with_gnutls:Requires:       gnutls-libs >= 3.1.10}
-%{?with_ssh:Requires:  libssh2 >= 1.2.8}
-%{?with_http2:Requires:        nghttp2-libs >= 1.12.0}
+%{?with_ssh:Requires:  libssh2 >= 1.11.0}
+%{?with_http2:Requires:        nghttp2-libs >= 1.15.0}
 %if %{with ssl} && %{without gnutls}
 Requires:      libbrotli >= 1.0.0
 Requires:      openssl >= 1.0.1
@@ -142,7 +146,7 @@ Summary(pt_BR.UTF-8):       Arquivos de cabeçalho e bibliotecas de desenvolvimento
 Summary(ru.UTF-8):     Файлы для разработки с использованием библиотеки curl
 Summary(uk.UTF-8):     Файли для розробки з використанням бібліотеки curl
 Group:         Development/Libraries
-Requires:      %{name}-libs = %{version}-%{release}
+Requires:      %{name}-libs%{?_isa} = %{version}-%{release}
 %{?with_ares:Requires: c-ares-devel}
 %{?with_gsasl:Requires:        gsasl-devel}
 %{?with_kerberos5:Requires:    heimdal-devel}
@@ -150,8 +154,8 @@ Requires:   libbrotli-devel >= 1.0.0
 Requires:      libidn2-devel
 Requires:      libpsl-devel
 %{?with_rtmp:Requires: librtmp-devel}
-%{?with_ssh:Requires:  libssh2-devel >= 1.2.8}
-%{?with_http2:Requires:        nghttp2-devel >= 1.12.0}
+%{?with_ssh:Requires:  libssh2-devel >= 1.11.0}
+%{?with_http2:Requires:        nghttp2-devel >= 1.15.0}
 %{?with_ldap:Requires: openldap-devel}
 %if %{with ssl}
 %if %{with gnutls}
@@ -162,7 +166,7 @@ Requires:   openssl-devel >= 0.9.7c
 %endif
 Requires:      zlib-devel
 Requires:      zstd-devel
-Obsoletes:     libcurl2-devel
+Obsoletes:     libcurl2-devel < 7.12
 
 %description devel
 Header files and development documentation for curl library.
@@ -251,11 +255,13 @@ Dopełnianianie parametrów w ZSH dla polecenia curl.
 %configure \
        ac_cv_header_gss_h=no \
        %{__enable_disable ares} \
-       %{__enable_disable gsasl} \
+       %{__with_without gsasl libgsasl} \
+       --enable-headers-api \
        --enable-ipv6 \
        %{__enable_disable ldap} \
        %{__enable_disable ldap ldaps} \
        --disable-silent-rules \
+       --enable-websockets \
 %if %{with ssl}
        --with-ca-bundle=/etc/certs/ca-certificates.crt \
 %if %{with gnutls}
@@ -270,6 +276,8 @@ Dopełnianianie parametrów w ZSH dla polecenia curl.
        %{__with_without kerberos5 gssapi %{_prefix}} \
        %{__with_without rtmp librtmp} \
        %{__with_without http2 nghttp2} \
+       %{__with_without http3 nghttp3} \
+       %{__with_without http3 ngtcp2} \
        %{__with_without ssh libssh2}
 
 %{__make}
This page took 0.038522 seconds and 4 git commands to generate.