]> git.pld-linux.org Git - packages/crossmingw32-bzip2.git/blobdiff - crossmingw32-bzip2.spec
- adjusted patch instead of spec hacking
[packages/crossmingw32-bzip2.git] / crossmingw32-bzip2.spec
index b78f5f1271060a35ac1b9ef18873da57d4446fb5..d9a97d637561f6365a25e98dd2ccc35089df2ef8 100644 (file)
@@ -35,6 +35,9 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 # arch-specific flags (like alpha's -mieee) are not valid for i386 gcc
 %define                optflags        -O2
 %endif
+# -z options are invalid for mingw linker, most of -f options are Linux-specific
+%define                filterout_ld    -Wl,-z,.*
+%define                filterout_c     -f[-a-z0-9=]*
 
 %description
 Bzip2 compresses files using the Burrows-Wheeler block-sorting text
@@ -115,24 +118,12 @@ Group:            Applications/Emulators
 %patch0 -p1
 
 %build
-AR=%{target}-ar
-RANLIB=%{target}-ranlib
-
 %{__make} \
-       AR="$AR" \
-       RANLIB="$RANLIB" \
+       AR="%{target}-ar" \
+       RANLIB="%{target}-ranlib" \
        CC="%{__cc}" \
        CFLAGS="%{rpmcflags} -Wall \$(BIGFILES)"
 
-# makefile made libbz2.a as DLL import library...
-# recreate libbz2.dll.a as import library and libbz2.a as static
-%{__rm} libbz2.a libbz2.dll
-
-OBJS="blocksort.o huffman.o crctable.o randtable.o compress.o decompress.o bzlib.o"
-$AR cru libbz2.a $OBJS
-$RANLIB libbz2.a
-%{target}-dllwrap --def libbz2.def --implib libbz2.dll.a -o bzip2.dll $OBJS
-
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir},%{_dlldir}}
This page took 0.041872 seconds and 4 git commands to generate.