]> git.pld-linux.org Git - packages/bash.git/blame - bash.spec
- rel 2; additional non-upstream hardening (from FC)
[packages/bash.git] / bash.spec
CommitLineData
b92ff090 1#
cb14c662 2# Conditional build:
a651f1c4
JB
3%bcond_without static # don't build static version
4%bcond_with bash_history # build with additional history in /var/log/bash_hist ;)
e407816c 5%bcond_without tests # do not perform "make test"
4adb4b80 6
37b19da9 7# NOTE: when updating patchleve, do not forget to update 'sources' file!
0c16d439 8%define ver 4.3
f2f33bf1 9%define patchlevel 26
d6f116f1 10%define rel 2
7d6d2b69 11Summary: GNU Bourne Again Shell (bash)
dcd748fa
ER
12Summary(fr.UTF-8): Le shell Bourne Again de GNU
13Summary(pl.UTF-8): Powłoka GNU Bourne Again Shell (bash)
7d6d2b69 14Name: bash
03cee40d 15Version: %{ver}%{?patchlevel:.%{patchlevel}}
8bd2c87f 16Release: %{rel}%{?with_bash_history:inv}
4e122b9a 17License: GPL
23ed535f 18Group: Applications/Shells
ec429726 19Source0: http://ftp.gnu.org/gnu/bash/%{name}-%{ver}.tar.gz
0c16d439 20# Source0-md5: 81348932d5da294953e15d4814c74dd1
23ed535f 21Source1: %{name}rc
678800bc
JB
22Source2: %{name}-skel-.bash_logout
23Source3: %{name}-skel-.bash_profile
24Source4: %{name}-skel-.bashrc
df8b9a69 25Source5: http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
60c0b40e 26# Source5-md5: d2aacf89c4a444c5da648da69afdb01a
23ed535f 27Patch0: %{name}-paths.patch
070ee007 28Patch1: %{name}-security.patch
29Patch2: %{name}-autoconf.patch
30Patch3: %{name}-info.patch
31Patch4: %{name}-profile.patch
32Patch5: %{name}-requires.patch
33Patch6: %{name}-compat.patch
60c0b40e
JB
34Patch8: %{name}-sighup.patch
35Patch9: %{name}-backup_history.patch
716158f0 36Patch10: %{name}-act_like_sh.patch
232f944c 37Patch11: %{name}-elinks_cont.patch
678800bc 38Patch12: %{name}-pl.po-update.patch
d6f116f1
AM
39# http://www.openwall.com/lists/oss-security/2014/09/25/13 ; patches from FC
40Patch13: bash-4.2-cve-2014-7169-1.patch
41Patch14: bash-4.2-cve-2014-7169-2.patch
0237e5f4 42%patchset_source -f https://ftp.gnu.org/gnu/bash/bash-4.3-patches/bash43-%03g 1 %{patchlevel}
8cdc40d7 43URL: http://www.gnu.org/software/bash/
0422a072 44BuildRequires: autoconf
c0ebe85a 45BuildRequires: automake
0422a072 46BuildRequires: bison
de477a4d 47BuildRequires: ncurses-devel >= 5.2
0c16d439 48BuildRequires: readline-devel >= 6.3
41a1b1c8 49BuildRequires: rpmbuild(macros) >= 1.462
ccf2597d 50BuildRequires: sed >= 4.0
6b611e4d 51BuildRequires: texinfo
cf6e8919 52%if %{with static}
de477a4d 53# Require static library only for static build
0422a072 54BuildRequires: glibc-static >= 2.2
4e122b9a 55BuildRequires: ncurses-static >= 5.2
0c16d439 56BuildRequires: readline-static >= 6.3
de477a4d 57%endif
0c16d439 58Requires: readline >= 6.3
0c55bbdc 59Requires: setup >= 2.4.6-2
0b28b541 60Obsoletes: bash-doc
f40d50c2 61Obsoletes: bash2
62Obsoletes: bash2-doc
0b28b541 63Obsoletes: etcskel
60c0b40e 64BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67581caa 65
66%description
001c539f 67Bash is a GNU project sh-compatible shell or command language
68interpreter. Bash (Bourne Again shell) incorporates useful features
69from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
70be run by bash without modification. Bash offers several improvements
71over sh, including command line editing, unlimited size command
72history, job control, shell functions and aliases, indexed arrays of
73unlimited size and integer arithmetic in any base from two to 64. Bash
74is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
75Shell and Tools standard. Bash is the default shell for Linux
76Mandrake. You should install bash because of its popularity and power.
77You'll probably end up using it.
a3871122 78
ef6e8bca 79%description -l es.UTF-8
1d0ad239 80Bash es un interpretador de comandos compatible con sh, que ejecuta
ef6e8bca
JR
81comandos leídos de la entrada padrón o de un archivo. Bash también
82incorpora características útiles de las shells Korn y C (ksh y csh).
83Bash ha sido desarrollado para ser una adición compatible con la
84especificación IEEE Posix para shells y herramientas (IEEE Working
1d0ad239 85Group 1003.2).
86
ef6e8bca 87%description -l de.UTF-8
001c539f 88Bash ist eine sh-kompatible Shell und Kommandosprache aus dem
ef6e8bca 89GNU-Projekt. Bash (Bourne Again Shell) vereinigt die nützlichen
001c539f 90Features aus der Korn-Shell (ksh) und der C-Shell (csh). Die meisten
ef6e8bca 91sh-Skripte laufen ohne Änderungen auf bash. Bash hat viele
001c539f 92Erweiterungen im Vergleich zur "normalen" sh, wie z.B.
ef6e8bca
JR
93Kommandozeilenbearbeitung, unbeschränkte Größe der command-history,
94Job-Kontrolle, Shell-Funktionen und -Aliase, unbegrenzt große
001c539f 95indizierte Arrays und Integer-Arithmetik in einer Basis von 2 bis 64.
96Hauptziel von bash ist es, den IEEE POSIX P1003.2/ISO 9945.2 Shell-
ef6e8bca 97und Tools-Standard einzuhalten. Bash ist die Standard-Shell für Linux
8a4ad51c 98Mandrake.
a3871122 99
ef6e8bca
JR
100%description -l fr.UTF-8
101Bash est un shell (interpréteur de commande) du projet GNU, compatible
001c539f 102avec le shell historique sh. Bash (Bourne Again SHell) comprend de
ef6e8bca
JR
103nombreuses fonctionnalités du Korn SHell (ksh) et du C SHell (csh). La
104plupart des scripts sh sont exécutables sans modifications. Bash
105comprend nombre d'améliorations par rapport à sh : édition de la ligne
106de commande, historique illimité, contrôle des processus
107d'arrière-plan, fonctions de shell, alias, tableaux indexés de taille
108illimitée et calcul sur des entiers dans n'importe quelle base de 2 à
001c539f 10964. Bash est conforme au standard IEEE POSIX P1003.2/ISO 9945.2 Shell
ef6e8bca
JR
110and Tools. Bash est le shell par défaut de Mandrake. Vous devriez
111l'installer du fait de sa puissance et de sa popularité. Vous finirez
001c539f 112probablement par l'utiliser.
7d6d2b69 113
ef6e8bca
JR
114%description -l pl.UTF-8
115Bash (Bourne Again SHell) jest projektem GNU powłoki kompatybilnej z
116sh oraz interpretera języka poleceń. Posiada użyteczne właściwości
117powłok Korn (ksh) i C (csh). Większość skryptów sh może być
118uruchamiana w bashu bez modyfikacji. Oferuje on kilka ulepszeń w
119stosunku do sh, włączając edycję linii poleceń, nieograniczony rozmiar
120historii poleceń, funkcje i aliasy, indeksowane tablice
121nieograniczonych rozmiarów oraz arytmetykę całkowitoliczbową o
122dowolnej podstawie od 2 do 64. W zamierzeniu ostatecznie ma być zgodny
4d6d135d 123ze standardem IEEE POSIX P1003.2/ISO 9945.2 Shell and Tools.
67581caa 124
ef6e8bca
JR
125%description -l pt_BR.UTF-8
126Bash é um interpretador de comandos compatível com sh, que executa
127comandos lidos da entrada padrão ou de um arquivo. Bash também
128incorpora características úteis das shells Korn e C (ksh e csh). Bash
129tem sido desenvolvido para ser uma implementação compatível com a
130especificação IEEE Posix para shells e ferramentas (IEEE Working Group
1d0ad239 1311003.2).
132
ef6e8bca
JR
133%description -l ru.UTF-8
134Bash - это sh-совместимый интерпретатор командного языка (shell),
135исполняющий команды, поступающие со стандартного ввода или из файла.
136Bash включает полезные расширения из интерпретаторов Korn и C shell
137(ksh и csh).
1d0ad239 138
ef6e8bca 139Bash разрабатывается как реализация, отвечающая IEEE Posix Shell and
1d0ad239 140Tools specification (IEEE Working Group 1003.2).
141
ef6e8bca
JR
142%description -l tr.UTF-8
143Bash standart girişten ya da bir dosyadan komut okuyup çalıştıran sh
144uyumlu bir komut dili yorumlayıcısıdır. Aynı zamanda Korn ve C
145kabuklarının (ksh ve csh) kullanışlı özelliklerini de kapsar. Bash,
146IEEE Posix Kabuk ve Araç ayrıntılarına (IEEE Working Group 1003.2)
147uyumlu bir uygulama olarak tasarlanmıştır.
67581caa 148
ef6e8bca
JR
149%description -l uk.UTF-8
150Bash - це sh-сумістний інтерпретатор командної мови (shell),
151виконуючий команди зі стандартного вводу або з файла. Bash містить
152користні розширення з інтерпретаторів Korn та C shell (ksh та csh).
1d0ad239 153
ef6e8bca 154Bash розроблявся як реалізація, що відповідає IEEE Posix Shell and
1d0ad239 155Tools specification (IEEE Working Group 1003.2).
156
4f62851f 157%package static
0d32bda9 158Summary: Statically linked GNU Bourne Again Shell (bash)
dcd748fa 159Summary(pl.UTF-8): Statycznie skonsolidowany GNU Bourne Again Shell (bash)
23ed535f 160Group: Applications/Shells
80a4c26d 161Requires: %{name} = %{version}-%{release}
4f62851f
JR
162
163%description static
001c539f 164Bash is a GNU project sh-compatible shell or command language
165interpreter. Bash (Bourne Again shell) incorporates useful features
166from the Korn shell (ksh) and the C shell (csh). Most sh scripts can
167be run by bash without modification. Bash offers several improvements
168over sh, including command line editing, unlimited size command
169history, job control, shell functions and aliases, indexed arrays of
170unlimited size and integer arithmetic in any base from two to 64. Bash
171is ultimately intended to conform to the IEEE POSIX P1003.2/ISO 9945.2
172Shell and Tools standard. Bash is the default shell for Linux
173Mandrake. You should install bash because of its popularity and power.
2f1a3089 174You'll probably end up using it. This package contains statically
c59be5db 175linked version of bash.
4f62851f 176
ef6e8bca
JR
177%description static -l pl.UTF-8
178Bash jest zaawansowaną powłoką, która wykonuje komendy czytane ze
179standardowego wejścia (stdin) lub z pliku. Posiada właściwości powłok
180Korn i C (ksh i csh). Bash jest również zaimplementowany IEEE Posix
181Shell oraz jest zgodny ze specyfikacją - IEEE Working Group 1003.2. W
97eb1e25 182tym pakiecie jest wersja basha skonsolidowana statycznie.
4f62851f 183
67581caa 184%prep
8bd2c87f 185%setup -q -n %{name}-%{ver} -a5
e588d508 186# official patches
03cee40d 187%{?patchlevel:%patchset_patch 1 %{patchlevel}}
7d6d2b69 188%patch0 -p1
189%patch1 -p1
190%patch2 -p1
191%patch3 -p1
0e4146b6 192%patch4 -p1
6ff1ee53 193%patch5 -p1
de76156e 194%patch6 -p1
c23570b7 195%patch8 -p1
60c0b40e 196%{?with_bash_history:%patch9 -p1}
f2c0c7f0 197%patch10 -p1
232f944c 198%patch11 -p1
b92ff090 199%patch12 -p1
d6f116f1
AM
200%patch13 -p0
201%patch14 -p0
4dfcefcb 202
322c0adb
AM
203sed -i -e 's#/usr/bin/printf#/bin/printf#g' tests/intl2.sub
204
67581caa 205%build
80a4c26d 206cp -f /usr/share/automake/config.* support
f2c0c7f0 207%{__autoconf}
cf6e8919 208for mode in %{?with_static:static} shared; do
a3871122 209%configure \
7d6d2b69 210 --enable-alias \
211 --enable-help-builtin \
212 --enable-history \
213 --enable-job-control \
214 --enable-restricted \
67581caa 215 --enable-readline \
e301b341 216 --with-curses \
217 --enable-extended-glob \
96160a7f 218 --enable-dparen-arithmetic \
c70eed6a 219 --enable-separate-helpfiles \
2246337a 220 --without-bash-malloc \
d7465fdf 221 $([ "$mode" = "static" ] && echo "--enable-static-link") \
61e3c662 222 --with-installed-readline
31838660 223
80a4c26d
JB
224%{__make} \
225 DEFS="-DHAVE_CONFIG_H -D_GNU_SOURCE"
c23570b7 226
d7465fdf 227[ "$mode" = "static" ] && mv -f bash bash.static
c23570b7 228done
67581caa 229
e407816c
ER
230%{?with_tests:%{__make} tests}
231
67581caa 232%install
5b3ea703 233rm -rf $RPM_BUILD_ROOT
c70eed6a 234install -d $RPM_BUILD_ROOT{/bin,/etc/skel,%{_datadir}/%{name}}
cf6e8919 235%{?with_bash_history:install -d $RPM_BUILD_ROOT/var/log/bash_hist}
83cdd671 236
2e52df12
PG
237%{__make} install \
238 DESTDIR=$RPM_BUILD_ROOT
7d6d2b69 239
5b3ea703 240mv -f $RPM_BUILD_ROOT%{_bindir}/bash $RPM_BUILD_ROOT/bin
a651f1c4 241%{?with_static:install bash.static $RPM_BUILD_ROOT/bin}
e301b341 242
5b3ea703 243install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/bashrc
001c539f 244echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/man1/rbash.1
245
1e516eb0 246for d in es fr it ja ko nl pl ; do
6bcdcdc6
JB
247 install -d $RPM_BUILD_ROOT%{_mandir}/$d/man1
248 install man/$d/* $RPM_BUILD_ROOT%{_mandir}/$d/man1
249 echo .so bash.1 > $RPM_BUILD_ROOT%{_mandir}/$d/man1/rbash.1
250done
251
7a3d4a72 252ln -sf bash $RPM_BUILD_ROOT/bin/rbash
67581caa 253
5b3ea703
TP
254install %{SOURCE2} $RPM_BUILD_ROOT/etc/skel/.bash_logout
255install %{SOURCE3} $RPM_BUILD_ROOT/etc/skel/.bash_profile
256install %{SOURCE4} $RPM_BUILD_ROOT/etc/skel/.bashrc
cd415c53 257rm -f $RPM_BUILD_ROOT%{_infodir}/dir
8f301559 258
d5597b0f
ER
259# use our bugtracker, upstream will ignore reports from this anyway
260rm -f $RPM_BUILD_ROOT%{_bindir}/bashbug
261
60c0b40e
JB
262%find_lang %{name}
263
7a3d4a72
JB
264%clean
265rm -rf $RPM_BUILD_ROOT
266
41a1b1c8
ER
267%post -p <lua>
268%lua_add_etc_shells /bin/bash /bin/rbash
b77458b2 269os.execute("/usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1")
7d6d2b69 270
41a1b1c8
ER
271%preun -p <lua>
272if arg[2] == 0 then
273 %lua_remove_etc_shells /bin/bash /bin/rbash
274end
4f62851f 275
27fc3f6e
ER
276%postun -p /sbin/postshell
277-/usr/sbin/fix-info-dir -c %{_infodir}
f358ed26 278
41a1b1c8
ER
279%post static -p <lua>
280%lua_add_etc_shells /bin/bash.static
281
282%preun static -p <lua>
283if arg[2] == 0 then
284 %lua_remove_etc_shells /bin/bash.static
285end
ee4033f9 286
60c0b40e 287%files -f %{name}.lang
7d6d2b69 288%defattr(644,root,root,755)
60c0b40e 289%doc CHANGES NEWS README doc/{FAQ,INTRO}
7d6d2b69 290
3eb3ef3a
ER
291%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bashrc
292%config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bash_logout
293%config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bash_profile
294%config(noreplace,missingok) %verify(not md5 mtime size) /etc/skel/.bashrc
7d6d2b69 295
96160a7f 296%attr(755,root,root) /bin/bash
297%attr(755,root,root) /bin/rbash
7d6d2b69 298
b26f8c7c 299%{?with_bash_history:%attr(1733,root,root) %dir /var/log/bash_hist}
dd7e7833 300%{_infodir}/bash.info*
8e2e3651 301%{_mandir}/man1/*
1e516eb0 302%lang(es) %{_mandir}/es/man1/*
6bcdcdc6
JB
303%lang(fr) %{_mandir}/fr/man1/*
304%lang(it) %{_mandir}/it/man1/*
305%lang(ja) %{_mandir}/ja/man1/*
306%lang(ko) %{_mandir}/ko/man1/*
307%lang(nl) %{_mandir}/nl/man1/*
308%lang(pl) %{_mandir}/pl/man1/*
38cd3b3d
ER
309%dir %{_datadir}/%{name}
310%doc %{_datadir}/%{name}/*
67581caa 311
a651f1c4
JB
312%if %{with static}
313%files static
314%defattr(644,root,root,755)
315%attr(755,root,root) /bin/bash.static
316%endif
This page took 0.08473 seconds and 4 git commands to generate.