]> git.pld-linux.org Git - packages/avr_simulator.git/blame - avr_simulator.spec
- for 1.3.0
[packages/avr_simulator.git] / avr_simulator.spec
CommitLineData
54518591
MP
1#
2# Conditional build:
3%bcond_with tests # build with tests
4%bcond_without tests # build without tests
5#
6Summary: avr simulator
7Name: avr_simulator
8Version: 1.3.0
9Release: 0.1
10License: GPL v2+
11Group: Applications
12Source0: http://dl.sourceforge.net/avr/%{name}-%{version}.tar.gz
13# Source0-md5: 2a73a98db3bf97013acc75324eb005f7
14Patch0: %{name}-quick.patch
15Patch1: %{name}-DESTDIR.patch
16Patch2: %{name}-install.patch
17URL: http://sourceforge.net/projects/avr/
18BuildRequires: motif-devel
19#BuildRequires: autoconf
20#BuildRequires: automake
21#BuildRequires: intltool
22#BuildRequires: libtool
23#Requires(postun): -
24#Requires(pre,post): -
25#Requires(preun): -
26#Requires: -
27#Provides: -
28#Provides: group(foo)
29#Provides: user(foo)
30#Obsoletes: -
31#Conflicts: -
32#BuildArch: noarch
33#ExclusiveArch: %{ix86}
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36%description
37
38%prep
39%setup -q -n %{name}
40%patch0 -p1
41%patch1 -p1
42%patch2 -p1
43
44# undos the source
45#find '(' -name '*.php' -o -name '*.inc' ')' -print0 | xargs -0 %{__sed} -i -e 's,\r$,,'
46
47# remove CVS control files
48#find -name CVS -print0 | xargs -0 rm -rf
49
50# you'll need this if you cp -a complete dir in source
51# cleanup backups after patching
52find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
53
54%build
55# if ac/am/* rebuilding is necessary, do it in this order and add
56# appropriate BuildRequires
57#%%{__intltoolize}
58#%%{__gettextize}
59#%%{__libtoolize}
60#%%{__aclocal}
61#%%{__autoconf}
62#%%{__autoheader}
63#%%{__automake}
64# if not running libtool or automake, but config.sub is too old:
65#cp -f /usr/share/automake/config.sub .
66#%%configure
67%{__make} \
68 CFLAGS="%{rpmcflags}" \
69 LDFLAGS="%{rpmldflags}"
70
71%install
72rm -rf $RPM_BUILD_ROOT
73# create directories if necessary
74#install -d $RPM_BUILD_ROOT
75#install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
76install -d $RPM_BUILD_ROOT%{_bindir}
77install -d $RPM_BUILD_ROOT%{_datadir}
78
79%{__make} install \
80 DESTDIR=$RPM_BUILD_ROOT
81
82%clean
83rm -rf $RPM_BUILD_ROOT
84
85%files
86%defattr(644,root,root,755)
87%doc README doc/*
88%attr(755,root,root) %{_bindir}/%{name}
89%{_datadir}/%{name}
90
91#%{_examplesdir}/%{name}-%{version}
This page took 0.751338 seconds and 4 git commands to generate.