]> git.pld-linux.org Git - packages/atlas-upload-cli.git/blob - atlas-upload-cli.spec
6859e4b3bf9798a5f14ecf25a1bb1d4c30935849
[packages/atlas-upload-cli.git] / atlas-upload-cli.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 Summary:        CLI to upload application code to Atlas
6 Name:           atlas-upload-cli
7 Version:        0.2.0
8 Release:        1
9 License:        MPL v2.0
10 Group:          Applications/System
11 Source0:        https://github.com/hashicorp/atlas-upload-cli/archive/v%{version}/%{name}-%{version}.tar.gz
12 # Source0-md5:  06fa00b9feb63b0a25e5331831b5b968
13 URL:            https://github.com/hashicorp/atlas-upload-cli
14 BuildRequires:  golang >= 1.2.1
15 BuildRequires:  rpmbuild(macros) >= 1.228
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 # binary stripped or something
19 %define         _enable_debug_packages 0
20
21 %description
22 The Atlas Upload CLI is a lightweight command line interface for
23 uploading application code to Atlas to kick off deployment processes.
24 This is the CLI used to power the vagrant push command and other parts
25 of Atlas Go with the Atlas strategy.
26
27 It can also be downloaded and used externally with other systems (such
28 as a CI service like Jenkins or Travis CI) to initiate Atlas-based
29 deploys.
30
31 %prep
32 %setup -q
33
34 # handle external deps:
35 #package github.com/hashicorp/atlas-go/archive: cannot download, $GOPATH not set. For more details see: go help gopath
36 #package github.com/hashicorp/atlas-go/v1: cannot download, $GOPATH not set. For more details see: go help gopath
37 #package github.com/hashicorp/logutils: cannot download, $GOPATH not set. For more details see: go help gopath
38 #package github.com/mitchellh/ioprogress: cannot download, $GOPATH not set. For more details see: go help gopath
39
40 %build
41 export GOPATH=$(pwd)/vendor
42 # make -j1 because https://github.com/hashicorp/atlas-upload-cli/pull/10
43 %{__make} -j1
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47 install -d $RPM_BUILD_ROOT%{_bindir}
48 install -p bin/atlas-upload $RPM_BUILD_ROOT%{_bindir}
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc README.md CHANGELOG.md LICENSE
56 %attr(755,root,root) %{_bindir}/atlas-upload
This page took 0.096833 seconds and 2 git commands to generate.